Click Here
home features news forums classifieds faqs links search
5644 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Channel: #Amigaworld
Channel Policy and Guidelines

(Uses JAVA Applet and Port 1024)
Visit the Chatroom Website

Who's Online
 41 guest(s) on-line.
 1 member(s) on-line.


 Drewlio77

You are an anonymous user.
Register Now!
 Drewlio77:  3 mins ago
 marko:  29 mins ago
 clusteruk:  31 mins ago
 AmigaMac:  1 hr 22 mins ago
 daveyw:  1 hr 30 mins ago
 Yssing:  1 hr 38 mins ago
 Barret:  1 hr 50 mins ago
 Jasper:  1 hr 59 mins ago
 wawa:  2 hrs 8 mins ago
 dommer416:  2 hrs 35 mins ago

/  Forum Index
   /  Amiga PPC Linux
      /  Need testers for a 2.6.24-rc2 Linux kernel
Register To Post

PosterThread
Geri 
Need testers for a 2.6.24-rc2 Linux kernel
Posted on 10-Nov-2007 16:35:10
#1 ]
Elite Member
Joined: 7-Oct-2003
Posts: 2004
From: Unknown

I compiled a new kernel for the AmigaOne, which you can download here. The kernel boots on my machine, but locks up when loading the first program (which is /sbin/init to setup the rest of the system). I don't know, if this is problem of my machine, of a specifc CPU or if it affects all AmigaOnes. Thus I need some users that can test this kernel on their machines.

Please add the kernel image to your a1boot.conf file (but DO NOT remove the working kernel entries!) and report how far the kernel boots on your machine.

Last edited by Geri on 10-Nov-2007 at 04:41 PM.

_________________
A1SE: G3@600MHz, 2GB, 1GBit network card
A1XE: G4@933MHz, 2GB, refitted AC'97 codec
microA1: G3@800MHz, 512MB

- A1 Linux support -

 Status: Offline
Profile     Report this post  
lionstorm 
Re: Need testers for a 2.6.24-rc2 Linux kernel
Posted on 10-Nov-2007 19:57:58
#2 ]
Super Member
Joined: 31-Jul-2003
Posts: 1546
From: the french side

@Geri

boot up to the pingu logo but no output on the console.

my entry in a1boot.conf :
test /boot/kernel-2.6.24-rc2 root=/dev/hdc2 ide1=ata66 video=radeonfb:1024x768-8@70 l2cr=0x80000000

 Status: Offline
Profile     Report this post  
Geri 
Re: Need testers for a 2.6.24-rc2 Linux kernel
Posted on 10-Nov-2007 20:43:05
#3 ]
Elite Member
Joined: 7-Oct-2003
Posts: 2004
From: Unknown

@lionstorm

Hmm, that's strange. It boots fine here (except for the complete system lockup later on). Could you do a reset after booting the kernel and dump the kernel log? Enter the U-boot console (interrupt the autoboot) and type "md 3e1c24". Then just press enter a hundred times until U-boot doesn't display any readable text.

_________________
A1SE: G3@600MHz, 2GB, 1GBit network card
A1XE: G4@933MHz, 2GB, refitted AC'97 codec
microA1: G3@800MHz, 512MB

- A1 Linux support -

 Status: Offline
Profile     Report this post  
lionstorm 
Re: Need testers for a 2.6.24-rc2 Linux kernel
Posted on 10-Nov-2007 22:41:44
#4 ]
Super Member
Joined: 31-Jul-2003
Posts: 1546
From: the french side

@Geri

last readable thing is "calling INIT"

 Status: Offline
Profile     Report this post  
broadblues 
Re: Need testers for a 2.6.24-rc2 Linux kernel
Posted on 11-Nov-2007 0:36:03
#5 ]
Elite Member
Joined: 20-Jul-2004
Posts: 4132
From: Portsmouth England

@lionstorm

Same thing here boots till pingu then freezes

_________________
BroadBlues On Blues BroadBlues On Amiga Walker Broad

 Status: Offline
Profile     Report this post  
RacerX 
Re: Need testers for a 2.6.24-rc2 Linux kernel
Posted on 11-Nov-2007 1:03:23
#6 ]
Super Member
Joined: 21-Aug-2003
Posts: 1158
From: Parts Unknown, USA

@Geri

Same as lionstorm here. Boots until the Tux logo then nothing. If it means anything, it seems slower just getting to Tux.

A1G4 XE. attempted boot to the 'Lenny' partition.

_________________
'unfixed' A1XE, 512mb RAM, plug-in USB card, Sil 0680 IDE card, Radeon 9250, built-in sound, OS4.1 update 5.

 Status: Offline
Profile     Report this post  
Pierre55 
Re: Need testers for a 2.6.24-rc2 Linux kernel
Posted on 25-Nov-2007 14:49:02
#7 ]
Regular Member
Joined: 2-Apr-2005
Posts: 283
From: Unknown

@Geri

Same here... boots till pingu then nothing!

Bye!

 Status: Offline
Profile     Report this post  
Fabio 
Re: Need testers for a 2.6.24-rc2 Linux kernel
Posted on 19-Dec-2007 18:02:52
#8 ]
Regular Member
Joined: 25-Jan-2005
Posts: 125
From: Finland

@Geri

Just tried kernel 2.6.24-rc2. It works almost
first there is some carbage in screen for second then tux logo appears and it load but don't show any messages. At last gdm starts but I can't log in because keyboard doesn't work.

In a1boot.conf i have this line: /boot/kernel-2.6.24-rc2 root=/dev/hda6 video=radeonfb:1024x768-8@70
I have stock micro

Last edited by Fabio on 19-Dec-2007 at 06:04 PM.

_________________
A1200T, A4000 Mirage pro, mAmigaOne C, LAN.

 Status: Offline
Profile     Report this post  
Geri 
Re: Need testers for a 2.6.24-rc2 Linux kernel
Posted on 19-Dec-2007 18:16:47
#9 ]
Elite Member
Joined: 7-Oct-2003
Posts: 2004
From: Unknown

@Fabio

Now that's really strange!
Keyboard was working for some time with this kernel on my A1 (when using busybox or /bin/sh as init program, the machine locks up with INIT 2.86 as init program).

What happens, if you boot the kernel with "single" appended to the kernel command line? The system should present a terminal login.

Last edited by Geri on 19-Dec-2007 at 06:17 PM.

_________________
A1SE: G3@600MHz, 2GB, 1GBit network card
A1XE: G4@933MHz, 2GB, refitted AC'97 codec
microA1: G3@800MHz, 512MB

- A1 Linux support -

 Status: Offline
Profile     Report this post  
Fabio 
Re: Need testers for a 2.6.24-rc2 Linux kernel
Posted on 19-Dec-2007 21:20:57
#10 ]
Regular Member
Joined: 25-Jan-2005
Posts: 125
From: Finland

@Geri

How can I get boot messages visible because now I can't log in when it only shows tux logo and no login prompt ?

_________________
A1200T, A4000 Mirage pro, mAmigaOne C, LAN.

 Status: Offline
Profile     Report this post  
Geri 
Re: Need testers for a 2.6.24-rc2 Linux kernel
Posted on 20-Dec-2007 8:28:08
#11 ]
Elite Member
Joined: 7-Oct-2003
Posts: 2004
From: Unknown

@Fabio

Hmm, it's strange that boot messages are not displayed. Can you connect to the machine with ssh or telnet?

_________________
A1SE: G3@600MHz, 2GB, 1GBit network card
A1XE: G4@933MHz, 2GB, refitted AC'97 codec
microA1: G3@800MHz, 512MB

- A1 Linux support -

 Status: Offline
Profile     Report this post  
Fabio 
Re: Need testers for a 2.6.24-rc2 Linux kernel
Posted on 20-Dec-2007 17:33:50
#12 ]
Regular Member
Joined: 25-Jan-2005
Posts: 125
From: Finland

@Geri

ssh works fine. Here is dmesg:
[ 0.000000] Crash kernel location must be 0x2000000
[ 0.000000] Reserving 0MB of memory at 32MB for crashkernel (System RAM: 256MB)
[ 0.000000] Using AmigaOne machine description
[ 0.000000] Total memory = 256MB; using 512kB for hash table (at cff80000)
[ 0.000000] Linux version 2.6.24-rc2 (geri@earth) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #21 Sat Nov 10 15:46:09 CET 2007
[ 0.000000] Found legacy serial port 0 for /pci@80000000/isa@7/serial@2f8
[ 0.000000] port=2f8, taddr=fe0002f8, irq=0, clk=1843200, speed=0
[ 0.000000] Found legacy serial port 1 for /pci@80000000/isa@7/serial@3f8
[ 0.000000] port=3f8, taddr=fe0003f8, irq=0, clk=1843200, speed=0
[ 0.000000] console [udbg0] enabled
[ 0.000000] Entering add_active_range(0, 0, 65536) 0 entries of 256 used
[ 0.000000] AmigaOne l2cr : L2 cache was not active, activating.
[ 0.000000] Top of RAM: 0x10000000, Total RAM: 0x10000000
[ 0.000000] Memory hole size: 0MB
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0 -> 65536
[ 0.000000] Normal 65536 -> 65536
[ 0.000000] HighMem 65536 -> 65536
[ 0.000000] Movable zone start PFN for each node
[ 0.000000] early_node_map[1] active PFN ranges
[ 0.000000] 0: 0 -> 65536
[ 0.000000] On node 0 totalpages: 65536
[ 0.000000] DMA zone: 512 pages used for memmap
[ 0.000000] DMA zone: 0 pages reserved
[ 0.000000] DMA zone: 65024 pages, LIFO batch:15
[ 0.000000] Normal zone: 0 pages used for memmap
[ 0.000000] HighMem zone: 0 pages used for memmap
[ 0.000000] Movable zone: 0 pages used for memmap
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 65024
[ 0.000000] Kernel command line: root=/dev/hda6 video=radeonfb:1024x768-8@70
[ 0.000000] i8259 legacy interrupt controller initialized
[ 0.000000] PID hash table entries: 1024 (order: 10, 4096 bytes)
[ 0.000000] time_init: decrementer frequency = 33.333333 MHz
[ 0.000000] time_init: processor frequency = 800.000000 MHz
[ 0.000015] clocksource: timebase mult[7800001] shift[22] registered
[ 0.006285] clockevent: decrementer mult[888] shift[16] cpu[0]
[ 0.012254] Console: colour dummy device 80x25
[ 0.017694] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
[ 0.025268] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
[ 0.062381] High memory: 0k
[ 0.062391] Memory: 254780k/262144k available (3752k kernel code, 7060k reserved, 156k data, 301k bss, 176k init)
[ 0.072688] SLUB: Genslabs=11, HWalign=32, Order=0-1, MinObjects=4, CPUs=1, Nodes=1
[ 0.080269] Calibrating delay loop... 66.56 BogoMIPS (lpj=133120)
[ 0.168378] Security Framework initialized
[ 0.172428] SELinux: Disabled at boot.
[ 0.176216] Capability LSM initialized
[ 0.179961] Mount-cache hash table entries: 512
[ 0.185255] Calling numa_default_policy()
[ 0.189259] Calling unlock_kernel()
[ 0.192666] Calling init_idle_bootup_task()
[ 0.196852] Calling preempt_enable_no_resched()
[ 0.201378] Calling schedule()
[ 0.204760] khelper used greatest stack depth: 7332 bytes left
[ 0.210757] net_namespace: 64 bytes
[ 0.215055] NET: Registered protocol family 16
[ 0.221393] PCI: Probing PCI hardware
[ 0.225072] PCI: Scanning bus 0000:00
[ 0.225108] PCI: Found 0000:00:00.0 [10cc/0660] 000600 00
[ 0.225139] PCI: Calling quirk c00131d4 for 0000:00:00.0
[ 0.225159] PCI: Found 0000:00:01.0 [10cc/0661] 000604 01
[ 0.225171] PCI: Calling quirk c00131d4 for 0000:00:01.0
[ 0.225196] PCI: Found 0000:00:05.0 [13f6/0111] 000401 00
[ 0.225220] PCI: Calling quirk c00131d4 for 0000:00:05.0
[ 0.225239] PCI: Found 0000:00:06.0 [10b7/9200] 000200 00
[ 0.225261] PCI: Calling quirk c00131d4 for 0000:00:06.0
[ 0.225280] PCI: Found 0000:00:07.0 [1106/0686] 000601 00
[ 0.225303] PCI: Calling quirk c00131d4 for 0000:00:07.0
[ 0.225308] PCI: Calling quirk c0148d28 for 0000:00:07.0
[ 0.225327] PCI: Found 0000:00:07.1 [1106/0571] 000101 00
[ 0.225353] PCI: Calling quirk c00131d4 for 0000:00:07.1
[ 0.225371] PCI: Found 0000:00:07.2 [1106/3038] 000c03 00
[ 0.225393] PCI: Calling quirk c00131d4 for 0000:00:07.2
[ 0.225417] PCI: Found 0000:00:07.3 [1106/3038] 000c03 00
[ 0.225439] PCI: Calling quirk c00131d4 for 0000:00:07.3
[ 0.225462] PCI: Found 0000:00:07.4 [1106/3057] 000000 00
[ 0.225485] PCI: Calling quirk c00131d4 for 0000:00:07.4
[ 0.225490] PCI: Calling quirk c014a5ec for 0000:00:07.4
[ 0.225499] PCI: Calling quirk c0149824 for 0000:00:07.4
[ 0.225523] PCI: Found 0000:00:07.5 [1106/3058] 000401 00
[ 0.225546] PCI: Calling quirk c00131d4 for 0000:00:07.5
[ 0.225569] PCI: Found 0000:00:07.6 [1106/3068] 000780 00
[ 0.225593] PCI: Calling quirk c00131d4 for 0000:00:07.6
[ 0.225616] PCI: Fixups for bus 0000:00
[ 0.225685] PCI: Scanning behind PCI bridge 0000:00:01.0, config 010100, pass 0
[ 0.225781] PCI: Scanning bus 0000:01
[ 0.225805] PCI: Found 0000:01:00.0 [1002/5159] 000300 00
[ 0.225827] PCI: Calling quirk c00131d4 for 0000:01:00.0
[ 0.225854] PCI: Fixups for bus 0000:01
[ 0.225874] PCI: Bus scan for 0000:01 returning with max=01
[ 0.225883] PCI: Scanning behind PCI bridge 0000:00:01.0, config 010100, pass 1
[ 0.225892] PCI: Bus scan for 0000:00 returning with max=01
[ 0.227009] khelper used greatest stack depth: 7156 bytes left
[ 0.232922] PCI: Cannot allocate resource region 0 of device 0000:00:00.0
[ 0.242204] SCSI subsystem initialized
[ 0.245983] libata version 3.00 loaded.
[ 0.246592] Calling preempt_disable()
[ 0.250230] Calling cpu_idle()
[ 0.253280] NET: Registered protocol family 8
[ 0.257567] NET: Registered protocol family 20
[ 0.263098] NET: Registered protocol family 2
[ 0.267363] Time: timebase clocksource has been installed.
[ 0.272860] Switched to high resolution mode on CPU 0
[ 0.311534] IP route cache hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.318774] TCP established hash table entries: 8192 (order: 4, 65536 bytes)
[ 0.325998] TCP bind hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.332429] TCP: Hash tables configured (established 8192 bind 8192)
[ 0.338713] TCP reno registered
[ 0.351742] sysctl table check failed: /kernel .1 Writable sysctl directory
[ 0.358637] Call Trace:
[ 0.361075] [c0821ee0] [c0008cd0] show_stack+0x50/0x184 (unreliable)
[ 0.367425] [c0821f00] [c003de6c] set_fail+0x50/0x68
[ 0.372396] [c0821f20] [c003e4e4] sysctl_check_table+0x660/0x6b0
[ 0.378399] [c0821f50] [c002a634] register_sysctl_table+0x64/0xb4
[ 0.384471] [c0821f70] [c0384ec8] register_powersave_nap_sysctl+0x18/0x2c
[ 0.391260] [c0821f80] [c037e1d0] kernel_init+0xb4/0x270
[ 0.396552] [c0821ff0] [c0011414] kernel_thread+0x44/0x60
[ 0.401959] Thermal assist unit using timers, shrink_timer: 500 jiffies
[ 0.409207] audit: initializing netlink socket (disabled)
[ 0.414559] audit(0.351:1): initialized
[ 0.423745] VFS: Disk quotas dquot_6.5.1
[ 0.427666] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[ 0.435289] io scheduler noop registered
[ 0.439152] io scheduler anticipatory registered
[ 0.443755] io scheduler deadline registered
[ 0.448055] io scheduler cfq registered (default)
[ 0.452750] PCI: Calling quirk c014a318 for 0000:00:00.0
[ 0.452758] PCI: Calling quirk c020ebe8 for 0000:00:00.0
[ 0.452767] PCI: Calling quirk c014a318 for 0000:00:01.0
[ 0.452773] PCI: Calling quirk c020ebe8 for 0000:00:01.0
[ 0.452780] PCI: Calling quirk c014a318 for 0000:00:05.0
[ 0.452786] PCI: Calling quirk c020ebe8 for 0000:00:05.0
[ 0.452793] PCI: Calling quirk c014a318 for 0000:00:06.0
[ 0.452798] PCI: Calling quirk c020ebe8 for 0000:00:06.0
[ 0.452805] PCI: Calling quirk c014a318 for 0000:00:07.0
[ 0.452811] PCI: Calling quirk c020ebe8 for 0000:00:07.0
[ 0.452818] PCI: Calling quirk c014a318 for 0000:00:07.1
[ 0.452824] PCI: Calling quirk c020ebe8 for 0000:00:07.1
[ 0.452830] PCI: Calling quirk c014a318 for 0000:00:07.2
[ 0.452836] PCI: Calling quirk c020ebe8 for 0000:00:07.2
[ 0.452863] PCI: Calling quirk c014a318 for 0000:00:07.3
[ 0.452869] PCI: Calling quirk c020ebe8 for 0000:00:07.3
[ 0.452885] PCI: Calling quirk c014a318 for 0000:00:07.4
[ 0.452890] PCI: Calling quirk c020ebe8 for 0000:00:07.4
[ 0.452897] PCI: Calling quirk c014a318 for 0000:00:07.5
[ 0.452903] PCI: Calling quirk c020ebe8 for 0000:00:07.5
[ 0.452909] PCI: Calling quirk c014a318 for 0000:00:07.6
[ 0.452915] PCI: Calling quirk c020ebe8 for 0000:00:07.6
[ 0.452921] PCI: Calling quirk c014a318 for 0000:01:00.0
[ 0.452927] PCI: Calling quirk c020ebe8 for 0000:01:00.0
[ 0.453548] radeonfb (0000:01:00.0): Cannot match card to OF node !
[ 0.658097] got res [88020000:8803ffff] bus [88020000:8803ffff] flags 2200 for BAR 6 of 0000:01:00.0
[ 0.658120] radeonfb (0000:01:00.0): Invalid ROM signature 0 should be 0xaa55
[ 0.731372] xtal calculation failed: 22967
[ 0.735396] radeonfb: Used default PLL infos
[ 0.739669] radeonfb: Reference=27.00 MHz (RefDiv=60) Memory=166.00 Mhz, System=166.00 MHz
[ 0.747937] radeonfb: PLL min 12000 max 35000
[ 0.851121] i2c-adapter i2c-1: unable to read EDID block.
[ 1.011106] i2c-adapter i2c-1: unable to read EDID block.
[ 1.171106] i2c-adapter i2c-1: unable to read EDID block.
[ 1.331106] i2c-adapter i2c-3: unable to read EDID block.
[ 1.491106] i2c-adapter i2c-3: unable to read EDID block.
[ 1.651106] i2c-adapter i2c-3: unable to read EDID block.
[ 1.959372] radeonfb: Monitor 1 type CRT found
[ 1.963731] radeonfb: EDID probed
[ 1.967047] radeonfb: Monitor 2 type no found
[ 2.318207] Console: switching to colour frame buffer device 128x48
[ 2.334091] radeonfb (0000:01:00.0): ATI Radeon QY
[ 2.348103] Generic RTC Driver v1.07
[ 2.351766] Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
[ 2.360578] serial8250.0: ttyS0 at I/O 0x2f8 (irq = 3) is a 16550A
[ 2.366639] console handover: boot [udbg0] -> real [ttyS0]
[ 2.372320] serial8250.0: ttyS1 at I/O 0x3f8 (irq = 4) is a 16550A
[ 2.379422] parport_pc: VIA 686A/8231 detected
[ 2.379428] parport_pc: probing current configuration
[ 2.379458] parport_pc: Current parallel port base: 0x278
[ 2.379523] parport0: PC-style at 0x278 [PCSPP,TRISTATE,EPP]
[ 2.479432] parport_pc: VIA parallel port: io=0x278
[ 2.485042] Floppy drive(s): fd0 is 2.88M
[ 2.506728] FDC 0 is a post-1991 82077
[ 2.513182] RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
[ 2.521423] 3c59x: Donald Becker and others.
[ 2.526046] 0000:00:06.0: 3Com PCI 3c905C Tornado at d100c000.
[ 2.554067] Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
[ 2.560908] ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
[ 2.569757] VP_IDE: IDE controller (0x1106:0x0571 rev 0x06) at PCI slot 0000:00:07.1
[ 2.578222] PCI: Calling quirk c0149a00 for 0000:00:07.1
[ 2.578237] VP_IDE: not 100% native mode: will probe irqs later
[ 2.584632] VP_IDE: VIA vt82c686b (rev 40) IDE UDMA100 controller on pci0000:00:07.1
[ 2.593002] ide0: BM-DMA at 0xcc00-0xcc07, BIOS settings: hda:pio, hdb:pio
[ 2.600808] ide1: BM-DMA at 0xcc08-0xcc0f, BIOS settings: hdc:pio, hdd:pio
[ 2.608676] Probing IDE interface ide0...
[ 3.399568] hdb: LG DVD-ROM DRD-8160B, ATAPI CD/DVD-ROM drive
[ 3.739551] hda: SAMSUNG SP1203N, ATA DISK drive
[ 3.744557] hda: host max PIO5 wanted PIO255(auto-tune) selected PIO4
[ 3.744649] hda: host side 80-wire cable detection failed, limiting max speed to UDMA33
[ 3.753285] hda: UDMA 2 mode selected
[ 3.753349] hdb: host max PIO5 wanted PIO255(auto-tune) selected PIO4
[ 3.753453] hdb: UDMA 2 mode selected
[ 3.753654] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
[ 3.758776] Probing IDE interface ide1...
[ 4.327995] hda: max request size: 512KiB
[ 4.340855] hda: 234493056 sectors (120060 MB) w/2048KiB Cache, CHS=16383/255/63, UDMA(33)
[ 4.350005] hda: cache flushes supported
[ 4.354334] hda: RDSK (512) hda1 (DOS^G)(res 2 spb 4) hda2 (DOS^G)(res 2 spb 4) hda3 (DOS^G)(res 2 spb 4) hda4 (DOS^G)(res 2 spb 4) hda5 (DOS^A)(res 2 spb 1) hda6 (LNX^@)(res 2 spb 1) hda7 (SWP^@)(res 2 spb 1)
[ 4.385526] hdb: ATAPI 48X DVD-ROM drive, 512kB Cache, UDMA(33)
[ 4.392009] Uniform CD-ROM driver Revision: 3.20
[ 4.398999] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 4.404382] serio: i8042 AUX port at 0x60,0x64 irq 12
[ 4.410203] mice: PS/2 mouse device common for all mice
[ 4.953319] input: AT Translated Set 2 keyboard as /class/input/input0
[ 5.381595] rtc_cmos: dev (254:0)
[ 5.381610] rtc_cmos rtc_cmos: rtc core: registered rtc_cmos as rtc0
[ 5.388537] rtc0: alarms up to one day
[ 5.548522] logips2pp: Detected unknown logitech mouse model 89
[ 6.033891] input: ImExPS/2 Logitech Explorer Mouse as /class/input/input1
[ 6.058128] i2c /dev entries driver
[ 6.062329] EDAC MC: Ver: 2.1.0 Nov 10 2007
[ 6.067389] TCP bic registered
[ 6.070833] NET: Registered protocol family 1
[ 6.075519] NET: Registered protocol family 17
[ 6.080691] rtc_cmos rtc_cmos: setting the system clock to 2007-12-20 19:32:16 (1198179136)
[ 6.105747] kjournald starting. Commit interval 5 seconds
[ 6.111709] EXT3-fs: mounted filesystem with ordered data mode.
[ 6.118129] VFS: Mounted root (ext3 filesystem) readonly.
[ 6.124040] Freeing unused kernel memory: 176k init
[ 6.160964] Calling INIT
[ 6.525029] khelper used greatest stack depth: 6868 bytes left
[ 6.994277] stty used greatest stack depth: 6148 bytes left
[ 7.188082] sed used greatest stack depth: 6004 bytes left
[ 7.563072] mount used greatest stack depth: 5796 bytes left
[ 9.881537] Adding 468920k swap on /dev/hda7. Priority:-1 extents:1 across:468920k
[ 10.087985] fsck.ext3 used greatest stack depth: 5684 bytes left
[ 10.122317] EXT3 FS on hda6, internal journal
[ 12.505399] eth0: setting full-duplex.
[ 16.681684] rc used greatest stack depth: 5476 bytes left

_________________
A1200T, A4000 Mirage pro, mAmigaOne C, LAN.

 Status: Offline
Profile     Report this post  
Fabio 
Re: Need testers for a 2.6.24-rc2 Linux kernel
Posted on 20-Dec-2007 17:42:55
#13 ]
Regular Member
Joined: 25-Jan-2005
Posts: 125
From: Finland

@Geri

Found this in Xorg.log.0:
(WW) `fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/fonts/misc".
Entry deleted from font path.
(Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/misc").
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(WW) `fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/fonts/100dpi/".
Entry deleted from font path.
(Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/100dpi/").
(WW) `fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/fonts/75dpi/".
Entry deleted from font path.
(Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/75dpi/").
(WW) `fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/fonts/Type1".
Entry deleted from font path.
(Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/Type1").
(WW) `fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/fonts/100dpi".
Entry deleted from font path.
(Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/100dpi").
(WW) `fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/fonts/75dpi".
Entry deleted from font path.
(Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/75dpi").
(WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not e
xist.
Entry deleted from font path.

This must be the problem

edit: or not because funtion keys don't work so I can't change to console

Last edited by Fabio on 20-Dec-2007 at 05:44 PM.

_________________
A1200T, A4000 Mirage pro, mAmigaOne C, LAN.

 Status: Offline
Profile     Report this post  
Geri 
Re: Need testers for a 2.6.24-rc2 Linux kernel
Posted on 23-Dec-2007 14:23:49
#14 ]
Elite Member
Joined: 7-Oct-2003
Posts: 2004
From: Unknown

@Fabio

Looks like on my A1, except that yours doesn't lock up. I don't understand this!?

Quote:
[ 0.658120] radeonfb (0000:01:00.0): Invalid ROM signature 0 should be 0xaa55
[ 0.731372] xtal calculation failed: 22967
[ 0.735396] radeonfb: Used default PLL infos

Hmm, normally the radeon driver should find an INTEL BIOS expansion ROM on a radeon card. It looks, as if this is not the case with your card. I have to take a look at the driver source.

Quote:
...
(WW) `fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/fonts/misc".
Entry deleted from font path.
(Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/misc").
...

That's normal. It shows up on all my Debian installation.

Thanks a lot for the info!

_________________
A1SE: G3@600MHz, 2GB, 1GBit network card
A1XE: G4@933MHz, 2GB, refitted AC'97 codec
microA1: G3@800MHz, 512MB

- A1 Linux support -

 Status: Offline
Profile     Report this post  
Fabio 
Re: Need testers for a 2.6.24-rc2 Linux kernel
Posted on 8-Jan-2008 17:00:53
#15 ]
Regular Member
Joined: 25-Jan-2005
Posts: 125
From: Finland

@Geri

You are welcome

_________________
A1200T, A4000 Mirage pro, mAmigaOne C, LAN.

 Status: Offline
Profile     Report this post  

[ home ][ about us ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright 2000 - 2017 Amigaworld.net.

Amigaworld.net was originally founded by David Doyle