Click Here
home features news forums classifieds faqs links search
5665 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
» Home
» Features
» News
» Forums
» Classifieds
» Links
» Downloads
Extras
» OS4 Zone
» IRC Network
» AmigaWorld Radio
» Newsfeed
» Top Members
» Amiga Dealers
Information
» About Us
» FAQs
» Advertise
» Polls
» Terms of Service
» Search

IRC Channel
Server: irc.amigaworld.net
Channel: #Amigaworld
Channel Policy and Guidelines

(Uses JAVA Applet and Port 1024)
Visit the Chatroom Website

Who's Online
 47 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 g01df1sh:  22 mins ago
 Rob:  26 mins ago
 Robert:  30 mins ago
 redfox:  33 mins ago
 simplex:  52 mins ago
 OneTimer1:  1 hr 12 mins ago
 AmigaBlitter:  1 hr 16 mins ago
 Cheese:  1 hr 20 mins ago
 lionstorm:  1 hr 43 mins ago
 zipper:  1 hr 54 mins ago

/  Forum Index
   /  Amiga OS4 Software
      /  SMTube : new version on OS4Depot
Register To Post

Goto page ( 1 | 2 | 3 | 4 | 5 Next Page )
PosterThread
zzd10h 
SMTube : new version on OS4Depot
Posted on 22-Jun-2014 19:18:07
#1 ]
Super Member
Joined: 21-May-2012
Posts: 1046
From: Unknown


SMTube svn6262


* [AmigaOS4] DON'T FORGET to download the latest Qt libQtCore from Alfkill and to install it in your Qt:Lib drawer
libQtCore

* Added a "Download URL" button at the bottom of the main window

* Fixed problem when downloading/cancelling 1080p videos

* 1080p download are splitted into 2 files, an audio M4A and a video MP4.
Use ffmpeg to merge them

APPDIR:ffmpeg -i filename.mp4 -i filename.m4a -vcodec copy -acodec copy
output_video.mp4

* [AmigaOS4] Removed auto-conversion of audio track to avoid potential legal issue.
Now, until AmigaAmp or TuneNet can read DASH M4A, you have to manually convert the audio file with ffmpeg

APPDIR:ffmpeg -i file.m4a output_file.mp3

SMTube on OS4Depot

_________________
http://apps.amistore.net/zTools

 Status: Offline
Profile     Report this post  
NutsAboutAmiga 
Re: SMTube : new version on OS4Depot
Posted on 22-Jun-2014 21:56:24
#2 ]
Elite Member
Joined: 9-Jun-2004
Posts: 10737
From: Norway

@zzd10h

Excellent will try it out asap.

_________________
Please check out my software:
Excalibur, Basilisk 2, AmigaInputAnywhere.
LiveForIt-Music
http://lifeofliveforit.blogspot.no/

 Status: Offline
Profile     Report this post  
samo79 
Re: SMTube : new version on OS4Depot
Posted on 22-Jun-2014 22:19:43
#3 ]
Elite Member
Joined: 13-Feb-2003
Posts: 3354
From: Italy, Perugia

@zzd10h

Thanks

_________________
BACK FOR THE FUTURE

http://www.betatesting.it/backforthefuture

Sam440ep Flex 800 Mhz 1 GB Ram + AmigaOS 4.1 Update 6
AmigaOne XE G3 800 Mhz - 640 MB Ram - Radeon 9200 SE + AmigaOS 4.1 Update 6

 Status: Offline
Profile     Report this post  
ilbarbax 
Re: SMTube : new version on OS4Depot
Posted on 23-Jun-2014 9:48:56
#4 ]
Regular Member
Joined: 17-Jan-2010
Posts: 143
From: Italy

@zzd10h

does libQTcore.so needs to be copied as it is (libQTcore.so.4.7.0) or renamed to libQTcore.so?

 Status: Offline
Profile     Report this post  
pvanni 
Re: SMTube : new version on OS4Depot
Posted on 23-Jun-2014 13:07:11
#5 ]
Regular Member
Joined: 25-Aug-2003
Posts: 459
From: Lecco, Italy

@ilbarbax
since all libraries are without version number in theirs names I think
your second reply it's the right one

Last edited by pvanni on 23-Jun-2014 at 01:07 PM.

 Status: Offline
Profile     Report this post  
pvanni 
Re: SMTube : new version on OS4Depot
Posted on 23-Jun-2014 13:26:08
#6 ]
Regular Member
Joined: 25-Aug-2003
Posts: 459
From: Lecco, Italy

@zzd10h
nice work, thanks I use it regulary

 Status: Offline
Profile     Report this post  
JohnFante 
Re: SMTube : new version on OS4Depot
Posted on 23-Jun-2014 16:41:54
#7 ]
Member
Joined: 14-Apr-2004
Posts: 99
From: Copenhagen, Denmark

@zzd10h

IGNORE THIS. My X1000 had a fit. After a short off period it works again.

Hmm strange. I have copied the latest libQTcore.so to the Qt:lib drawer and now 4.1 goes to dos.

It shows the 4.1 loading screen and then i goes to dos after a couple of seconds.

Anybody else have this problem?

I will try to downgrade later to see if that solves it.

Last edited by JohnFante on 23-Jun-2014 at 05:03 PM.

 Status: Offline
Profile     Report this post  
zzd10h 
Re: SMTube : new version on OS4Depot
Posted on 23-Jun-2014 18:22:02
#8 ]
Super Member
Joined: 21-May-2012
Posts: 1046
From: Unknown

@ilbarbax 
yes, pvanni is right, rename it to libQtCore.so

@JohnFante
At end, not a Qt problem, right ?

_________________
http://apps.amistore.net/zTools

 Status: Offline
Profile     Report this post  
zzd10h 
Re: SMTube : new version on OS4Depot
Posted on 19-Aug-2014 5:57:11
#9 ]
Super Member
Joined: 21-May-2012
Posts: 1046
From: Unknown


SMTube 14.7 svn6307


14/08/18 : port of the latest 14.7 svn6307

* this version fix some problems with recents YouTube changes.

Especially the need to click many times on a video to play it

### WARNING ###
To apply these fixes, please, delete your previous smtube settings drawer.

in a CLI, issue the command :

delete Qt:home/.config/smtube/#?

_________________
http://apps.amistore.net/zTools

 Status: Offline
Profile     Report this post  
pvanni 
Re: SMTube : new version on OS4Depot
Posted on 19-Aug-2014 13:57:52
#10 ]
Regular Member
Joined: 25-Aug-2003
Posts: 459
From: Lecco, Italy

@zzd10h
just downloaded, it's working well many thanks

 Status: Offline
Profile     Report this post  
zzd10h 
Re: SMTube : new version on OS4Depot
Posted on 21-Sep-2014 16:55:54
#11 ]
Super Member
Joined: 21-May-2012
Posts: 1046
From: Unknown

SMTube 14.8 svn6396

available on OS4Depot and overall via AmiUpdate.

Please, try to download it via AmiUpdate and say me the result.

Normally, the Amiga drawer is not replaced, therefore you should not lose your PlayVideo.rexx modifications.
But, please, save ./Amiga/PlayVideo.rexx before the update.

14/09/21 : port of the latest 14.8 svn6396

* [AmigaOS 4] Now AmiUpdate compatible by adding a Version cookie

The AutoInstall script should not delete the Amiga drawer to save your
PlayVideo.rexx, but please save it before the update...

* [AmigaOS 4] AmigaOS4_ReadMe.txt updated to reflect the AmiUpdate compilation
change.

* Fix playback.

* Possibility to compile without the option to download videos.

_________________
http://apps.amistore.net/zTools

 Status: Offline
Profile     Report this post  
mbrantley 
Re: SMTube : new version on OS4Depot
Posted on 21-Sep-2014 19:23:25
#12 ]
Cult Member
Joined: 10-Jun-2010
Posts: 519
From: Mobile, Alabama, United States

@zzd10h

Updated via AmiUpdate... no problems to report. Thanks!

_________________

 Status: Offline
Profile     Report this post  
zzd10h 
Re: SMTube : new version on OS4Depot
Posted on 21-Sep-2014 19:34:19
#13 ]
Super Member
Joined: 21-May-2012
Posts: 1046
From: Unknown

@mbrantley

Great, therefore finally it works without overwrite the PlayVideo.rexx !

The today first version AmiUpdate script on os4depot was wrong.


Thank you for the feedback.

_________________
http://apps.amistore.net/zTools

 Status: Offline
Profile     Report this post  
SOFISTISOFTWARE 
Re: SMTube : new version on OS4Depot
Posted on 21-Sep-2014 20:43:51
#14 ]
Regular Member
Joined: 25-Dec-2003
Posts: 454
From: Latina, Italy

@zzd10h

this version doesn't work well on my system, the videos are not fast enought as the previous one, i cancelled the .config directory and i restored the usual resolution 360, i tried with the old afx mplayer and the new one from liveforit same result...

_________________
Sam 460EX, 2Gb Ram, Radeon R7 250, AmigaOS4.1 FE
A4000 PPC604@233, Mediator
A1200 PPC603@160, Mediator
uA1 G3@800, 512 Mb [sold]

 Status: Offline
Profile     Report this post  
zzd10h 
Re: SMTube : new version on OS4Depot
Posted on 21-Sep-2014 20:47:00
#15 ]
Super Member
Joined: 21-May-2012
Posts: 1046
From: Unknown

@SOFISTISOFTWARE

Certainly not related to SMTube. SMTube just pass YouTube URL to MPlayer.

Maybe a temporary slowndown in your internet bandwith ?
Try SysMon SpeedTest benchmark in Network Benchmark tab

edit : I forgot, does AmiUpdate worked well for you ? Is your PlayVideo.rexx was preserved ?

Last edited by zzd10h on 21-Sep-2014 at 08:48 PM.

_________________
http://apps.amistore.net/zTools

 Status: Offline
Profile     Report this post  
Metalheart 
Re: SMTube : new version on OS4Depot
Posted on 22-Sep-2014 7:34:39
#16 ]
Elite Member
Joined: 21-Aug-2003
Posts: 2967
From: Somewhere in the Dutch mountains....

I get a "failed to create opengl context" message then it crashes...

_________________
Theres a time to live and a time to die
When its time to meet the maker
Theres a time to live but isnt it strange
That as soon as you're born you're dying

 Status: Offline
Profile     Report this post  
zzd10h 
Re: SMTube : new version on OS4Depot
Posted on 22-Sep-2014 8:12:11
#17 ]
Super Member
Joined: 21-May-2012
Posts: 1046
From: Unknown

@Metalheart

Follow the 1) below and don't forget to say me if it works.

http://amigaworld.net/modules/newbb/viewtopic.php?topic_id=38696&forum=32#728190

_________________
http://apps.amistore.net/zTools

 Status: Offline
Profile     Report this post  
SOFISTISOFTWARE 
Re: SMTube : new version on OS4Depot
Posted on 22-Sep-2014 13:28:18
#18 ]
Regular Member
Joined: 25-Dec-2003
Posts: 454
From: Latina, Italy

@zzd10h

thanks for reply, now it's ok the issue was about slowdown of my internet connection dropped to 56kb/s, therefore about the amiupdate i can't say much because i updated it from os4depot, thanks for you constant work on amigaOS

bye

Last edited by SOFISTISOFTWARE on 22-Sep-2014 at 01:39 PM.

_________________
Sam 460EX, 2Gb Ram, Radeon R7 250, AmigaOS4.1 FE
A4000 PPC604@233, Mediator
A1200 PPC603@160, Mediator
uA1 G3@800, 512 Mb [sold]

 Status: Offline
Profile     Report this post  
Metalheart 
Re: SMTube : new version on OS4Depot
Posted on 22-Sep-2014 14:24:56
#19 ]
Elite Member
Joined: 21-Aug-2003
Posts: 2967
From: Somewhere in the Dutch mountains....

@Metalheart

nope.... but the OS doesnt crash anymore....

_________________
Theres a time to live and a time to die
When its time to meet the maker
Theres a time to live but isnt it strange
That as soon as you're born you're dying

 Status: Offline
Profile     Report this post  
zzd10h 
Re: SMTube : new version on OS4Depot
Posted on 22-Sep-2014 17:14:47
#20 ]
Super Member
Joined: 21-May-2012
Posts: 1046
From: Unknown

@SOFISTISOFTWARE

Hopefully, it was not SMTube

@MetalHeart

1) Is another Qt program works on your system ?

2) Did you install Qt updates from Alfkill as spotted in the thread that i gave you ?

3) and after, did you install the latest libqtcore ? Link here :
http://amigaworld.net/modules/newbb/viewtopic.php?topic_id=39157&forum=32#736111

_________________
http://apps.amistore.net/zTools

 Status: Offline
Profile     Report this post  
Goto page ( 1 | 2 | 3 | 4 | 5 Next Page )

[ home ][ about us ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright © 2000 - 2017 Amigaworld.net.

Amigaworld.net was originally founded by David Doyle