Click Here
home features news forums classifieds faqs links search
5595 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Channel: #Amigaworld
Channel Policy and Guidelines

(Uses JAVA Applet and Port 1024)
Visit the Chatroom Website

Who's Online
 72 guest(s) on-line.
 2 member(s) on-line.


 Spectre660,  Ned

You are an anonymous user.
Register Now!
 Ned:  2 secs ago
 Spectre660:  14 secs ago
 iggy:  11 mins ago
 Barret:  19 mins ago
 gregthecanuck:  22 mins ago
 kolla:  25 mins ago
 K-L:  26 mins ago
 kilaueabart:  53 mins ago
 dooz:  55 mins ago
 amigakit:  1 hr 6 mins ago

/  Forum Index
   /  Amiga Emulation
      /  AmigaForever Premium Edition 2016 - How can I install OS 4.1 FE classic?
Register To Post

PosterThread
Dandy 
AmigaForever Premium Edition 2016 - How can I install OS 4.1 FE classic?
Posted on 27-Feb-2017 20:29:57
#1 ]
Elite Member
Joined: 24-Mar-2003
Posts: 3048
From: Cologne * Germany

I made the settings in the AmigaForever Premium Edition 2016 - system "Amiga 4000 PPC - OS 4.1 FE U1" (a copy of "Amiga 4000 PPC") according to the manual.

I inserted the "BootFloppy" as .adf in DF0: and the "OS 4.1 FE classic"-CD in the PC-drive D: (DVD-RW).

When I start the "Player", green lamps at the symbols for Floppy Disk and CD start flashing (apparently booting). If I locate the mousepointer above the Floppy Disk symbol, a bubble pops up telling

Floppy disk drive (DF0):
"BootFloppy" (BootFloppy.adf)


and if I put the pointer above the CD symbol the bubble says

CD drive:
D:
.

But after a few seconds the player shows an AmigaDOS-screen with this error message:

"AMIGA ROM Operating System and Libraries
Copyright 1985-1993 Commodore-Amiga, Inc.
All Rights Reserved.
Can't find System
BootFloppy:C/Assign failed returncode 20
1>


Looks like the OS4-BootFloppy could not be assigned as "Systen"?

A look at the startup-sequence in the "S"-directory in the "BootFloppy"-folder of the OS4-CD (assuming that this one is identical to the one in the "BootFloppy.adf"-file) showed:

...
CD "AmigaOS 4.1 Final Edition:"
;
BootFloppy:C/Assign SYS: System
BootFloppy:C/Assign S: SYS:S
BootFloppy:C/Assign Devs: SYS:Devs
BootFloppy:C/Assign C: SYS:C
BootFloppy:C/Assign FONTS: SYS:Fonts
BootFloppy:C/Assign KEYMAPS: SYS:Devs/Keymaps
BootFloppy:C/Assign L: SYS:L
BootFloppy:C/Assign LIBS: SYS:Libs
BootFloppy:C/Assign CLASSES: SYS:Classes
BootFloppy:C/Assign LOCALE: SYS:Locale
BootFloppy:C/Assign REXX: SYS:S/AREXX
BootFloppy:C/Assign SOBJS: SYS:SObjs
...


Apparently the startup-sequence was executed without error until CD "AmigaOS 4.1 Final Edition:", while the first assign BootFloppy:C/Assign SYS: System caused the error message.
This leads me to the assumption that AmigaForever does not know the name of the CD inserted in PC-drive D: and so the assign fails. Placing the mouse pointer over the CD symbol at the bottom of the player window also supports this assumption, as it just tells "CD drive: D: and not CD drive: AmigaOS 4.1 Final Edition.


But why doesn't AF know the CD's name?

If I look at PC-drive D: in WinExplorer it clearly says:
DVD-RW-Drive (d:) AmigaOS 4.1 Final Edition

And AF is set up to automount PC resources upon start - and "CD0" also has a checkmark.

But why does the "BootFloppy" not work?

_________________
Ciao

Dandy
__________________________________________
If someone enjoys marching to military music, then I already despise him.
He got his brain accidently - the bone marrow in his back would have been sufficient for him!
(Albert Einstein)

 Status: Offline
Profile     Report this post  
g01df1sh 
Re: AmigaForever Premium Edition 2016 - How can I install OS 4.1 FE classic?
Posted on 27-Feb-2017 23:19:04
#2 ]
Cult Member
Joined: 16-Apr-2009
Posts: 885
From: UK

@Dandy

HI

I have not tried it my self but you could give this new software installer a go. Flower power

http://www.amikit.amiga.sk/

 Status: Offline
Profile     Report this post  
Dandy 
Re: AmigaForever Premium Edition 2016 - How can I install OS 4.1 FE classic?
Posted on 28-Feb-2017 10:44:14
#3 ]
Elite Member
Joined: 24-Mar-2003
Posts: 3048
From: Cologne * Germany

@g01df1sh

Quote:

g01df1sh wrote:
@Dandy

HI

I have not tried it my self but you could give this new software installer a go. Flower power

http://www.amikit.amiga.sk/

Thanks for the link.
If nothing else helps, I'll try that.

But isn't it "Amiga Spirit", if I try to find the cause for the failure?

_________________
Ciao

Dandy
__________________________________________
If someone enjoys marching to military music, then I already despise him.
He got his brain accidently - the bone marrow in his back would have been sufficient for him!
(Albert Einstein)

 Status: Offline
Profile     Report this post  

[ home ][ about us ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright 2000 - 2017 Amigaworld.net.

Amigaworld.net was originally founded by David Doyle