Click Here
home features news forums classifieds faqs links search
5584 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Channel: #Amigaworld
Channel Policy and Guidelines

(Uses JAVA Applet and Port 1024)
Visit the Chatroom Website

Who's Online
 92 guest(s) on-line.
 3 member(s) on-line.


 BigD,  number6,  Cheese

You are an anonymous user.
Register Now!
 BigD:  21 secs ago
 number6:  1 min ago
 Cheese:  3 mins ago
 OneTimer1:  9 mins ago
 SaludaLabs:  13 mins ago
 Paula:  14 mins ago
 zipper:  15 mins ago
 _ThEcRoW:  21 mins ago
 BSzili:  28 mins ago
 pavlor:  37 mins ago

/  Forum Index
   /  Amiga OS4 Hardware
      /  Amiga one SE cant install OS 4.0 or Debian
Register To Post

Goto page ( 1 | 2 | 3 | 4 Next Page )
PosterThread
pearson101 
Amiga one SE cant install OS 4.0 or Debian
Posted on 30-Apr-2017 17:04:50
#1 ]
Member
Joined: 26-Apr-2017
Posts: 32
From: Unknown

Hi Guys

I have recently purchased an Amiga one g3 se developers edition motherboard in which i have put in an atx case and powers on ok only that i cannot install any os system to the system

I have partitioned the drive for Linux using the original Amigaone install disk for suse linux 7.3 dist
This works so far and then fails to decompress files to the hard drive i have tried muliple times using diffrent cd roms burning other disks etc without success.

Also I have tried Debian Woody 3.0 Dist, This installs and fails on installing a base system aswell. Also I have tried with success.
My uboot version is 0.1.1 jun 10 2003

Also i cant find any updates to upgrade this rom to a later version on the internet anymore as I cant install Amiga OS 4.0 without doing so I believe after reading many users issues and postings on forums etc.

Please can anybody help me in getting anything installed to this Amigaone g3 SE as i am really stuck i feel that i have been beaten without the support outthere due to the rarity of this board etc

thanks

pearson101

 Status: Offline
Profile     Report this post  
lionstorm 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 30-Apr-2017 17:46:45
#2 ]
Super Member
Joined: 31-Jul-2003
Posts: 1539
From: the french side

@pearson101

you have plenty of info here http://amigaone-linux.sourceforge.net/

PS: Welcome

 Status: Offline
Profile     Report this post  
Tomppeli 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 30-Apr-2017 18:53:09
#3 ]
Super Member
Joined: 18-Jun-2004
Posts: 1570
From: Home land of Santa, sauna, sisu and salmiakki

@pearson101

You can find the Uboot update from Hyperion's website. AmigaOS 4.0 CD should just boot.

Do you have any IDE addon cards like Si0680 ?

Last edited by Tomppeli on 30-Apr-2017 at 06:55 PM.

_________________
Rock lobster bit me, so excuse me.
X1000 + AmigaOS4.1 FE. Be authentic.
"Anyone can build a fast CPU. The trick is to build a fast system." -Seymour Cray

 Status: Offline
Profile     Report this post  
Geri 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 30-Apr-2017 18:54:38
#4 ]
Elite Member
Joined: 7-Oct-2003
Posts: 2001
From: Unknown

@pearson101

Quote:
pearson101 wrote:
Hi Guys

I have recently purchased an Amiga one g3 se developers edition motherboard in which i have put in an atx case and powers on ok only that i cannot install any os system to the system

Oh, another rare A1G3SE user.

As far as I know there are different revisions of the A1G3SE motherboard: would be cool, if you could post a photo of the motherboard.

Quote:
Also I have tried Debian Woody 3.0 Dist, This installs and fails on installing a base system aswell. Also I have tried with success.

Debian Woody is pretty old. Hypex is working on an installer for Debian Jessie, which I tested successfully on my A1SE. I could imagine that this is enough beta-testing to release it to the public. Hypex?

Quote:
My uboot version is 0.1.1 jun 10 2003

Also i cant find any updates to upgrade this rom to a later version on the internet anymore as I cant install Amiga OS 4.0 without doing so I believe after reading many users issues and postings on forums etc.

Yes, U-Boot version 0.1.1 is too old for AmigaOS4. Linux may work, but we're only testing on U-Boot 1.1.1 or later these days. So upgrading the firmware would be the first step. You need a floppy or CD updater image, as you can't use AmigaOS4's BIOSUpdater to perform the update.

_________________
A1SE: G3@600MHz, 2GB, 1GBit network card
A1XE: G4@933MHz, 2GB, refitted AC'97 codec
microA1: G3@800MHz, 512MB

- A1 Linux support -

 Status: Offline
Profile     Report this post  
pavlor 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 30-Apr-2017 19:21:17
#5 ]
Elite Member
Joined: 10-Jul-2005
Posts: 8201
From: Unknown

@pearson101

Welcome!

 Status: Offline
Profile     Report this post  
SACC-dude 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 30-Apr-2017 20:58:01
#6 ]
Regular Member
Joined: 16-May-2005
Posts: 198
From: Sacramento, CA

@pearson101

If memory serves.. the 0.1.1 rom is not writable!!!

In order to use 1.1.1 rom image from Hyperion, you have to get a writable rom.

WE who bought this a1-g3 back in the day were up-graded by our dealers.

At least that's what I remember.

My A1-G3 is working fine with AmigaOS 4.1.6

 Status: Offline
Profile     Report this post  
Morphix 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 1-May-2017 1:09:24
#7 ]
Regular Member
Joined: 10-Aug-2009
Posts: 431
From: Greece

@Geri

Quote:
Debian Woody is pretty old. Hypex is working on an installer for Debian Jessie, which I tested successfully on my A1SE. I could imagine that this is enough beta-testing to release it to the public. Hypex?


I am here to beta test as well. Have worked with Hypex Linux installer releases in the past. Link me to the installer and to the required set of install CDs for the latest Debian. Will write to Hyoex as well.

_________________
Peg1, Peg2, Efika,
Amiga 500, Amiga 600, Amiga 1230,
Amiga 1200PPC, Amiga 4000PPC,
CDTV, CD32,
Sam 440EP, AmigaOne XE,
MacMini PPC, PowerMac G4

 Status: Offline
Profile     Report this post  
Morphix 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 1-May-2017 1:57:37
#8 ]
Regular Member
Joined: 10-Aug-2009
Posts: 431
From: Greece

@SACC-dude

Quote:
WE who bought this a1-g3 back in the day were up-graded by our dealers. At least that's what I remember.


What was the upgrade? Newer revision of SE boards?

_________________
Peg1, Peg2, Efika,
Amiga 500, Amiga 600, Amiga 1230,
Amiga 1200PPC, Amiga 4000PPC,
CDTV, CD32,
Sam 440EP, AmigaOne XE,
MacMini PPC, PowerMac G4

 Status: Offline
Profile     Report this post  
SACC-dude 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 1-May-2017 4:12:02
#9 ]
Regular Member
Joined: 16-May-2005
Posts: 198
From: Sacramento, CA

@Morphix

Just a tiny square rom chip (but writable for future rom images)

this chip is back by the pci slots, I guess it's like the bios? of the amigaone-g3 and a1-g4

 Status: Offline
Profile     Report this post  
Geri 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 1-May-2017 15:35:54
#10 ]
Elite Member
Joined: 7-Oct-2003
Posts: 2001
From: Unknown

@SACC-dude

Quote:
SACC-dude wrote:
@pearson101

If memory serves.. the 0.1.1 rom is not writable!!!

In order to use 1.1.1 rom image from Hyperion, you have to get a writable rom.

WE who bought this a1-g3 back in the day were up-graded by our dealers.

Indeed, you're right! But was this the case for all A1SE motherboards?

Even if there are no dealers left that can help in this case, there are two options:
- ask someone with a programming tool (like a TL866 or Galep) to program a new flash ROM (they don't cost that much) or
- send the pure U-Boot image to one of these small companies that flash BIOS chips for you.

Quote:
SACC-dude wrote:
@Morphix

Just a tiny square rom chip (but writable for future rom images)

this chip is back by the pci slots, I guess it's like the bios? of the amigaone-g3 and a1-g4

Right, its the socketed chip near the first 33MHz PCI slot (just below the Winbond SRAM for the U-Boot config).

Last edited by Geri on 01-May-2017 at 03:40 PM.

_________________
A1SE: G3@600MHz, 2GB, 1GBit network card
A1XE: G4@933MHz, 2GB, refitted AC'97 codec
microA1: G3@800MHz, 512MB

- A1 Linux support -

 Status: Offline
Profile     Report this post  
Hypex 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 1-May-2017 16:49:27
#11 ]
Elite Member
Joined: 6-May-2007
Posts: 8414
From: Greensborough, Australia

@Geri

Quote:
Hypex is working on an installer for Debian Jessie, which I tested successfully on my A1SE. I could imagine that this is enough beta-testing to release it to the public. Hypex?


Oh no. It has issues. Really, it worked on your SE? Did I read the memo? I'll look.

@All

Well it's here the current beta for who wants to check.

http://home.lizzy.com.au/dmaen/downloads/Testing/BootTest.iso

So quick instructions for testing:

If it's fresh install with no Linux then you need to setup a boot partition. Create and format an Ext2 partition and mount at point "/boot/a1boot". Yes it sounds strange but trust me. Make 50-100MB in size.

If you have a recent one you are installing over or adding a new install with an exsting a1boot menu the installer will locate and use this.

Next setup the root volume and using Ext4 is recommended by me. It works. 5GB bare bones and 10GB to be comfortable.

It will then check if all is okay. After it installs the system it will then install A1 packages. If all is well it will reboot and a new Linux boot menu is waiting.

I still class it as beta as there are issues that may show up. Some I know of. That were fixed until Linux froze recently on me and to took some of my work.

Known issues you may encounter. Ext2 formatting may not format with 128 size inodes it needs to. The boot check may fail. The desktop can fail.

If your desktop fails then try this. Boot into recovery mode can be good. Log in and install this for starters:
apt-get install gnome-session-fallback

Or try:
apt-get install firmware-linux-nonfree.

Or this may be best:
apt-get install mate-desktop

Good luck! Did I say beta? Beta everybody. Beta. Get your beta here! No refunds, Linux is free.

 Status: Offline
Profile     Report this post  
Geri 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 2-May-2017 21:53:58
#12 ]
Elite Member
Joined: 7-Oct-2003
Posts: 2001
From: Unknown

@Hypex

Quote:
Hypex wrote:
@Geri

Quote:
Hypex is working on an installer for Debian Jessie, which I tested successfully on my A1SE. I could imagine that this is enough beta-testing to release it to the public. Hypex?


Oh no. It has issues. Really, it worked on your SE? Did I read the memo? I'll look.

Okay, I still have to do a full installation on my A1SE, but I could successfully boot the installer. And that's what counts most on this board!

Quote:
@All

Well it's here the current beta for who wants to check.

http://home.lizzy.com.au/dmaen/downloads/Testing/BootTest.iso

A note from my side:
The installer expects an existing OS4 installation in the sense that the slb_v2 bootloader should be installed in the RDB. Also its best to put the Linux boot partition right after the OS4 system partition to make sure that the a1boot.conf file for Linux is correctly detected by slb_v2.

Quote:
Good luck! Did I say beta? Beta everybody. Beta. Get your beta here! No refunds, Linux is free.

Ah, let's say its release candidate 1.

_________________
A1SE: G3@600MHz, 2GB, 1GBit network card
A1XE: G4@933MHz, 2GB, refitted AC'97 codec
microA1: G3@800MHz, 512MB

- A1 Linux support -

 Status: Offline
Profile     Report this post  
pearson101 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 5-May-2017 8:59:25
#13 ]
Member
Joined: 26-Apr-2017
Posts: 32
From: Unknown

@Morphix
http://s1044.photobucket.com/user/cadescam/media/IMG_20170504_201840_zpsgmmnrpr2.jpg.html?filters[user]=146444897&filters[recent]=1&sort=1&o=0



Hi Guys thanks for the advise but i think its a dead duck looks like as you said the rom needs to be unlocked

Also thanks for your help.


Still cant find the bios image out there for the flashing or a tool to do this just to see if the chip is locked


Also i have tried the iso link that was sent by hypex thanks to him but i have to had a previous os 4.0 install already in which i have nothing.


Thanks everyone for the help

if anyone can image there harddrive maybe try that but i will need to still flash the uboot.


 Status: Offline
Profile     Report this post  
pearson101 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 5-May-2017 9:05:44
#14 ]
Member
Joined: 26-Apr-2017
Posts: 32
From: Unknown

@Tomppeli

Hi thats for the advise no got no other cards installed the bios maybe locked i think

 Status: Offline
Profile     Report this post  
pearson101 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 5-May-2017 9:09:29
#15 ]
Member
Joined: 26-Apr-2017
Posts: 32
From: Unknown

@SACC-dude

can it be possible to copy your harddrive image, maybe i could get my system working from a working harddrive image, but i may need to flash the bios to the later still


thanks for your advise people



 Status: Offline
Profile     Report this post  
pearson101 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 5-May-2017 10:34:08
#16 ]
Member
Joined: 26-Apr-2017
Posts: 32
From: Unknown

@pearson101

Downloaded debian-etch-install.iso.bz2 to try burned the image to cd


I am now getting a boot loop as per pictures the drive is partitioned aswell

http://s1044.photobucket.com/user/cadescam/media/IMG_20170505_101942_zpsnjsbl3n3.jpg.html

 Status: Offline
Profile     Report this post  
pearson101 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 5-May-2017 10:46:12
#17 ]
Member
Joined: 26-Apr-2017
Posts: 32
From: Unknown

@pearson101


I have tried everything accept flashing the bios h-boot has anybody got a copy and flashing tools to do this as i am really stuck on this one if you have that will be great i will try to update the bios.

Also can anyone remember the person who could re-flash the bios chip to the latest firmware, that will be great for the information- i have also read on another forum somewhere that somebody called sven from switzerland i recall from the article who was one of the original developers who could only re-flash the chip but i am not sure on this one this was going back to 2008 when this post was mentioned a long time back lol.




Thanks again guys for your support




 Status: Offline
Profile     Report this post  
Hypex 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 5-May-2017 14:34:05
#18 ]
Elite Member
Joined: 6-May-2007
Posts: 8414
From: Greensborough, Australia

@Geri

Quote:
Okay, I still have to do a full installation on my A1SE, but I could successfully boot the installer. And that's what counts most on this board!


Oh that. Well yes booting would be easy. The first step in the process.

Quote:
Ah, let's say its release candidate 1.


Yes that would be suitable. Next could RC2. RC3. Done.

 Status: Offline
Profile     Report this post  
Hypex 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 5-May-2017 15:51:39
#19 ]
Elite Member
Joined: 6-May-2007
Posts: 8414
From: Greensborough, Australia

@pearson101

First did you get any OS4 CDs with your board? You should have at least the developer pre-release. Since you do have a developer board.

Next, did you test the U-Boot updater from floppy or CD, and it failed to update?

As to my Jessie installer needing OS4, all it really requires is a bootable FFS partition, even an empty one. I don't recall if it checks for FFS2, but it might, which is DOS7. A FFS partition can be set up from the Linux partitioner, but it may not be able to create DOS7. In any case you will need an RDB partitioned HD with slb_v2 and without a working OS4 CD will be almost impossible to set up. However, can it still boot?

As to my Etch CD, I don't recall seeing that issue before, but it looks like the boot image loaded in is somehow corrupted. Or is missing a root specifier. USB is known to cause trouble on an A1SE. The following added to the boot args will disable it. Also you have "root=/dev/ram" set in boot args?
usbcore.nousb=Y

As you point out, you will still eventually need an updated UBoot, since the slb_v2 boot loader needed won't be able to load and boot OS4.

Last edited by Hypex on 05-May-2017 at 03:53 PM.

 Status: Offline
Profile     Report this post  
NutsAboutAmiga 
Re: Amiga one SE cant install OS 4.0 or Debian
Posted on 5-May-2017 16:38:15
#20 ]
Elite Member
Joined: 9-Jun-2004
Posts: 10558
From: Norway

@pearson101

1 Register your self



2 Register your software.

You find the registration code on cd cover.
If some else has registered the software before, you need transference ownership.



3 Download firmware.



Last edited by NutsAboutAmiga on 05-May-2017 at 04:50 PM.
Last edited by NutsAboutAmiga on 05-May-2017 at 04:45 PM.
Last edited by NutsAboutAmiga on 05-May-2017 at 04:40 PM.

_________________
Please check out my software:
Excalibur, Basilisk 2, AmigaInputAnywhere.
LiveForIt-Music
http://lifeofliveforit.blogspot.no/

 Status: Offline
Profile     Report this post  
Goto page ( 1 | 2 | 3 | 4 Next Page )

[ home ][ about us ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright 2000 - 2017 Amigaworld.net.

Amigaworld.net was originally founded by David Doyle