Click Here
home features news forums classifieds faqs links search
5637 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
52 crawler(s) on-line.
 10 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 umisef:  8 mins ago
 Overflow:  15 mins ago
 pavlor:  27 mins ago
 kamelito:  36 mins ago
 Rob:  54 mins ago
 K-L:  1 hr 37 mins ago
 recedent:  2 hrs 28 mins ago
 SimplePPC:  2 hrs 37 mins ago
 BSzili:  2 hrs 38 mins ago
 jacknife:  3 hrs 4 mins ago

/  Forum Index
   /  Amiga OS4 Software
      /  ignitionOS4
Register To Post

Goto page ( Previous Page 1 | 2 | 3 | 4 | 5 Next Page )
PosterThread
walkero 
Re: ignitionOS4
Posted on 8-Dec-2016 0:02:57
#41 ]
Regular Member
Joined: 4-Mar-2004
Posts: 368
From: Athens

@turbo4.1

This is a great addon. Thanks for that. Looking forward to test it.

_________________
Amiga-Look.org - Beautify your Workbench

 Status: Offline
Profile     Report this post  
Hypex 
Re: ignitionOS4
Posted on 8-Dec-2016 13:15:01
#42 ]
Elite Member
Joined: 6-May-2007
Posts: 9538
From: Greensborough, Australia

@turbo4.1

Okay, but what is it? Amiga app to start my car?

 Status: Offline
Profile     Report this post  
PhantomInterrogative 
Re: ignitionOS4
Posted on 8-Dec-2016 13:26:37
#43 ]
Cult Member
Joined: 10-Sep-2004
Posts: 749
From: The Interrogative Lair

@Hypex

Consider the context of the thread. People are talking about filling cells and ods. You fill cells on car batteries. ODS means "over drive sport." The project is maintained by someone going by the handle "Turbo4.1." So, yes, it is an app to start your car

Last edited by PhantomInterrogative on 08-Dec-2016 at 01:28 PM.
Last edited by PhantomInterrogative on 08-Dec-2016 at 01:27 PM.

_________________
I sold my SAM460ex lite... waiting for money to buy the X5000... or Amiga Reloaded... or an A1222... and OS4.2 FE update 9000

 Status: Offline
Profile     Report this post  
klx300r 
Re: ignitionOS4
Posted on 9-Dec-2016 5:59:31
#44 ]
Elite Member
Joined: 4-Mar-2008
Posts: 3462
From: Toronto, Canada

@turbo4.1

just tried ignition for 1st time and works great on some simple spreadsheets though I did notice that I made an error on a cell and typed 36..3 instead of 36.3 and ignition didn't note the error in the format when adding it to the sum equation? The sum was correct in that ignition just ignored the extra '.' but if the type o was supposed to be another number instead of the '.' I would never have noticed unless I checked the the full column sum manually.

All in all very handy to have on my X1000 natively instead of loading up AmiCygnix for simple spreadsheet stuff.

_________________
____________________________
c64-2sids, A1000, A1200T-060@50(finally working!),A4000-CSMKIII
! My Master Miggies- Amiga 1000 & AmigaOne X1000 !
mancave-ramblings
X1000 I BELIEVE

 Status: Offline
Profile     Report this post  
Hypex 
Re: ignitionOS4
Posted on 9-Dec-2016 15:04:52
#45 ]
Elite Member
Joined: 6-May-2007
Posts: 9538
From: Greensborough, Australia

@PhantomInterrogative

I'm not familiar with ODS. And Turbo4.1 implies OS4.1 will be around for a while running on a fast setup.

But, I didn't read the whole thread, since my point was about the OP.

I imagine myself opening a thread about the latest program I wrote, perhaps with the name in the title, saying a few words and providing a link. That would be nice. But if I failed to describe it many people wouldn't have a clue what I as on about.

I suppose I don't like to click a third party link just to see what something is about. I like to have a brief in front me. Especially when I forget what that program did.

 Status: Offline
Profile     Report this post  
turbo4.1 
Re: ignitionOS4
Posted on 9-Dec-2016 17:00:31
#46 ]
Member
Joined: 23-Jan-2010
Posts: 87
From: north of germany

@walkero
thank you too.
please let me know, what are the results of your tests

_________________
Sam667Flex, CDTV, A600 und CD32
Amiga User since 1987

 Status: Offline
Profile     Report this post  
turbo4.1 
Re: ignitionOS4
Posted on 9-Dec-2016 17:10:24
#47 ]
Member
Joined: 23-Jan-2010
Posts: 87
From: north of germany

@Hypex
ignitionOS4 is a spreadsheet program with an interface for extern "plugins" called "addons". these addons give ignition the possibility to load/save other file-formats then his own.
with this addon ignition now supports the opendocument-fileformat, which is used for example by openoffice-calc.
you now can exchange files with spreadsheet which also supports the ods-format.

if you can start your car with these program, please let me know this and i expand the documentation.

_________________
Sam667Flex, CDTV, A600 und CD32
Amiga User since 1987

 Status: Offline
Profile     Report this post  
turbo4.1 
Re: ignitionOS4
Posted on 9-Dec-2016 17:30:42
#48 ]
Member
Joined: 23-Jan-2010
Posts: 87
From: north of germany

@klx300r
thank you for this bug-report, i can also create this behaviour.
i will fix this with the next release!
hope, you will continue using ignition.

_________________
Sam667Flex, CDTV, A600 und CD32
Amiga User since 1987

 Status: Offline
Profile     Report this post  
klx300r 
Re: ignitionOS4
Posted on 9-Dec-2016 21:21:32
#49 ]
Elite Member
Joined: 4-Mar-2008
Posts: 3462
From: Toronto, Canada

Quote:

turbo4.1 wrote:
@klx300r
thank you for this bug-report, i can also create this behaviour.
i will fix this with the next release!
hope, you will continue using ignition.


my pleasure & thank you for making ignition better & better for AmigaOS4.1 users

_________________
____________________________
c64-2sids, A1000, A1200T-060@50(finally working!),A4000-CSMKIII
! My Master Miggies- Amiga 1000 & AmigaOne X1000 !
mancave-ramblings
X1000 I BELIEVE

 Status: Offline
Profile     Report this post  
Tomppeli 
Re: ignitionOS4
Posted on 9-Dec-2016 23:17:31
#50 ]
Super Member
Joined: 18-Jun-2004
Posts: 1631
From: Home land of Santa, sauna, sisu and salmiakki

@turbo4.1

When I'm quitting Ignition I get a crash with CCCCCCCC memory pointer which means you're releasing the same memory twice or removing a list node twice.

_________________
Rock lobster bit me, so excuse me. If you'll plan to deal with me, be serious !
X1000 + AmigaOS4.1 FE. Be authentic.
"Anyone can build a fast CPU. The trick is to build a fast system." -Seymour Cray

 Status: Offline
Profile     Report this post  
Hypex 
Re: ignitionOS4
Posted on 10-Dec-2016 8:21:53
#51 ]
Elite Member
Joined: 6-May-2007
Posts: 9538
From: Greensborough, Australia

@turbo4.1

Thanks.

I'll let you know if I can start my car with it.

 Status: Offline
Profile     Report this post  
turbo4.1 
Re: ignitionOS4
Posted on 11-Dec-2016 21:28:14
#52 ]
Member
Joined: 23-Jan-2010
Posts: 87
From: north of germany

@Tomppeli
i do not have this failure when i am quit ignition and also my tester do not report such a problem. so i need a little bit help from you.
i think you use 4.1fe and ignition beta4?!
did this happend every time?
if you use ignition.debug, did the grim-reaper also appear?!
if the error also appears, please send me the grim-reaper logfile of the debug version.
thx

_________________
Sam667Flex, CDTV, A600 und CD32
Amiga User since 1987

 Status: Offline
Profile     Report this post  
OneTimer1 
Re: ignitionOS4
Posted on 11-Dec-2016 21:59:07
#53 ]
Regular Member
Joined: 3-Aug-2015
Posts: 464
From: Unknown

@turbo4.1

It looks really great, its one of the few modern programs for AmigaOS.

But please post the screen shots on os4depot as PNG or GIF, using JPG on such pictures generates artefacts and increases size.

Last edited by OneTimer1 on 11-Dec-2016 at 10:01 PM.

 Status: Offline
Profile     Report this post  
broadblues 
Re: ignitionOS4
Posted on 11-Dec-2016 22:05:29
#54 ]
Amiga Developer Team
Joined: 20-Jul-2004
Posts: 4379
From: Portsmouth England

@turbo4.1

Quote:

@Tomppeli
i do not have this failure when i am quit ignition and also my tester do not report such a problem. so i need a little bit help from you.
i think you use 4.1fe and ignition beta4?!
did this happend every time?
if you use ignition.debug, did the grim-reaper also appear?!
if the error also appears, please send me the grim-reaper logfile of the debug version.
thx


The DSI on 0xCCCCCCCC will only occur when using the debug kernel, it's one of it's features that it munges the pointers in nodes once they have been removed. It will mean that you have accessed a node's ln_Pred or ln_Succ after it has been removed from a list (either directly or via a Exec function).

_________________
BroadBlues On Blues BroadBlues On Amiga Walker Broad

 Status: Offline
Profile     Report this post  
turbo4.1 
Re: ignitionOS4
Posted on 12-Dec-2016 18:05:12
#55 ]
Member
Joined: 23-Jan-2010
Posts: 87
From: north of germany

@broadblues
thank you for this information. i start my sam with the debug-kernel and then the grim-appear.
now i am a little bit better programmer

_________________
Sam667Flex, CDTV, A600 und CD32
Amiga User since 1987

 Status: Offline
Profile     Report this post  
turbo4.1 
Re: ignitionOS4
Posted on 12-Dec-2016 18:09:47
#56 ]
Member
Joined: 23-Jan-2010
Posts: 87
From: north of germany

@Tomppeli
the error is located and i have remove this bug. i put it in the archiv of the next release of ignition or in the next addon release.
thank you again for reporting this error!

@all
have someone testing the ods-addon and has something to report?

_________________
Sam667Flex, CDTV, A600 und CD32
Amiga User since 1987

 Status: Offline
Profile     Report this post  
elwood 
Re: ignitionOS4
Posted on 13-Dec-2016 12:38:04
#57 ]
Elite Member
Joined: 17-Sep-2003
Posts: 3417
From: Lyon, France

@turbo4.1

Then you should read this

_________________
Philippe 'Elwood' Ferrucci
Sam460 1.10 Ghz
AmigaOS 4 betatester
Amiga Translator Organisation

 Status: Offline
Profile     Report this post  
lionstorm 
Re: ignitionOS4
Posted on 26-Dec-2016 17:32:57
#58 ]
Super Member
Joined: 31-Jul-2003
Posts: 1557
From: the french side

@turbo4.1

I gave it a try and it works... somehow
I probably did not chose the most basic file but thats the one I have at hand


my file is 2 sheets with some formulas, one picture and formatted text with colors.

- the picture is not shown (that was expected since it is the very first version)
- the colors are gone, as is the formatting (that was expected since it is the very first version)
- the text is having some characters problems : although characters like and are ok, " or ' are shown as " or ' respectively
- the merged text in the ods file is shown as unmerged
- some text are missing
- the loading is slow (25 seconds for a file of 71471 octects)

anyway it is a first shot so you deserve a big thank for this first addon !

PS: I can send you the file anytime if needed.

 Status: Offline
Profile     Report this post  
turbo4.1 
Re: ignitionOS4
Posted on 27-Dec-2016 10:38:06
#59 ]
Member
Joined: 23-Jan-2010
Posts: 87
From: north of germany

@lionstorm
thank you for spend the time to write this report, it is very important for me to get this infomation from the user. i need this to make the addon better and speed up the development!!!

you are make it right! use your typical files to test the ods-addon. remember also other spreadsheet programs can create ods files, not only open- and libre-calc.

the first two points are clear, in the moment these attributes are not converted.
the third i do not understand, i think you mean that wrong characters are shown. maybe this is a problem with the diffferent character-set in france and germany. but normaly this could not be happend, because i use function which respects the charactersets.

problem four and five, i can not explain, maybe it is solved in the version 0.11 which is in the testing phase at the beta-tester. also the problem six maybe solved, some xml-sections in 0.10 are unknown and then the addon runs in a ermergency-break, this creates the long load time.

please sent me the file with a email, when no private data are in it. my email-addres you find in the documentation.

_________________
Sam667Flex, CDTV, A600 und CD32
Amiga User since 1987

 Status: Offline
Profile     Report this post  
lionstorm 
Re: ignitionOS4
Posted on 27-Dec-2016 20:55:39
#60 ]
Super Member
Joined: 31-Jul-2003
Posts: 1557
From: the french side

@turbo4.1

email sent

the original file is a xlsx that I loaded into GoogleDocs and exported from there as ods.
I might try the ods file under amicygnix/GNUmeric to see if how it looks like.

EDIT: just tried to open the ods file with GNUmeric and it fails (the error is XML file not valid) so Intuition performed already better

Last edited by lionstorm on 27-Dec-2016 at 09:04 PM.
Last edited by lionstorm on 27-Dec-2016 at 08:57 PM.

 Status: Offline
Profile     Report this post  
Goto page ( Previous Page 1 | 2 | 3 | 4 | 5 Next Page )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle