Click Here
home features news forums classifieds faqs links search
5619 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Channel: #Amigaworld
Channel Policy and Guidelines

(Uses JAVA Applet and Port 1024)
Visit the Chatroom Website

Who's Online
 76 guest(s) on-line.
 4 member(s) on-line.


outrun1978, Zendarion, Punkyclown, more...

You are an anonymous user.
Register Now!
 Punkyclown:  29 secs ago
 Zendarion:  2 mins ago
 outrun1978:  2 mins ago
 amyren:  2 mins ago
 bennymee:  5 mins ago
 amigasociety:  6 mins ago
 pavlor:  6 mins ago
 samo79:  7 mins ago
 AmeegaGuy:  8 mins ago
 Trixie:  11 mins ago

/  Forum Index
   /  Amiga OS4 Software
      /  [PARTIALLY SOLVED] AmigaInput- Fix for USB UD4, need more info though.
Register To Post

Goto page ( Previous Page 1 | 2 | 3 | 4 | 5 Next Page )
PosterThread
acefnq 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 8:52:25
#21 ]
Cult Member
Joined: 11-Jan-2006
Posts: 617
From: Adelaide, South Australia

@Samwel
First top left, then middle and then bottom right. Have you had any luck inusing it on any games?

ace

 Status: Offline
Profile     Report this post  
Samwel 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 8:58:11
#22 ]
Elite Member
Joined: 7-Apr-2004
Posts: 3396
From: Sweden

@acefnq

No, I don't have any games installed.

But I'll try and download some and try this out. But the swedish translation
is for sure off. It says top right, middle, low right. This makes everything
screwed up in the test box.

What about Z-axis kalibration? Should that say up & down?
As I wrote, my joypad worked right left for this one.

_________________

 Status: Offline
Profile     Report this post  
Samwel 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 9:01:49
#23 ]
Elite Member
Joined: 7-Apr-2004
Posts: 3396
From: Sweden

@Samwel

Hey.. Replying to myself.

There is a huge bug in AmigaInput prefs, I think!
I used KGrach prefs file to get my joypad to get reqognised.
Then kalibrated it, pressed save prefs. Now when I restarted
AmigaInput prefs my joypad is gone.. How so?

_________________

 Status: Offline
Profile     Report this post  
AmiDog 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 9:39:47
#24 ]
Cult Member
Joined: 1-Jun-2004
Posts: 916
From: Kumla, Sweden

@Samwel

The usual way to "fix" AmigaInput prefs problems is to delete the old prefs and configure it again. Using someone elses prefs file is asking for trouble (IMHO).

 Status: Offline
Profile     Report this post  
Samwel 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 9:45:46
#25 ]
Elite Member
Joined: 7-Apr-2004
Posts: 3396
From: Sweden

@AmiDog

Yeah I know. But AmigaInput has a bug that prevents us from using USB
joypads. There is NO WAY I can reqognise my pad without KGrach prefs file.
Also When I open his prefs file for the first time everything is correct.
When I press use or save everything about USB is gone..

EDIT: And yes I have tried to erase all AmigaInput prefs and did a reboot.

Last edited by Samwel on 10-Feb-2006 at 09:47 AM.

_________________

 Status: Offline
Profile     Report this post  
acefnq 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 9:48:59
#26 ]
Cult Member
Joined: 11-Jan-2006
Posts: 617
From: Adelaide, South Australia

@AmiDog

Whilst you are here, do all sdl emulators automatically find "system" attributed joysticks/pads? Or does the emulator need to actively support them. For instance I looked at your emulator and the plugins are definitely not joystick/pad specific. Maybe you don't want to tell us at this stage but is there any real hope of using sticks and pads, believe me this is one thing that would shut most of us up on for a long while -:)

cheers
ace

 Status: Offline
Profile     Report this post  
Serpi 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 11:18:59
#27 ]
Cult Member
Joined: 31-Jul-2003
Posts: 547
From: Germany

@kgrach

Quote:
map your USB joystick to a Gamepad and all will work fine


Do you know which (lowlevel) port is the standard port for gamepads? Is this usually port 0 or port 1 (I think reference would be the CD32, so I think it might be port 0, but on a normal Amiga the mouse plugs into port 0 so it could be port 1)?

Ciao, Alfred

 Status: Offline
Profile     Report this post  
BlackNinja 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 11:38:56
#28 ]
Regular Member
Joined: 2-May-2005
Posts: 123
From: Germany

@kgrach

Thanke my Analog Joystick ist working. But I can not Calibrieren with the new Prefs the Jystick any longer. I have a standard Speed Link Pc Joystick on my AmigaOne this is a gameport Joystick.

 Status: Offline
Profile     Report this post  
Glames 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 11:53:59
#29 ]
Regular Member
Joined: 16-Mar-2003
Posts: 362
From: Nantes, France

@Samwel,

Exactly the same troubles here...

Last edited by Glames on 10-Feb-2006 at 11:54 AM.

_________________
Glames / Boing Attitude :)

 Status: Offline
Profile     Report this post  
AmiDog 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 15:36:31
#30 ]
Cult Member
Joined: 1-Jun-2004
Posts: 916
From: Kumla, Sweden

@acefnq

No idea about SDL, never used it. I've added AmigaInput support to FPSE and VICE (not release yet though). I'll probably add it to more emulators later, but just as all of you, I can't seem to get my USB pad working with upd4, so I've gone back to my upd3 install which has some beta release of AmigaInput.

 Status: Offline
Profile     Report this post  
whose 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 16:15:04
#31 ]
Cult Member
Joined: 21-Jun-2005
Posts: 893
From: Germany

@Samwel

Maybe you are using WookieChat all the time? I have to verify this, but I had the problem with vanishing USB options right after I start WookieChat. Next reboot I can see the USB devices option again (until I start WookieChat). Done that 2 times now, but I think that isn´t enough to clarify this strange behaviour. It seems like something is messing up AmigaInput...

Greetz

 Status: Offline
Profile     Report this post  
wegster 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 17:02:15
#32 ]
Elite Member
Joined: 29-Nov-2004
Posts: 8554
From: RTP, NC USA

@Samwel

Quote:
There is a huge bug in AmigaInput prefs, I think!
I used KGrach prefs file to get my joypad to get reqognised.
Then kalibrated it, pressed save prefs. Now when I restarted
AmigaInput prefs my joypad is gone.. How so?


Similar problems here still, although I am able to get it to show back up by deleting the prefs from ENV:AmigaInput and ENVARC:AmigaInput. I _suspect_ it may mean somethings 'not quite right' in our stick or the USB stack, so basically meaning 'not working with our joysticks/gamepads/etc.' May be wrong, but I've yet to manage to use it with a game, although I can calibrate it fine and it recognizes all the buttons etc.

Last edited by wegster on 10-Feb-2006 at 05:02 PM.

_________________
Are we not done with the same silly arguments and flames yet??!

 Status: Offline
Profile     Report this post  
whose 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 17:39:07
#33 ]
Cult Member
Joined: 21-Jun-2005
Posts: 893
From: Germany

@wegster

WookieChat is out of the line

USB option of AI prefs disappears every time here when I open it for the second time.
No save or use needed, just a simple reopen and the USB option is gone. After a
reboot it appears again (A1, kgrachs prefs file replacement).

When I dare do disconnect the Pad _after_ USB option is disappeared, my machine
crashes immediately. If I don't touch AI prefs, the machine doesn't crash when the
game pad is disconnected.

Perhaps Generic_usb.driver of AI is broken?

Greetz

Last edited by whose on 10-Feb-2006 at 05:41 PM.
Last edited by whose on 10-Feb-2006 at 05:40 PM.

 Status: Offline
Profile     Report this post  
Chris_Y 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 17:43:02
#34 ]
Elite Member
Joined: 21-Jun-2003
Posts: 3130
From: Beds, UK

@wegster/samwel

Exactly the same here. Can get the prefs option (using kgrach's prefs file), calibration works but saving wipes everything out so it doesn't work. I doubt it is a compatibility problem - the stick wouldn't show up in AmigaInput at all if that was the case.

Chris


_________________
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar is Tabitha by Eric W Schwartz

 Status: Offline
Profile     Report this post  
Jorge 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 18:37:55
#35 ]
Cult Member
Joined: 20-Oct-2003
Posts: 657
From: Scottsdale, AZ

@kgrach

Quote:
wipeout 2097 works in OS4 and it supports the cd32 gamepad so map your USB joystick to a Gamepad and all will work fine just rember to disable the opening intro


Yes, thx. It works fine ... I should change my game settings, too, from time to time

_________________

 Status: Offline
Profile     Report this post  
Rob 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 19:18:05
#36 ]
Elite Member
Joined: 20-Mar-2003
Posts: 5752
From: S.Wales

I have an XFX executioner Joypad.

There are a couple of issues. The dpad works in the calibration although only if I press the analog on button and it doesn't work with my games

I've only tested Wipeout and Payback. I can use the left analog stick for controlling th games though.

 Status: Offline
Profile     Report this post  
IceDragon 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 20:26:28
#37 ]
Member
Joined: 4-Mar-2005
Posts: 91
From: Unknown

even with deleting the prefs files, there is no way to get the USB driver to show up.
The only way is to use kgrachs prefs file, but sadly that way i cant actually configure the USB joystick/map it since when i change something and save/use it does not show up anymore so it is useless in that case (Crossfire II cant recognise it).

Any chance to get a fixed AInput once the bug is found ? Would be really cool ! I appreciate the efforts done by the OS4 team, keep it coming !


 Status: Offline
Profile     Report this post  
DoodooHead 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 20:56:57
#38 ]
Cult Member
Joined: 8-Mar-2003
Posts: 641
From: Reno, Nevada, U.S.

@IceDragon

Quote:
Any chance to get a fixed AInput once the bug is found ?


One thing I know for a fact is that Hyperion (a game company) will make sure that we can use joysticks and play games.

_________________
Amiga user since 1985.

 Status: Offline
Profile     Report this post  
FuZion 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 23:35:56
#39 ]
Super Member
Joined: 22-Nov-2003
Posts: 1962
From: Birmingham, England

@all

I seem to have my USB joypad working here. I started by following KGrach tips but now I have my own prefs saved (All buttons recognised & analogue sticks calibrated). It didn't work out like this first time mind. I was having the same problem as most of you. The settings were there, then not.

I had a strange thing happen where I'd boot up, load the AmigaInput prefs & the USB driver would be showing. Without changing anything, I'd close this & reload it, then the USB driver wasn't showing. I wondered if the file in ENV: (Not ENVARC:) was being corrupt so I deleted this & tried again. It kept happening.

After a few boots I got bored of that & tried out Wipeout 2097. Eventually I ended up with Gamepad 0, Joystick 0, Gamepad 1 & Joystick 1 ALL assigned to my joypad. Wipeout now works with the joypad (I think it's using one of the Joystick assigns rather than the Joypad ones).

The only thing I may have done different to what I've read here is assign al those ports.

Another thing, I seem to only be able to use the joypad if it's connected up at boot up. I haven't tried stopping the USB stack & restarting it from a CLI yet.

On a side note, playing games through E-UAE with a controller rather than an emulated joystick on keyboard is nice.

The joypad I am using is, this one.

Personally I'm wondering if there's a USB problem. When I connected this joypad to my A1 under Update 3, the USB 'attachment' window would pop up telling me what I'd connected (As it would with most things I connected). This isn't happening under Update 4. I am also getting no feedback when I connect an MP3 player Standard drive type thing) & a 4 in 1 card reader.

FuZion.

 Status: Offline
Profile     Report this post  
IceDragon 
Re: AmigaInput- Anyone got it working/where are the 'hidden' docs?
Posted on 10-Feb-2006 23:54:25
#40 ]
Member
Joined: 4-Mar-2005
Posts: 91
From: Unknown

@DoodooHead
you're right, and i never really doubted that. You can see that they take this serious by trying to implement a generic solution that works for most common joysticks & gamepads and have flexible remapping (thats really awesome). The thing i was wondering about was if it would be possible to release a single AmigaInput fix for this problem independent of waiting for OS4 final ? But i guess first the problem would need to be identified before asking for a fix :P

 Status: Offline
Profile     Report this post  
Goto page ( Previous Page 1 | 2 | 3 | 4 | 5 Next Page )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright 2000 - 2017 Amigaworld.net.

Amigaworld.net was originally founded by David Doyle