Click Here
home features news forums classifieds faqs links search
5696 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
46 crawler(s) on-line.
 12 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 DiscreetFX:  12 mins ago
 kolla:  15 mins ago
 BigD:  20 mins ago
 NutsAboutAmiga:  25 mins ago
 bennymee:  30 mins ago
 Kronos:  34 mins ago
 _ThEcRoW:  34 mins ago
 Musashi5150:  36 mins ago
 Rob:  40 mins ago
 megol:  46 mins ago

/  Forum Index
   /  Amiga OS4 Hardware
      /  "Exodus The Last War" in OS 4.1 installed?
Register To Post

Goto page ( Previous Page 1 | 2 )
PosterThread
Gebrochen 
Re: Anybody has installed "Exodus The Last War" in OS 4.1?
Posted on 9-Apr-2009 8:23:15
#21 ]
Super Member
Joined: 23-Nov-2008
Posts: 1410
From: Australia, VIC

@Nitro and @ Templario

all I can say is this, I got Exodus The Last War working on my SAM and OS4.1

Should I repeat that again, a third time?

Anyway

templario, perhaps your rtgmaster, etc are ld versions, please make sure to have the latest libraries installed.

Another note, as Hypex mentions, if the cd device you place in there is incorrect, exodus will freeze or hang your system.

I wish I could just do it for you, that way all these communication errors wouldnt be happening, and I could see what it is doing LIVE!

Cheers.

_________________
Courtesy of SAM440Flex & Amiga OS4.1 only
CD32 / SX1 Expansion
A500 with HxC & 1mb Chip Ram, Flicker Fixer Box
C=OS (Usa) Laptops
MorphOS PowerBook G4
AROS / AmiPUP Netbook
A1000 with 1.5MB RAM.
https://blitterwolf.blogspot.com

 Status: Offline
Profile     Report this post  
Templario 
Re: Anybody has installed "Exodus The Last War" in OS 4.1?
Posted on 9-Apr-2009 11:20:04
#22 ]
Elite Member
Joined: 22-Jun-2004
Posts: 3432
From: Palencia (Spain)

@Gebrochen

Hey, that I don't say nothing now I have stopped because I'm doing other things more importants, for example testing the Eye Viewer in my Sam, when I'' can I'll try it.

_________________
Amiga 500 with ROMs 1.3-2.05 and M-Tec AT500 with hard disk and 4MB Ram.
WinUAE + original OS 3.5&3.9
Sam440ep 800 MHZ + OS 4.1 F.E.
Sam460ex 1 GHz + OS 4.1 F.E.
MacMini 1.5 GHz + MorphOS 3.12
PowerBook G4 1.65 + MorphOS 3.12

 Status: Offline
Profile     Report this post  
Gebrochen 
Re: Anybody has installed "Exodus The Last War" in OS 4.1?
Posted on 10-Apr-2009 12:39:04
#23 ]
Super Member
Joined: 23-Nov-2008
Posts: 1410
From: Australia, VIC

@Templario

Eye viewer, interesting.

Im using AmiPhoto. But recently have decided to test out all of the amiCygnix programs, and I find them relatively nice. I am also trying to get various other things working also, should be fun when they do.

as for exodus, I had double checked, and the Patch I have is version 2.1

Well, If all odds fail, you can always try Earth 2140, which I also have working.
Or Moonbases.
Or Warcraft 2
Or Heroes of might and magic 2

Or just get something like Battle for wesnoth, thats also nice gameplay and effects. I noticed slght differences between the windows version and the Amiga version, that after playing both, the amiga version had some nicer attack effects with the mages and so forth.

But one that everybody seems to really struggle with to get working, (I dont think anyone has yet) Is Napalm game on OS4.1.

Man, this game Napalm is a ***** to get working, and no, not yet, but I plan to try again at a later stage.

Cheers.

I really hope you love your sam and os4.1 like I do, its awesome. Only hope they come out with hardware this year still, that is beyond 1 ghz, something like 1.2 or 1.6 would be ACE indeed.

Even if they decided upon a laptop next year, after releasing a 1.6ghz or so desktop this year.

_________________
Courtesy of SAM440Flex & Amiga OS4.1 only
CD32 / SX1 Expansion
A500 with HxC & 1mb Chip Ram, Flicker Fixer Box
C=OS (Usa) Laptops
MorphOS PowerBook G4
AROS / AmiPUP Netbook
A1000 with 1.5MB RAM.
https://blitterwolf.blogspot.com

 Status: Offline
Profile     Report this post  
Hypex 
Re: Anybody has installed "Exodus The Last War" in OS 4.1?
Posted on 10-Apr-2009 14:49:01
#24 ]
Elite Member
Joined: 6-May-2007
Posts: 9637
From: Greensborough, Australia

@Templario

Okay, then try this. Erase the device name and save it. Now try running it. It should say there is no cdda device. Continue and you should get to the game. But without CD music I guess.

I've only tried a demo here and it works. Well it crashes when it runs but it starts up which is what you want.

 Status: Offline
Profile     Report this post  
Cool_amigaN 
Re: Anybody has installed "Exodus The Last War" in OS 4.1?
Posted on 20-Aug-2011 15:52:47
#25 ]
Super Member
Joined: 6-Oct-2006
Posts: 1189
From: Athens/Greece

@Templario

I am reviving this old thread to report my own findings and progress.

System: SamEp440 667Mhz, 512MB Ram, M9
OS: Vanilla setup of AOS4.1 U2.

First I've downloaded the "Installer" replacement from aminet.

Downloaded the updated installation script (patch) of Exodus.

* Note that the default installation from Exodus CD is broken and won't work with OS4.1.2.

After running the updated installation I 've got also my graphics patched.

* Note that by the end of the procedure (and after I've received a message that everything was done correctly), the installation will freeze my system, no matter what I choose (e.g. close the gagdet or click ok, etc) and I have to hard reboot.

Copied from the Exodus Update to Exodus drawer the file named "Setup".

* Note that by executing the default one, and after filling up the details, you will have a new system freeze whether you choose "Save" and/or "Cancel".

* Note that the version number remained 2.0 even though I had replaced it with 2.1.

* Note that even version 2.1 "Setup" will freeze the system if you choose "Cancel". So even if you type something wrong, you must always select "Save".

When typing information to the cdda row you must always press "ENTER" in order for the Setup to understand it and later save it.

I have tried running the game via 2 different methods:

1) Made an Image of the cd, copied to hd, mount it by diskimage (last version) and typed the following to setup "diskimage.device","4".

- By executing Exodus I was getting the following error: "unable to open cdda device or Exodus is missing"

2) Inserted the CD to the cd-rom and added the following to Setup utility "sii3114ide.device","3".

Now, I am able to run the game with the following minor problems:

a) I cannot playback the intro. In order to avoid the error message you have to select "Skip intro" in the setup utility.

b) I am getting the error "unable to open null modem", even though I had tried adding different network devices of my Sam. No solution yet.

c) I cannot hear the music of the game even though the SFX works well and I have selected from ingame options to play the music. No solution yet.

d) I am receiving DSI error right after clicking the main executable of Exodus. In order to proceed I have to "Ignore" them.

Overal

To me, it seems that a) The installer (even the updated) is still broken, causing system freeze, b) Setup utility is still bugged and c) The game has still some OS4 related bugs.

That's a work for the author that tries to fix currently Napalm imho. Perhaps he could try afterwards to iron out those bugs.

Ingame though runs pretty much stable and Save/Load state works as well, although I haven't tested it extensively.

EDIT: In case you run into unexpected troubles, other than the above, an additional installation technique is to browse at Exodus CD, copy main exodus drawer (big drawer containing graphics etc) into your HD. Unpack patch (new installtion script) into the same dir and execute from there. E.g:
DH1:Games/Test/
--Exodus
--Installation
This will create later a new drawer (e.g. DH1:Games/Exodus) with patched graphics. Unzip the Setup v 2.1, fill in the details, place the cd into the cd-rom and play.

Last edited by Cool_amigaN on 20-Aug-2011 at 06:07 PM.
Last edited by Cool_amigaN on 20-Aug-2011 at 03:55 PM.

_________________

 Status: Offline
Profile     Report this post  
Severin 
Re: Anybody has installed "Exodus The Last War" in OS 4.1?
Posted on 20-Aug-2011 18:12:27
#26 ]
Elite Member
Joined: 18-Aug-2003
Posts: 2740
From: Gloucestershire UK

@Cool_amigaN

I totally agree, I just tried installing it and got even worse results. I couldn't find the updated install script so installed everything manually before running the update stuff. So far exodus was a total waste of money, I've never got the game to do anything.

_________________
OS4 Rocks
X1000 beta tester, Sam440 Flex (733)

Visit the Official OS4 Support Site for more help.

It may be that your sole purpose is to serve as a warning to others.

 Status: Offline
Profile     Report this post  
Cool_amigaN 
Re: Anybody has installed "Exodus The Last War" in OS 4.1?
Posted on 20-Aug-2011 20:27:21
#27 ]
Super Member
Joined: 6-Oct-2006
Posts: 1189
From: Athens/Greece

@Severin

Indeed the game is broken/misbehaving. Honestly, I haven't heard anyone else, other than Gebrochen, to have it fully functional on OS4.x and don't know if he tried playing with update 2 at all.

IMHO, it's wrong for web stores (e.g. AmigaKIt) to present the game as OS4.x fully supported where the truth is that it is partially compatible and only playable with crippled features (no network, no music, no intro).

OTOH, the errors I mention above should be trivial to fix compared to the Napalm patch that currently is being developed.

The good part is that, as I stated above:
- Save/Load works
- Controlling/moving units works
- Display works correctly (M9 640x480 CLUT8 in Fullscreen).

* Although I would have to repeat that I haven't tested for more than 1 hour.

I will patiently wait for alkfil to finish his job on Napalm and afterwards I will suggest him to help us, if can/wants of course.

:)

_________________

 Status: Offline
Profile     Report this post  
Reth 
Re: Anybody has installed "Exodus The Last War" in OS 4.1?
Posted on 20-Aug-2011 20:54:21
#28 ]
Regular Member
Joined: 28-Jun-2005
Posts: 185
From: Germany

I already mentioned it in another thread, the game works fine for me on PegII AOS4.1.2 - though I do not know how I installed it once (but I think I used the game installer and the GFX converter + update afterwards).
The anims are not played and an appropriate error message occurs. After starting the game a GR occurs which I always ignore. Afterwards the game works fine!

 Status: Offline
Profile     Report this post  
Toaks 
Re: Anybody has installed "Exodus The Last War" in OS 4.1?
Posted on 20-Aug-2011 21:32:47
#29 ]
Elite Member
Joined: 10-Mar-2003
Posts: 8040
From: amigaguru.com

@Cool_amigaN

to get cdda (MUSIC) working you will need to hook up the cd audio cable on your cdrom to the soundcard, its quite obvious but a lot of people seem to forget about that.

as for running the game with today's OS4 state seems to be harder, seems so indeed but i managed to get it working here.

that said, shame that this game has proved to be a pain in the ass regarding OS4 :(

i know the author of the game and worked closely with him to get the game working better with os4 final all thoose moons back...


lets hope next os4 update solves a few issues but i wouldnt bet on it since the game ain't really all that system friendly afterall :(


_________________
See my blog and collection website! . https://www.blog.amigaguru.com

 Status: Offline
Profile     Report this post  
ribdevil 
Re: Anybody has installed "Exodus The Last War" in OS 4.1?
Posted on 20-Aug-2011 22:01:27
#30 ]
Regular Member
Joined: 22-Jan-2010
Posts: 260
From: Vigo - Galicia - Spain

@Cool_amigaN

Well, I make the same like you, and the same results except :

The music works for me, I have an IDE DVD rewriter with a converter and a cable to the Live 5.1 Soundcard

I make a CD Image and the game works fine from there.

So, the error is the GrimRipper at the begin, but the rest works.

My system is a SAM 440Flex at 800 with 1 GB RAM and Radeon 9250 512Mb

 Status: Offline
Profile     Report this post  
Templario 
Re: Anybody has installed "Exodus The Last War" in OS 4.1?
Posted on 20-Aug-2011 22:14:24
#31 ]
Elite Member
Joined: 22-Jun-2004
Posts: 3432
From: Palencia (Spain)

@Cool_amigaN
I don't test this game in my new SAMex, because now only I play to Battle for the Wesnoth and programming my next game in Hollywood.

_________________
Amiga 500 with ROMs 1.3-2.05 and M-Tec AT500 with hard disk and 4MB Ram.
WinUAE + original OS 3.5&3.9
Sam440ep 800 MHZ + OS 4.1 F.E.
Sam460ex 1 GHz + OS 4.1 F.E.
MacMini 1.5 GHz + MorphOS 3.12
PowerBook G4 1.65 + MorphOS 3.12

 Status: Offline
Profile     Report this post  
Cool_amigaN 
Re: Anybody has installed "Exodus The Last War" in OS 4.1?
Posted on 20-Aug-2011 22:30:35
#32 ]
Super Member
Joined: 6-Oct-2006
Posts: 1189
From: Athens/Greece

@Toaks

I have a sata dvd and using the onboard sound chip. That said, I *can* play/hear the music tracks if I choose them individualy by opening TuneNet and browsing to the Exodus's CD, selecting Track01,02,03 etc aiff. I think the problem is caused by a bug not a hardware connection problem.

IMHO the game has more potential than Napalm (to my eyes it has a hell lot better gfx than Napalm for example), but it was always hard to make it run flawlessly on any Amiga configuration (classic, OS4, MOS) I tried.

I really hope someone skilled enough can pick up the binary, installation script and setup configuration utility and patch them appropiately.

_________________

 Status: Offline
Profile     Report this post  
ChrisH 
Re: Anybody has installed "Exodus The Last War" in OS 4.1?
Posted on 21-Aug-2011 9:17:52
#33 ]
Elite Member
Joined: 30-Jan-2005
Posts: 6673
From: Unknown

@Cool_amigaN Quote:
I think the problem is caused by a bug not a hardware connection problem.

From what has been said, I think it is not a bug, but rather your machine's CD *analogue* audio is not wired-up (despite *digital* playback of CD tracks working). You can prove this by trying to play the CD's music tracks with analogue output using Sys:Utilities/PlayCD.

Beware that CD audio can be played two ways, analogue & digital:

1. Analogue is the old way, and requires that your CD drive (a) has analogue outputs (modern SATA drives often do not!), and (b) that the analogue outputs are connected to your soundcard (the Sam440 does actually have such an audio mixing connector - J14). PlayCD only works with this method.

2. Digital is the modern way, which AmigaOS4 does not fully support. Yes, OS4 can treat an audio CD as a collection of AIFF music files, so you can play it with TuneNet/etc. But software/games which try to make the CD drive itself play the music (by sending it a "play track N" command) won't work digitally (it still uses the old analogue way). What OS4 needs is a software compatibility layer that intercepts those "play track N" commands, and then emulates analogue CD playback using digital methods (i.e. tells a hidden music program to play a certain AIFF track).

I guess that no-one has bothered to add such a compatibility layer yet, because:
1. There are few games which use CD music.
2. Until a few years ago most CD drives has analogue audio output. However that is no-longer the case (typically SATA drives don't have analogue output), and I had to resort to using an old IDE drive to get analogue output, along with an IDE-to-SATA adapter to make it work in my Sam440.

_________________
Author of the PortablE programming language.
I can usually be found on www.Amigans.net (my favourite Amiga forum).
It is pitch black. You are likely to be eaten by a grue...

 Status: Offline
Profile     Report this post  
Cool_amigaN 
Re: Anybody has installed "Exodus The Last War" in OS 4.1?
Posted on 21-Aug-2011 9:49:41
#34 ]
Super Member
Joined: 6-Oct-2006
Posts: 1189
From: Athens/Greece

@ChrisH

Thanks for dropping by! Yes, you are right! I cannot hear the music via PlayCD. I pressumed that there was a compatibility layer such as the one you describe. Unfortunately I have a SATA dvd so I suppose that without an IDE one I have no hope for the being.

Last edited by Cool_amigaN on 21-Aug-2011 at 09:51 AM.

_________________

 Status: Offline
Profile     Report this post  

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle