Click Here
home features news forums classifieds faqs links search
5763 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Channel: #Amigaworld
Channel Policy and Guidelines

(Uses JAVA Applet and Port 1024)
Visit the Chatroom Website

Who's Online
 66 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 tonyw:  9 mins ago
 Tuxedo:  11 mins ago
 michalsc:  14 mins ago
 Fl@sh:  16 mins ago
 cip060:  24 mins ago
 BigD:  30 mins ago
 Rob:  31 mins ago
 tlosm:  34 mins ago
 matthey:  36 mins ago
 utri007:  44 mins ago

/  Forum Index
   /  Amiga OS4 Software
      /  Open URL SOLVED
Register To Post

PosterThread
sicky 
Open URL SOLVED
Posted on 21-Jul-2012 14:47:00
#1 ]
Elite Member
Joined: 11-Mar-2003
Posts: 2795
From: Essex, UK

Hi all, been trying to get OpenURL to work with AmiPad and Simplemail but doesn't fully work!

I have tried to get working with following settings within OpenURL Prefs:

Name: MUIOWB
Path: OS4.1:Internet/muiowb/owb
ARexx port: OWB.1

Show: SHOW
To front: SCREENTOFRONT
Open URL: OPEN NAME "%u" NEWPAGE
New window: OPENURL "%u"

MUIOWB launches but does not go to website!

Are these setting correct, I have the same issue with AmiPad and Simplmail and clicking on a URL link within a mail and trying to get MUIOWB to show link?

Is there something I have set wrong?

Last edited by sicky on 21-Jul-2012 at 07:06 PM.

_________________
SAM 460 with 2GB or RAM, 1000GB HD, 4 port SATA, DVDRW drive and Radeon HD 4650 GFX card.

 Status: Offline
Profile     Report this post  
number6 
Re: Open URL
Posted on 21-Jul-2012 14:54:07
#2 ]
Elite Member
Joined: 25-Mar-2005
Posts: 10345
From: In the village

@sicky

Quote:
Path: OS4.1:Internet/muiowb/owb


Mine - space after path then "%u"

Quote:
Open URL: OPEN NAME "%u" NEWPAGE


Mine without "NEWPAGE"

Quote:
New window: OPENURL "%u"


Mine - no entry

Quote:
ARexx port: OWB.1


From the docs:

Quote:
The ARexx portname should be set to "BROWSER" even for
browsers that call their ports "BROWSER.1", "BROWSER.2", etc.
The library will look for any port named "BROWSER.x" where
"x" is a number and ".x" is optional.


Dunno if this will work for you, since my setup is different.

#6

Last edited by number6 on 21-Jul-2012 at 03:42 PM.
Last edited by number6 on 21-Jul-2012 at 02:57 PM.

_________________
This posting, in its entirety, represents solely the perspective of the author.
*Secrecy has served us so well*

 Status: Offline
Profile     Report this post  
ribdevil 
Re: Open URL
Posted on 21-Jul-2012 15:42:17
#3 ]
Regular Member
Joined: 22-Jan-2010
Posts: 251
From: Vigo - Galicia - Spain

@number6

I have the same problem, now it works fine.

Thanks so much.

 Status: Offline
Profile     Report this post  
sicky 
Re: Open URL
Posted on 21-Jul-2012 17:51:43
#4 ]
Elite Member
Joined: 11-Mar-2003
Posts: 2795
From: Essex, UK

@number6

After applying your settings it all works for both AmiPad and Simplemail now

I thank you very much, this is what the Amiga community is all about, helping each other

_________________
SAM 460 with 2GB or RAM, 1000GB HD, 4 port SATA, DVDRW drive and Radeon HD 4650 GFX card.

 Status: Offline
Profile     Report this post  
Swoop 
Re: Open URL
Posted on 22-Jul-2012 16:18:39
#5 ]
Elite Member
Joined: 20-Jun-2003
Posts: 2085
From: Long Riston, East Yorkshire

@sicky

Does this work with Timberwold-RC1?

_________________
Peter Swallow.
A1XEG3-800 [IBM 750FX PowerPC], running OS4.1FE, using ac97 onboard sound.

"There are 10 types of people in the world: those who understand binary, and those who don't."

 Status: Offline
Profile     Report this post  
sicky 
Re: Open URL
Posted on 22-Jul-2012 18:56:26
#6 ]
Elite Member
Joined: 11-Mar-2003
Posts: 2795
From: Essex, UK

@Swoop

Quote:
Does this work with Timberwold-RC1?


Apparently so, someone over at Amigans.net says he's got it working with Timberwolf and not MUIOWB!

_________________
SAM 460 with 2GB or RAM, 1000GB HD, 4 port SATA, DVDRW drive and Radeon HD 4650 GFX card.

 Status: Offline
Profile     Report this post  
scabit 
Re: Open URL
Posted on 22-Jul-2012 19:36:01
#7 ]
Super Member
Joined: 8-Jan-2005
Posts: 1664
From: Satellite Beach, FL USA

@number6

Quote:
The ARexx portname should be set to "BROWSER" even for
browsers that call their ports "BROWSER.1", "BROWSER.2", etc.
The library will look for any port named "BROWSER.x" where
"x" is a number and ".x" is optional.


Does that mean I should call the AREXX port OWB or literally BROWSER

I assume that BROWSER is just a generic name for whatever browser you are using, so the entry should be OWB. Is that correct?

Scott

_________________
AmigaOne uA1-c 512M RAM - Only Amiga Makes It Possible!
Check my blog AmigaOne Computing

 Status: Offline
Profile     Report this post  
number6 
Re: Open URL
Posted on 22-Jul-2012 19:40:55
#8 ]
Elite Member
Joined: 25-Mar-2005
Posts: 10345
From: In the village

@scabit

Quote:
I assume that BROWSER is just a generic name for whatever browser you are using, so the entry should be OWB. Is that correct?


Yes.

Name:Browser name.

But since the other lines indicate path, ARexx port, etc. I'm not sure "Name" is anything more than a personal label you give each browser.
I'm sure someone could confirm or deny that with a quick test.

#6

_________________
This posting, in its entirety, represents solely the perspective of the author.
*Secrecy has served us so well*

 Status: Offline
Profile     Report this post  

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright 2000 - 2017 Amigaworld.net.

Amigaworld.net was originally founded by David Doyle