Click Here
home features news forums classifieds faqs links search
5752 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
65 crawler(s) on-line.
 16 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 kamelito:  18 mins ago
 gdg:  23 mins ago
 amisteph:  34 mins ago
 terminills:  43 mins ago
 BigD:  50 mins ago
 MEGA_RJ_MICAL:  54 mins ago
 Vidar:  1 hr 9 mins ago
 paolone:  1 hr 13 mins ago
 Paul:  1 hr 17 mins ago
 Dragster:  1 hr 27 mins ago

/  Forum Index
   /  Classic Amiga Hardware
      /  Lost Compact Flash Drive Partitions - Sorted.
Register To Post

PosterThread
Gemmstone4291 
Lost Compact Flash Drive Partitions - Sorted.
Posted on 22-May-2020 8:00:33
#1 ]
New Member
Joined: 18-Jun-2017
Posts: 8
From: Unknown

I need help big-time.

I completely messed up partitioning my 4Gb CF. Drive I installed from Amigakit.

Basically I created a bootable partition on DH0: and a second as DH1: but I think there were 2 x colons in the names. I re-booted and all I got was a blank screen.

Ran my WB 3.0 and it loads fine but the CF drive partitions are not visible.I tried running the supplied install disk provided by Amigakit but it has a read error (stored in plastic box in dry conditions). My 20 year old floppy disks mostly work fine! Tried running quarterback and an old WB 1.3 HD install disk with no joy.

Any help or advice gratefully received. I have emailed Amigakit too but haven't had a reply yet. I'm probably looking at getting another CF and starting again.

I run an A1200, 4 Mb extended ram and I believe Kickstart rom 39.

UPDATE. Managed to install HDTools to floppy, partitioned CF drive x3 and restored 45 x disks via Quarterback that was last backed up In 1995! Only 4 disks had slight corrupt sectors; 2 of which were fonts.

Thanks to everyone who has pointed me in the right direction. Final act is to restore MagicMenu.

Last edited by Gemmstone4291 on 24-May-2020 at 06:04 PM.
Last edited by Gemmstone4291 on 24-May-2020 at 05:59 PM.
Last edited by Gemmstone4291 on 22-May-2020 at 08:03 AM.
Last edited by Gemmstone4291 on 22-May-2020 at 08:01 AM.

 Status: Offline
Profile     Report this post  
thomas 
Re: Lost Compact Flash Drive Partitions.
Posted on 22-May-2020 11:54:26
#2 ]
Super Member
Joined: 28-May-2003
Posts: 1123
From: Germany

@Gemmstone4291

Which program did you use to create these partitons? I'd suggest to use that very same program again.

If you say your old 3.0 disks still work, you can also use the Install3.0 disk and run HDToolbox from the HDTools directory.

_________________
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de

 Status: Offline
Profile     Report this post  
Gemmstone4291 
Re: Lost Compact Flash Drive Partitions.
Posted on 22-May-2020 12:05:03
#3 ]
New Member
Joined: 18-Jun-2017
Posts: 8
From: Unknown

@thomas

Hi Thomas. My Workbench 3.0 is the original disk set and doesn't have any install option nor HDtools. The disk supplied with CF is corrupt.

My fault - tried to be too ambitious.

Last edited by Gemmstone4291 on 22-May-2020 at 12:05 PM.

 Status: Offline
Profile     Report this post  
thomas 
Re: Lost Compact Flash Drive Partitions.
Posted on 22-May-2020 12:53:52
#4 ]
Super Member
Joined: 28-May-2003
Posts: 1123
From: Germany

@Gemmstone4291

Do you have a means to transfer files from the internet to your Amiga? This one should be helpful: http://aminet.net/package/disk/misc/hdinst

_________________
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de

 Status: Offline
Profile     Report this post  
Gemmstone4291 
Re: Lost Compact Flash Drive Partitions.
Posted on 22-May-2020 13:14:07
#5 ]
New Member
Joined: 18-Jun-2017
Posts: 8
From: Unknown

@thomas

Hi Thomas.

Thanks for the link. I'll see what I can do.

Many thanks,

Graham

 Status: Offline
Profile     Report this post  
Hypex 
Re: Lost Compact Flash Drive Partitions.
Posted on 22-May-2020 17:55:39
#6 ]
Elite Member
Joined: 6-May-2007
Posts: 9973
From: Greensborough, Australia

@Gemmstone4291

The Install disk should have HDToolbox. And IIRC an installer. I'm always using the install disk a lot as it boots quickly compared to Workbench which is slow.

 Status: Offline
Profile     Report this post  
Gemmstone4291 
Re: Lost Compact Flash Drive Partitions.
Posted on 22-May-2020 19:27:30
#7 ]
New Member
Joined: 18-Jun-2017
Posts: 8
From: Unknown

@Hypex

G'day.

Thanks for your post. I have triple-checked all my WB 3.0 disks. HDToolbox isn't on them. This includes all the original disks.

I used crossdos to transfer hdinsttools to a floppy disk. I now just need a lha archive utility to unpack hdinsttools. My 3 versions of lha don't work.....My job for tomorrow.

Regards, Graham.

 Status: Offline
Profile     Report this post  
thomas 
Re: Lost Compact Flash Drive Partitions.
Posted on 22-May-2020 19:43:23
#8 ]
Super Member
Joined: 28-May-2003
Posts: 1123
From: Germany

@Gemmstone4291

This is the one you need: http://aminet.net/package/util/arc/lha

_________________
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de

 Status: Offline
Profile     Report this post  
Gemmstone4291 
Re: Lost Compact Flash Drive Partitions.
Posted on 22-May-2020 21:06:44
#9 ]
New Member
Joined: 18-Jun-2017
Posts: 8
From: Unknown

@thomas

Thanks again Thomas.

 Status: Offline
Profile     Report this post  
Hypex 
Re: Lost Compact Flash Drive Partitions.
Posted on 23-May-2020 18:39:58
#10 ]
Elite Member
Joined: 6-May-2007
Posts: 9973
From: Greensborough, Australia

@Gemmstone4291

I just checked and HDToolbox is found in the HDTools drawer of the Install disk. However, that was on a 3.1 disk. I don't recall any major changes between 3.0 and 3.1. So it should be there.

I know about the LhA stuck problem when transferring from a PC disk. We had less trouble before PCs took over. An easy way was to create a self extracting archive. Just run it and go. But of course you need another AmigaOS for that. More common before PCs took over.

 Status: Offline
Profile     Report this post  
Gemmstone4291 
Re: Lost Compact Flash Drive Partitions.
Posted on 23-May-2020 19:51:34
#11 ]
New Member
Joined: 18-Jun-2017
Posts: 8
From: Unknown

@Hypex

Hi there.

Appreciate your observations and efforts but my set of WB 3.0 doesn't have HDTools or any form of install option on them at all. I believe the tools were pre-loaded on my original hard drive.

I have checked every file and folder and so far my attempts have been unsuccessful. I'm currently still stuck getting arc to extract as I haven't got anywhere to save it other than RAM.

A few tinnies tonight, a bit more research and another attempt tomorrow. Be great if someone out there could send me a copy of Amikit OS Install floppy.

Graham

 Status: Offline
Profile     Report this post  
Hypex 
Re: Lost Compact Flash Drive Partitions.
Posted on 25-May-2020 17:57:49
#12 ]
Elite Member
Joined: 6-May-2007
Posts: 9973
From: Greensborough, Australia

@Gemmstone4291

If the tools are preloaded that could explain it. Though I'm not aware of any HD install missing out on HDToolbox sitting in the Tools drawer. That would be more broken than a missing Installer. You can't edit or examine what partitions there are.

I read somewhere that not all floppy disks were included if the HD was pre-loaded .

If an Install disk is missing that would be what you needed. As that was the only floppy I found it on. You at least have a substitute on Aminet.

Last edited by Hypex on 26-May-2020 at 05:59 PM.

 Status: Offline
Profile     Report this post  
Gemmstone4291 
Re: Lost Compact Flash Drive Partitions.
Posted on 29-May-2020 13:15:50
#13 ]
New Member
Joined: 18-Jun-2017
Posts: 8
From: Unknown

@Hypex

Hi,

I'm finally back up and running. I restored my WB 3.0 from quarterback all the way from 1994 and all my magic WB and icons have returned. Loads rapidly too.

My final act will be to edit the start-up and reinstall games in their own partition.

G

 Status: Offline
Profile     Report this post  
Hypex 
Re: Lost Compact Flash Drive Partitions.
Posted on 29-May-2020 18:01:37
#14 ]
Elite Member
Joined: 6-May-2007
Posts: 9973
From: Greensborough, Australia

@Gemmstone4291

Well done.

I tried Quaterback in the day.

But my backup collection consists of LhA and AmiBack files.

 Status: Offline
Profile     Report this post  

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle