Click Here
home features news forums classifieds faqs links search
6050 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
» Home
» Features
» News
» Forums
» Classifieds
» Links
» Downloads
Extras
» OS4 Zone
» IRC Network
» AmigaWorld Radio
» Newsfeed
» Top Members
» Amiga Dealers
Information
» About Us
» FAQs
» Advertise
» Polls
» Terms of Service
» Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
19 crawler(s) on-line.
 12 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 VooDoo:  21 mins ago
 BigD:  23 mins ago
 DiscreetFX:  40 mins ago
 kolla:  55 mins ago
 Karlos:  56 mins ago
 BuLa:  1 hr 53 mins ago
 pixie:  2 hrs 15 mins ago
 clint:  2 hrs 34 mins ago
 Templario:  2 hrs 50 mins ago
 terminills:  2 hrs 59 mins ago

hardware OS4   hardware OS4 : New AmigaOne firmware update available
   posted by Rogue on 5-Mar-2005 14:20:09 (19191 reads)
Leuven, Belgium - 3. March, 2005

Hyperion Entertainment is pleased to announce the immediate availability of a new AmigaOne firmware update for registered customers of AmigaOS 4.0. New features in this release include

- Improvements in the x86 BIOS emulator
- Reworked IDE/ATA-Code with better support of multiple IDE controllers
- Preliminary support for the Catweasel Mark IV controller by Individual Computers
- Ability to choose graphics card for booting
- Multiple bugs fixed, including a wrong IRQ assignment for AGP graphics cards (Vertical Blanking interrupts should now function correctly)

The update can be downloaded from the file area on Hyperion Entertainment's website.
    

STORYID: 2138
Related Links
· More about hardware OS4
· News by Rogue


Most read story about hardware OS4
20 Answers with Alan Redhouse of Eyetech

Last news about hardware OS4
Sam460LE updates
Printer Friendly Page  Send this Story to a Friend

Goto page ( 1 | 2 | 3 | 4 | 5 | 6 | 7 )

PosterThread
Anonymous 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 10:10:12
# ]



Hmm, help?

I missed the slb readme as well. So I tried booting an old formware update cd to go back to an old uboot but this command just doesn't work:

diskboot 500000 2:0 1

It just says device 2 not available. I have a paralell sil device. And the CDROM is on device 2.

So I decided to try booting the os4 update CD instead. But I can't get it to boot from the CD. Boota doesn't work. I can't change the default boot device in the menu system, it just resets back to the onboard ide device.

So what do I do?

Ps. Why not provide one singe readme in the root level sayign READTHISORDIE or something instead of hiding it away in some sub directory?

/Björn

 
     Report this post  
GregS 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 10:22:53
#82 ]
Super Member
Joined: 28-Apr-2003
Posts: 1797
From: Perth Australia

Thank you Hyperion.

After a little fiddling about my boot time from pushing the power button to the time that AmigaOS4 is ready to use is now just 38 seconds!

I could shave even that down by two seconds, and I am sure if I really knew what I was doing it could get even lower.

UBoot is marvelous, I sit looking at my XP machine which does all sorts of things I have no control over and where the kids have got so many startups in the registry and hell knows where that I have to purge the threads once it is eventually going and then I come to a 38 second cold bootup -- its just magic, moreover that even I can get my head around Uboot and could see how I could style it for specific needs.

Great work, -- please let the next update come realy soon.... it just gets better and better.


_________________
Greg Schofield, Perth Australia

 Status: Offline
Profile     Report this post  
Mufa 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 10:31:23
#83 ]
Member
Joined: 24-Jan-2004
Posts: 70
From: Poland

Now my problem is only the long BUS 0: timeout because I have a PCI IDE, otherwise no bother.

Menu > Intergated Peripherals > Internal IDE Controller: Disabled

 Status: Offline
Profile     Report this post  
Rogue 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 10:31:33
#84 ]
OS4 Core Developer
Joined: 14-Jul-2003
Posts: 3999
From: Unknown

Quote:
It just says device 2 not available. I have a paralell sil device. And the CDROM is on device 2.


Have you tried "ide reset"? If the CD was not in the drive when you switched on, it would not be recognized in U-Boot.

Quote:
Boota doesn't work. I can't change the default boot device in the menu system, it just resets back to the onboard ide device.


Try the following from the U-Boot prompt

setenv boot1 psii (or psiicdrom if you want to boot from the CD)
boota

and see if that works.

Quote:
Why not provide one singe readme in the root level sayign READTHISORDIE or something instead of hiding it away in some sub directory?


Last-minute addition. I thought that if people would find the slb they would also find the readme for that...


_________________
Seriously, if you want to contact me do not bother sending me a PM here. Write me a mail

 Status: Offline
Profile     Report this post  
GregS 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 10:35:26
#85 ]
Super Member
Joined: 28-Apr-2003
Posts: 1797
From: Perth Australia

@mufa
Quote:
Menu > Intergated Peripherals > Internal IDE Controller: Disabled

Thanks for that, I did finally find it, but it is useful to have it published here, there might be others.


_________________
Greg Schofield, Perth Australia

 Status: Offline
Profile     Report this post  
Anonymous 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 10:41:21
# ]



Installed the october uboot. Turned out I had to reboot to get it to boot from the oct uboot update cd. ide reset did absolutely nothing. Possible because changing default device in the menu system doesn't work. I guess "setenv boot1 psii" would have worked.

Anyway, I continued:

I updated the slb to slb_v2 from the updater archive.

reset and installed new mar 2005 uboot.

reset again.

waited very long for the internal ide checks to timeout.

Disabled internal ide in the menu system.

set the boot device to paralell sil. Saved and exited menu system.

System refused to boot 4.0 with boota.

started menu system again, boot device had reset to internal ide. exited menu system.

tried setenv boot1 psii after reading your reply

saved prefs

boota

AmigaOS boots as normal.

/Björn

 
     Report this post  
Rogue 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 11:04:08
#87 ]
OS4 Core Developer
Joined: 14-Jul-2003
Posts: 3999
From: Unknown

Quote:
started menu system again, boot device had reset to internal ide. exited menu system.


I'll investigate that. Can't really imagine why it would not save the variable correctly...


_________________
Seriously, if you want to contact me do not bother sending me a PM here. Write me a mail

 Status: Offline
Profile     Report this post  
AlexC 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 11:16:47
#88 ]
Super Member
Joined: 22-Jan-2004
Posts: 1297
From: City of Lost Angels, California.

@Greg
Quote:
and then I come to a 38 second cold bootup -- its just magic,

Magic eh? Now how about cutting that in half?

I could tell you how, but figuring it out is more fun, at least now you know that it's possible.
(It takes 20 sec. here if there's no disk in the CD drive)


_________________
AlexC's free OS4 software collection

AmigaOne XE/X1000/X5000/UAE-PPC OS4 laptop/X-10 Home Automation

 Status: Offline
Profile     Report this post  
Matt 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 11:35:42
#89 ]
Regular Member
Joined: 16-Nov-2003
Posts: 467
From: Sherborne, UK

@ Rogue

I also had problems getting the new SII Parallel Disk settings to save. I gave up trying to do it with setenv, so used the menu in UBoot and each time I saved it there it would reset back to the onboard VIA. Eventually, after 4 attempts it finally saved and all is fine here now.

Thanks for the update.


_________________


AmigaOne XE-G4, 512MB RAM (AmigaOS 4.1)
Radeon 9250, Terratec Aureon 5.1
CDRW, DVDRW, SII0680

 Status: Offline
Profile     Report this post  
tonyw 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 11:49:57
#90 ]
Elite Member
Joined: 8-Mar-2003
Posts: 3232
From: Sydney (of course)

@lylehaze:

"Flash is wonderful stuff, sure beats booting from paper tape. (Oops, my age is showing again)"

Ah, but can you still remember the PDP-11 absolute loader to key in on the front panel switches?

tony


_________________
cheers
tony

Hyperion Support Forum: http://forum.hyperion-entertainment.biz/index.php

 Status: Offline
Profile     Report this post  
NutsAboutAmiga 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 12:24:34
#91 ]
Elite Member
Joined: 9-Jun-2004
Posts: 12379
From: Norway

@Rogue

It's as likely as "ide reset" don't read the variable


_________________
http://lifeofliveforit.blogspot.no/
Facebook::LiveForIt Software for AmigaOS

 Status: Offline
Profile     Report this post  
Toaks 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 12:37:36
#92 ]
Elite Member
Joined: 10-Mar-2003
Posts: 8042
From: amigaguru.com

mtreasure:

odd, all thats needed is "setenv ide=psii" and then hit enter and type "saveenv" anyway glad u got it running again.


_________________
See my blog and collection website! . https://www.blog.amigaguru.com

 Status: Offline
Profile     Report this post  
Wizzard_o 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 15:54:57
#93 ]
Cult Member
Joined: 13-Sep-2004
Posts: 701
From: UK, Northern Hemisphere, Earth, Solar System, Alpha Quadrant, The Milky-Way, Universe. 1.1.1.3.44.HP

Installed and rockin' its a good job i read these posts before i updated or my
A1 would not of booted with the old SLB!

Still no VIA DMA, I suppose a 30 sec. boot time will just have to do for now!

Wizz.


_________________
Rev 1D3 Amiga 1200, Apollo 1240 (40Mhz '040, 64MB RAM), Indivision MKII, Fast ATA MK V, Rapid Road USB, PCMCIA WIFI & OS 3.14

 Status: Offline
Profile     Report this post  
Rogue 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 16:45:26
#94 ]
OS4 Core Developer
Joined: 14-Jul-2003
Posts: 3999
From: Unknown

Quote:
Still no VIA DMA, I suppose a 30 sec. boot time will just have to do for now!


VIA DMA has nothing to do with the firmware. You need a DMA-enabled driver for that.


_________________
Seriously, if you want to contact me do not bother sending me a PM here. Write me a mail

 Status: Offline
Profile     Report this post  
jiyong 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 17:43:29
#95 ]
Cult Member
Joined: 25-Oct-2003
Posts: 594
From: Lelystad, The Netherlands

Quote:
VIA DMA has nothing to do with the firmware. You need a DMA-enabled driver for that.


Since Eyetech claims that the problems with VIA DMA is in the initialization, I would suspect the firmware would be the place for the initialization. Or am I wrong?

After the VIA DMA has been setup correctly, yes, we would need a DMA-enabled driver.

 Status: Offline
Profile     Report this post  
NutsAboutAmiga 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 18:31:50
#96 ]
Elite Member
Joined: 9-Jun-2004
Posts: 12379
From: Norway

"problems with VIA DMA"

oh plase go and get your hw fixed for the driver now,


_________________
http://lifeofliveforit.blogspot.no/
Facebook::LiveForIt Software for AmigaOS

 Status: Offline
Profile     Report this post  
wegster 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 18:45:02
#97 ]
Elite Member
Joined: 29-Nov-2004
Posts: 8554
From: RTP, NC USA

Quote:
Poster: drHirudo Date: 6-Mar-2005 2:02:10

Quote:
"1. with an A1XE-G4 with radeon 9200SE/128MB card, post uBoot/AOS4 selection, my screen remains blank for ~10+ seconds before coming up with the workbench screen. Will the AGP fix in uBoot perhaps affect this?"

That has happened to me and to my friend after we installed update 2 (we both own ua1)
He thought maybe it was scanning usb drvices.

Anyone have any ideas on this?


During the black screen AmigaOS4 also configures the Internet connection, and when I used DHCP there was such slowdown. So I turned off DHCP and configured my LAN settings properly and now it boots much faster.


Thanks, I'll give that a shot. Normally all my systems are indeed static IP, but figured 'if it works, don't fix it' might be an idea for a bit.

Last edited by wegster on 06-Mar-2005 at 06:47 PM.


_________________
Are we not done with the same silly arguments and flames yet??!

 Status: Offline
Profile     Report this post  
Rogue 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 19:55:05
#98 ]
OS4 Core Developer
Joined: 14-Jul-2003
Posts: 3999
From: Unknown

Quote:
Since Eyetech claims that the problems with VIA DMA is in the initialization, I would suspect the firmware would be the place for the initialization. Or am I wrong?

After the VIA DMA has been setup correctly, yes, we would need a DMA-enabled driver.


I don't know of any form of initialization that could cure the DMA problems. A lot of research has gone into this topic, and to the best of my knowledge there is no software fix (all software fixes involve the VIA Northbridge).

The hardware fix is the only thing that works.


_________________
Seriously, if you want to contact me do not bother sending me a PM here. Write me a mail

 Status: Offline
Profile     Report this post  
mwoof 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 20:02:34
#99 ]
Super Member
Joined: 12-Jan-2004
Posts: 1174
From: Larisa, Greece

Quote:
Suns and flowers, btw...you mean like "Sun Microsystems" and "Petunia"?


_________________
And may the AmigaGuide you!

AmigaOne G3-SE, OS4 Final (July 2007 update), Debian Sarge, 512 MB RAM, 20 + 80 GB hard disks, NEC 3540 DVD writer, LG DVD reader, Radeon 9250, SB Live, Intracom Netfaster router, PCI USB card (NEC - OHCI/EHCI)

 Status: Offline
Profile     Report this post  
MichaelMerkel 
Re: New AmigaOne firmware update available
Posted on 6-Mar-2005 20:23:29
#100 ]
Cult Member
Joined: 9-Mar-2003
Posts: 819
From: Ilvesheim, Germany

Quote:
Quote:
am i correct that the "keyboard-mouse-usb-combos" are not yet supported with this update? at least here my hardware is not identified/used.

Mice are unsupported in U-Boot.

that's clear
Quote:
A combo should be recognized,
though, at least my Microsoft wireless combo is correctly identified.

strange...

i tried both of our wireless keyboard/mouse combos: "logitech wireless desktop" and "logitch wireless desktop navigator"... both are neither recognized by u-boot nor by os4.
u-boot does not recognize the usb device at all (only telling me "one usb device found" which is the controller...)
with os4 i always get "hub drive was unable to add the attached device" when i plug it in.

what's wrong?

byebye...


_________________
Michael Merkel
(Michael.Merkel@gmx.net Home)
Member of Amiga-Freunde Pfalz, OS4 Welt

 Status: Offline
Profile     Report this post  

Goto page ( 1 | 2 | 3 | 4 | 5 | 6 | 7 )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle