Click Here
home features news forums classifieds faqs links search
6036 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
» Home
» Features
» News
» Forums
» Classifieds
» Links
» Downloads
Extras
» OS4 Zone
» IRC Network
» AmigaWorld Radio
» Newsfeed
» Top Members
» Amiga Dealers
Information
» About Us
» FAQs
» Advertise
» Polls
» Terms of Service
» Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
51 crawler(s) on-line.
 19 guest(s) on-line.
 1 member(s) on-line.


 Rob

You are an anonymous user.
Register Now!
 Rob:  1 min ago
 Karlos:  5 mins ago
 Jasper:  8 mins ago
 FairBoy:  14 mins ago
 bhabbott:  20 mins ago
 Futaura:  22 mins ago
 amigang:  24 mins ago
 clint:  34 mins ago
 Mobileconnect:  44 mins ago
 cdimauro:  48 mins ago

Software News   Software News : OS4 prerelease update #3 available
   posted by EntilZha on 14-Jun-2005 14:29:31 (46427 reads)
Leuven, Belgium. 13 June, 2005.

Hyperion Entertainment announces the immediate availability of the final intermediate update of Amiga OS 4.0 prior to its full commercial release later this year.


An overview of the added functionality:

* New Kernel
* New IDE devices
* New Picasso96/Graphics and monitor drivers
* Warp3D V51 (Including support for Voodoo 3, Voodoo 4/5, and Radeon 7x00)
* WarpUp support
* New Shell and updated shell commands
* Update reaction classes and new intuition
* New Roadshow TCP/IP stack and updated eth3com.device
* All new version of the Sirion USB stack and usbprinter.device
* Updated datatypes
* Updated Preferences programs
* Updated Locale
* And much more

Registered users of Amiga OS 4.0 can download update 3 from Hyperion Entertainment's website.


Hyperion Entertainment and the Amiga OS 4.0 development team wish to thank you for your continued patience and support which we hope will be rewarded in a few months time.
    

STORYID: 2357
Related Links
· More about Software News
· News by EntilZha


Most read story about Software News
UBoot 2010.06.04 for Sam460ex available

Last news about Software News
Hollywood APK Compiler 4.0 released
Printer Friendly Page  Send this Story to a Friend

Goto page ( 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 )

PosterThread
Rogue 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 0:44:42
#221 ]
OS4 Core Developer
Joined: 14-Jul-2003
Posts: 3999
From: Unknown

@Fransexy
Quote:
As I read in this thread seems that update 3 gives more problems that solve


For most of the people it works without problem, and some have simply not read the fine manual that came with it.

@Chris_Y:
Quote:
Are there any unforeseen problems with running the old ATIRadeon.chip?


It doesn't work with Warp3D.

Make sure you have the *latest* firmware. If it still does not work, boot from CD, open you devs:monitors, and try to comment out "INTERRUPT=Yes".


_________________
Seriously, if you want to contact me do not bother sending me a PM here. Write me a mail

 Status: Offline
Profile     Report this post  
wegster 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 0:47:35
#222 ]
Elite Member
Joined: 29-Nov-2004
Posts: 8554
From: RTP, NC USA

Quote:
Well, I rebooted, but all I got was a funky low-res blue, grey, mostly white WB screen with no icons or menus. I had to reinstall updates 1 and 2, and then I was able to get update 3 to install from beginning to end. However, when I rebooted I still got the funky WB screen. So here I am back at update 2 with no clue how to get update 3 installed.


Re-bind your graphics modes to your graphics cards in p96, reboot, then reset your Screen Mode.


_________________
Are we not done with the same silly arguments and flames yet??!

 Status: Offline
Profile     Report this post  
Crumb 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 0:48:17
#223 ]
Elite Member
Joined: 12-Mar-2003
Posts: 2209
From: Zaragoza (Aragonian State)

@Hyperion

impressive! good job


_________________
The only spanish amiga news web page/club: CUAZ

 Status: Offline
Profile     Report this post  
madtrekker 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 0:56:49
#224 ]
Regular Member
Joined: 11-Mar-2003
Posts: 271
From: Unknown

I think I narrowed down issue #2 to the boot picture I'd installed. I've disabled it for now and haven't seen any crashes on start-up since then. *crosses fingers*

 Status: Offline
Profile     Report this post  
Tomppeli 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 1:07:40
#225 ]
Super Member
Joined: 18-Jun-2004
Posts: 1645
From: Home land of Santa, sauna, sisu and salmiakki

Installer failed with file Libs/Warp3DPPC.library. But I managed to install everything anyway (after removing that certain file from archive and ofcourse I copied it to right place manually at first). MD5sum is ok with that update-file.

After I reattached that graphics card and I had to reboot there was some random crashes with different software. But after I managed to change screenmode back to normal everything is working ok.

Some files I had to copy manually after installation.

I tested that new uboot.prefs and it crashed and it left one uboot variable empty and my machine didn't boot up to workbench anymore. It took me a while to find out the reason to this.

Now everything works ok.

Thanks for the update ! Btw. That new installer looks nice.


_________________
Rock lobster bit me, so excuse me. My Workbench has always preferences. X1000 + AmigaOS4.1 FE
"Anyone can build a fast CPU. The trick is to build a fast system." -Seymour Cray

 Status: Offline
Profile     Report this post  
Steff 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 1:12:50
#226 ]
Super Member
Joined: 11-Mar-2003
Posts: 1342
From: Göteborg, Sweden

@madtracker

Quote:
do have one question. In the install guide it says that to enable DMA you need to read the instructions in SYS:Documentation, which I have done.
Now, unless I missed something the option that needs to be changed is the one with the different PIO/UDMA options, but I'm not familiar with how this all works, so my question is which UDMA option is 'safe'? Does it depend on the drive or the motherboard? And should UDMA be enabled for CD/DVD drives as well as hard drives? If anyone knows the answer to this question I would appreciate it very much.


Open a shell and type idetool -u (a1ide,device/sii0680ide.device/etc) chosse one without the parenthesis and the unit # of your drive/cdrom (0=primary master 1=primary slave 2=secondary master 3= secondary slave). This will tell what your drive/cdrom/whatever prefers for speed.

If you have an XE or SE board then you need to have the "fix" to use UDMA on the a1ide.device.

The above should look like this, ex:

idetool -u sii0680ide.device 0 for info from a hardrive on a Sil controller on the primary interface as master.

And the results should look something like this:

Xfer mode : best pio / best dma / current : 12 / 69 / 69
Total blocks : 234441648
Blocksize : 512
Power mode : 2 / idle (ready for operation)
IO1 / IO2 / BMCR @ : $802400 / $80240A / $802420

From the documentation under SYS: you can read which mode is represented by the numbers from the readout.

You can then set the values in the new uboot prefs.

Make sure you have checked all numbers correctly before changing uboot and don't try to set higher values than what is reccomended

Edit:

BTW the update went without a hitch and the only problem was the lowres screen after reboot (which was immediately fixed). Everything seems to work flawlessly, some screen modes seem to have dissappeared and had to be reinstalled but otherwise no problems.

Haven't tried to many things but Myst (which crawled along before) is so fast I'm might even try to play it some time.

Last edited by Steff on 15-Jun-2005 at 01:19 AM.


_________________
Fixed A1G4XE 7455 RX933PC with fried CPU
Sapphire Radeon 9100 128mb
ESI Juli@ 24bit 192kHz Envy24HT
Sil 680 Ultra Ata 133 E-ide
SeaGate Barracuda 120gb 8mb cache

 Status: Offline
Profile     Report this post  
Kay 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 1:22:06
#227 ]
Super Member
Joined: 9-Mar-2003
Posts: 1411
From: Norway

What, no new narrator.device? What kind of lame-ass update is this?!

Seriously, excellent news. Looking forward to trying it out this weekend. With some luck, it might cure my mysterious, one of a kind, overly long kickstart boot delay. But even if it doesn't, this is a brilliant update.

Warp support at last!

Kay

 Status: Offline
Profile     Report this post  
Tomppeli 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 1:28:21
#228 ]
Super Member
Joined: 18-Jun-2004
Posts: 1645
From: Home land of Santa, sauna, sisu and salmiakki

How can I disable automatic unpacking with the new unarc ?


_________________
Rock lobster bit me, so excuse me. My Workbench has always preferences. X1000 + AmigaOS4.1 FE
"Anyone can build a fast CPU. The trick is to build a fast system." -Seymour Cray

 Status: Offline
Profile     Report this post  
wegster 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 1:40:58
#229 ]
Elite Member
Joined: 29-Nov-2004
Posts: 8554
From: RTP, NC USA

@Valiant/others
Quote:

Yeah, I read the readme file and even all of the posts up to the point I did the install. I even ran p96Mode after the install and it supposedly showed my graphic card, so I assumed I didn't need to reattach it. However it wasn't clear to me and still isn't how to reattach the gc. I'll give it another go and in the meantime keep to myself what you can go do. ;^P


Right click on each individual mode after making sure it's active in P96 Prefs, and then select Attach to Board. Reboot then re-set Screen Mode and you're happy.


_________________
Are we not done with the same silly arguments and flames yet??!

 Status: Offline
Profile     Report this post  
wegster 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 2:55:13
#230 ]
Elite Member
Joined: 29-Nov-2004
Posts: 8554
From: RTP, NC USA

@The_Editor
Quote:
So it only takes about 4 mins to bootup now.

That'll impress the win crowd !!


Ack! No change it boot times noticed by me- is there a thread with your issues listed, or is it lost in here somewhere?


_________________
Are we not done with the same silly arguments and flames yet??!

 Status: Offline
Profile     Report this post  
wegster 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 3:00:29
#231 ]
Elite Member
Joined: 29-Nov-2004
Posts: 8554
From: RTP, NC USA

@Fransexy
Quote:
As I read in this thread seems that update 3 gives more problems that solve
And this is the last update after the main release, I hope that hyperion guys could solve all this problems and made Amigaos as fast, easy and robust as always has been before update 3.


I don't think that's fair. See my 'long review' in the forums- I had 3 issues so far:
1. p96 prefs reset and screen mode didn't want to allow me to reset, caused by GoldEd AIX 'TSR' and NOT update 3.

2. KingCon running in replacement mode for CON: presumably had some files over-written, as I got a few GRs, like when opening a PDF through workbench. Old 68k program, re-installing it solved the problem.

Umm..ok, that's it.

The_Editor and a few others have had a few issues, which happens with every version of Windows and other OSes as well- people post more with problems than with 'happy stories' of zero problems, bear that in mind.

I think all of them have been resolved as well as far as I've seen, so this seems to be a pretty good problem-free update in MY book..?


_________________
Are we not done with the same silly arguments and flames yet??!

 Status: Offline
Profile     Report this post  
wegster 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 3:06:07
#232 ]
Elite Member
Joined: 29-Nov-2004
Posts: 8554
From: RTP, NC USA

@madtrekker
Quote:
I do have one question. In the install guide it says that to enable DMA you need to read the instructions in SYS:Documentation, which I have done.
Now, unless I missed something the option that needs to be changed is the one with the different PIO/UDMA options, but I'm not familiar with how this all works, so my question is which UDMA option is 'safe'? Does it depend on the drive or the motherboard? And should UDMA be enabled for CD/DVD drives as well as hard drives? If anyone knows the answer to this question I would appreciate it very much.


See the notes on a1ide_xfer in the docs, and note that it will fall back to lower DMA speeds if your HD doesn't support it (although NOT the case for ANY UNFIXED A1).

The MB onboard IDE can do ATA100, so even if your drive can do ATA133, ATA100 is the highest you'll get using the onboard Via. If your HD is ATA33 (pretty old now) and you set that drive to 'F' (ATA100), the driver will detect your drive can only do ATA33 and use ATA33.


_________________
Are we not done with the same silly arguments and flames yet??!

 Status: Offline
Profile     Report this post  
wegster 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 3:08:08
#233 ]
Elite Member
Joined: 29-Nov-2004
Posts: 8554
From: RTP, NC USA

Quote:
Have anyone with a 750GX CPU tested IBrowse 2.3?

How does it work? More stable than before?


The 750GX issue has apparently been resolved. Re-enable your cpu cahce after the update and chime in on the thread in the forums RE: 750GX issue fixed in update 3.


_________________
Are we not done with the same silly arguments and flames yet??!

 Status: Offline
Profile     Report this post  
Kicko 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 3:14:59
#234 ]
Elite Member
Joined: 19-Jun-2004
Posts: 5009
From: Sweden

Downloaded os4 update 3 and when i wanted to install it
it complained for corrupt files. So i unpacked it using
lha and i could unpack it ok. So i press on install and
the install GUI appears and complains of corrupted
files like base.lha etc.

So i used lha again and i got it unpacked to ram:
I copied the files manually and it worked.
Had to change the kicklayout as said in docs.
Updated the smartfilesystem to harddisk.
And had to make new setenv's in uboot as its not
anymore called si680 but sii0680. So changed makecd
frying pan etc to use this. There is sure much more
to change. And i made all stuff to use UDMA even DVD :)

At last Perfectpaint works but it gets the grimreaper.
So i press continue to get it to work. Some colours
gets wrong but seems to work.

Fryingpan now doesnt crash on exit anymore :)
update3 seems more stable now and faster, specially
opening mui windows like yam.
More to explore :)
Too bad there are no 3d drivers for my radeon 9200.
I have voodoo5 but that will stay in my a4000.

Thanks Hyperion

 Status: Offline
Profile     Report this post  
The_Editor 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 3:48:59
#235 ]
Elite Member
Joined: 7-Mar-2003
Posts: 7629
From: 192.168.0.02 ..Pederburgh .. Iceni

ok.. Had a little sleep. Now 03:45 .. soon time for work.



Here's the screen shot of Os4 update 3 on my system.

Screenshot


Its actually worse since I deleted AmigaOne.card ( This was before I deleted that file).


_________________
******************************************
I dont suffer from Insanity - I enjoy it

******************************************

 Status: Offline
Profile     Report this post  
antony 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 4:02:46
#236 ]
Member
Joined: 10-Apr-2005
Posts: 70
From: Unknown

@Orgin

Quote:
And it might be an idea to either print out the installation document or copy it to another computer where you can view it before installing the update. AmiPDF can't view it properly once your p96 modes are gone.


Can you please tell me what happens with AmiPDF in that case (I'm currently away and can't check myself).

 Status: Offline
Profile     Report this post  
antony 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 4:04:34
#237 ]
Member
Joined: 10-Apr-2005
Posts: 70
From: Unknown

@T_Power

Quote:
Have A HP LaserJet 5 connected to the Par port. If I disable Turboprint and print using the Workbench drivers, all is OK with AmiPDF.
This is the error given, ***Command 'Ghostscript:gs' returned with unfreed signals 60000000!

All other Programmes print fine with TurboPrint 5.02 .


AmiPDF prints through Ghostscript. The Ghostscript Turboprint driver is the one from Irsee (modified to take GS 8 changes in architecture in account) and it requires TP 7 or higher. Additional modifications to have error message in this case and proper freeing of allocated signals in this case are on my ToDo list, but with a low priority.

Since your printer is supported in Ghostscript ("HP LaserJet 5/6 gray" or mono in the list) you can try printing using that (use PAR: for Output file, this should be the default).

 Status: Offline
Profile     Report this post  
Tomppeli 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 4:13:19
#238 ]
Super Member
Joined: 18-Jun-2004
Posts: 1645
From: Home land of Santa, sauna, sisu and salmiakki

@The_Editor

From where I can find that Amplifier skin you are using ?


_________________
Rock lobster bit me, so excuse me. My Workbench has always preferences. X1000 + AmigaOS4.1 FE
"Anyone can build a fast CPU. The trick is to build a fast system." -Seymour Cray

 Status: Offline
Profile     Report this post  
firbodi 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 4:30:42
#239 ]
Super Member
Joined: 2-Sep-2003
Posts: 1046
From: Planet Earth!

@Fransexy

I never ever had a single problem installing any of the OS4 or firmware updates. My system got more and more useful and stable after each update. You know why?

Because I read the manuals and readme's word by word before I start doing anything and during the update follow the instructions line by line, word by word.

I strongly believe that most of the time people are doing something wrong, or don't pay attention to the requirements and instructions. They don't even read the posts. See reattaching of new driver with screen modes has been repeated many times in this single thread.

Firbodi


_________________
MicroA1 G3, 512MB RAM, DVD-RW; and A1-SE G3,512MB RAM, CD-RW & DVD-ROM
Avatar: Perspolis, Capital of Achaemenid Empire 500 B.C.

 Status: Offline
Profile     Report this post  
rossv 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 4:56:56
#240 ]
Regular Member
Joined: 22-Mar-2003
Posts: 383
From: Sydney, Australia

Quote:
Does anyone know if the new update will work with the Mobility Radeon 7500? (PCI ID 0x1002:0x4c57)?


Where on earth did you get a *Mobility* Radeon on a PCI/AGP card?!?

Unfortuatenly PCIGraphics.card does not look for that particular PCI Device, so it will not work with the update.

Regards.


_________________
The standard disclaimer applies

 Status: Offline
Profile     Report this post  

Goto page ( 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle