Click Here
home features news forums classifieds faqs links search
6034 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
84 crawler(s) on-line.
 20 guest(s) on-line.
 2 member(s) on-line.


 bison,  cdimauro

You are an anonymous user.
Register Now!
 bison:  40 secs ago
 cdimauro:  2 mins ago
 DiscreetFX:  6 mins ago
 number6:  9 mins ago
 pavlor:  18 mins ago
 Futaura:  24 mins ago
 PhantomInterrogative:  29 mins ago
 Deniil715:  34 mins ago
 Rob:  59 mins ago
 zipper:  1 hr 16 mins ago

Software News   Software News : OS4 prerelease update #3 available
   posted by EntilZha on 14-Jun-2005 14:29:31 (46418 reads)
Leuven, Belgium. 13 June, 2005.

Hyperion Entertainment announces the immediate availability of the final intermediate update of Amiga OS 4.0 prior to its full commercial release later this year.


An overview of the added functionality:

* New Kernel
* New IDE devices
* New Picasso96/Graphics and monitor drivers
* Warp3D V51 (Including support for Voodoo 3, Voodoo 4/5, and Radeon 7x00)
* WarpUp support
* New Shell and updated shell commands
* Update reaction classes and new intuition
* New Roadshow TCP/IP stack and updated eth3com.device
* All new version of the Sirion USB stack and usbprinter.device
* Updated datatypes
* Updated Preferences programs
* Updated Locale
* And much more

Registered users of Amiga OS 4.0 can download update 3 from Hyperion Entertainment's website.


Hyperion Entertainment and the Amiga OS 4.0 development team wish to thank you for your continued patience and support which we hope will be rewarded in a few months time.
    

STORYID: 2357
Related Links
· More about Software News
· News by EntilZha


Most read story about Software News
UBoot 2010.06.04 for Sam460ex available

Last news about Software News
Hollywood APK Compiler 4.0 released
Printer Friendly Page  Send this Story to a Friend

Goto page ( 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 )

PosterThread
CodeSmith 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 5:21:01
#241 ]
Elite Member
Joined: 8-Mar-2003
Posts: 3045
From: USA

@rossv

Ebay

It's a no-name reference board (the fan on the GPU says "ATI"), it was sold as a regular Radeon 7500, the box says "Radeon 7500" and a little sticker on the board says "Radeon 7500". The only one who says it's not is UBoot, and I believe UBoot...

If you live in the USA, I can mail you the card so you can add support for it if you want.

[Edit] Never mind, I see that you live a *bit* far away from the USA

Last edited by CodeSmith on 15-Jun-2005 at 05:24 AM.

 Status: Offline
Profile     Report this post  
saimo 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 7:17:30
#242 ]
Elite Member
Joined: 11-Mar-2003
Posts: 2381
From: Unknown

@Tomppeli

You have to disable the DESTINATION tooltype of Unarc, as it's taken as an implicit command.


@developer/mantainer of Unarc

Suggestion: why not just adding a tooltype that allows the user to explicitly ask for unpacking? That would be a more flexible solution.
F.ex., I used to have DESTINATION=RAM:, but sometimes I'm interested only in viewing the listing of an archive; before, when I wanted to actually unpack the stuff, I just had to hit "start". Now I can't do that anymore: for viewing the contents it's OK, but when it comes to unpacking (i.e. most of the times) I had to specify RAM: each and every time.


saimo


_________________
RETREAM - retro dreams for Amiga, Commodore 64 and PC

 Status: Offline
Profile     Report this post  
rossv 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 7:50:48
#243 ]
Regular Member
Joined: 22-Mar-2003
Posts: 383
From: Sydney, Australia

@CodeSmith

Ah, that is a strange one! Especially since Mobility chips would cost more than the standard ones.

I'm no Radeon expert, but I think it's quite possible that this card could work with the Radeon driver as is, if it is sufficiently similar to a real 7500. I'll take note of the PCI ID and ask on the dev list.

Regards.


_________________
The standard disclaimer applies

 Status: Offline
Profile     Report this post  
FuZion 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 8:00:58
#244 ]
Super Member
Joined: 22-Nov-2003
Posts: 1962
From: Birmingham, England

I get the garbled mess too.

It happens everytime I load up Amplifier.

FuZion.

 Status: Offline
Profile     Report this post  
freaks 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 8:26:13
#245 ]
Regular Member
Joined: 8-Jun-2004
Posts: 318
From: france

Thanks a lot Hyperion, Well done ! Keep up the good work!

Amiga rulez

 Status: Offline
Profile     Report this post  
Chris_Y 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 8:27:59
#246 ]
Elite Member
Joined: 21-Jun-2003
Posts: 3191
From: Beds, UK

@Rogue
Quote:
If it still does not work, boot from CD, open you devs:monitors, and try to comment out "INTERRUPT=Yes".


Ah, that fixed it, thanks. Any reason why the interrupt setting might not work here?

Chris


_________________
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar is Tabitha by Eric W Schwartz

 Status: Offline
Profile     Report this post  
Hammer 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 9:53:58
#247 ]
Elite Member
Joined: 9-Mar-2003
Posts: 4273
From: Australia

Quote:
Well it looks as though Amiga OS4 will beat Longhorn to the punch and by more than a year.

Erm, factor in MS Windows XP X64 Edition release....

Quote:
. This is great news

Dito for AOS4's progress.


_________________
Ryzen 7 5800X, DDR4-3600 64 GB RAM, GeForce RTX 3080 Ti
Ryzen 9 3900X, DDR4-3200 32 GB RAM, GeForce RTX 3080 Ti
Amiga 1200 (rev 1D1, KS 3.2, TF1260, 68060 @ 63 Mhz, 128 MB)
Amiga 500 (rev 6A, KS 3.2, 68K 50Mhz, 12 MB RAM)

 Status: Offline
Profile     Report this post  
EntilZha 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 10:03:07
#248 ]
OS4 Core Developer
Joined: 27-Aug-2003
Posts: 1679
From: The Jedi Academy, Yavin 4

Quote:
Its actually worse since I deleted AmigaOne.card ( This was before I deleted that file).


Did you use the provided kicklyout file ? Note that AmigaOne.card is not loaded anymore.

If you do use the provided kicklayout, then it doesn't matter at all whether you delete AmigaOne.card or not. If a kickstart file is not loaded in kicklayout, deleting it will make no difference at all.


_________________
Thomas, the kernel guy

"I don't have a frigging clue. I'm norwegian" -- Ole-Egil

All opinions expressed are my own and do not necessarily represent those of Hyperion Entertainment

 Status: Offline
Profile     Report this post  
madtrekker 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 11:10:53
#249 ]
Regular Member
Joined: 11-Mar-2003
Posts: 271
From: Unknown

@Steff

I only had time to test-run idetool before I left for work this morning but it reported the DMA modes so it should be easy to switch it over this evening.

Thanks for your help with this.

Also, there's an odd epilogue to my problems getting the Workbench Prefs program to run. This morning I had a brainstorm and decided to try running it through the pop-up menus instead of the icon to see if that made any difference. I wasn't really expecting it to, but I thought a different execution method might help. Imagine my surprise when it worked! Even more puzzlingly I tried running it from the icon, just to check, and now it works fine!

I have no idea what was causing it to crash before, as I think the only thing I've added/removed/changed since last night was that I installed oggenc into c: - hardly likely to affect a Prefs program. I guess this'll have to be chalked up as 'one of those things'.

Still this means that pretty much everything is now fully working.

Last edited by madtrekker on 15-Jun-2005 at 11:15 AM.

 Status: Offline
Profile     Report this post  
Rogue 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 11:22:24
#250 ]
OS4 Core Developer
Joined: 14-Jul-2003
Posts: 3999
From: Unknown

Quote:
Downloaded os4 update 3 and when i wanted to install it


I would like to point out that you can get an MD5 checksum of every file you download from hyperion-entertainment.biz (It is displayed on the Info page). Compare that to the output of md5sum to see if there was a problem while downloading.


_________________
Seriously, if you want to contact me do not bother sending me a PM here. Write me a mail

 Status: Offline
Profile     Report this post  
Rogue 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 11:26:47
#251 ]
OS4 Core Developer
Joined: 14-Jul-2003
Posts: 3999
From: Unknown

Quote:
Any reason why the interrupt setting might not work here?


Not really, no. Did you upgrade to the latest firmwware? What does the "version" command in U-Boot tell you?

The latest firmware fixed a bug in the interrupt routing that would result in interrupts not being delivered properly.


_________________
Seriously, if you want to contact me do not bother sending me a PM here. Write me a mail

 Status: Offline
Profile     Report this post  
Kicko 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 12:08:31
#252 ]
Elite Member
Joined: 19-Jun-2004
Posts: 5009
From: Sweden

Yes i did use c:md5 and it showed it correctly.
Its just when i use unpack or the install from the package.
Using lha from dopus4 works fine. So i did it that way.

I dont know could be something corrupted in my system.

Im a litte organized person so i use also my own s-s

C:MakeDir RAM:Cache RAM:Cache/T RAM:Cache/Clipboards RAM:Cache/Internet

C:Assign >NIL: T: RAM:Cache/T
C:Assign >NIL: CLIPS: RAM:Cache/Clipboards

This way i only see ram:Cache and inside is everything needed.
Its because i use ram: daily and dont want to have too much
dirs showed in ram:

however this i believe isnt the problem with the installer part
as i never did have any problems. There were maybe one program that
used ram:t instead of t: but that author have fixed that.
just informing the changes i do use. Everything else is same.
Oh yes and i use kingcon to takeover the shell complete.

 Status: Offline
Profile     Report this post  
deathcon 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 12:13:05
#253 ]
New Member
Joined: 20-Jun-2004
Posts: 2
From: Unknown

hello,

after installing os4 update 3 I have a Grim Reaper issue. The system tells me that i need exec.library 51.23 to run the Reaper.

i have crashed a MUI exchange clone. in the other updates i simply pressed the continue button in Grim Reaper and moved on and all works fine. now however Grim Reaper needs a newer version of the exec.library to run.

i have exec.library 51.19 installed.

where can i get version 51.23 from?

thanks

 Status: Offline
Profile     Report this post  
ajk 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 12:23:57
#254 ]
Regular Member
Joined: 13-Oct-2003
Posts: 291
From: Finland

I updated the firmware, no probs there except some lost settings (can't boot linux with "diskboot" any more). Well no prob, will sort that out later so I booted OS4 and installed the update. Worked ok, the screenmodes got buggered but that was easy to fix.

Then I tried disabling the internal ide bus via the uboot prefs program to get rid of the long bus scan when booting (since my drives are on the SIL card anyway). A reboot after that started giving me "General Drive Failures" when trying to start programs. Well, I rebooted again and now I can't get anywhere - I just get a "FLB: No SLB found in any of the designated boot sources; returning to u-boot". What has gone wrong and how do I fix this?

 Status: Offline
Profile     Report this post  
Mr_Capehill 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 12:39:00
#255 ]
Super Member
Joined: 15-Mar-2003
Posts: 1932
From: Yharnam

@deathcon:

After installation your exec.library version number should be 51.28 (I think). Did you do a cold boot?

 Status: Offline
Profile     Report this post  
ajk 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 12:51:17
#256 ]
Regular Member
Joined: 13-Oct-2003
Posts: 291
From: Finland

@ajk

Ok, well apparently it was just the U-Boot variables that got messed around with a lot more than I wanted. I've got the thing back booting now, but I'm getting a SetPatch crash immediately after kickstart is loaded.

What was the U-Boot command to boot from the OS4 CD again? I seem to get only "Device not available" messages. Or how do I get to the early startup menu having a USB mouse (ie. which key should I press instead of the buttons)?

 Status: Offline
Profile     Report this post  
ajk 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 13:16:11
#257 ]
Regular Member
Joined: 13-Oct-2003
Posts: 291
From: Finland

@ajk

Ok, managed to boot and fix things. Sheesh, not going to touch that U-Boot prefs proggy any more

 Status: Offline
Profile     Report this post  
madtrekker 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 13:23:34
#258 ]
Regular Member
Joined: 11-Mar-2003
Posts: 271
From: Unknown

Probably a good plan. The way it works at the moment the U-Boot prefs is pretty dangerous. It should at least have a disclaimer saying that settings aren't loaded from U-Boot and that all settings saved not just ones changed.

Luckily I read about this before I got a chance to switch to DMA, but I bet this has caused a lot of problems for people.

 Status: Offline
Profile     Report this post  
mbilla 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 13:25:35
#259 ]
Super Member
Joined: 25-May-2003
Posts: 1369
From: EU

Thank you Hyperion!
I will try it this evening!

Many many thx!!!


_________________
A computerworld without MS products and Windows!
Connect your Amigas ...
...The Red ONE-A1XE G4 - A3000T- A3000 - A4000 - A2500- A1000 - A600 - CDTV - CD32...
and your PDAs and laptops ...
Psion 5mx Pro - Psion NetBook - Apple iPhone - MSI Wind OSX

 Status: Offline
Profile     Report this post  
Rogue 
Re: OS4 prerelease update #3 available
Posted on 15-Jun-2005 13:35:55
#260 ]
OS4 Core Developer
Joined: 14-Jul-2003
Posts: 3999
From: Unknown

Quote:
Yes i did use c:md5 and it showed it correctly.


You might want to delete libs:xpkmaster.library and do an avail flush before you install. The installer should tell you that xpkmaster is missing and propose to update it for you before continuing.

Maybe that helps.


_________________
Seriously, if you want to contact me do not bother sending me a PM here. Write me a mail

 Status: Offline
Profile     Report this post  

Goto page ( 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle