Click Here
home features news forums classifieds faqs links search
6044 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
17 crawler(s) on-line.
 13 guest(s) on-line.
 1 member(s) on-line.


 Rob

You are an anonymous user.
Register Now!
 Rob:  4 secs ago
 zipper:  19 mins ago
 OlafS25:  35 mins ago
 Karlos:  47 mins ago
 dauber:  47 mins ago
 michalsc:  1 hr 9 mins ago
 emeck:  1 hr 18 mins ago
 BigD:  1 hr 28 mins ago
 lionstorm:  1 hr 46 mins ago
 Oscar12:  1 hr 46 mins ago

Software News   Software News : mui-mplayer port from morphos to amigaos4 released
   posted by kas1e on 24-Oct-2011 20:16:06 (18563 reads)
Hi all

We with Deniil, with big help from Fab (of course, and as usuall :) ) , release a first version of mui-mplayer port from morphos. Check os4depot for it (in upload query for now).


screenshot

There is many thinks to say, but in brief:

The advantages over the our current os4 port: newer mplayer code, better structurisation and code itself, mui-gui with all the stuff , better integration of streaming (working over bsdsocket.library directly), no SDL, sound over AHI, rendering over cgx_wpa and all the other pluses about which know only Fab as he author.

The minus now only one: No overlay. Because of it, in full-screenmode you have no scalling (to avoid slowdowns). Overlay will be implemented pretty soon (i hope).

If you want command line : use it from the shell

If you want GUI: run from the icon (tooltype GUI). If you disable that tooltype, then from the icon it will just ask for the file which need to open.

PS: its is _NECESSARY_ to have update3 minimum, if you want to use GUI. Or, you need MUI from update3, which you can copy on older version of OS and it will works as well. Through, better to just have update3, to avoid any possible problems.

So as usuall thanks to Fab for his sources, to Thore who works on MUI, to Deniil who help with porting and to DeadWood for some help as well.
    

STORYID: 6121
Related Links
· More about Software News
· News by kas1e


Most read story about Software News
UBoot 2010.06.04 for Sam460ex available

Last news about Software News
Hollywood APK Compiler 4.0 released
Printer Friendly Page  Send this Story to a Friend

Goto page ( 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 )

PosterThread
Mrodfr 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 17:29:40
#101 ]
Super Member
Joined: 28-Jan-2007
Posts: 1396
From: French

Hello,

Just played 60 .wmv files without problems. Just .wmv files work great.

Problems are located around video decoders IMHO.


_________________
BTW, what you have done for the amiga today ????

-A1200+Mediator+VooDoo3+060/50+96mo+SCSI-KIT
-SAM440EP-667mhz-on MapowerKC3000+AOS4.1

Amiga Docs Disks Preservation Project

 Status: Offline
Profile     Report this post  
kas1e 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 17:36:32
#102 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3538
From: Russia

@vulture
yes, send it at kas1e@yandex.ru plz

@Spectre660
Yep, right. Added LIBS:asyncio.library to archive.

Last edited by kas1e on 25-Oct-2011 at 05:43 PM.


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
VooDoo 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 18:50:12
#103 ]
Super Member
Joined: 16-Jun-2003
Posts: 1502
From: Croatia

The same as first version, crash on startup :( uA1c OS4.1 upd 3 ...


_________________
--
A1200 sandwich :)

uA1c/g3-800 mHz/512mb/160gb hdd/OS4.1 Final + upd #1

MacMini G4 1.5ghz 1GB ram + MorphOS 3.9

Croatian Amiga portal

 Status: Offline
Profile     Report this post  
Spectre660 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 18:51:59
#104 ]
Elite Member
Joined: 4-Jun-2005
Posts: 3912
From: Unknown

@ VooDoo

Do you have asyncio.library installed ?


_________________
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card

 Status: Offline
Profile     Report this post  
VooDoo 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 18:54:07
#105 ]
Super Member
Joined: 16-Jun-2003
Posts: 1502
From: Croatia

yeah , version 50.3 (asyncio.library) ?


_________________
--
A1200 sandwich :)

uA1c/g3-800 mHz/512mb/160gb hdd/OS4.1 Final + upd #1

MacMini G4 1.5ghz 1GB ram + MorphOS 3.9

Croatian Amiga portal

 Status: Offline
Profile     Report this post  
Spectre660 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 19:13:53
#106 ]
Elite Member
Joined: 4-Jun-2005
Posts: 3912
From: Unknown

Hvae you tried running from CLI to see if it prints an error before the crash ?


_________________
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card

 Status: Offline
Profile     Report this post  
VooDoo 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 19:21:16
#107 ]
Super Member
Joined: 16-Jun-2003
Posts: 1502
From: Croatia

This is from shell

"/0.RAM Disk:mplayer!> mplayer -gui 1
The -gui option will only work as the first command line argument.
MPlayer UNKNOWN-4.4.3 (C) 2000-2010 MPlayer Team
160 audio & 349 video codecs
VO: [cgx_wpa] Welcome man !.
VO: Disabling blankero (h264),
"

have only this , and have crash log if you need it.


_________________
--
A1200 sandwich :)

uA1c/g3-800 mHz/512mb/160gb hdd/OS4.1 Final + upd #1

MacMini G4 1.5ghz 1GB ram + MorphOS 3.9

Croatian Amiga portal

 Status: Offline
Profile     Report this post  
kas1e 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 19:27:48
#108 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3538
From: Russia

@all and voodoo

Let's contnue all of this in the mplayer thread , i upload new version, with 2 bins,as well as include asyncio.library, so no need to worry,. Check this out


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
sicky 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 19:30:52
#109 ]
Elite Member
Joined: 11-Mar-2003
Posts: 2843
From: Essex, UK

@kasle

Quote:
Dunno for now .. Maybe CGX emulation for sam460 somehow works different ? Or maybe it crashes by some reassons because of "las


I tried that and it made no difference.

Could it be due to graphic card I am using Radeon HD 4650 as DVPlayer also crashes every time I try to run it, was wondering if the current GFX card driver has issues?


Edit

Sorry just saw all the other posts, looks like altivec issue not gfx card issue....... sorry!

Last edited by sicky on 25-Oct-2011 at 07:41 PM.


_________________
SAM 460 with 2GB or RAM, 1000GB HD, 4 port SATA, DVDRW drive and Radeon HD 4650 GFX card.

 Status: Offline
Profile     Report this post  
SinanG 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 19:31:34
#110 ]
Regular Member
Joined: 24-Dec-2004
Posts: 334
From: Unknown

Hello Kas1e,

Tried on my Sam460 + OS4.1 Update4 Beta. It started without any crashes. I have tried 2 DivX movies, both of them plays very well (even in full screenmode)

However when I move the time slider in the GUI, GUI crashes however MPlayer itself continues to work.. I have sent crashlog to your e-mail address


_________________
AmigaOS4 Beta-Tester
----------------------------------
Amiga X5000 8GB Radeon RX 560
Amiga A1222 2GB Radeon RX 550
Sam 460 2GB RadeonRX 550

 Status: Offline
Profile     Report this post  
Spectre660 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 19:35:02
#111 ]
Elite Member
Joined: 4-Jun-2005
Posts: 3912
From: Unknown

I have my screen blanker disabled . this is what I get

12.System:> Programs:Video/mplayer-MUI/mplayer -gui
The -gui option will only work as the first command line argument.
MPlayer UNKNOWN-4.4.3 (C) 2000-2010 MPlayer Team
160 audio & 349 video codecs
VO: [cgx_wpa] Welcome man !.
VO: Disabling blanker
VO: Enabling blanker
DEFNEW: before dosupernew in mplayergroupslcass.c
DEFNEW of mplayergroupclass.c: 0x545848cc
we in the !mygui->embedded
DEFNEW: we do all domethods if if obj
12.System:>


_________________
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card

 Status: Offline
Profile     Report this post  
kas1e 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 19:35:57
#112 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3538
From: Russia

@Sicky
I think its because of non-include asyncio.library . Now i include everything and making 2 versions (generic one, and altivec one). Test plz (archive are in the mplayer thread, let's conntinue in it).

@SinanG
Cool :) Which version you try ? Very latest one, with generic binary ?

Related to crash - its all confirmed to be a bug in mui which already fixed (and in beta version of mui for now). I will make some workorounds till moment of course.


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
kas1e 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 19:36:41
#113 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3538
From: Russia

@Spectre660

Let's continue in mplayer thread. Did you try very latest version from thread ? And argument for gui should be "1". I.e. "mplayer -gui 1". Not just "gui".

Last edited by kas1e on 25-Oct-2011 at 07:37 PM.


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
SinanG 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 19:43:40
#114 ]
Regular Member
Joined: 24-Dec-2004
Posts: 334
From: Unknown

@kas1e

I downloaded 10 minutes ago. Timestamp 25.10.2011 19:43:20

Btw I tried playing a mpeg movie, mplayer itself crashed after opening a blank window. I have sent the crashlog of this crash as well.

Last edited by SinanG on 25-Oct-2011 at 07:48 PM.


_________________
AmigaOS4 Beta-Tester
----------------------------------
Amiga X5000 8GB Radeon RX 560
Amiga A1222 2GB Radeon RX 550
Sam 460 2GB RadeonRX 550

 Status: Offline
Profile     Report this post  
kas1e 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 19:44:44
#115 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3538
From: Russia

@Sinang

Did you try generic version of course ? And in my achive there is no GenericPPC versions btw, just "mplayer_altivec" and "mplayer_generic". That it , right ?

Last edited by kas1e on 25-Oct-2011 at 07:45 PM.


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
sicky 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 19:46:28
#116 ]
Elite Member
Joined: 11-Mar-2003
Posts: 2843
From: Essex, UK

@kasle

Quote:
@Sicky
I think its because of non-include asyncio.library . Now i include everything and making 2 versions (generic one, and altivec one).Test plz (archive are in mplayer thread, lets continue in it).


Where can I find that archive, looked through thread and can't see it?

Edit:

Just seen the link!

Last edited by sicky on 25-Oct-2011 at 07:52 PM.


_________________
SAM 460 with 2GB or RAM, 1000GB HD, 4 port SATA, DVDRW drive and Radeon HD 4650 GFX card.

 Status: Offline
Profile     Report this post  
mr2 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 19:52:49
#117 ]
Cult Member
Joined: 3-Feb-2004
Posts: 691
From: Poland

@sicky


This thread ;)

http://www.crocko.com/B14872F41B184A38A1E3D205B0455053/muimplayer.lha


_________________
Sam440ep-flex 800MHz 1GB RAM R9250 128MB SB Live!

 Status: Offline
Profile     Report this post  
SinanG 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 19:54:11
#118 ]
Regular Member
Joined: 24-Dec-2004
Posts: 334
From: Unknown

GenericPPC was left from earlier versions.. I deleted...

The archive that I have downloaded has only 1 binary...I'll download the new version you have uploaded but that freehosting site tells me to wait for 20 mins :)


_________________
AmigaOS4 Beta-Tester
----------------------------------
Amiga X5000 8GB Radeon RX 560
Amiga A1222 2GB Radeon RX 550
Sam 460 2GB RadeonRX 550

 Status: Offline
Profile     Report this post  
kas1e 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 19:56:06
#119 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3538
From: Russia

@SinanG
Yeah, you need to dl latest one, because your crashlog point that you still use Altivec version.


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
danwood 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 20:13:51
#120 ]
Super Member
Joined: 30-Sep-2008
Posts: 1059
From: Unknown

Quote:
I would like to see some stuff go the other way (i.e. OS4 to MOS), to help reduce tensions between both "sides", and hopefully engender a more co-operative attitude from both sides (i.e. beyond Fab + Kas1e/etc).


Well from a MOS and AmigaOS user, I'd love to be able to run TuneNet on MOS :)

OS4Emu handles a few things, but not Tunenet sadly.

 Status: Offline
Profile     Report this post  

Goto page ( 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle