Click Here
home features news forums classifieds faqs links search
6066 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
38 crawler(s) on-line.
 28 guest(s) on-line.
 2 member(s) on-line.


 BigD,  BSzili

You are an anonymous user.
Register Now!
 BSzili:  2 secs ago
 BigD:  35 secs ago
 AMIGASYSTEM:  7 mins ago
 eliyahu:  8 mins ago
 Rob:  11 mins ago
 dframeli:  13 mins ago
 zipper:  18 mins ago
 Everblue:  26 mins ago
 AF-Domains.net:  28 mins ago
 kriz:  41 mins ago

Software News   Software News : mui-mplayer port from morphos to amigaos4 released
   posted by kas1e on 24-Oct-2011 20:16:06 (18430 reads)
Hi all

We with Deniil, with big help from Fab (of course, and as usuall :) ) , release a first version of mui-mplayer port from morphos. Check os4depot for it (in upload query for now).


screenshot

There is many thinks to say, but in brief:

The advantages over the our current os4 port: newer mplayer code, better structurisation and code itself, mui-gui with all the stuff , better integration of streaming (working over bsdsocket.library directly), no SDL, sound over AHI, rendering over cgx_wpa and all the other pluses about which know only Fab as he author.

The minus now only one: No overlay. Because of it, in full-screenmode you have no scalling (to avoid slowdowns). Overlay will be implemented pretty soon (i hope).

If you want command line : use it from the shell

If you want GUI: run from the icon (tooltype GUI). If you disable that tooltype, then from the icon it will just ask for the file which need to open.

PS: its is _NECESSARY_ to have update3 minimum, if you want to use GUI. Or, you need MUI from update3, which you can copy on older version of OS and it will works as well. Through, better to just have update3, to avoid any possible problems.

So as usuall thanks to Fab for his sources, to Thore who works on MUI, to Deniil who help with porting and to DeadWood for some help as well.
    

STORYID: 6121
Related Links
· More about Software News
· News by kas1e


Most read story about Software News
UBoot 2010.06.04 for Sam460ex available

Last news about Software News
Hollywood APK Compiler 4.0 released
Printer Friendly Page  Send this Story to a Friend

Goto page ( 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 )

PosterThread
petrol 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 21:16:49
#121 ]
Regular Member
Joined: 25-Jun-2004
Posts: 410
From: France

Is Bean interesting for port his soft? Anybody asked him?

On MorphOs, Aminetradio looks pretty cool too.

@Fab, Kas1e and all involved

Thanks for all great things you are doing for our small community.

Petrol.

 Status: Offline
Profile     Report this post  
samo79 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 21:23:19
#122 ]
Elite Member
Joined: 13-Feb-2003
Posts: 3445
From: Italy, Perugia

@kas1e

Just try the version (not the latest it seems) infact i have the usual crash at startup because asyncio.library, aniway it seems ok now altrought very buggy i can say, i have a crash also moving the timer slider and in many other part of the program, some freeze too ...

Aniway how about opening the usual space for bugreports under bugs.os4depot ?


_________________
BACK FOR THE FUTURE

http://www.betatesting.it/backforthefuture

Sam440ep Flex 800 Mhz 1 GB Ram + AmigaOS 4.1 Update 6
AmigaOne XE G3 800 Mhz - 640 MB Ram - Radeon 9200 SE + AmigaOS 4.1 Update 6

 Status: Offline
Profile     Report this post  
kas1e 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 21:35:52
#123 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3536
From: Russia

@samo79
Quote:

altrought very buggy


What bugs you also found ? I for now know only about :

1. slider bug (already fixed)
2. crashes because of altivec (already make 2 versions)
3. non asyncio-library (already included)
4. some crash with .flv, which imho related to stack (already inluded stack cookie).

Quote:

and in many other part of the program


Describe plz (in the mplayer-thread)

Last edited by kas1e on 25-Oct-2011 at 09:36 PM.


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
samo79 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 21:45:58
#124 ]
Elite Member
Joined: 13-Feb-2003
Posts: 3445
From: Italy, Perugia

@kas1e

Quote:
Describe plz (in the mplayer-thread)


Ok just let me some time, i have some problems now (read my private message for detail)


_________________
BACK FOR THE FUTURE

http://www.betatesting.it/backforthefuture

Sam440ep Flex 800 Mhz 1 GB Ram + AmigaOS 4.1 Update 6
AmigaOne XE G3 800 Mhz - 640 MB Ram - Radeon 9200 SE + AmigaOS 4.1 Update 6

 Status: Offline
Profile     Report this post  
kas1e 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 25-Oct-2011 22:42:07
#125 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3536
From: Russia

@all
New version


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
Swoop 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 26-Oct-2011 0:00:15
#126 ]
Elite Member
Joined: 20-Jun-2003
Posts: 2158
From: Long Riston, East Yorkshire

@kas1e
Quote:
Binary will auto-detect altivec when its need it, and will not use it , when its not available.

Link (no direct, so you need scroll down, and choice "free download"):
http://www.crocko.com/F79CBF93AAC0465F84AD8A2F16F91594/muimplayer.lha

Still crashes on my A1XE-G3 800.


_________________
Peter Swallow.
A1XEG3-800 [IBM 750FX PowerPC], running OS4.1FE, using ac97 onboard sound.

"There are 10 types of people in the world: those who understand binary, and those who don't."

 Status: Offline
Profile     Report this post  
acefnq 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 26-Oct-2011 2:08:47
#127 ]
Cult Member
Joined: 11-Jan-2006
Posts: 617
From: Adelaide, South Australia

Thanks for your hard work (and to others who assisted). Works fine with on my SAM 460 noting the crashes after using flv files, do you expect any fix for this problem?

Cheers

ace

 Status: Offline
Profile     Report this post  
wawa 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 26-Oct-2011 5:52:06
#128 ]
Elite Member
Joined: 21-Jan-2008
Posts: 6259
From: Unknown

mmm, delicious, even if i can only smell it from the other side. kas1e and others: great work, doesnt matter if complete, cause it will eventually be. also i fully support os4 ambient port. mos team will not easily resign on their advantages, but this is a move in a long discussed direction. hope will have a pp account again as soon as you establish the bounty. being selfish of course. i'd expect you will support aros ambient port with your expertise, when the time comes.

 Status: Offline
Profile     Report this post  
Crumb 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 26-Oct-2011 8:02:59
#129 ]
Elite Member
Joined: 12-Mar-2003
Posts: 2209
From: Zaragoza (Aragonian State)

Quote:
I don't really care about WHICH apps, merely that SOME should get ported, to (at the very least!) show our good intentions. But if necessary, people should write new OS4 apps in MUI, so that can then be easily ported to MorphOS.


Friedens already showed their goodwill and kindness announcing that they wouldn't release amiga-specific changes of Timberwolf.


_________________
The only spanish amiga news web page/club: CUAZ

 Status: Offline
Profile     Report this post  
kas1e 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 26-Oct-2011 8:39:30
#130 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3536
From: Russia

@Swoop
As i pointed out : try the version from os4depot which for now in upload query (i.e. not the version which in recent files, but that one which for now in upload query)


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
afxgroup 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 26-Oct-2011 8:58:12
#131 ]
Super Member
Joined: 8-Mar-2004
Posts: 1968
From: Taranto, Italy

Since i'm a little bit expert on mplayer..

@Kas1e
Actually you cannot release a single mplayer exe because every time you use the altivec switch with gcc the compiler will activate optimisations also in the code and so it will be unusable on machines that doesn't have altivec. Yes it is also needed by libavcodec to use altivec instructions but not only for this.
That's why i've always released two version of mplayer.. this problem was already known. There is also a message on mplayer mailing list regard this problem


_________________
http://www.amigasoft.net

 Status: Offline
Profile     Report this post  
Fab 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 26-Oct-2011 9:03:45
#132 ]
Super Member
Joined: 17-Mar-2004
Posts: 1178
From: Unknown

@afxgroup

Sure you can have a single binary. I do it, and it's no issue. But it requires special care, as said previously, because of their build system not taking that into account.

 Status: Offline
Profile     Report this post  
Tuxedo 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 26-Oct-2011 11:19:20
#133 ]
Elite Member
Joined: 28-Nov-2003
Posts: 2327
From: Perugia, ITALY

Hi,
here on my Peg2 works quite nice the only big issue was the non overlay support...

It was about 2 time slower than the afxgroup version in that way... :P
And on MOS side the Fab version was instead faster than afx one...

So hope to get an overaly version soon :)


_________________
Simone"Tuxedo"Monsignori, Perugia, ITALY.

 Status: Offline
Profile     Report this post  
Fab 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 26-Oct-2011 11:58:11
#134 ]
Super Member
Joined: 17-Mar-2004
Posts: 1178
From: Unknown

Well, if you want to make a fair comparison test, since this port doesn't have overlay yet, you should use the SDL output driver with the older OS4 version.

 Status: Offline
Profile     Report this post  
stevieu 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 26-Oct-2011 12:12:06
#135 ]
Cult Member
Joined: 23-Apr-2003
Posts: 647
From: England, UK

Excellent work!

Just played a few random AVI files as a quick test... works really nicely. Will do more testing as soon as I get chance!

Many thanks to all involved.

Stephen


_________________
A1200T - OS4.0,OS3.9: 603e PPC 200mhz,060 50mhz, 256mb ram, FastATA MK-III, BVision, 160gb,20gb HDDs

A1200 - OS3.1: Blizzard IV 030, 64mb ram, 400mb HDD

OS4.x - Flying the AMIGA flag

 Status: Offline
Profile     Report this post  
tommysammy 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 26-Oct-2011 15:50:58
#136 ]
Cult Member
Joined: 20-Jan-2010
Posts: 659
From: Isselburg,Germany

The new version works great on my X1000.I use the altivec version


_________________
Amiga600/Vampire2/PrismaMegaMix

 Status: Offline
Profile     Report this post  
kas1e 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 26-Oct-2011 16:04:58
#137 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3536
From: Russia

@tommysammy
What about generic version ? I hope also works fine ?

As i know, you not have in radeonhd now overlay support, so, all the other players (like dvplayer and old mplayer) also works for you without overlay. So, can you please test some video, and see, what version faster or slower.


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
tommysammy 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 26-Oct-2011 16:08:53
#138 ]
Cult Member
Joined: 20-Jan-2010
Posts: 659
From: Isselburg,Germany

Yes sure


_________________
Amiga600/Vampire2/PrismaMegaMix

 Status: Offline
Profile     Report this post  
tommysammy 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 26-Oct-2011 16:19:03
#139 ]
Cult Member
Joined: 20-Jan-2010
Posts: 659
From: Isselburg,Germany

Both version from mplayer works fine here.The altivec version is here 8-10 percent faster .
I have found two problems .VoB files from a DVD movie eating in both version my CPU.
CPU ist at 100 percent.
When i use clipdown for youtube ,the video is playing but i don`t see something?No window opens but the CPU power showing me that something happens
Is that an overlay problem?

Last edited by tommysammy on 26-Oct-2011 at 04:19 PM.


_________________
Amiga600/Vampire2/PrismaMegaMix

 Status: Offline
Profile     Report this post  
kas1e 
Re: mui-mplayer port from morphos to amigaos4 released
Posted on 26-Oct-2011 16:42:16
#140 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3536
From: Russia

@tommysammy

Quote:

VoB files from a DVD movie eating in both version my CPU.
CPU ist at 100 percent.


100% cpu loading was caused by some optimisation flag which cause such problems in our current gcc (it was -O4 optimisation flag). Now i build everything with -O2 , and no more 100% cpu loading should be.

Still, try to play the same Vob files via Andrea's version, to see, if it will better or worse.

Quote:

When i use clipdown for youtube ,the video is playing but i don`t see something?No window opens but the CPU power showing me that something happens
Is that an overlay problem?


Did you mean it not show GUI , and only show video window, or , it just show nothing for you at all ?

IF first : then you need to spawn "mplayer -gui 1"
If second: then try to use mplayer from command line, to see, what will happens.


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  

Goto page ( 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle