Click Here
home features news forums classifieds faqs links search
6092 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
» Home
» Features
» News
» Forums
» Classifieds
» Links
» Downloads
Extras
» OS4 Zone
» IRC Network
» AmigaWorld Radio
» Newsfeed
» Top Members
» Amiga Dealers
Information
» About Us
» FAQs
» Advertise
» Polls
» Terms of Service
» Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
24 crawler(s) on-line.
 14 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 michalsc:  9 mins ago
 Rob:  25 mins ago
 Hammer:  39 mins ago
 freak:  1 hr 24 mins ago
 Zylesea:  1 hr 30 mins ago
 DiscreetFX:  1 hr 32 mins ago
 PhantomInterrogative:  1 hr 35 mins ago
 utri007:  1 hr 39 mins ago
 mbrantley:  1 hr 53 mins ago
 NutsAboutAmiga:  2 hrs 2 mins ago

Announcement   Announcement : AmigaOS 4 running on AmigaOne at Pianeta Amiga 2003
   posted by DaveyD on 20-Sep-2003 9:55:20 (21652 reads)
"AmigaOS 4 running on AmigaOne to be demoed at the Pianeta Amiga 2003 show in Italy this weekend."

Spot the Difference >>>>

Source: Ben Hermans Managing partner Hyperion Entertainment
    

Related Links
· More about Announcement
· News by DaveyD


Most read story about Announcement
APoV Issue 3 is Released

Last news about Announcement
Boing, new (French) magazine dedicated to the Amiga.
Printer Friendly Page  Send this Story to a Friend

Goto page ( 1 | 2 | 3 | 4 | 5 )

PosterThread
_Steve_ 
Re: AmigaOS 4 running on AmigaOne at Pianeta Amiga 2003
Posted on 20-Sep-2003 17:12:06
#61 ]
Team Member
Joined: 18-Oct-2002
Posts: 6783
From: UK

Quote:
Poster: Chris_Y Date: 20-Sep-2003 15:34:57

Hmm, if ShowConfig was running under Petunia, surely the CPU would show up as a 680x0? I think the custom chips reference must be a default that ShowConfig reports when it doesn't know.


Actually I would be more inclined to say the custom chip references are there because OS4 will also run on legacy hardware which would still have them. And ShowConfig I would imagine is OS4 native ergo wouldn't report it was running on a 68K chip


_________________
Test sig

 Status: Offline
Profile     Report this post  
EntilZha 
Re: AmigaOS 4 running on AmigaOne at Pianeta Amiga 2003
Posted on 20-Sep-2003 17:51:57
#62 ]
OS4 Core Developer
Joined: 27-Aug-2003
Posts: 1679
From: The Jedi Academy, Yavin 4

Quote:
Hmm, if ShowConfig was running under Petunia, surely the CPU would show up as a 680x0? I think the custom chips reference must be a default that ShowConfig reports when it doesn't know.


What's running is a slightly modified ShowConfig. It just shows the CPU and it's configuration.

There are no PCI cards shown because they don't have ConfigDev's that would show up in ShowConfig.

Plus, the Agnus/Denise values are of course bogus. As we are running original graphics.library (not the rewrite) we had to build a *very tiny* "chipset emulation" that just delivers correct values for custom chip registers when needed, for example blitter finish and stuff like that. ShowConfig tries to read the ID's of the chips, and of course just receives zeros.

Additionally, the CPU it mentions is only identified by class, i.e. it shows 7400 when in fact it's a 7455 (which is, as most would agree, light years ahead of the 7400 )


_________________
Thomas, the kernel guy

"I don't have a frigging clue. I'm norwegian" -- Ole-Egil

All opinions expressed are my own and do not necessarily represent those of Hyperion Entertainment

 Status: Offline
Profile     Report this post  
Anonymous 
Re: AmigaOS 4 running on AmigaOne at Pianeta Amiga 2003
Posted on 20-Sep-2003 18:06:47
# ]



GREAT NEWS!!!!
BIG congratulations to the AOS 4 team.

 
     Report this post  
Chris_Y 
Re: AmigaOS 4 running on AmigaOne at Pianeta Amiga 2003
Posted on 20-Sep-2003 18:27:06
#64 ]
Elite Member
Joined: 21-Jun-2003
Posts: 3166
From: Beds, UK

@EntilZha
How far is the replacement graphics.library away from completion? (I can already sense the answer..)

It might be a good idea to modify the output of ShowConfig so it says "PPC7400 series" or "PPC74xx". Is it possible to show PCI board IDs in ShowConfig, as this would be a bit more useful on an AmigaOne than Zorro board IDs The WB titlebar would look neater if it showed "free memory", rather than showing the amount of memory twice (or is it showing half as chip, half as fast?).

Anyway, I'm nitpicking, I'm sure there are far more important things that need doing.

Chris


_________________
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar is Tabitha by Eric W Schwartz

 Status: Offline
Profile     Report this post  
Zorro 
Re: AmigaOS 4 running on AmigaOne at Pianeta Amiga 2003
Posted on 20-Sep-2003 20:43:19
#65 ]
Super Member
Joined: 30-Apr-2003
Posts: 1081
From: Italy

Rogue, EntilZha and all the OS4 team :

the Force is strongly with you...


_________________
-------------------------------
AmigaOS, the last hope...

 Status: Offline
Profile     Report this post  
trgse 
Re: AmigaOS 4 running on AmigaOne at Pianeta Amiga 2003
Posted on 20-Sep-2003 21:10:56
#66 ]
Regular Member
Joined: 11-Mar-2003
Posts: 315
From: tellus

Hyperion'ers... if I was a woman I would you lot but since I ain't I will just you... the only thing I want now is ...
the SDK/dev tools and... BPPC version and the dual G4 CPU board for the A1



have a couple of


_________________
MicroSoft Game Studios ==

 Status: Offline
Profile     Report this post  
_Steve_ 
Re: AmigaOS 4 running on AmigaOne at Pianeta Amiga 2003
Posted on 20-Sep-2003 21:12:26
#67 ]
Team Member
Joined: 18-Oct-2002
Posts: 6783
From: UK

Quote:
Poster: EntilZha Date: 20-Sep-2003 12:40:04

Quote:

Love your new Avatars Rogue & Entilzha


Yep... Big thanks to Karlos


It does somewhat resemble his little avatar And the avatars are still "twins" too hehe


_________________
Test sig

 Status: Offline
Profile     Report this post  
Karlos 
Re: AmigaOS 4 running on AmigaOne at Pianeta Amiga 2003
Posted on 20-Sep-2003 21:22:03
#68 ]
Elite Member
Joined: 24-Aug-2003
Posts: 2020
From: As-sassin-aaate! As-sassin-aaate! Ooh! We forgot the ammunition!

@_Steve_

Heh, you don't say Well, I was thinking along the lines of a theme, you see...


_________________
IBrowse/AWeb user? amiga.org - classic browser edition

 Status: Offline
Profile     Report this post  
redfox 
Re: AmigaOS 4 running on AmigaOne at Pianeta Amiga 2003
Posted on 20-Sep-2003 21:36:49
#69 ]
Super Member
Joined: 7-Mar-2003
Posts: 1844
From: Canada

WOW

to all involved.

---------------
redfox

PS (great screenshot, too)

 Status: Offline
Profile     Report this post  
The_Editor 
Re: AmigaOS 4 running on AmigaOne at Pianeta Amiga 2003
Posted on 20-Sep-2003 22:45:17
#70 ]
Elite Member
Joined: 7-Mar-2003
Posts: 7629
From: 192.168.0.02 ..Pederburgh .. Iceni

Yup



............. All hail the Mighty Hyperion...................


_________________
******************************************
I dont suffer from Insanity - I enjoy it

******************************************

 Status: Offline
Profile     Report this post  
Alkemyst 
Re: AmigaOS 4 running on AmigaOne at Pianeta Amiga 2003
Posted on 20-Sep-2003 22:50:50
#71 ]
Regular Member
Joined: 1-Mar-2003
Posts: 266
From: Unknown

@The_Editor

LOL


_________________
PowerTower A1200, 060/80Mhz, Heatsink & Fan, 66MBRam, PowerFlyerGold, 50xCDRomdrive, 250Zip, 2.1

 Status: Offline
Profile     Report this post  
Anonymous 
Re: AmigaOS 4 running on AmigaOne at Pianeta Amiga 2003
Posted on 20-Sep-2003 23:39:28
# ]



@The_Editor

Blue trolls and a red troll.

Wishful thinking? ;)

/Björn

 
     Report this post  
Mountain_Myst 
Re: AmigaOS 4 at Pianeta Amiga 2003
Posted on 21-Sep-2003 4:30:57
#73 ]
Regular Member
Joined: 8-Jan-2003
Posts: 112
From: Unknown

Oh crap...

Don't leave me out of all this.

I've just finished playing a new game I bought...
Midnight Club II.

After getting my arse kicked over and over again, and realizing that this is the best freaking driving game I've ever played, I decided to slip on over here to check the news.

well, a phone call from my brother out of state actually tipped me off...

And now, what am I seeing?

I never had any doubts about Amiga Inc, Hyperion, and the rest involved in this project.

It's just a matter of time now.

Wooottt !!!

 Status: Offline
Profile     Report this post  
JurassicC 
Re: AmigaOS 4 at Pianeta Amiga 2003
Posted on 21-Sep-2003 10:42:25
#74 ]
Super Member
Joined: 13-Mar-2003
Posts: 1441
From: Somerset, UK



OS4 on the A1 how cool is that!

Can't want to get linux of this thing

Does the A1 version use a different UBoot ?

@ Mountain Myst... Midnight Club II. I know where your coming from.


_________________
A1200T 603e 330Mhz - Mediator TX OS4.1 F.E.
CDTV 8MB Fast, OS3.1, SCSI, MicroSD SCSI & CD32 FMV
X5000, X1000, A1XE with OS4.1F.E.

 Status: Offline
Profile     Report this post  
olegil 
Re: AmigaOS 4 at Pianeta Amiga 2003
Posted on 21-Sep-2003 11:07:59
#75 ]
Elite Member
Joined: 22-Aug-2003
Posts: 5888
From: Work

Eh? different UBoot from what?


_________________
This weeks pet peeve:
Using "voltage" instead of "potential", which leads to inventing new words like "amperage" instead of "current" (I, measured in A) or possible "charge" (amperehours, Ah or Coulomb, C). Sometimes I don't even know what people mean.

 Status: Offline
Profile     Report this post  
JurassicC 
Re: AmigaOS 4 at Pianeta Amiga 2003
Posted on 21-Sep-2003 11:39:22
#76 ]
Super Member
Joined: 13-Mar-2003
Posts: 1441
From: Somerset, UK

Quote:
Eh? different UBoot from what?


Just curious as to what changes might have been made. Since 10/9/03 Uboot.


_________________
A1200T 603e 330Mhz - Mediator TX OS4.1 F.E.
CDTV 8MB Fast, OS3.1, SCSI, MicroSD SCSI & CD32 FMV
X5000, X1000, A1XE with OS4.1F.E.

 Status: Offline
Profile     Report this post  
Agafaster 
Re: AmigaOS 4 running on AmigaOne at Pianeta Amiga 2003
Posted on 21-Sep-2003 12:11:46
#77 ]
Super Member
Joined: 10-Mar-2003
Posts: 1413
From: West Midlands, England - sector ZZ9 plural Z alpha

Absolutely top banana !

but the big question is ... how long did it take to boot ?

top work, lads ! have one () on me !


_________________
XH558 - the worlds last flying Vulcan.
ok, its actually XL426 in the picture but you know what I mean.

 Status: Offline
Profile     Report this post  
sicky 
Re: AmigaOS 4 at Pianeta Amiga 2003
Posted on 21-Sep-2003 13:31:20
#78 ]
Elite Member
Joined: 11-Mar-2003
Posts: 2836
From: Essex, UK

Well done Hyperion,looking forward to reviewing it for Total Amiga http://www.totalamiga.org magazine

As soon as I have Amiga OS4 on my AmigaOne, Linux will be shown the door (the exit I hasten to add).


_________________
SAM 460 with 2GB or RAM, 1000GB HD, 4 port SATA, DVDRW drive and Radeon HD 4650 GFX card.

 Status: Offline
Profile     Report this post  
Mountain_Myst 
Re: AmigaOS 4 at Pianeta Amiga 2003
Posted on 21-Sep-2003 15:03:23
#79 ]
Regular Member
Joined: 8-Jan-2003
Posts: 112
From: Unknown

Ok.

It's Sunday morning here now...


Where's the pics?



Who's got'em?

 Status: Offline
Profile     Report this post  
Asemoon 
Re: AmigaOS 4 running on AmigaOne at Pianeta Amiga 2003
Posted on 21-Sep-2003 16:22:13
#80 ]
Member
Joined: 10-Mar-2003
Posts: 38
From: Unknown

Yippee!!!!

Well done!

 Status: Offline
Profile     Report this post  

Goto page ( 1 | 2 | 3 | 4 | 5 )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle