Click Here
home features news forums classifieds faqs links search
6072 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
22 crawler(s) on-line.
 31 guest(s) on-line.
 1 member(s) on-line.


 Karlos

You are an anonymous user.
Register Now!
 Karlos:  4 mins ago
 Rob:  28 mins ago
 zipper:  46 mins ago
 matthey:  50 mins ago
 Gunnar:  1 hr 22 mins ago
 Tpod:  1 hr 28 mins ago
 Kronos:  1 hr 44 mins ago
 cdimauro:  2 hrs 20 mins ago
 duga:  2 hrs 21 mins ago
 fatbob_gb:  2 hrs 24 mins ago

/  Forum Index
   /  Amiga OS4 Hardware
      /  SAM Flex/USB Mouse compatibility & ScreenMode
Register To Post

PosterThread
TrevorDick 
SAM Flex/USB Mouse compatibility & ScreenMode
Posted on 4-Nov-2009 11:49:43
#1 ]
Elite Member
Joined: 30-Dec-2004
Posts: 2678
From: Wellington

When I switched on my shiny new SAM Flex this morning it booted to a horrible low res 640x480 256 colour display. I rebooted but still the same result. I tried to change the Screenmode prefs but none of the high res Radeon modes were available, only the low res P96 FakeNative 640x480 modes.

As a quick test I decided to boot from the AmigaOS4.1 CD but got exactly the same results. I made a quick call to AmigaKit to discuss the problem and a possible solution. After making sure the battery and UBoot settings were OK I remembered I was using a different USB Mouse and Keyboard. As a test I removed the mouse and the SAM booted to the normal high res display. I re-inserted the mouse and again the SAM booted to the low res display.

I decided to try another (cheap) USB mouse I use with a netbook and this gave the same problem. I installed a Logitech USB mouse and again OK.

For future reference the USB mice that caused boot problems with the SAM Flex/OS4.1 were:-

PC-Line Model: PCL-WS01 (5V ~~100mA)
Optical Mouse Model: CM103C

TrevorD



_________________
No, I don't need no reason, I'm just breezin'

 Status: Offline
Profile     Report this post  
meet.mrnrg 
Re: SAM Flex/USB Mouse compatibility & ScreenMode
Posted on 4-Nov-2009 12:12:35
#2 ]
Super Member
Joined: 5-Feb-2007
Posts: 1919
From: UK, AUS, US

@TrevorDick

Are you serious? Or just pulling a leg?
How bizarre!

_________________
Quote:
Easy Pocket Money, Freelancers & Experts Online
MiniMig FPGA, Sam440 Flex 733Mhz PPC, Amiga OS 4.1 Update 2, MorphOS 2.4, Other - AmiKit + Cloanto Amiga Forever 2008 + E-UAE, AmigaSYS

 Status: Offline
Profile     Report this post  
TrevorDick 
Re: SAM Flex/USB Mouse compatibility & ScreenMode
Posted on 4-Nov-2009 12:37:49
#3 ]
Elite Member
Joined: 30-Dec-2004
Posts: 2678
From: Wellington

@meet.mrnrg

Quote:
Are you serious? Or just pulling a leg?

Very serious and I've just confirmed that the PC-Line mouse does the same to the SAM 440EP.

TrevorD

Last edited by TrevorDick on 04-Nov-2009 at 12:38 PM.

_________________
No, I don't need no reason, I'm just breezin'

 Status: Offline
Profile     Report this post  
ChrisH 
Re: SAM Flex/USB Mouse compatibility & ScreenMode
Posted on 4-Nov-2009 12:48:55
#4 ]
Elite Member
Joined: 30-Jan-2005
Posts: 6679
From: Unknown

@TrevorDick
It might be that OS4 thought one of the mouse buttons was held down, and this caused it to start in special 'safe' mode (I think it has one but I forget).

_________________
Author of the PortablE programming language.
It is pitch black. You are likely to be eaten by a grue...

 Status: Offline
Profile     Report this post  
amigauser 
Re: SAM Flex/USB Mouse compatibility & ScreenMode
Posted on 4-Nov-2009 12:55:04
#5 ]
Regular Member
Joined: 2-Nov-2009
Posts: 100
From: Unknown

@TrevorDick

some of the makers of usb equimpent dont follow the usb stantard 100%. then you will experience things like this, this can even happen to ms windows users. when it comes to sam and aos4 i would stick to known brand like logitech.

 Status: Offline
Profile     Report this post  
TrevorDick 
Re: SAM Flex/USB Mouse compatibility & ScreenMode
Posted on 4-Nov-2009 13:03:01
#6 ]
Elite Member
Joined: 30-Dec-2004
Posts: 2678
From: Wellington

@amigauser

Quote:
i would stick to known brand like logitech.

Agreed! I was using my logitech mouse on another system and grabbed another USB mouse that was handy.

TrevorD

_________________
No, I don't need no reason, I'm just breezin'

 Status: Offline
Profile     Report this post  
TrevorDick 
Re: SAM Flex/USB Mouse compatibility & ScreenMode
Posted on 4-Nov-2009 13:10:33
#7 ]
Elite Member
Joined: 30-Dec-2004
Posts: 2678
From: Wellington

@ChrisH

Quote:
It might be that OS4 thought one of the mouse buttons was held down, and this caused it to start in special 'safe' mode

Thanks Chris, I just performed a test with the logitech mouse. Holding down the right mouse button while booting does forces the SAM to boot into a low res 640x480 256 colour screen mode.

TrevorD

Last edited by TrevorDick on 04-Nov-2009 at 01:11 PM.

_________________
No, I don't need no reason, I'm just breezin'

 Status: Offline
Profile     Report this post  
Phantom 
Re: SAM Flex/USB Mouse compatibility & ScreenMode
Posted on 4-Nov-2009 13:12:35
#8 ]
Elite Member
Joined: 2-Aug-2007
Posts: 2047
From: Unknown

@TrevorDick

I use a Microsoft mouse via a KVM switch, but I never had this problem you describe.

_________________

 Status: Offline
Profile     Report this post  
Xenic 
Re: SAM Flex/USB Mouse compatibility & ScreenMode
Posted on 4-Nov-2009 13:38:33
#9 ]
Super Member
Joined: 2-Feb-2004
Posts: 1246
From: Pennsylvania, USA

@TrevorDick
I've never had your problem but I have a wireless Kensington mouse that isn't recognize at system boot on my SAM Flex or my A1. If I plug it in after the system has booted, it works fine. I've tested some friend's mice and older mice that are serial & USB compatable (they came with a USB adapter) all seem to work with USB. Some newer "USB only" mice seem to present problems when used with OS 4.x.

_________________
X1000 with 2GB memory & OS4.1FE

 Status: Offline
Profile     Report this post  
TrevorDick 
Re: SAM Flex/USB Mouse compatibility & ScreenMode
Posted on 4-Nov-2009 13:44:55
#10 ]
Elite Member
Joined: 30-Dec-2004
Posts: 2678
From: Wellington

@Xenic

Quote:
If I plug it in after the system has booted, it works fine. I

Yes, I've also discovered that although the PC-Line mouse causes fallback to low res screen if it's connected on boot-up, I can connect it after OS4 has booted and it works fine!

@Phantom
First time I've seen the problem too.

TrevorD

Last edited by TrevorDick on 04-Nov-2009 at 01:46 PM.

_________________
No, I don't need no reason, I'm just breezin'

 Status: Offline
Profile     Report this post  

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle