Click Here
home features news forums classifieds faqs links search
6081 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
61 crawler(s) on-line.
 14 guest(s) on-line.
 1 member(s) on-line.


 pavlor

You are an anonymous user.
Register Now!
 pavlor:  32 secs ago
 V8:  21 mins ago
 xe54:  27 mins ago
 Deniil715:  29 mins ago
 CygnusEd:  40 mins ago
 Karlos:  41 mins ago
 paolone:  1 hr 17 mins ago
 zipper:  1 hr 19 mins ago
 fishy_fis:  3 hrs 6 mins ago
 VooDoo:  3 hrs 9 mins ago

/  Forum Index
   /  Classic Amiga Software
      /  steps to run OWB 68k more than 3* faster
Register To Post

Goto page ( Previous Page 1 | 2 | 3 | 4 | 5 | 6 Next Page )
PosterThread
Mrodfr 
Re: steps to run OWB 68k more than 3* faster
Posted on 8-Dec-2008 15:07:53
#81 ]
Super Member
Joined: 28-Jan-2007
Posts: 1396
From: French

@wawa

actually (actual SDL.library 68k with defpengui), the mouse pointer move and stop and move and stop forever..... because CPU reach 100% (sometime but not allways).

Move your mouse pointer around the wb screen when Defpengui run on a window and youwill understand.

But no problem to load scout and open the task window and resize to see the CPU used by Defpengui. this operation isn't with full speed because defpengui run but It's possible.

Something on SDL eat too much CPU (I mean not regularly).

About testing:

All are free to test for fun if futur improvment made by bernd on SDL and ixemul give a better use of SDL program and ixemul program. Just let the thing growing (and wait first improved new SDL and ixemul.library for 68k).

_________________
BTW, what you have done for the amiga today ????

-A1200+Mediator+VooDoo3+060/50+96mo+SCSI-KIT
-SAM440EP-667mhz-on MapowerKC3000+AOS4.1

Amiga Docs Disks Preservation Project

 Status: Offline
Profile     Report this post  
wawa 
Re: steps to run OWB 68k more than 3* faster
Posted on 8-Dec-2008 15:27:38
#82 ]
Elite Member
Joined: 21-Jan-2008
Posts: 6259
From: Unknown

@Mrodfr

no, i mean even after i exit the sdl app the system is not responsive anymore even though the scout shows cpu working at ~10%. it is like the sdl has trashed the input handling permamently or something

 Status: Offline
Profile     Report this post  
wawa 
Re: steps to run OWB 68k more than 3* faster
Posted on 8-Dec-2008 18:04:40
#83 ]
Elite Member
Joined: 21-Jan-2008
Posts: 6259
From: Unknown

by now im testing it with os4. since the sdl.library is embedded into the app (as i understand it it) it could also give some results.

the executable from 6.12 runs very slowly with disabled jit. regard the message i get after closing the app. system remains responsive at all times.

5.os4:> prog/defendguin/defendguin_68k.exe --nosound
***Befehl 'prog/defendguin/defendguin_68k.exe' endete mit nicht freigegebenen Signalen 40000000!

the 8.12 executable causes an immediate grim reaper:
http://img242.imageshack.us/img242/3825/grimtk1.jpg

Last edited by wawa on 08-Dec-2008 at 06:49 PM.
Last edited by wawa on 08-Dec-2008 at 06:48 PM.
Last edited by wawa on 08-Dec-2008 at 06:46 PM.
Last edited by wawa on 08-Dec-2008 at 06:44 PM.

 Status: Offline
Profile     Report this post  
Mrodfr 
Re: steps to run OWB 68k more than 3* faster
Posted on 8-Dec-2008 18:45:42
#84 ]
Super Member
Joined: 28-Jan-2007
Posts: 1396
From: French

@wawa

Quote:
no, i mean even after i exit the sdl app the system is not responsive anymore............


Here I haven't this kind of problems. Quitting SDL defpengui 68k or barrage 68k and the system respond well all the time and the mouse work fine. Of course, I haven't checked if actual SDL cause hits or related, when using defpengui.

I could let Defpengui running and jump to YAM on his own screen and write a mail (of course the pointer move and stop forever and typing on keyboard verry slighty slow). just one example

all mediator elbox settings here are NO (of course not numeric settings).

NOTE after reading your last post:

defpengui_68k first version cause a divide per zero hit, when using --nosound, on classic amiga and greatly removed by the great MCP

last bernd version (884668ko) not make this hit.

Last edited by Mrodfr on 08-Dec-2008 at 06:48 PM.

_________________
BTW, what you have done for the amiga today ????

-A1200+Mediator+VooDoo3+060/50+96mo+SCSI-KIT
-SAM440EP-667mhz-on MapowerKC3000+AOS4.1

Amiga Docs Disks Preservation Project

 Status: Offline
Profile     Report this post  
wawa 
Re: steps to run OWB 68k more than 3* faster
Posted on 8-Dec-2008 18:54:57
#85 ]
Elite Member
Joined: 21-Jan-2008
Posts: 6259
From: Unknown

@Mrodfr:
i do not understand what mediator settings u mean. sorry

ok. ive enabled jit for the 6.12 version. i get here 5 fps and it is running stable except again:

***Befehl 'prog/defendguin/defendguin_68k.exe' endete mit nicht freigegebenen Signalen 40000000!

on exit

the 8.12 version crashes as well with jit as without

Last edited by wawa on 08-Dec-2008 at 06:56 PM.

 Status: Offline
Profile     Report this post  
Mrodfr 
Re: steps to run OWB 68k more than 3* faster
Posted on 8-Dec-2008 19:06:33
#86 ]
Super Member
Joined: 28-Jan-2007
Posts: 1396
From: French

@wawa

in SYS:prefs/en-varc/mediator/

NOTE: BTW, what mean 6.12 and 8.12 ???? SDL is 12.6 and defpengui is 0.11.



Last edited by Mrodfr on 08-Dec-2008 at 07:12 PM.
Last edited by Mrodfr on 08-Dec-2008 at 07:11 PM.

_________________
BTW, what you have done for the amiga today ????

-A1200+Mediator+VooDoo3+060/50+96mo+SCSI-KIT
-SAM440EP-667mhz-on MapowerKC3000+AOS4.1

Amiga Docs Disks Preservation Project

 Status: Offline
Profile     Report this post  
wawa 
Re: steps to run OWB 68k more than 3* faster
Posted on 8-Dec-2008 19:29:54
#87 ]
Elite Member
Joined: 21-Jan-2008
Posts: 6259
From: Unknown

@Mrodfr:
does that mean you do not have any environmental variables for the mediator set at all??!!
6.12 is the version of defendguin from the 6th of december
8.12 is respectively version from the 8th of december, the only way to distinguish between the both since bernd didnt change the version number

 Status: Offline
Profile     Report this post  
bernd_afa 
Re: steps to run OWB 68k more than 3* faster
Posted on 8-Dec-2008 19:32:46
#88 ]
Cult Member
Joined: 14-Apr-2006
Posts: 829
From: Unknown

@wawa

there are very few changes between SDL from both versions.a copy routine is remove
maybe the crash come from the AHI unit change.

try a player program winamp etc and set unit to 3.maybe you have not choose a device

also i notice that you should for better speed add a file in sys:prefs/envarc

sdl_hwsurface

then it run faster.also on my classic

if that make so much problems because of unit change i maybe should let unit at 0

 Status: Offline
Profile     Report this post  
wawa 
Re: steps to run OWB 68k more than 3* faster
Posted on 8-Dec-2008 19:55:20
#89 ]
Elite Member
Joined: 21-Jan-2008
Posts: 6259
From: Unknown

@bernd_afa

has sdl_hwsurface be set to 1?
if so the game seems to load a liitle faster and seems to play faster but the counter is still around 5fps on both os4/mediator/voodoo and os3.9/piv. on voodoo trashed palette.

Last edited by wawa on 08-Dec-2008 at 10:52 PM.

 Status: Offline
Profile     Report this post  
Mrodfr 
Re: steps to run OWB 68k more than 3* faster
Posted on 9-Dec-2008 6:34:41
#90 ]
Super Member
Joined: 28-Jan-2007
Posts: 1396
From: French

@wawa

Quote:
does that mean you do not have any environmental variables for the mediator set at all??!!


No explain that all mediator settings, on env/mediator, are all setted to NO (of course not the settings who need numbers).

_________________
BTW, what you have done for the amiga today ????

-A1200+Mediator+VooDoo3+060/50+96mo+SCSI-KIT
-SAM440EP-667mhz-on MapowerKC3000+AOS4.1

Amiga Docs Disks Preservation Project

 Status: Offline
Profile     Report this post  
Mrodfr 
Re: steps to run OWB 68k more than 3* faster
Posted on 9-Dec-2008 6:37:50
#91 ]
Super Member
Joined: 28-Jan-2007
Posts: 1396
From: French

@wawa

around 5 fps and is you use ctrl+lalt+h (during the SDL run- SDL window active) the game run faster because 15fps used).

Have you trashed palette just with voodoo and not with PIV ??? Maybe a problem with elbox voodoo driver when 16 bit screenmode used.

_________________
BTW, what you have done for the amiga today ????

-A1200+Mediator+VooDoo3+060/50+96mo+SCSI-KIT
-SAM440EP-667mhz-on MapowerKC3000+AOS4.1

Amiga Docs Disks Preservation Project

 Status: Offline
Profile     Report this post  
bernd_afa 
Re: steps to run OWB 68k more than 3* faster
Posted on 9-Dec-2008 9:43:24
#92 ]
Cult Member
Joined: 14-Apr-2006
Posts: 829
From: Unknown

>but the counter is still around 5fps on both os4/mediator/voodoo and os3.9/piv. on >voodoo trashed palette.

when it work on OS4,this seem you use on your OS3.9 P96 system a 16bit PC screenmode.Does P4 not offer 16 bit screenmode, that have no PC at end ?

I verify this and try on winuae sdl_HWSURFACE and 16 bit.winuae i test 16 bit PC screenmode and i see here too display problems.

My classic amiga use a 16 bit screenmode and work with SDL_hwsurface much faster and counter show this.

but when both told game run faster but counter is same, then maybe a timer problem or the eclock timer is unavailable.

I use for timing e-clock thats best precision.maybe i should try out the microhz timer.

I am not very familar with the amiga timers what happen if 2 programs want use e-clock timer,so i open and close every timer wait the timer device to be on safe side.

@mrodfr

you told that the mousepointer hang then move then hang ?

does this happen also with --nosound ?

sorry for problems, but it is hard to see whats go wrong, when all work ok(except SDL_HWSURFACE and 16 bit PC mode) on my A4000 with cybervisionPPC and winuae.

On my classic i get 8-9 fps and after CTR+alt+h is pressed 20-22 fps without mouse hang

Last edited by bernd_afa on 09-Dec-2008 at 11:50 AM.
Last edited by bernd_afa on 09-Dec-2008 at 09:46 AM.
Last edited by bernd_afa on 09-Dec-2008 at 09:45 AM.

 Status: Offline
Profile     Report this post  
wawa 
Re: steps to run OWB 68k more than 3* faster
Posted on 9-Dec-2008 12:33:56
#93 ]
Elite Member
Joined: 21-Jan-2008
Posts: 6259
From: Unknown

@bernd_afa
bernd, isnt that possible to insert request register to choose screenmode or it is too much work?
i didnt tried ctrl+alt+h, but if i get 5fps on mediator/voodoo it figures that you get 8-9 on cv_ppc since it is on a direct ppc-pci bus while voodoo receives data through the native a4k zorro3 bus without dma which is slow and eats processing power. the only advantage of voodoo is that it has fast blitter itself and could be used for 3d but this is not the case.

@Mrodfr
Quote:

No explain that all mediator settings, on env/mediator, are all setted to NO (of course not the settings who need numbers).


i dont think that it matters.
could you please tell me what versions of libraries do you have in libs/picasso96
i mean rtg.library and emulation.library

and also what versions of present cybergraphics.library and cgxvideo.library are reported by scout or artm.
i do not know if this is of any importance, just guessing

 Status: Offline
Profile     Report this post  
wawa 
Re: steps to run OWB 68k more than 3* faster
Posted on 9-Dec-2008 12:39:20
#94 ]
Elite Member
Joined: 21-Jan-2008
Posts: 6259
From: Unknown

@bernd
do you know this thread:
http://amigaworld.net/modules/newbb/viewtopic.php?topic_id=25625&forum=15#431347

there is a sdl benchmark for os4, maybe possible to compile for 68k:
http://www.os4depot.net/index.php?function=showfile&file=utility/benchmark/sdlbench.lha

i do not know where sources are, but probably not hard to find

 Status: Offline
Profile     Report this post  
wawa 
Re: steps to run OWB 68k more than 3* faster
Posted on 9-Dec-2008 12:41:18
#95 ]
Elite Member
Joined: 21-Jan-2008
Posts: 6259
From: Unknown

@bernd:
you did some kind of p96fix for amikit ive seen, what kind of fix is that? maybe it is what i need?

 Status: Offline
Profile     Report this post  
bernd_afa 
Re: steps to run OWB 68k more than 3* faster
Posted on 9-Dec-2008 14:03:47
#96 ]
Cult Member
Joined: 14-Apr-2006
Posts: 829
From: Unknown

>the only advantage of voodoo is that it has fast blitter itself and could be used for >3d but this is not the case.

DMA does gfx card not need.I only know from a piccolo 2 Z3 Card.This transfer 7 megabytes.then i own a merlin card.this was the fastest Z3 Card.transfer 13 MB.

the cybervision PPC is still not so fast as onboard mem.z3 mem transfer i get 21 megabytes/sec.

the mem bus of the current 060 Cards (from natami if this work i dont know)slow down much the performance.

winuae when jit is DISABLE get with sysspeed 38 mips.so CPU core is much slower than 060.But the mentransfer rate is 40 megabytes and 2* faster.

so winue get with that settings and sound 18 fps and with control H full framerate, so i thought a Voodoo3 can reach the 8-9 fps my cybervison get reach too.

then it seem important to get 3d working with SDL.
code for storm mesa is in.

does storm mesa Demos with voodoo3 work good ?
I only know from cybervision PPC it work usefull.

but first i make sdl 2d and ixemul and 68k compilers.
thge ixemul i get miss file start.s for in ixent dir, seem i need too source of 68k 49.10 because in MOS Version is much change and get linker error

>you did some kind of p96fix for amikit ive seen, what kind of fix is that? maybe it is >what i need?

I dont know what you mean

the 68060 load store bypass disable that cause wrong zune draw, maybe get SDL working.

Last edited by bernd_afa on 09-Dec-2008 at 02:06 PM.

 Status: Offline
Profile     Report this post  
wawa 
Re: steps to run OWB 68k more than 3* faster
Posted on 9-Dec-2008 15:32:55
#97 ]
Elite Member
Joined: 21-Jan-2008
Posts: 6259
From: Unknown

@bernd_afa

i know, a gfx card doesnt actuallyneed dma (i think only for overlays), but since voodoo is attached to pci bus along with some other devieces like ethernet controller and such that might need it, and all that pack together communicates with amiga through mediator pci/zorro bridge that has no dma its sure should be slower than the pci bridge of csppc that is used for grex and also cvppc i take it?

Quote:
the 68060 load store bypass disable that cause wrong zune draw, maybe get SDL working.

no it didnt help in other cases but still its great thomas has tracked it down. zune is nearly usable on my system now. current problem is, the zune prefs (after loading patterns for backgrounds) disable powerwindows_ng function for moving windows out of screen. i have similar problem with warp3d workbench apps. but otherwise it works now.

strom mesa?it works. it doesnt seem to be very fast the way it is but if wee agree on a dependable benchmark we can compare

Last edited by wawa on 09-Dec-2008 at 03:49 PM.

 Status: Offline
Profile     Report this post  
bernd_afa 
Re: steps to run OWB 68k more than 3* faster
Posted on 9-Dec-2008 16:22:31
#98 ]
Cult Member
Joined: 14-Apr-2006
Posts: 829
From: Unknown

>strom mesa?it works. it doesnt seem to be very fast the way it is but if wee agree >on a dependable benchmark we can compare

in the gears demo, when can rotate the gears fast with cursor key then it use wapr3d.if they run slow, dont work with warp3d.

 Status: Offline
Profile     Report this post  
wawa 
Re: steps to run OWB 68k more than 3* faster
Posted on 9-Dec-2008 18:45:55
#99 ]
Elite Member
Joined: 21-Jan-2008
Posts: 6259
From: Unknown

@bernd_afa

dont know wchich demo you mean, sorry

 Status: Offline
Profile     Report this post  
Mrodfr 
Re: steps to run OWB 68k more than 3* faster
Posted on 10-Dec-2008 7:53:13
#100 ]
Super Member
Joined: 28-Jan-2007
Posts: 1396
From: French

@bernd

see post 29

http://www.amigans.net/modules/newbb/viewtopic.php?topic_id=2306&start=20

joerg explain how he compile OWB and the fork() missing thing.

_________________
BTW, what you have done for the amiga today ????

-A1200+Mediator+VooDoo3+060/50+96mo+SCSI-KIT
-SAM440EP-667mhz-on MapowerKC3000+AOS4.1

Amiga Docs Disks Preservation Project

 Status: Offline
Profile     Report this post  
Goto page ( Previous Page 1 | 2 | 3 | 4 | 5 | 6 Next Page )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle