Click Here
home features news forums classifieds faqs links search
6081 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
23 crawler(s) on-line.
 21 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 DiscreetFX:  7 mins ago
 Amigo1:  1 hr 1 min ago
 noXLar:  1 hr 2 mins ago
 AF-Domains.net:  1 hr 38 mins ago
 Seiya:  1 hr 40 mins ago
 Steady:  1 hr 49 mins ago
 V8:  2 hrs 48 mins ago
 Marcian:  3 hrs 28 mins ago
 Amiga4000:  4 hrs 6 mins ago
 Bezzen:  4 hrs 8 mins ago

/  Forum Index
   /  Amiga OS4 Software
      /  AmigaOS4.1 OWB Development whilst we wait?
Register To Post

Goto page ( Previous Page 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 34 | 35 | 36 | 37 | 38 | 39 | 40 | 41 | 42 | 43 | 44 | 45 | 46 | 47 | 48 | 49 | 50 | 51 | 52 | 53 | 54 | 55 Next Page )
PosterThread
pvanni 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 28-Feb-2011 12:34:09
#721 ]
Regular Member
Joined: 25-Aug-2003
Posts: 470
From: Lecco, Italy

@kas1e

Quote:
I think i also will try to compile everything without optimisation (now i use -O2), just in hope that crash info will be chacnged on something more readable.

I think optimisation must be used only when an application works correctly,
while debugging the optimisator can do nasty things and drive you on the wrong way.

 Status: Offline
Profile     Report this post  
Framiga 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 28-Feb-2011 13:08:46
#722 ]
Elite Member
Joined: 5-Jul-2003
Posts: 2213
From: Unknown

@_Steve_

Quote:

_Steve_ wrote:
@Framiga

Let's try and keep the personal comments to PMs and not public. I don't see the need for them in this thread.


uncalled and redundant remark, as i already gave up with the thing

Thanks anyway for the suggestion

Last edited by Framiga on 28-Feb-2011 at 01:17 PM.

_________________

 Status: Offline
Profile     Report this post  
Mo 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 28-Feb-2011 14:46:07
#723 ]
Member
Joined: 15-May-2004
Posts: 11
From: Unknown

@kas1e

I don't know if this will help you or not, but since OWB version 1.9 and up, I also have problems on morphos 1.4.5 related to png.library. This didn't happen with version 1.8 or earlier. here is one part from the log, maybe FAB can see where the problem is.


LIB_FreePooled: Reached Large Puddle Area, your memblock can't be found anymore
LIB_FreePooled: Pool 0x216083a8, Memory 0x2547c768, Size 137
LIB_FreePooled: Pool Flags 0x1, Size 4096, Thresh 4096
LIB_FreePooled: Puddle 0x2182fefc, Type 0x0
-------------------------------------------------------------------
Alert: 0x0100000f
Alert: Process 0x2187e2e8
EmulHandle 0x218f7750
D0=00000089 00020000 0000000d 000000a8 000004e6 000002de 000000c0 000000ff
A0=216083a8 2547c768 253a8408 00000000 277fba08 2181b630 20000c44 218823c8
VBR=2000cf60 USP=218823c8 SSP=200028a8
PC=87654321 SR=0000 CCR=00 (X=0 N=0 Z=0 V=0 C=0)
SSP:
USP:
ShowPPCStackHistory: Stack 0x277fc060 StackEnd 0x277fd060
PPCStackFrame History:
ShowPPCStackHistory: StackPtr 0x277fc090
StackFrame[-0].LR-> Address 0x10117c74 **Not Valid**
ShowPPCStackHistory: StackPtr 0x277fc0c0
StackFrame[-1].LR-> Address 0x1010a87c **Not Valid**
ShowPPCStackHistory: StackPtr 0x277fc0e0
StackFrame[-2].LR-> Address 0x1010b148 **Not Valid**
ShowPPCStackHistory: StackPtr 0x277fc100
StackFrame[-3].LR-> Address 0x2128d844 -> MOSSYS:LIBS/png.library Hunk 1 Offset 0x0000043c
ShowPPCStackHistory: StackPtr 0x277fc110
StackFrame[-4].LR-> Address 0x2128f944 -> MOSSYS:LIBS/png.library Hunk 1 Offset 0x0000253c
ShowPPCStackHistory: StackPtr 0x277fc120
StackFrame[-5].LR-> Address 0x2128f908 -> MOSSYS:LIBS/png.library Hunk 1 Offset 0x00002500
ShowPPCStackHistory: StackPtr 0x277fc130
StackFrame[-6].LR-> Address 0x212933e8 -> MOSSYS:LIBS/png.library Hunk 1 Offset 0x00005fe0
ShowPPCStackHistory: StackPtr 0x277fc250
StackFrame[-7].LR-> Address 0x21293304 -> MOSSYS:LIBS/png.library Hunk 1 Offset 0x00005efc
ShowPPCStackHistory: StackPtr 0x277fc280
StackFrame[-8].LR-> Address 0x25e49174 -> OWB Hunk 1 Offset 0x008ac354
ShowPPCStackHistory: StackPtr 0x277fc2b0
StackFrame[-9].LR-> Address 0x25e49378 -> OWB Hunk 1 Offset 0x008ac558
ShowPPCStackHistory: StackPtr 0x277fc2d0
StackFrame[-10].LR-> Address 0x25b31a90 -> OWB Hunk 1 Offset 0x00594c70
ShowPPCStackHistory: MaxLevel end
Task 0x2187e2e8 Type 13 Pri 0
Flags 0x08 State 0x02 IDNestCnt -1 TDNestCnt -1
SigAlloc 0xffc0ffff SigWait 0x7c00d000 SigRecvd 0x00200020 SigExcept 0x00000000
ExceptCode 0x1010067c ExceptData 0x00000000 TrapCode 0x10100984 TrapData 0x00000000
Switch 0x00000000 Launch 0x00000000 UserData 0x00000000
SPReg 0x21882368 SPLower 0x2187e3cc SPUpper 0x218823cc
-------------------------------------------------------------------

_________________
Pegasos 2 G3 1 GB ram Radeon 9000 Pro MOS 1.4 sitting around collecting dust.

 Status: Offline
Profile     Report this post  
Fab 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 28-Feb-2011 14:53:38
#724 ]
Super Member
Joined: 17-Mar-2004
Posts: 1178
From: Unknown

@Mo

Well, it's entirely unrelated, anyway. About your issue, noone else ever reported this before. I'd suggest double checking this png.library, and other system components as well (assuming you pasted the 1st hit and not the last, in which case it wouldn't be very useful). Also, you should mention how you actually trigger that hit.

Last edited by Fab on 28-Feb-2011 at 02:54 PM.

 Status: Offline
Profile     Report this post  
Mo 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 28-Feb-2011 15:41:52
#725 ]
Member
Joined: 15-May-2004
Posts: 11
From: Unknown

@Fab

Quote:
Well, it's entirely unrelated, anyway. About your issue, noone else ever reported this before. I'd suggest double checking this png.library, and other system components as well


png.library is ok, I have a very stable installation no hits or crashes, the only problem is OWB version 1.9 and above.

Quote:
Also, you should mention how you actually trigger that hit.


By starting OWB :)

_________________
Pegasos 2 G3 1 GB ram Radeon 9000 Pro MOS 1.4 sitting around collecting dust.

 Status: Offline
Profile     Report this post  
Fab 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 28-Feb-2011 15:52:00
#726 ]
Super Member
Joined: 17-Mar-2004
Posts: 1178
From: Unknown

@Mo

Could be some corrupted png image somehow, then, if it happens right at start. Did you customize some of the images?

You could also try with morphos 2.x, by the way.

 Status: Offline
Profile     Report this post  
Mo 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 28-Feb-2011 16:21:52
#727 ]
Member
Joined: 15-May-2004
Posts: 11
From: Unknown

@Fab

don't bother yourself with me :) I don't use morphos for anything else than testing new stuff.

_________________
Pegasos 2 G3 1 GB ram Radeon 9000 Pro MOS 1.4 sitting around collecting dust.

 Status: Offline
Profile     Report this post  
kas1e 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 28-Feb-2011 18:53:58
#728 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3536
From: Russia

@samo79

While i trying to test binary with "-g -O1" (500mb of size!) , can you do tests also with disabled image loading ? Just in case , maybe its still png library related somehow (because for example authors of png library, already ####s there and there, and for example with very latest png lib, we have DSIs on loading stage, while with some old one are ok). But just to be sure, tests withou images loading will be helpfull as well.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
samo79 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 28-Feb-2011 19:01:26
#729 ]
Elite Member
Joined: 13-Feb-2003
Posts: 3445
From: Italy, Perugia

@kas1e

Ok, i try it

_________________
BACK FOR THE FUTURE

http://www.betatesting.it/backforthefuture

Sam440ep Flex 800 Mhz 1 GB Ram + AmigaOS 4.1 Update 6
AmigaOne XE G3 800 Mhz - 640 MB Ram - Radeon 9200 SE + AmigaOS 4.1 Update 6

 Status: Offline
Profile     Report this post  
Beeblebrox 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 28-Feb-2011 19:28:51
#730 ]
Regular Member
Joined: 9-Feb-2005
Posts: 351
From: germany

@samo79

your signature link is dead.

 Status: Offline
Profile     Report this post  
samo79 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 28-Feb-2011 19:44:46
#731 ]
Elite Member
Joined: 13-Feb-2003
Posts: 3445
From: Italy, Perugia

@Beeblebrox

I know, one day i will solve this ...

_________________
BACK FOR THE FUTURE

http://www.betatesting.it/backforthefuture

Sam440ep Flex 800 Mhz 1 GB Ram + AmigaOS 4.1 Update 6
AmigaOne XE G3 800 Mhz - 640 MB Ram - Radeon 9200 SE + AmigaOS 4.1 Update 6

 Status: Offline
Profile     Report this post  
Tomppeli 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 28-Feb-2011 22:59:57
#732 ]
Super Member
Joined: 18-Jun-2004
Posts: 1646
From: Home land of Santa, sauna, sisu and salmiakki

@kas1e

Use -O0 (o zero) to get no optimization, not -O1.

_________________
Rock lobster bit me. My Workbench has always preferences. X1000 + AmigaOS4.1 FE
"Anyone can build a fast CPU. The trick is to build a fast system." -Seymour Cray

 Status: Offline
Profile     Report this post  
ChrisH 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 28-Feb-2011 23:44:45
#733 ]
Elite Member
Joined: 30-Jan-2005
Posts: 6679
From: Unknown

@kas1e Quote:
For now it looks like something wrong with backporintg, which maybe related to timer, strings, locale or something in the OS / compiler itself.

With memory corruption, I don't think you can infer ANYTHING from what actually crashes. What I mean here is that you MIGHT be lead down entirely the wrong path.

But then again, I don't think you should be guessing anything (99.9% certain to never find the cause). Just disable as much code as possible (not OWB core, but any Amiga code, be it stuff called by OWB core, or MUI code, or whatever), unless you have a better method to locate the fault. However, I am beginning to sound like a broken record, so I refrain from saying anything else.

_________________
Author of the PortablE programming language.
It is pitch black. You are likely to be eaten by a grue...

 Status: Offline
Profile     Report this post  
kas1e 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 1-Mar-2011 9:42:31
#734 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3536
From: Russia

@ChrisH

Yeah, i think now i will start cut-off the parts one by one.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
Deniil715 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 1-Mar-2011 10:42:00
#735 ]
Elite Member
Joined: 14-May-2003
Posts: 4226
From: Sweden

@kas1e

I was thinking... Is any code that runs in any of the subtasks in OWB using any exceptions (try/catch) anywhere??
This will absolutely not work at all and will cause this type of crash and lockup with our g++.

Try disabling all tasks and see what happens.

_________________
- Don't get fooled by my avatar, I'm not like that (anymore, mostly... maybe only sometimes)
> Amiga Classic and OS4 developer for OnyxSoft.

 Status: Offline
Profile     Report this post  
Fab 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 1-Mar-2011 11:20:37
#736 ]
Super Member
Joined: 17-Mar-2004
Posts: 1178
From: Unknown

@Deniil715

WebKit doesn't use exceptions.

 Status: Offline
Profile     Report this post  
ChrisH 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 1-Mar-2011 11:24:05
#737 ]
Elite Member
Joined: 30-Jan-2005
Posts: 6679
From: Unknown

@kas1e Quote:
Yeah, i think now i will start cut-off the parts one by one.

That will be a slow process. Best if you can disable "as much code as possible" in one go (i.e. at the most abstract level possible), then you can use a (human based!) binary search to find what part causes the problem. For example, maybe you can disable most of the GUI?

BTW, how ever much code you disable, for this method to work you NEED a (fairly) reliable way to reproduce the crash. Otherwise you will disable one bit of code, it seems to work (but in reality you were just lucky), so you partially enable some code, it crashes (this time you were unlucky), leading you to wrongly conclude that the faulty code was the code you just enabled. If this means you have to spend 30 mins each time you test OWB, then so be it, but really you will be much better if such test can be automated.

Last edited by ChrisH on 01-Mar-2011 at 11:27 AM.
Last edited by ChrisH on 01-Mar-2011 at 11:26 AM.

_________________
Author of the PortablE programming language.
It is pitch black. You are likely to be eaten by a grue...

 Status: Offline
Profile     Report this post  
Georg 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 1-Mar-2011 12:10:51
#738 ]
Regular Member
Joined: 14-May-2003
Posts: 450
From: Unknown

@kas1e

Regarding debugging mem trashes another thing I would do is to not always go on using the app until it finally freezes or crashes. The mungwall tool likely by default checks for mem trashes only when allocated memory is freed again. But if you are lucky there's an option to check all currently allocated memory for mem trashes. If so you should use that while the app is still (mostly) running fine. To see problems as early as possible.

If there's no such option in the mungwall tool, you should quit (and restart) app every once and then while it still is working fine but maybe showing some early hints about problem (gfx corruption or whatever) to force memory to be freeded and with it mem trash checks to be done.

 Status: Offline
Profile     Report this post  
samo79 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 1-Mar-2011 12:58:14
#739 ]
Elite Member
Joined: 13-Feb-2003
Posts: 3445
From: Italy, Perugia

@Fab

How about LibCURL or ICU ?

Can be one of these the real problem that can cause such freeze during navigation ?

_________________
BACK FOR THE FUTURE

http://www.betatesting.it/backforthefuture

Sam440ep Flex 800 Mhz 1 GB Ram + AmigaOS 4.1 Update 6
AmigaOne XE G3 800 Mhz - 640 MB Ram - Radeon 9200 SE + AmigaOS 4.1 Update 6

 Status: Offline
Profile     Report this post  
Fab 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 1-Mar-2011 13:33:50
#740 ]
Super Member
Joined: 17-Mar-2004
Posts: 1178
From: Unknown

@samo79

CURL is written in C so it can't have exceptions, and ICU doesn't use exceptions either. And anyway, in your case, when favicons and network thread is disabled, there's only the main task where exceptions could possibly happen (timer task just pulses events with Signal(), nothing more).

 Status: Offline
Profile     Report this post  
Goto page ( Previous Page 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 34 | 35 | 36 | 37 | 38 | 39 | 40 | 41 | 42 | 43 | 44 | 45 | 46 | 47 | 48 | 49 | 50 | 51 | 52 | 53 | 54 | 55 Next Page )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle