Click Here
home features news forums classifieds faqs links search
6072 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
45 crawler(s) on-line.
 41 guest(s) on-line.
 3 member(s) on-line.


 Karlos,  clusteruk,  mahimegh

You are an anonymous user.
Register Now!
 clusteruk:  5 secs ago
 Karlos:  28 secs ago
 mahimegh:  2 mins ago
 BSzili:  12 mins ago
 Rob:  20 mins ago
 kolla:  27 mins ago
 Massi:  51 mins ago
 fatbob_gb:  53 mins ago
 blmara:  2 hrs 46 mins ago
 DiscreetFX:  2 hrs 59 mins ago

/  Forum Index
   /  Amiga OS4 Software
      /  AmigaOS4.1 OWB Development whilst we wait?
Register To Post

Goto page ( Previous Page 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 34 | 35 | 36 | 37 | 38 | 39 | 40 | 41 | 42 | 43 | 44 | 45 | 46 | 47 | 48 | 49 | 50 | 51 | 52 | 53 | 54 | 55 Next Page )
PosterThread
kas1e 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 5-Mar-2011 19:00:23
#761 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3536
From: Russia

@AlexC

Quote:

So the code tried to jump to an instruction at address 0.
Unlike a DSI which usually happen with wrong or uniitialized pointers, this can be caused by a number of things.


Yeah, but we already know that with even default debug level, i mean in crash we have:

Quote:

Trap type: ISI exception
Machine State (raw): 0x1200F030
Machine State (verbose): [ExtInt on] [User] [FPU on] [IAT on] [DAT on]
Instruction pointer: 0x00000000
Crashed process: owb (0x66893AF0)


And there is already says that Instruction pointer: 0x00000000 .. I also found at end of crash that (in debug11):

Quote:

[HAL_Alert] ALERT! 0x80000003
[HAL_SuspendTaskWithUpdate] Suspending 0x66853DC0 with state 2, DAR = 0x00000004, at IP = 0x00000000, LR = 0x7FFF690C
[HAL_SuspendTaskWithUpdate] Adding to suspend list
[HAL_SuspendTaskWithUpdate] Context @ 0xEFDC9BA0


As far as i remember, that ALERT! 0x80000003 mean null-pointer access as well (but its also say not so much for me).

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
Antique 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 5-Mar-2011 23:29:28
#762 ]
Cult Member
Joined: 8-Jun-2005
Posts: 887
From: Norway

@kas1e

Crossing my fingers for you squashing those bugs.

_________________
I'm an antique. Don't light my fuse

 Status: Offline
Profile     Report this post  
NutsAboutAmiga 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 6-Mar-2011 0:32:51
#763 ]
Elite Member
Joined: 9-Jun-2004
Posts: 12344
From: Norway

@kas1e

If a library was not opened, you will get a ISI error.
If a plugin does not work you will get a ISI error.
If you have function pointer set to no value or NULL you get a ISI error.
If a MUI class is not loaded.

There are two option library a application depends on does not load, or the memory is corrupted.

Also look for pointers like

void (*my_func) (void *ptr) = NULL;

_________________
http://lifeofliveforit.blogspot.no/
Facebook::LiveForIt Software for AmigaOS

 Status: Offline
Profile     Report this post  
Fab 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 6-Mar-2011 0:47:23
#764 ]
Super Member
Joined: 17-Mar-2004
Posts: 1178
From: Unknown

@NutsAboutAmiga

In my opinion, the most obvious candidate in this case is a method called from a null or disposed c++ object, and there could be many reasons for that (even possibly webkit bugs).

Here, the real problem is we don't get any usable stack trace in this case. The fact this exception also takes down OS4 with it is also weird (unless it happens in a critical kernel module).

On MorphOS, I often stumbled on this kind of illegal instruction from 0x0/0xwhatever address, when porting or merging webkit, but at least, only OWB dies in this case, and i get a well readable stack trace telling me where it happened.

Last edited by Fab on 06-Mar-2011 at 12:48 AM.

 Status: Offline
Profile     Report this post  
NutsAboutAmiga 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 6-Mar-2011 2:36:53
#765 ]
Elite Member
Joined: 9-Jun-2004
Posts: 12344
From: Norway

@Fab

Well maybe it has some thing to do whit .so objects.

You normally get a error unless is loaded it dynamically whit dlopen().

Last edited by NutsAboutAmiga on 06-Mar-2011 at 02:37 AM.

_________________
http://lifeofliveforit.blogspot.no/
Facebook::LiveForIt Software for AmigaOS

 Status: Offline
Profile     Report this post  
kas1e 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 6-Mar-2011 8:37:56
#766 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3536
From: Russia

@NutsAboutAmiga

Quote:

If a library was not opened, you will get a ISI error.
If a plugin does not work you will get a ISI error.
If you have function pointer set to no value or NULL you get a ISI error.
If a MUI class is not loaded.


Its all sounds logical as well, but in this case you still have stack-trace, which point you on problem. )

Quote:

Also look for pointers like

void (*my_func) (void *ptr) = NULL;


Its not that easy. There is thousands functions, and which one are ####s and where - crashlog not say at all. No stack trace, nothing.


Quote:

Well maybe it has some thing to do whit .so objects.

You normally get a error unless is loaded it dynamically whit dlopen().


We not use any .so there, and everything static.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
Mrodfr 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 6-Mar-2011 18:11:20
#767 ]
Super Member
Joined: 28-Jan-2007
Posts: 1396
From: French

Removed and opened a new thread.

Last edited by Mrodfr on 06-Mar-2011 at 06:52 PM.
Last edited by Mrodfr on 06-Mar-2011 at 06:13 PM.

_________________
BTW, what you have done for the amiga today ????

-A1200+Mediator+VooDoo3+060/50+96mo+SCSI-KIT
-SAM440EP-667mhz-on MapowerKC3000+AOS4.1

Amiga Docs Disks Preservation Project

 Status: Offline
Profile     Report this post  
kas1e 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 6-Mar-2011 18:36:41
#768 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3536
From: Russia

@Mrodfr
If you doent mind, plz start new thread about (its a bit too much questions which will scare devels which will in interest to help us with our lockup-problem). But in other topic, for sure someone will explain you all the stuff more.

Last edited by kas1e on 06-Mar-2011 at 06:39 PM.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
TiredofLife 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 21-Mar-2011 23:13:42
#769 ]
Super Member
Joined: 6-Jul-2005
Posts: 1688
From: Here

@kas1e

Been a couple of weeks, just wondered if there had been any progress?

Cheers.

_________________
If your nose runs and your feet smell, you're upside down.

 Status: Offline
Profile     Report this post  
kas1e 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 22-Mar-2011 9:30:24
#770 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3536
From: Russia

@TiredofLife

In last time we was in slow mode about it, but yesterday we with Deniil start again, so the plans for now are: fix few little bugs which we have for now, and then, if our hardcore bug still will be present (that one which cause random freezes after a while), then fight with it.

Anyway why we a bit chill for now : because update3 will be minimum (because new mui will have many bug fixes, and update3 will 100% necessary for (or mui from update3). And while as i see it will be released dunno when, we can be not so fast (expectually now, when we have just few little bugs, and one hardcore one).

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
Deniil715 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 22-Mar-2011 9:55:38
#771 ]
Elite Member
Joined: 14-May-2003
Posts: 4226
From: Sweden

@TiredofLife

I've had some personal issues, a ski trip and a broken car that I've been busy with the last few weeks. But as kas1e says, since update3 is needed there is no huge rush anyway.

_________________
- Don't get fooled by my avatar, I'm not like that (anymore, mostly... maybe only sometimes)
> Amiga Classic and OS4 developer for OnyxSoft.

 Status: Offline
Profile     Report this post  
COBRA 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 22-Mar-2011 10:30:39
#772 ]
Super Member
Joined: 26-Apr-2004
Posts: 1809
From: Auckland, New Zealand

@kas1e

Quote:
Anyway why we a bit chill for now : because update3 will be minimum (because new mui will have many bug fixes, and update3 will 100% necessary for (or mui from update3). And while as i see it will be released dunno when, we can be not so fast (expectually now, when we have just few little bugs, and one hardcore one).


Unless it turns out that random freeze bug requires a fix in another OS/MUI component in which case it would be bad if Update 3 was released before you find that bug since then it couldn't include the necessary fix and then you'd have to wait for Update 4 to come out

 Status: Offline
Profile     Report this post  
kas1e 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 22-Mar-2011 11:13:42
#773 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3536
From: Russia

@COBRA
Quote:

Unless it turns out that random freeze bug requires a fix in another OS/MUI component in which case it would be bad if Update 3 was released before you find that bug since then it couldn't include the necessary fix and then you'd have to wait for Update 4 to come out


:) Right :)

Because of that i in hope that we of course will finish all before update3 will be out (to avoid that problems). Imho in next days / week we will fix all the small bugs and will concetrate on heavy one.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
TiredofLife 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 22-Mar-2011 11:55:09
#774 ]
Super Member
Joined: 6-Jul-2005
Posts: 1688
From: Here

@kas1e @Denill

Cheers lads.

_________________
If your nose runs and your feet smell, you're upside down.

 Status: Offline
Profile     Report this post  
kas1e 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 22-Mar-2011 12:34:26
#775 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3536
From: Russia

@all
Some summ-info about mui-owb port:

There is what need to fix (all the other mention before on other pages bugs are fixed):

1. BitmapImages by some reassons not works when we use List (maybe we use it wrong in terms of mui3.9, need to investigate), and because of its we not have :

- favicons in history-panel and history-of-urls
- gauge in download manager.

Need to invistigate, and make workorounds in code, or add stuff to our List (depens what will be easy way).

2. Context menu by RMB mostly works everythere, but at one-two windowse not (very small bug, and windowses are not so important, but still, to make all perfect need to fix).

3. need to fix "curl library port". I build latest version few days ago without threading/tls and all the wrong stuff, but still, need to do some manual work, to make "file://" protocol works with amiga pathes, which will fixes local usage of files, drag and drop of local file to OWB and related stuff.

4. "About" window show nothing (use mui4 about class, need a bit rewrite). Easy, but should be done as well.

5. Iconify not works (i.e. works, but wrong, need to fix). Should be easy as well, but still need to fix.

6. Some crash in some place on bubble-helps. Not big deal of course, can be disabled at all, but, for sure better to found why and which (better and for our mui, and for port at all).

7. Some random lockups - the heavy problem and the most important problem about which we talk on last 5 pages here: we will leave it to the final end, when all the other will works and only that will be last bug to fix (just to avoid any problems related to "because of that bugs which we not fix before, we have also side-effect bug which unpossible to fix before main one not fixed").

All the other works fine (well, at least as i can see, for sure somethere something still here, but visually only what i describe now are need to fix).

Last edited by kas1e on 22-Mar-2011 at 12:37 PM.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
Tomas 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 22-Mar-2011 19:21:47
#776 ]
Elite Member
Joined: 25-Jul-2003
Posts: 4286
From: Unknown

@kas1e
Thanks for the update.

 Status: Offline
Profile     Report this post  
djrikki 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 22-Mar-2011 19:26:38
#777 ]
Elite Member
Joined: 22-Jun-2010
Posts: 2077
From: Grimsby, UK

Awww bubble-help, I remember them from 'back in the day'. I wonder why Apple never nicked that one lol

A square tooltip vs a bubble tooltip... who will win? Only one way to find out...

FIGHT!!!

_________________

 Status: Offline
Profile     Report this post  
Tuxedo 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 22-Mar-2011 19:38:37
#778 ]
Elite Member
Joined: 28-Nov-2003
Posts: 2327
From: Perugia, ITALY

@kas1e

Thank's foe the update ang GOOD WORK!

_________________
Simone"Tuxedo"Monsignori, Perugia, ITALY.

 Status: Offline
Profile     Report this post  
kas1e 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 24-Mar-2011 12:07:28
#779 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3536
From: Russia

@all
mui-owb progress:

- iconify works now
- for "About" bug works on new class is starts
- and Deniil almost found why we have problems with images in urlhisotry/gauge

Last edited by kas1e on 24-Mar-2011 at 12:08 PM.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
samo79 
Re: AmigaOS4.1 OWB Development whilst we wait?
Posted on 24-Mar-2011 16:05:22
#780 ]
Elite Member
Joined: 13-Feb-2003
Posts: 3445
From: Italy, Perugia

@kas1e

Very good, so points 4 and 5 are closed now

_________________
BACK FOR THE FUTURE

http://www.betatesting.it/backforthefuture

Sam440ep Flex 800 Mhz 1 GB Ram + AmigaOS 4.1 Update 6
AmigaOne XE G3 800 Mhz - 640 MB Ram - Radeon 9200 SE + AmigaOS 4.1 Update 6

 Status: Offline
Profile     Report this post  
Goto page ( Previous Page 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 34 | 35 | 36 | 37 | 38 | 39 | 40 | 41 | 42 | 43 | 44 | 45 | 46 | 47 | 48 | 49 | 50 | 51 | 52 | 53 | 54 | 55 Next Page )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle