Click Here
home features news forums classifieds faqs links search
5777 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
29 crawler(s) on-line.
 27 guest(s) on-line.
 1 member(s) on-line.


 kolla

You are an anonymous user.
Register Now!
 kolla:  3 mins ago
 NutsAboutAmiga:  8 mins ago
 cgutjahr:  14 mins ago
 saimo:  22 mins ago
 matthey:  22 mins ago
 zipper:  25 mins ago
 number6:  26 mins ago
 BSzili:  31 mins ago
 towo2099:  33 mins ago
 amigakit:  40 mins ago

/  Forum Index
   /  Amiga OS4.x \ Workbench 4.x
      /  Hyperion Blog update....
Register To Post

Goto page ( Previous Page 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 34 | 35 | 36 | 37 | 38 | 39 | 40 | 41 | 42 | 43 | 44 | 45 Next Page )
PosterThread
wawa 
Re: Hyperion Blog update....
Posted on 14-Jun-2011 14:44:15
#101 ]
Elite Member
Joined: 21-Jan-2008
Posts: 6259
From: Unknown

@Mechanic

there was an initiative to fix warp3d that has been answered in a way that it was welcome only if this would exclude os3.x/68k support. i am not going to talk about it here, but worth to mention, that people involved with it help also with or make their software available on os4. warp3d licence is worded in such a way it cant become a common standard. the sources are not available. all this in course of time led to that i personally have given up and instead got engaged with aros. it is my personal choice. im not trying to scare others from contributing to os4, on the contrary.

 Status: Offline
Profile     Report this post  
kas1e 
Re: Hyperion Blog update....
Posted on 14-Jun-2011 16:04:37
#102 ]
Amiga Developer Team
Joined: 11-Jan-2004
Posts: 3425
From: Russia

@HammerD
Quote:

How about an update on your two interesting projects, MUI-OWB and MUI-MPlayer?


If only i be an os4betatester, and have access to post info on the hyperion blog, i will have write nice article about our MUI updates :) So , while i am plain user, i only can ask other developers to write info which closed from eyes.

Related to fab's ports on os4: MUI-OWB just wait for update3 and its ready, and mui-mplayer are on half stage and will want update3 as well :)

ps. check pm plz

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
ssolie 
Re: Hyperion Blog update....
Posted on 14-Jun-2011 17:11:37
#103 ]
Elite Member
Joined: 10-Mar-2003
Posts: 2747
From: Alberta, Canada

@ddni
Quote:
It is a shame that people cant say thanks for what is here, rather than complain about what is coming...

People do love to complain about anything and everything.

I'm still glad I started up the blog. Without it you'd get the usual random postings in web forums from random people. With the blog you at least know it is somebody actually working on AmigaOS and it is all in one place.

One thing is certain. Darren is super excited about AmigaOS 4.x on the classic and does everything in his power to keep the project alive. Without his efforts there would be no Classic release right now. I think we should cut him a little slack.

_________________
ExecSG Team Lead

 Status: Offline
Profile     Report this post  
samo79 
Re: Hyperion Blog update....
Posted on 14-Jun-2011 17:25:38
#104 ]
Elite Member
Joined: 13-Feb-2003
Posts: 3409
From: Italy, Perugia

@thellier

Thanks for the patch

_________________
BACK FOR THE FUTURE

http://www.betatesting.it/backforthefuture

Sam440ep Flex 800 Mhz 1 GB Ram + AmigaOS 4.1 Update 6
AmigaOne XE G3 800 Mhz - 640 MB Ram - Radeon 9200 SE + AmigaOS 4.1 Update 6

 Status: Offline
Profile     Report this post  
gtmooya 
Re: Hyperion Blog update....
Posted on 14-Jun-2011 18:27:43
#105 ]
Regular Member
Joined: 8-May-2011
Posts: 285
From: Unknown

@ssolie

The blog is definately a good thing, keep it up.

_________________
gtmooya's blog

 Status: Offline
Profile     Report this post  
Mechanic 
Re: Hyperion Blog update....
Posted on 14-Jun-2011 18:33:52
#106 ]
Elite Member
Joined: 27-Jul-2003
Posts: 2007
From: Unknown

@ssolie

Quote:

ssolie wrote:

I'm still glad I started up the blog.


As am I.

As for cutting people slack..............I can do that,,,,,, as the official Slacker around here.

(Yes dear, I'm busy thinking about your curtains right now.( sheeesh))

 Status: Offline
Profile     Report this post  
Jamie_S 
Re: Hyperion Blog update....
Posted on 14-Jun-2011 19:35:24
#107 ]
Cult Member
Joined: 26-Oct-2003
Posts: 794
From: Purbeck, UK

@ssolie

The blog was definately a good idea and is really appreciated.

_________________
A600 OS3.1 ACA620 | '030 A1200 OS3.5 | A1-C 750GX OS4.1 | SAM460 OS4.1 | '040 A3000 OS2.1 | Christian Aid |

 Status: Offline
Profile     Report this post  
TheKorn 
Re: Hyperion Blog update....
Posted on 14-Jun-2011 20:03:13
#108 ]
Regular Member
Joined: 15-Oct-2008
Posts: 169
From: Texas


+ Infinity for the Blog

_________________
Talos BlackBird (awaiting a Miggy like OS)
Amiga 4000 3.9 / Pegasos II 4.1 F.E.

 Status: Offline
Profile     Report this post  
Karlos 
Re: Hyperion Blog update....
Posted on 14-Jun-2011 22:23:37
#109 ]
Elite Member
Joined: 24-Aug-2003
Posts: 2020
From: As-sassin-aaate! As-sassin-aaate! Ooh! We forgot the ammunition!

@thellier

Do you get the impression the W3D source / dest blend enumerations were originally the same as those in the MIniGL implementation then diverged at some point? If they were, it might explain why said values are getting passed in.

Quote:

* patch: BlitzQuake/MiniGL use SetBlendMode but forget to activate with SetState() the blending */
SetState(context,W3D_BLENDING,TRUE);
[...]


That bothers me a bit. From an API behaviour expectation, you should definitely be able to change the blend mode whether or not the blending state is currently enabled or not, it should just take effect the next time the state is enabled. It shouldn't have to turn it on for you (which I realise is the point of the patch).

Something like this should probably be an environment setting so that the behaviour is not hard coded in to the library.

Last edited by Karlos on 14-Jun-2011 at 10:41 PM.

_________________
IBrowse/AWeb user? amiga.org - classic browser edition

 Status: Offline
Profile     Report this post  
thellier 
Re: Hyperion Blog update....
Posted on 15-Jun-2011 10:30:02
#110 ]
Regular Member
Joined: 2-Nov-2009
Posts: 258
From: Paris

>be able to change the blend mode whether or not the blending state is currently enabled or not
@Karlos
Yes i agree
In fact the patch in Wazp3D is a few more smart:

struct WAZP3D_context *WC=context->driver;

if(!WC->CallSetBlending)
SetState(context,W3D_BLENDING,TRUE);

with WC->CallSetBlending setted to FALSE at startup

and set to TRUE here
ULONG W3D_SetState(W3D_Context *context, ULONG state, ULONG action)
{
struct WAZP3D_context *WC=context->driver;

if(state==W3D_BLENDING)
WC->CallSetBlending=TRUE;

Like you told Warp3D/MiniGL often poke the w3d-context instead of calling the Warp3D function :-/


Note: you can make a quick search in Wazp3D sources for the string "patch:"

Alain


 Status: Offline
Profile     Report this post  
number6 
Re: Hyperion Blog update....
Posted on 17-Jun-2011 22:18:30
#111 ]
Elite Member
Joined: 25-Mar-2005
Posts: 10850
From: In the village

@thread

New Hyperion blog entry:

AmigaOS Support Forum Launched

#6

_________________
This posting, in its entirety, represents solely the perspective of the author.
*Secrecy has served us so well*

 Status: Offline
Profile     Report this post  
Mechanic 
Re: Hyperion Blog update....
Posted on 17-Jun-2011 22:52:24
#112 ]
Elite Member
Joined: 27-Jul-2003
Posts: 2007
From: Unknown

@number6

Quote:

New Hyperion blog entry:




It might also be useful to have some kind of 'feature request area', but then again that might get
messy pretty quick.

 Status: Offline
Profile     Report this post  
samo79 
Re: Hyperion Blog update....
Posted on 17-Jun-2011 23:08:57
#113 ]
Elite Member
Joined: 13-Feb-2003
Posts: 3409
From: Italy, Perugia

Yaii a new forum !
A good news for OS4 bug reporting and also for asking about Hyperion's games

_________________
BACK FOR THE FUTURE

http://www.betatesting.it/backforthefuture

Sam440ep Flex 800 Mhz 1 GB Ram + AmigaOS 4.1 Update 6
AmigaOne XE G3 800 Mhz - 640 MB Ram - Radeon 9200 SE + AmigaOS 4.1 Update 6

 Status: Offline
Profile     Report this post  
gregthecanuck 
Re: Hyperion Blog update....
Posted on 18-Jun-2011 1:15:07
#114 ]
Cult Member
Joined: 30-Dec-2003
Posts: 844
From: Vancouver, Canada

Quote:
New Hyperion blog entry:

AmigaOS Support Forum Launched


Excellent news! Nice work to those involved.

 Status: Offline
Profile     Report this post  
andres 
Re: Hyperion Blog update....
Posted on 18-Jun-2011 1:38:05
#115 ]
Regular Member
Joined: 3-Nov-2008
Posts: 328
From: Firenze (Italy)

Quote:
AmigaOS Support Forum Launched

a VERY GOOD move!!!
Finally!
There should be links for the blog and for the forum in the Hyperion website anyway, since some people may find difficult to find them...

_________________
A1200/020+68882 - 6 MB RAM - AmigaOS 3.0

Home Recording Audio

 Status: Offline
Profile     Report this post  
kas1e 
Re: Hyperion Blog update....
Posted on 18-Jun-2011 8:12:28
#116 ]
Amiga Developer Team
Joined: 11-Jan-2004
Posts: 3425
From: Russia

Quote:

AmigaOS Support Forum Launched


That was unexpected, but very right and good move. Maybe communication indeed will be better now ?

@ssolie
The only one moment, is that for making account on forum working, need to wait some manual aproving by admins (which can be busy sometimes later), and will be good to have automatic account enabling. Maybe by adding in account registration serial number info ?

And for sure, as Andres say, need to put on main hyperion site somethere at top "our support forum" , so all the users will know what and where

But its all good should to say, all those official blogs and forums are right steps.

edit: through, after a while, i start to think that forums for game-support looks a bit wrong: games very old (and we have better opensource relisations already), and non shogo, non heretic2 non working normally on os4.

Last edited by kas1e on 18-Jun-2011 at 09:28 AM.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
Tomppeli 
Re: Hyperion Blog update....
Posted on 18-Jun-2011 13:21:39
#117 ]
Super Member
Joined: 18-Jun-2004
Posts: 1635
From: Home land of Santa, sauna, sisu and salmiakki

@kas1e

Quote:
games very old (and we have better opensource relisations already)

I think it's for Hyperion's own products and not for every piece of AmigaOS software.

_________________
Rock lobster bit me, so excuse me. Amiga. Never forget.
X1000 + AmigaOS4.1 FE
"Anyone can build a fast CPU. The trick is to build a fast system." -Seymour Cray

 Status: Offline
Profile     Report this post  
kas1e 
Re: Hyperion Blog update....
Posted on 18-Jun-2011 13:33:15
#118 ]
Amiga Developer Team
Joined: 11-Jan-2004
Posts: 3425
From: Russia

@Tomppeli
Quote:

I think it's for Hyperion's own products and not for every piece of AmigaOS software.


Yeah, cross the fingers for shogo and heretic2 versions for aos4 :)

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
wawa 
Re: Hyperion Blog update....
Posted on 18-Jun-2011 16:34:44
#119 ]
Elite Member
Joined: 21-Jan-2008
Posts: 6259
From: Unknown

a related support forum is good move.

 Status: Offline
Profile     Report this post  
thellier 
Re: Hyperion Blog update....
Posted on 20-Jun-2011 15:06:11
#120 ]
Regular Member
Joined: 2-Nov-2009
Posts: 258
From: Paris

@Karlos

>Do you get the impression the W3D source / dest blend enumerations were originally the same as those in the MIniGL implementation then diverged at some point? If they were, it might explain why said values are getting passed in.
No .
I only think that they only converted the src/destmodes that existed in Warp3D v4
and forgot that OpenGL can also send some other value.
It is only a "parameter is not converted nor checked" problem

Alain
Error is in MiniGL/others.c in cgl_GLBlendFunc() -> It should be like that:

switch(sfactor)
{
BLS(ZERO);
BLS(ONE);
BLS(DST_COLOR);
BLS(ONE_MINUS_DST_COLOR);
BLS(SRC_ALPHA);
BLS(ONE_MINUS_SRC_ALPHA);
BLS(DST_ALPHA);
BLS(ONE_MINUS_DST_ALPHA);
BLS(SRC_ALPHA_SATURATE);
BLS(CONSTANT_COLOR);
BLS(ONE_MINUS_CONSTANT_COLOR);
BLS(CONSTANT_ALPHA );
BLS(ONE_MINUS_CONSTANT_ALPHA);

default:
GLFlagError(context, 1, GL_INVALID_ENUM);
}

switch(dfactor)
{
BLD(ZERO);
BLD(ONE);
BLD(SRC_COLOR);
BLD(ONE_MINUS_SRC_COLOR);
BLD(SRC_ALPHA);
BLD(ONE_MINUS_SRC_ALPHA);
BLD(DST_ALPHA);
BLD(ONE_MINUS_DST_ALPHA);
BLD(CONSTANT_COLOR);
BLD(ONE_MINUS_CONSTANT_COLOR);
BLD(CONSTANT_ALPHA );
BLD(ONE_MINUS_CONSTANT_ALPHA);
default:
GLFlagError(context, 1, GL_INVALID_ENUM);
}

 Status: Offline
Profile     Report this post  
Goto page ( Previous Page 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 34 | 35 | 36 | 37 | 38 | 39 | 40 | 41 | 42 | 43 | 44 | 45 Next Page )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle