Click Here
home features news forums classifieds faqs links search
5827 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
» Home
» Features
» News
» Forums
» Classifieds
» Links
» Downloads
Extras
» OS4 Zone
» IRC Network
» AmigaWorld Radio
» Newsfeed
» Top Members
» Amiga Dealers
Information
» About Us
» FAQs
» Advertise
» Polls
» Terms of Service
» Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
15 crawler(s) on-line.
 19 guest(s) on-line.
 1 member(s) on-line.


 sTix

You are an anonymous user.
Register Now!
 sTix:  4 mins ago
 noXLar:  6 mins ago
 billt:  9 mins ago
 -Sam-:  9 mins ago
 Fl@sh:  15 mins ago
 richieadam:  19 mins ago
 AmiKit:  20 mins ago
 MEGA_RJ_MICAL:  25 mins ago
 amigadave:  48 mins ago
 Yssing:  50 mins ago

/  Forum Index
   /  Amiga OS4.x \ Workbench 4.x
      /  Hyperion Blog update....
Register To Post

Goto page ( Previous Page 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 34 | 35 | 36 | 37 | 38 | 39 | 40 | 41 | 42 | 43 | 44 | 45 Next Page )
PosterThread
umisef 
Re: Hyperion Blog update....
Posted on 4-Apr-2013 0:03:43
#521 ]
Super Member
Joined: 19-Jun-2005
Posts: 1676
From: Melbourne, Australia

@Darrin

Quote:
The same goes for Corporate accounts too,


I don't see the necessity.

"Corporate accounts" are a special category of account, which is granted on a per-case basis and comes with considerable extra privilege (namely, being able to ignore a term of the TOS).

It's only sensible that the granting of privilege should come with requirements.

"You can have a corporate account, if you (a) convince us that you are a corporation in need of such an account, and (b) agree to unambiguously identify the real person behind each post made from such an account" are not onerous terms.

 Status: Offline
Profile     Report this post  
sundown 
Re: Hyperion Blog update....
Posted on 4-May-2013 21:25:38
#522 ]
Elite Member
Joined: 30-Aug-2003
Posts: 5117
From: Right here...

@All

Hyperion blog update...

"The HDAudio driver has recently been released to AmigaOne X1000 owners."

http://blog.hyperion-entertainment.biz/

_________________
Hate tends to make you look stupid...

 Status: Offline
Profile     Report this post  
pavlor 
Re: Hyperion Blog update....
Posted on 4-May-2013 22:29:58
#523 ]
Elite Member
Joined: 10-Jul-2005
Posts: 9120
From: Unknown

@sundown

Splendid!

 Status: Offline
Profile     Report this post  
mbrantley 
Re: Hyperion Blog update....
Posted on 4-May-2013 22:56:13
#524 ]
Cult Member
Joined: 10-Jun-2010
Posts: 524
From: Mobile, Alabama, United States

Getting some high-quality, good-sounding output here using the new driver on my X1000. Thanks to all who worked on it!

_________________

 Status: Offline
Profile     Report this post  
zzd10h 
Re: Hyperion Blog update....
Posted on 4-May-2013 23:35:07
#525 ]
Amiga Developer Team
Joined: 21-May-2012
Posts: 1073
From: France

Works brilliant !
No more need of the PCI2PCIE adapter

Many thanks to all the team

_________________
http://apps.amistore.net/zTools

 Status: Offline
Profile     Report this post  
sundown 
Re: Hyperion Blog update....
Posted on 5-May-2013 0:12:22
#526 ]
Elite Member
Joined: 30-Aug-2003
Posts: 5117
From: Right here...

@zzd10h

Yup, I have my network card on the PCI2PCIE adaptor, so both PCI slots are free now.

_________________
Hate tends to make you look stupid...

 Status: Offline
Profile     Report this post  
zzd10h 
Re: Hyperion Blog update....
Posted on 5-May-2013 0:17:19
#527 ]
Amiga Developer Team
Joined: 21-May-2012
Posts: 1073
From: France

@sundown
Is you network card not too large with the PCI2PCIE adapter ?

I had too my network card on the adapter but it was impossible to screw it, too much large.

Now, all is screwed, no more fear that my card move

_________________
http://apps.amistore.net/zTools

 Status: Offline
Profile     Report this post  
sundown 
Re: Hyperion Blog update....
Posted on 5-May-2013 3:34:56
#528 ]
Elite Member
Joined: 30-Aug-2003
Posts: 5117
From: Right here...

@zzd10h

My adaptor came with a second smaller slot bracket. I replaced the full size bracket with the smaller one. The adaptor is loose, but was able to screw the network card in place on top. Took me awhile to figure it out, but worked out well.

_________________
Hate tends to make you look stupid...

 Status: Offline
Profile     Report this post  
NutsAboutAmiga 
Re: Hyperion Blog update....
Posted on 5-May-2013 12:28:14
#529 ]
Elite Member
Joined: 9-Jun-2004
Posts: 11417
From: Norway

Thanks Lyle Hazelwood for an excellent blog update, lost of information to take in, I'm really Happy the drivers are out, I'm not shore what I'm going to use the extra PCI slot for, but anyway. It does not hurt having a free PCI slot, just in case I need it for some thing else.

_________________
http://lifeofliveforit.blogspot.no/
Facebook::LiveForIt Software for AmigaOS

 Status: Offline
Profile     Report this post  
Rob 
Re: Hyperion Blog update....
Posted on 5-May-2013 14:06:18
#530 ]
Elite Member
Joined: 20-Mar-2003
Posts: 5930
From: S.Wales

@NutsAboutAmiga

Agreed that it's a great blog entry. Lots of information but not so much that non coders get bogged down or bored by it.

 Status: Offline
Profile     Report this post  
scabit 
Re: Hyperion Blog update....
Posted on 5-May-2013 14:39:37
#531 ]
Super Member
Joined: 8-Jan-2005
Posts: 1667
From: Satellite Beach, FL USA

@mbrantley

I'm curious...does the X1000 actually produce all the separate audio channels that are part of Dolby 7 surround, or is it still stereo only?

Thanks,

Scott

_________________
AmigaOne uA1-c 512M RAM - Only Amiga Makes It Possible!
Check my blog AmigaOne Computing

 Status: Offline
Profile     Report this post  
lylehaze 
Re: Hyperion Blog update....
Posted on 5-May-2013 16:24:23
#532 ]
Super Member
Joined: 1-Sep-2004
Posts: 1128
From: North Florida - Big Bend area.

@scabit

I can not define "Dolby7", but we do have the capability and driver
support for 7.1 audio (seven channels plus a subwoofer/bass speaker)
I suspect the "Dolby" part of your question would require licensing from
the nice people at Dolby.

The current driver pushes 7.1 @ 32bit in all modes & units.

When AHI gives us Mono, we push that one sample to the left and right,
and the remaining six (leftside, rightside, leftrear,rightrear,center,lowfreq)
are muted.

When AHI gives us Stereo, left goes to left, and right goes to right,
and the remaining six (leftside, rightside, leftrear,rightrear,center,lowfreq)
are muted.

When AHI gives us 7.1, each channel gets it's own separate feed from AHI.

During the initial opening of the driver, it replies to AHI with a list of
capabilities. If it includes the flag AHISB_KNOW_MULTICHANNEL then the
driver has declared that it is capable of 7.1 audio.

When a stream of sound is coming from AHI into the driver, the driver
may query the type of stream available. Type "AHIST_L7_1" indicates a 7.1 audio stream. Other streams we see regularly include AHIST_S32S for stereo 32 bit and AHIST_M32S for mono 32 bit. The driver uses these to know how to handle the sound.

The current setup is adjusted to best fit AHI. The chip is capable of a completely separate stereo feed for the headphones while 7.1 is being processed as the main program. I think the only requirement is that they have the same rame rate. SInce AHI does not support multiple streams I simply feed the headphones from the primary sound channel.

Another detail is the rate of data.. most drivers before now supported up to
44100 and 48000 sample frames per second. This new driver can support those, as well as doubling or quadrupling those. I really didn't know what to expect from AHI at the higher frame rates, or even if AHI would provide the data for them, but it works very nicely with no issues at all.

_________________
question=(2b||!(2b))

 Status: Offline
Profile     Report this post  
delshay 
Re: Hyperion Blog update....
Posted on 5-May-2013 16:34:09
#533 ]
Regular Member
Joined: 20-Sep-2008
Posts: 447
From: Unknown

There's also DTS 7.1

_________________
The Machine: Bride Of The Pin•Bot by Williams Electronics

 Status: Offline
Profile     Report this post  
Darrin 
Re: Hyperion Blog update....
Posted on 5-May-2013 18:16:42
#534 ]
Team Member
Joined: 14-May-2003
Posts: 1941
From: Lake Charles, USA

Damn, I love the AmiUpdate function. Once click, 20 updates found (including the audio driver) and in a couple of minutes it was complete. Love it.

_________________
AmigaOne X1000, A4000(T), A3000, A2000, A1200(T), A1200, A500, CD32, Minimig+ARM, FPGA Arcade, Chameleon64, C-One, C128, C128D, C64C, C64, VIC-20, CBM 8032, CBM4032, Efika, Ultimate64

 Status: Offline
Profile     Report this post  
m3x 
Re: Hyperion Blog update....
Posted on 15-May-2013 12:05:21
#535 ]
Regular Member
Joined: 15-May-2003
Posts: 309
From: Bologna, Italy

@all

Hyperion blog update:

"More Noise from ACube"

http://blog.hyperion-entertainment.biz/?p=899

_________________
Massimiliano Tretene, ACube Systems, Soft3

 Status: Offline
Profile     Report this post  
Spectre660 
Re: Hyperion Blog update....
Posted on 15-May-2013 12:29:11
#536 ]
Elite Member
Joined: 5-Jun-2005
Posts: 3800
From: Unknown

@m3x

Nice.

A possible candidate for PCI machines :

http://www.siig.com/it-products/multimedia/sound/pci/soundwave-5-1-pci-lp.html

_________________

 Status: Offline
Profile     Report this post  
Spirantho 
Re: Hyperion Blog update....
Posted on 15-May-2013 13:06:33
#537 ]
Super Member
Joined: 4-Jun-2004
Posts: 1044
From: Aberystwyth, Wales

@Spectre660

I can't help but feel that'd look (sound?) really nice in my Sam440ep. :) It's a 3.3V card so I guess it should work!

 Status: Offline
Profile     Report this post  
olegil 
Re: Hyperion Blog update....
Posted on 15-May-2013 13:21:44
#538 ]
Elite Member
Joined: 22-Aug-2003
Posts: 5888
From: Work

@Spirantho

It's a universal voltage (3.3 / 5) card. But yes, it should work. I just feel it's smart to clear up any confusion in case an owner of an XE or micro or something read your response

_________________
This weeks pet peeve:
Using "voltage" instead of "potential", which leads to inventing new words like "amperage" instead of "current" (I, measured in A) or possible "charge" (amperehours, Ah or Coulomb, C). Sometimes I don't even know what people mean.

 Status: Offline
Profile     Report this post  
pavlor 
Re: Hyperion Blog update....
Posted on 15-May-2013 14:03:46
#539 ]
Elite Member
Joined: 10-Jul-2005
Posts: 9120
From: Unknown

@m3x

Nice!

 Status: Offline
Profile     Report this post  
delshay 
Re: Hyperion Blog update....
Posted on 15-May-2013 14:04:13
#540 ]
Regular Member
Joined: 20-Sep-2008
Posts: 447
From: Unknown

There are a few users with prelude sound cards,would be nice if their were supported also other than installing 68k drivers.

_________________
The Machine: Bride Of The Pin•Bot by Williams Electronics

 Status: Offline
Profile     Report this post  
Goto page ( Previous Page 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 34 | 35 | 36 | 37 | 38 | 39 | 40 | 41 | 42 | 43 | 44 | 45 Next Page )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle