Click Here
home features news forums classifieds faqs links search
5651 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
51 crawler(s) on-line.
 13 guest(s) on-line.
 1 member(s) on-line.


 amigakit

You are an anonymous user.
Register Now!
 amigakit:  11 secs ago
 samo79:  11 mins ago
 monstercoder:  21 mins ago
 Samurai_Crow:  27 mins ago
 blasterreal:  40 mins ago
 Hypex:  42 mins ago
 bennymee:  56 mins ago
 Fl@sh:  1 hr 5 mins ago
 Musashi5150:  1 hr 16 mins ago
 stefanjo:  1 hr 44 mins ago

/  Forum Index
   /  New Member Introductions
      /  hi
Register To Post

PosterThread
muyuu 
hi
Posted on 15-Feb-2019 8:33:26
#1 ]
Member
Joined: 14-Feb-2019
Posts: 12
From: London, UK

Hi, I'm a late 80s to 90s Amiga enthusiast. I tried posting elsewhere and got an automatic 1 day posting ban. I read the ToS post, and still I can't figure out why. What am I missing?

Regards.

 Status: Offline
Profile     Report this post  
pavlor 
Re: hi
Posted on 16-Feb-2019 10:18:54
#2 ]
Elite Member
Joined: 10-Jul-2005
Posts: 8993
From: Unknown

@muyuu

Probably website bugs.


And of course...


Welcome!

 Status: Offline
Profile     Report this post  

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle