Click Here
home features news forums classifieds faqs links search
6081 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)



Lost Password?

Don't have an account yet?
Register now!

Your support is needed and is appreciated as is primarily dependent upon the support of its users.

Main sections
OS4 Zone
IRC Network
AmigaWorld Radio
Top Members
Amiga Dealers
About Us
Terms of Service

IRC Channel
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
23 crawler(s) on-line.
 20 guest(s) on-line.
 1 member(s) on-line.


You are an anonymous user.
Register Now!
 Rose:  58 secs ago
 Cammy:  8 mins ago
 matthey:  18 mins ago
 Jasper:  18 mins ago
 OneTimer1:  25 mins ago
 BSzili:  28 mins ago
 Mobileconnect:  30 mins ago
 Rob:  42 mins ago
 gryfon:  58 mins ago
 NutsAboutAmiga:  1 hr 14 mins ago

/  Forum Index
   /  Classic Amiga Software
      /  Problem with Cybervsion64/3D and native modes
Register To Post

Problem with Cybervsion64/3D and native modes
Posted on 23-Jun-2020 12:33:14
#1 ]
New Member
Joined: 19-May-2020
Posts: 5
From: Unknown

Strange problem that is most likely self-induced. I am working on my A4000D bringing it up-to-date as I can and somewhere along the way ran into an unusual problem. Hardware is A4000D, Phase5 060 board 128 meg installed, Cybervision64/3d graphics card and a Xsurf-100 board. LCD Monitor.

I started from scratch

1. Installed OS3.1 on a 4gig CF card partitioned as 2/2.
2. Installed OS3.9 plus Boing Bags 1,2,3 and 4.
3. Installed OS3.1.4 plus the update OS3.1.4.1 (Using Updateto314)
4. Installed Picasso96 version 2.4.4

The problem I am having is if I select a native screen mode like 640x200 from screenmode in prefs I get a bunch of colorful garbage. I have a scan doubler hooked to the video out of the 4000 and this is the screen mode I used to install all of the above! If I boot with a floppy Workbench all is back to normal so I know it's not a hardware issue. Also if I mess up the startup-sequence or something and the boot process gets interrupted before it gets to the cybervision screenmode, a native mode 640x200 screen pops up with the error messages. Again indicating not a hardware problem.

I was looking for a way to get SysInfo to load in to my cybervision screenmode so I was messing around with NewMode and Modepro. Not much luck so I removed them from the WBstartup and removed the User-Startup entries.

Also installed Visualprefs somewhere along the way.

Long way of asking if anyone knows where to start to unravel this mess! If I can't pinpoint the exact change that created this issue I will have to start over and check each step to see where I've gone awry. Here is a quick list of the things I've installed in addition to the OS's listed above.


My list of suspects are Newmode, Modepro or visualPrefs. The first two I think I have removed from the equation. VisualPrefs is still installed. I hate to uninstall VisualPrefs unless I know for certain that its the issue.

Any thoughts?

 Status: Offline
Profile     Report this post  
Re: Problem with Cybervsion64/3D and native modes
Posted on 23-Jun-2020 17:27:43
#2 ]
Elite Member
Joined: 6-May-2007
Posts: 10179
From: Greensborough, Australia


Our hardware is almost exactly alike. Except my A4000D currently has a SCSI HD on he CyberSCSI bus and I just removed my backup IDE HDD. I don't have an X-Surf but do have an A2065.

Going through the list, there may be some conflicts. I don't know if Boing Bag 3 is official but and 4 is surely not.

With OS3.1.4 you were aware of any conflicts arising from installing an OS3.1 based OS on top of an OS3.9 OS? I don't recall what but extra attention needs to be paid.

GlowIcons shouldn't be needed as OS3.1.4 should support this by now and icons are included as extras.

VisualPrefs may conflict if there are no OS3.9 or OS3.1.4 compatible versions. MagicMenu should be okay.

ClicktoFront comes with the OS. Is there another? Or you just activated it?

MagicASL sounds bad. Is it special? Noclick should be okay.

Newmode and Modepro shouldn't be needed together. So there is is no mode promotion built in still?

Have you gone through this?

Last edited by Hypex on 23-Jun-2020 at 05:29 PM.

 Status: Offline
Profile     Report this post  
Re: Problem with Cybervsion64/3D and native modes
Posted on 23-Jun-2020 18:40:42
#3 ]
Regular Member
Joined: 28-Nov-2007
Posts: 233
From: wales


i would just install fresh install of os3.9 with mui 3.8 and the picasso96 which is on the os3.9 cd then boing bag 1 and 2 only, if still get a bunch of colorful garbage then that is a sign of faulty cybervision 64/3d, if that does happen try cleaning the card connector as if dirt is on there they it mite not get all the signals from amiga to display


 Status: Offline
Profile     Report this post  
Re: Problem with Cybervsion64/3D and native modes
Posted on 23-Jun-2020 22:26:44
#4 ]
New Member
Joined: 19-May-2020
Posts: 5
From: Unknown

The Cybervision64 doesn't have a scandoubler like a PicassoIV unless you happen to have the module. About as scarce as hen's teeth. I have a monitor switch set up for when I go into native modes running through an external scandoubler. I doubt the Cybervision is faulty.

I don't actually have newmode or modepro running together. I tried one and then the other to see if I could move at least some things to the cybervision screen. I have tried to edited them out completely but who knows what's been left behind and where.

MagicASL gives you a wonderful requester menu but I don't think that's the problem because of the trouble shooting step described below.

By way of troubleshooting, I moved my WBstartup drawer out of the system disk and rebooted. Made no difference other than I didn't have my little niceties. Still had garbage on a native mode.

It may be in Visualprefs. I will try to deinstall and see if it fixes the problem. Assuming I CAN deinstall it.

I agree that I could do a fresh install of OS3.9 and skip 3.1 but at the time I didn't have an emergency disk that would not crash. The 3.1.4 ROM doesn't like the OS3.9 loadmodule sequence. But now that I have the hard drive setup and I have a bootable emergency disk I can now skip that step.

So no one uses BB3 through 4? Don't really know what the changes were but I assumed I needed to add them to the update process.

As far as knowing the conflicts between 3.9 and 3.14, I'm aware and I downloaded a script that installs OS3.14 and overwrites certain files like the fastfilesystem and the like, while leaving Reaction and other things from 3.9 alone.

When I go through a reinstall I'll have to check the native mode on each step of the process though honestly I didn't install Picasso96 for the Cybervision until I had 3.14 already installed so I actually did the installs in native mode. Newmode, Modepro and Visualprefs were all added a few weeks later. I really feel like the issue lies there.

We shall see :)

 Status: Offline
Profile     Report this post  
Re: Problem with Cybervsion64/3D and native modes
Posted on 24-Jun-2020 6:40:01
#5 ]
Regular Member
Joined: 15-Mar-2003
Posts: 317
From: Vxj, Sweden


Can you list your picasso96 env settings?

I'm not att My Amiga now so it cant check My settings or the available settings but there is some variable to set the amigavideo to 31khz and i suspect you might have that One and that it is causing your problems.

 Status: Offline
Profile     Report this post  
Re: Problem with Cybervsion64/3D and native modes
Posted on 24-Jun-2020 10:09:31
#6 ]
New Member
Joined: 19-May-2020
Posts: 5
From: Unknown


I thought of that and I checked it early on. I did have it set to 31hz. I was hoping it would pass through the native video modes through the Cybervision somehow, which of course it didn't. Still don't know the purpose of that setting. Maybe if I had the scan doubler module? Anyway I set it back to 15hz and went looking for another cause for the issue.

 Status: Offline
Profile     Report this post  
Re: Problem with Cybervsion64/3D and native modes
Posted on 24-Jun-2020 16:25:15
#7 ]
Elite Member
Joined: 6-May-2007
Posts: 10179
From: Greensborough, Australia


Oh. I have a PicassoIV set up as a scan doubler. I did this when the VGA chip went dead. Something went bad one day and I lost all my RTG modes. But I reflashed the firmware from the software driver and got the scan doubler back.

The PicassoIV VGA out is connected to the VGA in on the CyberVision through a small gray VGA looping cable. The CyberVision VGA out is connected to the monitor. I don't have any physical switch on the CyberVision bracket. But it auto switches with a native mode. I didn't know it would do this and it's been very handy since my PicassoIV all in one went faulty. Even if I need an external cable to do it.

About the Boings Bags. It's not that they wouldn't be in use. But that they aren't an official OS3.9 update. Since HAAGE & PARTNER, the capital name computer people, stopped supporting it ages ago. That's not to say it isn't good, just a community effort. Feature list looks useful. The second link here has an OS3.1.4 mention you likely know about.

 Status: Offline
Profile     Report this post  
Re: Problem with Cybervsion64/3D and native modes
Posted on 24-Jun-2020 23:27:42
#8 ]
New Member
Joined: 19-May-2020
Posts: 5
From: Unknown


I have a PicassoIV also that I have sent off for repair. Should have it back in a few weeks. I'm not sure what you mean about a VGA looping cable. The Cybervsion64/3D only has one VGA port. Nice that you could still at least use the scan doubler portion of it. Have you tried to get it repaired?

As to my problem, I finally solved it without reinstalling everything. I uninstalled the Picasso96 (ver2.4.4) software and reinstalled. I can now go to native mode and have a normal screen. I really don't know what settings I had wrong as they look exactly the same in tooltypes on the CVision3D monitor file in DEVS as the old setup.

All's well that ends well I suppose.

 Status: Offline
Profile     Report this post  

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 was originally founded by David Doyle