Click Here
home features news forums classifieds faqs links search
5826 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
47 crawler(s) on-line.
 25 guest(s) on-line.
 2 member(s) on-line.


 Frank,  MEGA_RJ_MICAL

You are an anonymous user.
Register Now!
 MEGA_RJ_MICAL:  11 secs ago
 Frank:  4 mins ago
 Templario:  5 mins ago
 Trixie:  7 mins ago
 pavlor:  10 mins ago
 outrun1978:  17 mins ago
 Skateman:  18 mins ago
 Krethx:  18 mins ago
 dirkzwager:  20 mins ago
 towo2099:  39 mins ago

/  Forum Index
   /  Amiga OS4 Hardware
      /  Sam460ex - crackling audio, normal?
Register To Post

Goto page ( 1 | 2 | 3 Next Page )
PosterThread
Everblue 
Sam460ex - crackling audio, normal?
Posted on 25-Dec-2012 22:33:36
#1 ]
Cult Member
Joined: 24-Sep-2006
Posts: 638
From: Amigaland

This evening I tested audio by playing a few MP3s on my new 460ex system. It seems that whatever I play (even the test audio button) outputs constant crackling on the audio. From what I understand audio drivers are not complete yet, so is what I am experiencing 'normal'?

Is there a way I can decrease/remove this crackling? Thanks!

_________________

 Status: Offline
Profile     Report this post  
Fairdinkem 
Re: Sam460ex - crackling audio, normal?
Posted on 25-Dec-2012 23:10:13
#2 ]
Regular Member
Joined: 23-Feb-2010
Posts: 484
From: Victoria, Australia

@Everblue

The new beta audio driver has been made available as of recent link below.

http://os4depot.net/index.php?function=showfile&file=driver/audio/sm502_audio.lha

_________________
Pegasos 2 G4 - AmigaOS 4.1 FE / MorphOS 3.6

 Status: Offline
Profile     Report this post  
NutsAboutAmiga 
Re: Sam460ex - crackling audio, normal?
Posted on 25-Dec-2012 23:10:18
#3 ]
Elite Member
Joined: 9-Jun-2004
Posts: 11221
From: Norway

@Everblue

You my not have the latest driver check Acubes web page.
You can also get cracking sound from badly configured AHI, never turn volume up beyond 0 db, 0 db is on middle of the volume control, over the middle of volume control, AHI pre reforms something called boost, by multiplying the number the volume increases, but the sample volume has max/min volume on audio curve, when audio curve become bigger then Min/Max value you get what is called cliping, its type audio destitution.

I have also read some thing about problems whit frequency setting in AHI, but don't remember the details.

1. Get newest drivers.
2. Check that you do not have what is called cliping.

_________________
Please check out my software:
Excalibur, Basilisk 2, AmigaInputAnywhere.
LiveForIt-Music
http://lifeofliveforit.blogspot.no/

 Status: Offline
Profile     Report this post  
Androxyn 
Re: Sam460ex - crackling audio, normal?
Posted on 25-Dec-2012 23:55:41
#4 ]
Regular Member
Joined: 7-Mar-2003
Posts: 212
From: Oslo

@Everblue

Check your driver version. If you have the newest, try an older one. That worked for me. You may have to contact ACube support to get the older versions.

As for frequency in AHI, that is supposed to be locked at 48000.

 Status: Offline
Profile     Report this post  
graffias79 
Re: Sam460ex - crackling audio, normal?
Posted on 26-Dec-2012 3:36:03
#5 ]
Regular Member
Joined: 20-Apr-2005
Posts: 133
From: Madison, WI

@Everblue

The audio on mine is terrible also. I've tried everything I could think of from adjusting settings to different driver versions to removing the video card and hard drive controller card. I'm afraid some of us are "unlucky."

They've recently updated AmigaOS to use PCIe cards, but I've yet to try one that we have drivers for.

Also stay away from PEX chip based PCIe to PCI bridge adapters, they tend not to work at all. StarTech makes the most common PCIe to PCI bridge adapter card (PEX1PCI1) and unfortunately it uses this chip.

I'm awaiting news from a friend on whether or not he has luck with the PCIe version of the ESI Juli@ card. If so, I will be getting one as well, even though it's $150. The card looks absolutely drool worthy so I REALLY hope it works.

 Status: Offline
Profile     Report this post  
Everblue 
Re: Sam460ex - crackling audio, normal?
Posted on 26-Dec-2012 7:58:42
#6 ]
Cult Member
Joined: 24-Sep-2006
Posts: 638
From: Amigaland

I was using the drivers that came with the system up to OS4.1u6.

I have now installed those drives linked in the 2nd post but it did nothing to solve the problem. Whenever I play an MP3 I still get a lot of crackling. So I have no other option but contact Acube?

They are so bad at replying emails :(

_________________

 Status: Offline
Profile     Report this post  
imagodespira 
Re: Sam460ex - crackling audio, normal?
Posted on 26-Dec-2012 8:23:14
#7 ]
Regular Member
Joined: 20-Sep-2009
Posts: 251
From: Germany

@Everblue

my AHI Settings:



No sound problems here (playing internet radio, and our amibouing.de games the same time, mp3 also works)

_________________
www.amiboing.de - www.entwickler-x.de

 Status: Offline
Profile     Report this post  
joeled 
Re: Sam460ex - crackling audio, normal?
Posted on 26-Dec-2012 11:22:18
#8 ]
Cult Member
Joined: 25-Dec-2007
Posts: 724
From: Uppsala, Sweden

Email Ross and ask him if he has time to work on the driver. Alot of people are buying sam460 so the problem wont go away.

_________________
AmigaOS on Google+
AmigaOS on Facebook

 Status: Offline
Profile     Report this post  
Everblue 
Re: Sam460ex - crackling audio, normal?
Posted on 26-Dec-2012 11:22:52
#9 ]
Cult Member
Joined: 24-Sep-2006
Posts: 638
From: Amigaland

@imagodespira
Yup, I tried, no improvement.

Meanwhile I have contacted Acube and they have sent me a newer version of the drivers (dated 21/12.2012). When I play audio the crackling is gone (sound is perfect), BUT audio playback is like 60% of normal speed....

Any idea if I could fix this? Thanks guys.

_________________

 Status: Offline
Profile     Report this post  
NutsAboutAmiga 
Re: Sam460ex - crackling audio, normal?
Posted on 26-Dec-2012 11:33:50
#10 ]
Elite Member
Joined: 9-Jun-2004
Posts: 11221
From: Norway

@Everblue

Sound like you have become a beta tester.
there is noting to do but wait for new drivers, or get new PCIe soundcard.

_________________
Please check out my software:
Excalibur, Basilisk 2, AmigaInputAnywhere.
LiveForIt-Music
http://lifeofliveforit.blogspot.no/

 Status: Offline
Profile     Report this post  
Everblue 
Re: Sam460ex - crackling audio, normal?
Posted on 26-Dec-2012 11:37:01
#11 ]
Cult Member
Joined: 24-Sep-2006
Posts: 638
From: Amigaland

@NutsAboutAmiga
I guess there isnt much I could do but wait.

I dont think a 120-160 euro soundcard should be the solution!

_________________

 Status: Offline
Profile     Report this post  
Everblue 
Re: Sam460ex - crackling audio, normal?
Posted on 26-Dec-2012 11:46:56
#12 ]
Cult Member
Joined: 24-Sep-2006
Posts: 638
From: Amigaland

Here is some extra info about my system may be it is relevant:

1. When I setup my hdd I put buffer (on all partitions) 2000, later I put them on 1000 and restarted.

2. I am using onboard video.

_________________

 Status: Offline
Profile     Report this post  
graffias79 
Re: Sam460ex - crackling audio, normal?
Posted on 26-Dec-2012 11:57:13
#13 ]
Regular Member
Joined: 20-Apr-2005
Posts: 133
From: Madison, WI

@Everblue

Interesting, I had the slow speed issue with the drivers that were released before the current "release version" driver from this last May.

Just a thought, since some of us are having serious audio problems and some are not, do you think that perhaps there is a difference between some Sam motherboards? Perhaps something as simple as a different brand of chip to do the same function?

 Status: Offline
Profile     Report this post  
wawa 
Re: Sam460ex - crackling audio, normal?
Posted on 26-Dec-2012 13:09:24
#14 ]
Elite Member
Joined: 21-Jan-2008
Posts: 6259
From: Unknown

@graffias79

why dont you just ask support instead asking random users around? i mean its your right and it would most likely be:
1. competent (they did the board after all)
2. might be professionally fixed and could lead to improvement in future products if there is actually some problem on board.

Last edited by wawa on 26-Dec-2012 at 01:10 PM.

 Status: Offline
Profile     Report this post  
Everblue 
Re: Sam460ex - crackling audio, normal?
Posted on 26-Dec-2012 13:21:02
#15 ]
Cult Member
Joined: 24-Sep-2006
Posts: 638
From: Amigaland

@graffias79

Sorry I had a typo... the drivers I am now using (slow speed) are from 21st April, not December, so most probably the problems you had are replicating with my system,

With the latest version of the drivers I get audio noise.

:(

_________________

 Status: Offline
Profile     Report this post  
Everblue 
Re: Sam460ex - crackling audio, normal?
Posted on 26-Dec-2012 13:21:27
#16 ]
Cult Member
Joined: 24-Sep-2006
Posts: 638
From: Amigaland

@wawa
I did that too ;)

_________________

 Status: Offline
Profile     Report this post  
graffias79 
Re: Sam460ex - crackling audio, normal?
Posted on 26-Dec-2012 19:09:22
#17 ]
Regular Member
Joined: 20-Apr-2005
Posts: 133
From: Madison, WI

@wawa

I would think that at this point they should be aware of it. It must have come up in some sort of QC testing? I guess it would be worth a shot if they can do something, but I thought the driver was written by a 3rd party.

 Status: Offline
Profile     Report this post  
AlexC 
Re: Sam460ex - crackling audio, normal?
Posted on 26-Dec-2012 21:03:23
#18 ]
Super Member
Joined: 22-Jan-2004
Posts: 1293
From: City of Lost Angels, California.

@Everblue

Do you have some heavy CPU load while playing the MP3 or have compositing turned off or have VSync disabled in the monitor tooltypes?

On my XE AHI tends to struggle when it doesn't get enough CPU time or timely interrupts, the crackling being a symptom of buffer underruns.

Merely refreshing a 1024x768 bitmap at 60fps in a window is enough here to hog the pci bus long enough to cause crackling and likewise with 100% CPU load.

_________________
AlexC's free OS4 software collection

AmigaOne XE/X1000/X5000/UAE-PPC OS4 laptop/X-10 Home Automation

 Status: Offline
Profile     Report this post  
Everblue 
Re: Sam460ex - crackling audio, normal?
Posted on 26-Dec-2012 22:08:44
#19 ]
Cult Member
Joined: 24-Sep-2006
Posts: 638
From: Amigaland

@AlexC
Well I don't have a video card yet so I am using the onboard one. Compositing is off, dunno about vsync but I can check. The system isn't doing anything else while trying to play mp3s though.

_________________

 Status: Offline
Profile     Report this post  
wawa 
Re: Sam460ex - crackling audio, normal?
Posted on 26-Dec-2012 22:12:21
#20 ]
Elite Member
Joined: 21-Jan-2008
Posts: 6259
From: Unknown

@Everblue

what you people can do yourselves is to gather the crowd that has problems and try to record every possible aspect of configuration (that might matter) you have in common that dfiffers you from the people who are satisified..

 Status: Offline
Profile     Report this post  
Goto page ( 1 | 2 | 3 Next Page )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle