Click Here
home features news forums classifieds faqs links search
6040 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
85 crawler(s) on-line.
 13 guest(s) on-line.
 1 member(s) on-line.


 evilFrog

You are an anonymous user.
Register Now!
 evilFrog:  4 mins ago
 eliyahu:  10 mins ago
 PhantomInterrogative:  26 mins ago
 Steady:  27 mins ago
 ggw:  48 mins ago
 mac6:  1 hr 12 mins ago
 freak:  2 hrs 10 mins ago
 simplex:  2 hrs 36 mins ago
 RobertB:  2 hrs 39 mins ago
 tygre:  2 hrs 43 mins ago

/  Forum Index
   /  New Member Introductions
      /  Too long gone
Register To Post

PosterThread
NextGenAmigaMan 
Too long gone
Posted on 14-Feb-2021 2:23:18
#1 ]
New Member
Joined: 13-Feb-2021
Posts: 7
From: Unknown

Hi everyone!

I'm relatively new to the forum, but not to Amigas in general. I've owned:

2 original Amiga 1.5MB systems
1 Amiga 2000 Video Toaster setup
3 Amiga 1200 systems
2 Amiga 500 setups
1 AmigaOne 500 system


plus everything AmigaForever and AmiKit has to offer.
Looking forward to sharing info and asking questions :)

 Status: Offline
Profile     Report this post  
Skateman 
Re: Too long gone
Posted on 14-Feb-2021 7:12:12
#2 ]
Regular Member
Joined: 2-Nov-2017
Posts: 127
From: Netherlands

@NextGenAmigaMan

Welcome to the Forum!

_________________
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world

 Status: Offline
Profile     Report this post  
bennymee 
Re: Too long gone
Posted on 14-Feb-2021 9:37:16
#3 ]
Cult Member
Joined: 19-Aug-2003
Posts: 622
From: Netherlands

@NextGenAmigaMan

Welcome back !

 Status: Offline
Profile     Report this post  
AmigaOldskooler 
Re: Too long gone
Posted on 14-Feb-2021 11:02:51
#4 ]
Regular Member
Joined: 7-Mar-2015
Posts: 211
From: Unknown

@NextGenAmigaMan

Hi and welcome to the forum!

_________________
Old School Game Blog (oldschoolgameblog.com)
Gaming on AmigaOS 4 (amigaos4gaming.wordpress.com)
Void demo group (amigavoid.wordpress.com)

 Status: Offline
Profile     Report this post  
redfox 
Re: Too long gone
Posted on 14-Feb-2021 15:53:56
#5 ]
Super Member
Joined: 7-Mar-2003
Posts: 1785
From: Canada

@NextGenAmigaMan



Wow, you have owned alot of Amiga systems!

I've been here for many years.

I own an ancient Amiga 2000HD with OS 3.1
and a MicroA1 with AmigaOS 4.1 Final Edition Update 2

---
redfox

 Status: Offline
Profile     Report this post  
NextGenAmigaMan 
Re: Too long gone
Posted on 14-Feb-2021 17:23:58
#6 ]
New Member
Joined: 13-Feb-2021
Posts: 7
From: Unknown

@redfox

I personally loved red foxes. We have a few running across the yard during summer months.:)

And thank you! I upgraded by 2000HD system (plus CD-ROM) to AmigaOS 3.9, and a turtle could have beaten it for speed. I could only stuff 8MB into it. THAT was 20 years ago. I had also networked one of the 1200s networked with a WIN 98 box. Not very WELL, ut I did it.

I'm an old Amiga hand. Got into programming because of that, actually.

 Status: Offline
Profile     Report this post  

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle