Click Here
home features news forums classifieds faqs links search
6077 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
30 crawler(s) on-line.
 7 guest(s) on-line.
 2 member(s) on-line.


 matthey,  Lozspd4

You are an anonymous user.
Register Now!
 matthey:  3 mins ago
 Lozspd4:  3 mins ago
 Karlos:  7 mins ago
 Futaura:  8 mins ago
 BigD:  37 mins ago
 DiscreetFX:  44 mins ago
 zipper:  1 hr 13 mins ago
 babsimov:  1 hr 21 mins ago
 amigang:  1 hr 27 mins ago
 Comi:  1 hr 29 mins ago

/  Forum Index
   /  Amiga General Chat
      /  FAO: Hypex - The Maestix
Register To Post

PosterThread
Karlos 
FAO: Hypex - The Maestix
Posted on 17-Aug-2022 10:40:17
#1 ]
Elite Member
Joined: 24-Aug-2003
Posts: 2857
From: As-sassin-aaate! As-sassin-aaate! Ooh! We forgot the ammunition!

As a long time user of OctaMED (barring the seemingly eternal hiatus lately), I've used the Maestix on a number of AHI enabled systems.

Recently I got a tweaked version of my system (68K only) running under UAE and wanted to get OctaMED working with the UAE AHI device.

I've used the latest 68K build of The Maestix from aminet but the audio is really choppy, whereas Paula native (well, emulated) isn't. It doesn't seem to be affected by load or sample rate. I was wondering if you know of any solutions? I'm sure I can't be the only OMSS user with UAE.

_________________
Doing stupid things for fun...

 Status: Offline
Profile     Report this post  
Karlos 
Re: FAO: Hypex - The Maestix
Posted on 17-Aug-2022 10:41:35
#2 ]
Elite Member
Joined: 24-Aug-2003
Posts: 2857
From: As-sassin-aaate! As-sassin-aaate! Ooh! We forgot the ammunition!

I note that the PPC native V2 had a number of fixes (including the desync on flipping screen). Is there an equivalently up to date 68K variant?

_________________
Doing stupid things for fun...

 Status: Offline
Profile     Report this post  
Karlos 
Re: FAO: Hypex - The Maestix
Posted on 17-Aug-2022 10:45:05
#3 ]
Elite Member
Joined: 24-Aug-2003
Posts: 2857
From: As-sassin-aaate! As-sassin-aaate! Ooh! We forgot the ammunition!

I've just realised I'm an idiot and V2 supports 68K also. Hold my coffee ...

_________________
Doing stupid things for fun...

 Status: Offline
Profile     Report this post  
Karlos 
Re: FAO: Hypex - The Maestix
Posted on 17-Aug-2022 11:26:39
#4 ]
Elite Member
Joined: 24-Aug-2003
Posts: 2857
From: As-sassin-aaate! As-sassin-aaate! Ooh! We forgot the ammunition!

The newer version doesn't seem to have remedied the problem. It's likely something of my own making anyway, given I'm running WinUAE x64 via wine.

_________________
Doing stupid things for fun...

 Status: Offline
Profile     Report this post  
MEGA_RJ_MICAL 
Re: FAO: Hypex - The Maestix
Posted on 17-Aug-2022 12:20:56
#5 ]
Cult Member
Joined: 13-Dec-2019
Posts: 959
From: AMIGAWORLD.NET WAS ORIGINALLY FOUNDED BY DAVID DOYLE

Friend Karlos,

you're starting to channel Qbit.



/MEGA

_________________
I HAVE ABS OF STEEL
--
CAN YOU SEE ME? CAN YOU HEAR ME? OK FOR WORK

 Status: Offline
Profile     Report this post  
Karlos 
Re: FAO: Hypex - The Maestix
Posted on 17-Aug-2022 12:35:14
#6 ]
Elite Member
Joined: 24-Aug-2003
Posts: 2857
From: As-sassin-aaate! As-sassin-aaate! Ooh! We forgot the ammunition!

@MEGA_RJ_MICAL

It's just a one sided conversation for now.

_________________
Doing stupid things for fun...

 Status: Offline
Profile     Report this post  
Hypex 
Re: FAO: Hypex - The Maestix
Posted on 17-Aug-2022 16:32:09
#7 ]
Elite Member
Joined: 6-May-2007
Posts: 10718
From: Greensborough, Australia

@Karlos

Hello again and thanks for your support!

I haven't done much testing on 68K. Or a real 68K really. Since all my Amigas lack a sound card. And since it uses a 16 bit mode my audio database lacks any. Also, regarding the updated 68k version, lol. But, did you try the installer before looking? I put a lot of work into that. I take pride in my productions.

But, I have tested it in emulation. In the past I used to have trouble. I forget if it was UAE Amiga audio as well as my Maestrix but something was wrong with it.

However now I just loaded it up with FS-UAE and tested. Loaded OMSS, loaded up mix settings, played some 8 bit and 16 modules and it was fine! I don't know what to say. I quit it and then tested the OMSS solo player which would use Amiga audio. It worked but there was an issue as the samples over looped. Maestrix was in time.

Also, as a shortcut, or just to check, you can test the included SS config. It's in the MOS drawer and is preset with mixing settings. But, looks like it misses stereo and panning is even for some reason. I'm sure I followed my own instructions to produce it.

I checked my Maestrix settings and they are default. So, AHIUNIT=DEFAULT and BUFFERS=0.

In AHI settings I have Paula 14 bit stereo++ calibrated. Same for unit 0 but for some reason 1 channel at 8000 Hz. That doesn't look right. Are you using UAE audio or Paula as AHI driver?

I would suggest, if there is sound card emulation for Maestro or anything else, to use that directly as it would be best. I just found FS has Tocatta.

But, if it helps, I do recommend reading the mixing guide in the main guide. An OctaMED mixing guide is included inside, which explains what mix buffer means and also the Maestrix buffers options. You may need to use the BUFFERS tootype option if it helps. I didn't need it on my X1000 and UAE. But your setup is different.

You could be right about WINE being a problem. I stopped using it for things as I prefer native. It may introduce issues and testing other audio players for the same problem would be good to narrow things down.

Last edited by Hypex on 17-Aug-2022 at 04:37 PM.

 Status: Offline
Profile     Report this post  
Karlos 
Re: FAO: Hypex - The Maestix
Posted on 17-Aug-2022 23:05:00
#8 ]
Elite Member
Joined: 24-Aug-2003
Posts: 2857
From: As-sassin-aaate! As-sassin-aaate! Ooh! We forgot the ammunition!

@Hypex

Thanks. I've done some preliminary testing of AHI, which is v6 and using the UAE HiFi output at 44kHz as the default unit. There doesn't appear to be any specific issue for applications using it (bar a couple of clicks when opening the channels).

It almost seems like packet loss between OctaMED and AHI. The playback is the right speed but the audio is shuttered. I've read the guide and gotten the OctaMED mix buffer to match a few different values, experimenting with the equivalent buffers tooltype, but so far no dice.

_________________
Doing stupid things for fun...

 Status: Offline
Profile     Report this post  
Bosanac 
Re: FAO: Hypex - The Maestix
Posted on 21-Aug-2022 17:26:55
#9 ]
Regular Member
Joined: 10-May-2022
Posts: 129
From: Unknown

@Karlos

https://github.com/wineasio/wineasio

 Status: Offline
Profile     Report this post  
Karlos 
Re: FAO: Hypex - The Maestix
Posted on 21-Aug-2022 18:33:16
#10 ]
Elite Member
Joined: 24-Aug-2003
Posts: 2857
From: As-sassin-aaate! As-sassin-aaate! Ooh! We forgot the ammunition!

@Bosanac

I'll give that a go, thanks.

_________________
Doing stupid things for fun...

 Status: Offline
Profile     Report this post  
Hypex 
Re: FAO: Hypex - The Maestix
Posted on 22-Aug-2022 9:20:36
#11 ]
Elite Member
Joined: 6-May-2007
Posts: 10718
From: Greensborough, Australia

@Karlos

I checked and I have 4.18 installed. I was going to install v6. But it still lacks the installer and UAE files aren't included. Nor are other audio drivers that are present in 4.18. I thought UAE had a custom trap system all ports would share for custom drivers but it looks like FS-UAE misses out. Perhaps this is why WinUAE remains the most popualr as FS-UAE is a good effort but it just lacks normal WinUAE features.

So I did some more testing. For whatever reason MED keeps wiping my mixing settings. I save them to the config but it keeps wiping them with no errors in the title bar. I activated Toccata sound and installed AHI drivers. Kind of a round about way but it's the closest FS-UAE has to a native AHI driver. I then set Toccata in AHI at 16 it stereo ++ and used 1 channel for Unit 0. So I set MED (again) to mix mode with MaestroPro. I used 48K as frequency to push it.

I then tested MED. This time it seemed to work and it played audio. I went back to WB and played around. The sound was stable. But it was too soft which is a problem i have in Linux sometimes. AHI 4 is meant to be fastest in ASM but since mixing is done in MED v6 shouldn't slow it down. I can install v6 to match after finding all the files.

Edit:
Regarding packet loss. By default it acts as a middle man as direct as it can. So it takes the audio sent to it, tags the audio pointer, then sends it direct to AHI. It manages a double buffer and MED would send two buffers before waiting. It always checks for two buffers at a time which are sent as messages following the original API. And when AHI replies back it checks for another buffer return to avoid misses.

If BUFFERS are set it will cache audio sends until it's filled then send it to AHI. But, this is less efficient, and really isn't needed in normal circumstances. I ended up adding it as I found MED was sending audio, then would stop and free audio buffers before freeing audio, thus pulling the rug out. So it was a safer insurance option. But, at the same time, I was getting weird behaviour like MED sending blank buffers, so my X1000 may have had memory issues I wasn't aware of. I've replaced my RAM since.

Last edited by Hypex on 22-Aug-2022 at 09:35 AM.

 Status: Offline
Profile     Report this post  
Karlos 
Re: FAO: Hypex - The Maestix
Posted on 22-Aug-2022 9:23:09
#12 ]
Elite Member
Joined: 24-Aug-2003
Posts: 2857
From: As-sassin-aaate! As-sassin-aaate! Ooh! We forgot the ammunition!

@Hypex

I'm pretty sure I was using v4 on my actual Amiga but when setting up the emulation copy (based on a fairly vanilla 3.9) I got 6 and decided that it should be fine under UAE. I might try the v4 again.

Thanks for looking into it.

_________________
Doing stupid things for fun...

 Status: Offline
Profile     Report this post  
Hypex 
Re: FAO: Hypex - The Maestix
Posted on 22-Aug-2022 9:37:35
#13 ]
Elite Member
Joined: 6-May-2007
Posts: 10718
From: Greensborough, Australia

@Karlos

I edited my post but should just added a comment.

 Status: Offline
Profile     Report this post  
Karlos 
Re: FAO: Hypex - The Maestix
Posted on 22-Aug-2022 10:35:08
#14 ]
Elite Member
Joined: 24-Aug-2003
Posts: 2857
From: As-sassin-aaate! As-sassin-aaate! Ooh! We forgot the ammunition!

@Hypex

I still haven't ruled out this being some Wine issue.

_________________
Doing stupid things for fun...

 Status: Offline
Profile     Report this post  

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle