Click Here
home features news forums classifieds faqs links search
6097 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
38 crawler(s) on-line.
 26 guest(s) on-line.
 3 member(s) on-line.


 kolla,  Frank,  AmiRich

You are an anonymous user.
Register Now!
 AmiRich:  2 mins ago
 Frank:  3 mins ago
 kolla:  3 mins ago
 BigD:  10 mins ago
 Kronos:  16 mins ago
 Futaura:  50 mins ago
 VooDoo:  53 mins ago
 RobertB:  1 hr 5 mins ago
 AP:  1 hr 11 mins ago
 matthey:  2 hrs 15 mins ago

/  Forum Index
   /  Amiga OS4.x \ Workbench 4.x
      /  Tutorial: Installation guide for AmigaOS 4.1 under QEMU 8
Register To Post

Goto page ( Previous Page 1 | 2 | 3 )
PosterThread
Maijestro 
Re: Tutorial: Installation guide for AmigaOS 4.1 under QEMU 8
Posted on 18-Apr-2023 18:15:22
#41 ]
Member
Joined: 31-Mar-2023
Posts: 20
From: Unknown


I'll summarize it again briefly....

Problems we still have at the moment under Qemu Pegasos 2:


- Using -cpu 7447 with Altivec support there is no correct GUI/window output for some SDL applications, use -cpu g3 instead.

-After update FE 2 it is possible that your network connection becomes unstable, if this is the case please copy the older rtl8139.device from the Pegasos install.iso to system/devs/Networks on your installation HD

-Nvram is not yet emulated, so the firmware's environment variables are not preserved, so the boot command has to be entered at every startup

-Currently the maximum resolution is limited to 1440x900 16 bit under the Qemu Pegasos2 emulation

-AmigaOs4.1 cannot be terminated under Qemu via the "Shutdown" menu (there is already a patch for this, but it probably won't make it into Qemu 8 Final)

How can I help:

It can be helped to solve the -cpu 7447 problem by reproducing the whole thing with Qemu 8 and MorphOs. This means that you have to install MorphOs under Qemu and test different SDL applications that also access AltiVec directly. This would confirm that both systems have the same problems and it is not AmigaOs4.1 specific.

If someone wants to help, you can get the installation for Morphos under Qemu from here:

http://zero.eik.bme.hu/~balaton/qemu/amiga/

Let's create together the best Amiga NG emulation

 Status: Offline
Profile     Report this post  
Maijestro 
Re: Tutorial: Installation guide for AmigaOS 4.1 under QEMU 8
Posted on 20-Apr-2023 13:34:55
#42 ]
Member
Joined: 31-Mar-2023
Posts: 20
From: Unknown

@pavlor

Hello,

could you possibly do a small test on your real Pegasos2 board?

If your Pegasos 2 has a G4 Cpu please test the SDL output under AmigaOs4.1 in 16 bit screen mode.

You can test it with Mplay-Gui and Mplayer-mickjt (os4depot). Set the video output in MplayerGUI to SDL and play a video.

And you could test a game from http://hunoppc.amiga-projects.net/content/project-secret-maryo-chronicles. It is important that you use these apps in 16 bit mode.

If you get a faulty screen output, it proves that SDL under AmigaOs4.1 is broken and not emulation of the g4 cpu under Qemu is to blame.

 Status: Offline
Profile     Report this post  
OneTimer1 
Update: Installation guide for AmigaOS 4.1 under QEMU 8
Posted on 20-Apr-2023 21:34:58
#43 ]
Cult Member
Joined: 3-Aug-2015
Posts: 804
From: Unknown

Here is an update of this tutorial:

http://amiga-news.de/de/news/AN-2023-04-00086-EN.html

Last edited by OneTimer1 on 21-Apr-2023 at 07:08 PM.

 Status: Offline
Profile     Report this post  
pavlor 
Re: Tutorial: Installation guide for AmigaOS 4.1 under QEMU 8
Posted on 21-Apr-2023 15:55:18
#44 ]
Elite Member
Joined: 10-Jul-2005
Posts: 9494
From: Unknown

@Maijestro

G4 1266 MHz here. Will do tests tomorrow and report back.

 Status: Offline
Profile     Report this post  
pavlor 
Re: Tutorial: Installation guide for AmigaOS 4.1 under QEMU 8
Posted on 21-Apr-2023 19:22:43
#45 ]
Elite Member
Joined: 10-Jul-2005
Posts: 9494
From: Unknown

@Maijestro

On Pegasos 2 G4 1266 MHz, 1 GB RAM, Radeon 9250 128 MB:
MplayerGUI/Mplayer-mickjt (sdl video output): video garbled with both 16 bit and 32 bit screen mode. Works OK in Emotion. (I used this video: Amiga Ad)
Same result with both AltiVec and nonAltivec MPlayer build.

project-secret-maryo-chronicles: works OK on 16 bit WB. (well I played only few minutes, I'm quite weak on this kind of game )

Last edited by pavlor on 21-Apr-2023 at 07:26 PM.
Last edited by pavlor on 21-Apr-2023 at 07:24 PM.

 Status: Offline
Profile     Report this post  
Maijestro 
Re: Tutorial: Installation guide for AmigaOS 4.1 under QEMU 8
Posted on 22-Apr-2023 18:56:19
#46 ]
Member
Joined: 31-Mar-2023
Posts: 20
From: Unknown

@pavlor

Quote:

pavlor wrote:
@Maijestro

On Pegasos 2 G4 1266 MHz, 1 GB RAM, Radeon 9250 128 MB:
MplayerGUI/Mplayer-mickjt (sdl video output): video garbled with both 16 bit and 32 bit screen mode. Works OK in Emotion. (I used this video: Amiga Ad)
Same result with both AltiVec and nonAltivec MPlayer build.

project-secret-maryo-chronicles: works OK on 16 bit WB. (well I played only few minutes, I'm quite weak on this kind of game )


Just to be sure, they have Mplayer-GUI http://os4depot.net/?function=showfile&file=video/misc/mplayer-gui.lha

And Mplayer http://os4depot.net/?function=showfile&file=video/play/mplayer-mickjt.lha

Tested in 16/32 bit mode SDL?

At project-secret-maryo-chronicles they also tested in 16 bit mode and also used 16 bit mode in the games option? Please check the project-secret-maryo-chronicles preferences.ini there should be 16 bpp settings.

Thank you very much for testing it is really important...

Last edited by Maijestro on 22-Apr-2023 at 06:58 PM.

 Status: Offline
Profile     Report this post  
pavlor 
Re: Tutorial: Installation guide for AmigaOS 4.1 under QEMU 8
Posted on 22-Apr-2023 19:50:22
#47 ]
Elite Member
Joined: 10-Jul-2005
Posts: 9494
From: Unknown

@Maijestro

Quote:
they have Mplayer-GUI http://os4depot.net/?function=showfile&file=video/misc/mplayer-gui.lha


Yes.

Quote:
And Mplayer http://os4depot.net/?function=showfile&file=video/play/mplayer-mickjt.lha


Yes.

Quote:
Tested in 16/32 bit mode SDL?


Yes.

Quote:
they also tested in 16 bit mode and also used 16 bit mode in the games option? Please check the project-secret-maryo-chronicles preferences.ini there should be 16 bpp settings.


Yes and yes.


I think SDL libraries are OK, SDL video output in MPlayer was probably not tested with G4, because nobody would use it with G4 machine... until now. But this is only my assumption.

 Status: Offline
Profile     Report this post  
Maijestro 
Re: Tutorial: Installation guide for AmigaOS 4.1 under QEMU 8
Posted on 22-Apr-2023 20:21:03
#48 ]
Member
Joined: 31-Mar-2023
Posts: 20
From: Unknown

@pavlor

Many thanks for the test.

Exactly the same I suspected, SDL is buggy on G4 (Altivec), so probably on real and also under emulated hardware.

 Status: Offline
Profile     Report this post  
Goto page ( Previous Page 1 | 2 | 3 )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle