Click Here
home features news forums classifieds faqs links search
5763 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
56 crawler(s) on-line.
 15 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 K-L:  7 mins ago
 DiscreetFX:  59 mins ago
 MrFrench:  1 hr 15 mins ago
 MEGA_RJ_MICAL:  1 hr 35 mins ago
 billt:  1 hr 52 mins ago
 ggw:  2 hrs 1 min ago
 IRTheBorg:  2 hrs 17 mins ago
 amisteph:  2 hrs 19 mins ago
 GaryG:  2 hrs 28 mins ago
 freak:  3 hrs 38 mins ago

hardware OS4   hardware OS4 : MiniGL 2.5 released
   posted by marko on 5-Jan-2011 23:32:52 (5013 reads)
There is a new MiniGL on OS4Depot!

Changes in V2.5:
- Fixed the graphics corruption problems introduced in V2.4
- LodePaint's momentary freezes eliminated

Download
    

Related Links
· More about hardware OS4
· News by marko


Printer Friendly Page  Send this Story to a Friend

PosterThread
Phantom 
Re: MiniGL 2.5 released
Posted on 5-Jan-2011 23:51:53
#1 ]
Elite Member
Joined: 2-Aug-2007
Posts: 2047
From: Unknown

At least. Thanks for the update.


_________________

 Status: Offline
Profile     Report this post  
Tomas 
Re: MiniGL 2.5 released
Posted on 6-Jan-2011 1:40:55
#2 ]
Elite Member
Joined: 25-Jul-2003
Posts: 4286
From: Unknown

Thanks for the update. This solved the issues i had with warzone and armagetron advanced.

 Status: Offline
Profile     Report this post  
Kicko 
Re: MiniGL 2.5 released
Posted on 6-Jan-2011 9:54:14
#3 ]
Elite Member
Joined: 19-Jun-2004
Posts: 5009
From: Sweden

thanks for the update :)

 Status: Offline
Profile     Report this post  
Dwyloc 
Re: MiniGL 2.5 released
Posted on 6-Jan-2011 12:20:34
#4 ]
Super Member
Joined: 30-Mar-2005
Posts: 1051
From: Glasgow, Scotland

Thanks for the update I will install it when I get home.


_________________
Sam440ep 667mhz, 512MB, 120GB 2.5" HD, OS4.1FE
WinUae 3.0.0, OS 3.9, BB3, Catweasel MkIV
Amiga 1200, Blizzard 040/40 (BlizzardPPC 060/200 with SCSI removed at present), mediatorSX pci, Voodoo3, PCI network card os 3.9BB2
4MB Minimig with ARM addon boar

 Status: Offline
Profile     Report this post  
kas1e 
Re: MiniGL 2.5 released
Posted on 6-Jan-2011 12:34:49
#5 ]
Amiga Developer Team
Joined: 11-Jan-2004
Posts: 3411
From: Russia

@all

I already tested 2.5 before uploading to os4depot, so all should works fine. If someone in interst, i test some games/apps which show FPS, and that what we have in compare with 2.3:

Apps which show FPS:

Cube - speed up on 2 fps (was 38-39 with 2.3, and now, with 2.5 - 40-41 fps at the same place)
Quake3 - speed up on 2 fps .
Epiar - speed up on 1 fps.
NeverBall - speed up on 2 fps.
LodePaint - no more freezes and speedup on 1fps when do nothing (when drawing fps are the same as before).
Warzone2100 - no more gfx corruptions

And tested the stuff which not show FPS, but just to be sure that it works:

Aquaria - works fine, looks smoother
AssaultCube (not released for now, but almost works) - works fine with new lib
SuperTuxKart - works fine. Dunno how show fps here, but feels faster on 2-3 fps.
I have no tomatoes - works
X-Moto - works (feels a bit faster as well)
Lugaru - works
Some ogl demos (ante_dominium , ssri) - works fine


Of course 2 fps of speedup not so big difference , but for example in SuperTuxKart and in NeverBall (i.e. where FPS are very low), its even visually faster.

Verdict: need to update for everyone for sure.


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
klx300r 
Re: MiniGL 2.5 released
Posted on 6-Jan-2011 13:01:33
#6 ]
Elite Member
Joined: 4-Mar-2008
Posts: 3514
From: Toronto, Canada

@ kas1e

thanks, just what I was waiting to hear!..time to update now


_________________
____________________________
c64-2sids, A1000, A1200T-060@50(finally working!),A4000-CSMKIII
! My Master Miggies- Amiga 1000 & AmigaOne X1000 !
mancave-ramblings
X1000 I BELIEVE

 Status: Offline
Profile     Report this post  
samo79 
Re: MiniGL 2.5 released
Posted on 6-Jan-2011 13:26:58
#7 ]
Elite Member
Joined: 13-Feb-2003
Posts: 3389
From: Italy, Perugia

My benchmark with ioQuake 3 & MiniGL 2.5

Sam440ep Flex AMCC 440ep 800Mhz Radeon 9250 on AmigaOS 4.1.2
640x480 14,4 fps
800x600 12,6 fps
1024x768 9,1 fps
1280x1024 7.7 fps

And with MiniGL 2.4 (WIP release from m3x)

Sam440ep Flex AMCC 440ep 800Mhz Radeon 9250 on AmigaOS 4.1.2
640x480 14,4 fps
800x600 12,6 fps
1024x768 9,0 fps
1280x1024 8,0 fps


_________________
BACK FOR THE FUTURE

http://www.betatesting.it/backforthefuture

Sam440ep Flex 800 Mhz 1 GB Ram + AmigaOS 4.1 Update 6
AmigaOne XE G3 800 Mhz - 640 MB Ram - Radeon 9200 SE + AmigaOS 4.1 Update 6

 Status: Offline
Profile     Report this post  
Crisot 
Re: MiniGL 2.5 released
Posted on 6-Jan-2011 16:12:47
#8 ]
Regular Member
Joined: 25-Jan-2004
Posts: 159
From: France

Still a buffer problem in ioQuake3 when loading a level: It switch from 2 old video buffers instead of showing the level loading (level picture + displaying the bots).

I can do a little video if I explained it too bad

Anyway some benchmarks: 2.3 vs 2.5:

ioQuake 3:
640x480: 33.4 vs 34.1
1280x720: 25.6 vs 25.8

Quake 2:
640x480: 47.3 vs 48.6
1280x960: 30.5 vs 31.3

Cube:
640x480: 35 vs 36
1280x720: 27 vs 28

200x this speed upgrade and we'll have good minigl

Last edited by Crisot on 06-Jan-2011 at 04:51 PM.
Last edited by Crisot on 06-Jan-2011 at 04:50 PM.


_________________
AmigaOne XE --- 7455A@1400 --- Radeon 9000 Pro --- RAM 2GB --- SSD 40GB

 Status: Offline
Profile     Report this post  
Daniel 
Re: MiniGL 2.5 released
Posted on 6-Jan-2011 20:07:56
#9 ]
Regular Member
Joined: 6-Mar-2010
Posts: 239
From: Unknown

Thanks for the update!

 Status: Offline
Profile     Report this post  
Nibunnoichi 
Re: MiniGL 2.5 released
Posted on 6-Jan-2011 21:11:43
#10 ]
Cult Member
Joined: 18-Nov-2004
Posts: 951
From: Roma + Lecco, Italia

I have a question: i downloaded it from OS4Depot and installed (v2.5), it's dated 4th of January... then i ran AmiUpdate and it finds the same v2.5 but with 6th of January as date... any hint?
Thanks for the update anyhow


_________________
Proud Amigan since 1987
Owner of various Commodore and a SAM440ep\OS4.1FE
See them on http://retro.furinkan.org/

 Status: Offline
Profile     Report this post  
Phantom 
Re: MiniGL 2.5 released
Posted on 6-Jan-2011 23:08:23
#11 ]
Elite Member
Joined: 2-Aug-2007
Posts: 2047
From: Unknown

@Nibunnoichi

Yup, I have exactly the same problem. Even if you install it via AmiUpdate, the next time you run AmiUpdate it will show you the same update and so on!!!


_________________

 Status: Offline
Profile     Report this post  
spotUP 
Re: MiniGL 2.5 released
Posted on 7-Jan-2011 7:47:07
#12 ]
Elite Member
Joined: 19-Aug-2003
Posts: 2896
From: Up Rough Demo Squad

wrong date in the amiupdate database. hans needs to fix that i guess.
@hans fantastic work as usual!


_________________
AOS4 Betatester, Peg2, G4@1ghz, Radeon 9250 256mb, 1gb RAM.

http://www.asciiarena.com
http://www.uprough.net

 Status: Offline
Profile     Report this post  
AmigaBlitter 
Re: MiniGL 2.5 released
Posted on 7-Jan-2011 10:45:13
#13 ]
Elite Member
Joined: 26-Sep-2005
Posts: 3415
From: Unknown

Can't install MiniGL. I got an Error with Copystore.


_________________
retired

 Status: Offline
Profile     Report this post  
Phantom 
Re: MiniGL 2.5 released
Posted on 7-Jan-2011 13:48:33
#14 ]
Elite Member
Joined: 2-Aug-2007
Posts: 2047
From: Unknown

Maybe it was fixed. AmiUpdate finds nothing now.


_________________

 Status: Offline
Profile     Report this post  
kas1e 
Re: MiniGL 2.5 released
Posted on 7-Jan-2011 14:01:20
#15 ]
Amiga Developer Team
Joined: 11-Jan-2004
Posts: 3411
From: Russia

@Crisot
Quote:

Still a buffer problem in ioQuake3 when loading a level: It switch from 2 old video buffers instead of showing the level loading (level picture + displaying the bots).


With 2.3 is was fine, and such problem only happens with 2.5 ?


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
Crisot 
Re: MiniGL 2.5 released
Posted on 7-Jan-2011 16:13:14
#16 ]
Regular Member
Joined: 25-Jan-2004
Posts: 159
From: France

Yes. I double checked this once again: buffer corruption on map loading with ioquake 3 and minigl 2.5 (happened with 2.4 too). No problem with 2.2 or 2.3.

Not a big problem anyway, everything is fine ingame.


_________________
AmigaOne XE --- 7455A@1400 --- Radeon 9000 Pro --- RAM 2GB --- SSD 40GB

 Status: Offline
Profile     Report this post  
kas1e 
Re: MiniGL 2.5 released
Posted on 7-Jan-2011 16:20:40
#17 ]
Amiga Developer Team
Joined: 11-Jan-2004
Posts: 3411
From: Russia

@Crisot
Still need to fix.. Maybe you have some time, and can make a video in which show how it looks on 2.3 and how start to looks now (so will be easy to explain, just by giving link on youtube). And i will send mail to Hanz with all the info

Last edited by kas1e on 07-Jan-2011 at 04:22 PM.


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle