Click Here
home features news forums classifieds faqs links search
5823 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
55 crawler(s) on-line.
 12 guest(s) on-line.
 2 member(s) on-line.


 bennymee,  OldAmigan

You are an anonymous user.
Register Now!
 OldAmigan:  45 secs ago
 bennymee:  2 mins ago
 Jasper:  8 mins ago
 BSzili:  14 mins ago
 MEGA_RJ_MICAL:  18 mins ago
 terminills:  29 mins ago
 zipper:  34 mins ago
 Turrican3:  36 mins ago
 clint:  39 mins ago
 dirkzwager:  55 mins ago

hardware OS4   hardware OS4 : New RadeonHD driver, version 0.32
   posted by elwood on 21-Jan-2012 22:08:33 (2835 reads)
Sat, 21 Jan 2012
New RadeonHD driver, version 0.32
Bassano del Grappa (Italy) - 21 Jan 2012

Dear customer,

ACube Systems is happy to deliver another update of the RadeonHD driver developed by Hans de Ruiter for PCIe graphic cards. You'll find below a list of changes in this version.



If you are an AmigaOne 500 or Sam460 customer and didn't receive your driver update by email, send us a message using our contact page (please give also your name and the motherboard serial number).

We would like to take the opportunity to thank you for your support. This allows us to push Hans de Ruiter, the driver author, to work even more on this project and it helps moving the AmigaOS experience forward even more.
Thanks for contributing.

Here's a list of fixes:
- Some R700 GPUs were locking up when compositing "large" vertex arrays. FIXED
- Screens that were larger than the display resolution were garbled. FIXED.
- R500 vertex array clipping was one pixel larger than it was supposed to be (could cause the right-hand edge to spill over to the left most column of pixels). FIXED.
- Fixed an R500 compositing bug that could cause corruption if one compositing operation rapidly draws directly over the previous one
- WaitTOF() and similar functions could cause the machine to lockup when called from a task with a priority >= 1. FIXED.

The ACube Systems team
    

Related Links
· More about hardware OS4
· News by elwood


Printer Friendly Page  Send this Story to a Friend

PosterThread
Templario 
Re: New RadeonHD driver, version 0.32
Posted on 22-Jan-2012 14:17:36
#1 ]
Elite Member
Joined: 22-Jun-2004
Posts: 3494
From: Palencia city of the emptied Spain.

Thank you, now the sound is the big requirement.


_________________
Amiga 500 with ROMs 1.3-2.05 and M-Tec AT500 with hard disk and 4MB Ram.
WinUAE + original OS 3.5&3.9
Sam440ep 800 MHZ + OS 4.1 F.E.
Sam460ex 1 GHz + OS 4.1 F.E.
MacMini 1.5 GHz + MorphOS 3.13
PowerBook G4 1.65 + MorphOS 3.13

 Status: Offline
Profile     Report this post  
virgolamobile 
Re: New RadeonHD driver, version 0.32
Posted on 22-Jan-2012 19:07:15
#2 ]
Regular Member
Joined: 23-Feb-2004
Posts: 174
From: Somewhere in Northern Italy

Thank you Hans!
The composition now works like a charm!

 Status: Offline
Profile     Report this post  
kyle 
Re: New RadeonHD driver, version 0.32
Posted on 22-Jan-2012 22:32:59
#3 ]
Cult Member
Joined: 15-Oct-2006
Posts: 863
From: Livorno, Italy

Picasso96mode is no longer working after having installed the new drivers.

Any suggestion?

 Status: Offline
Profile     Report this post  
noXLar 
Re: New RadeonHD driver, version 0.32
Posted on 22-Jan-2012 23:58:17
#4 ]
Cult Member
Joined: 8-May-2003
Posts: 652
From: Norway

fantastic good news:))) keep up the good work Hans:)


_________________
noXLar -AmigaOne X1000&Sam460ex
2xAmiga 1230 33mhz 128MB Indivision ACA 1200 MK2 USB PCMCIA WIFI 60GB&DVD-ROM OS 3.9

 Status: Offline
Profile     Report this post  
Hans 
Re: New RadeonHD driver, version 0.32
Posted on 23-Jan-2012 0:31:17
#5 ]
Elite Member
Joined: 27-Dec-2003
Posts: 4919
From: New Zealand

@kyle

Quote:
Picasso96mode is no longer working after having installed the new drivers.

Any suggestion?


Have a look at your monitor's tool-types. You may have messed those up somehow. Picasso96Mode works for me.

Hans


_________________
http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more. Home of the RadeonHD driver for Amiga OS 4.x project.
https://keasigmadelta.com/ - More of my work.

 Status: Offline
Profile     Report this post  
kyle 
Re: New RadeonHD driver, version 0.32
Posted on 25-Jan-2012 5:45:47
#6 ]
Cult Member
Joined: 15-Oct-2006
Posts: 863
From: Livorno, Italy

There something wrong.

I can't change resolution on my monitor going to prefs/screenmode (es. 1024x766 or 800x600) that I got a black screen and I must reset the 460ex.

What shoul I check on my monitor's tooltype?

 Status: Offline
Profile     Report this post  
Hans 
Re: New RadeonHD driver, version 0.32
Posted on 25-Jan-2012 6:45:26
#7 ]
Elite Member
Joined: 27-Dec-2003
Posts: 4919
From: New Zealand

@kyle

I'm guessing that you have some bad modes in your monitor's tooltypes. I suggest that you delete your monitor file altogether, and your devs:Picasso96Settings file (after making a backup, of-course), and see what happens. Unless you've messed with the startup-sequence, Picasso96 should default to automatically getting the screenmodes using DDC.

If you still cannot get it working, then it would help if you posted your monitor's tooltypes, and explained more carefully what is going on. Which modes are not working? Are you testing the modes first? If so, you should be able to get back to the current screen-mode by pushing the escape key (the equivalent of clicking cancel on the test screen).

Hans


_________________
http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more. Home of the RadeonHD driver for Amiga OS 4.x project.
https://keasigmadelta.com/ - More of my work.

 Status: Offline
Profile     Report this post  
kyle 
Re: New RadeonHD driver, version 0.32
Posted on 25-Jan-2012 22:56:42
#8 ]
Cult Member
Joined: 15-Oct-2006
Posts: 863
From: Livorno, Italy

@ Hans

I tried what you said with no success.
I tried to reinstall the old drivers (rev. 027) but nothing changed. I think the problem could be the monitor: I chanched my old Benq some days ago with an Acer AL1751.

If I go in prefs/screenmode and try a different resolution (test mode) I got a black screen and I cannot go back also pressing "esc" key.
The only way is to hard reset the 460.
It is as my resolution is ever blocked to 1280x1024...

This is my tool type monitor

CMPLENGTH=6
BOARDNAME=PCIGraphics
VSYNCMIN=49
VSYNCMAX=160
HSYNCMIN=26000
HSYNCMAX=125000
MODE=320x256@60
MODE=640x480@60
MODE=800x600@60
MODE=1024x768@60
MODE=1280x720@60
MODE=1280x960@60
MODE=1280x1024@60
MODE=1440x900@60
MODE=1600x1050@60
FAKENATIVEMODES=No
INTERRUPT=Yes
BOARDTYPE=Radeon

Last edited by kyle on 25-Jan-2012 at 11:10 PM.

 Status: Offline
Profile     Report this post  
Hans 
Re: New RadeonHD driver, version 0.32
Posted on 26-Jan-2012 2:32:43
#9 ]
Elite Member
Joined: 27-Dec-2003
Posts: 4919
From: New Zealand

@kyle

Your tooltypes look okay. Since you have changed monitors you might want to double-check that the timing limits given in the tool-types are correct.
Get rid of:
Quote:
BOARDNAME=PCIGraphics


However, that shouldn't cause what you are describing. Here are some questions that might help in tracking down the problem:
- What is the current screenmode before you click the test button?
- Are you using VGA or DVI?
- Are all screenmodes failing when you click test? Or do some work?
- What happened when you removed your monitor file and DEVS:Picasso96mode? Did you reboot before doing any testing?
- Can you normally push escape to cancel requesters (please double-check)? If not, you have messed up settings somewhere.
- Are you doing something "weird" like connecting multiple monitors (or the same monitor via multiple outputs)?
- Could the cable for the new monitor be bad (unlikely to be a problem, but weird stuff happens)?

If pushing escape to cancel requesters normally works, then it screenmode prefs might be crashing as it changes the screenmode (i.e., your system is really messed up). The only way to double-check is to connect a null-modem cable to another machine, redirect debug ouput to serial (kdebug "console serial"), and watch the debug output.

Since you are Italian, it might be easier for you to get help from your fellow countrymen. This clearly isn't a driver problem, and it should be faster talking to people in your own timezone (and in your native language).

Hans


_________________
http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more. Home of the RadeonHD driver for Amiga OS 4.x project.
https://keasigmadelta.com/ - More of my work.

 Status: Offline
Profile     Report this post  
[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle