Click Here
home features news forums classifieds faqs links search
5851 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
15 crawler(s) on-line.
 14 guest(s) on-line.
 2 member(s) on-line.


 redfox,  Dragoon

You are an anonymous user.
Register Now!
 Dragoon:  1 min ago
 redfox:  2 mins ago
 cdimauro:  17 mins ago
 freak:  39 mins ago
 Fairdinkem:  1 hr 2 mins ago
 bison:  1 hr 3 mins ago
 Akiko:  1 hr 26 mins ago
 invent:  1 hr 51 mins ago
 asymetrix:  2 hrs 9 mins ago
 DiscreetFX:  2 hrs 24 mins ago

/  Forum Index
   /  Amiga OS4.x \ Workbench 4.x
      /  MPlayer for OS4 - Dirty Preview #2
Register To Post

Goto page ( 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 Next Page )
PosterThread
afxgroup 
MPlayer for OS4 - Dirty Preview #2
Posted on 17-Jan-2005 21:19:17
#1 ]
Super Member
Joined: 8-Mar-2004
Posts: 1967
From: Taranto, Italy

On www.amigasoft.net site you can found a first preview of MPlayer.

#WARNING
rename zip extension to lha! This because that stupid win2003 server doesn't recognize the lha extension (and the server is not mine. just an hosting server).
#END OF WARNING

Watch out! IT IS A PREEEEEVIEW so i list all things doesn't work (souldn't work):

Support to DVD via a1ide.device - The VOB can be played using -noframe option (otherwise are too slow)
Network support doesn't work
Overlay is not implemented
Fullscreen is not implemented yet

uhm.. many other things i suppose

Codec that works:

MPG (please report to me problems!)
AVI (DIVX, XVID and so on)
WMV

you can try other codecs

Audio is fully supported

Examples of use:

1) mplayer -vo cgx_vmem::ALWAYSBORDER filename
2) mplayer -vo cgx_wpa::ALWAYSBORDER filename
3) mplayer -vo cgx_vmem::NOBORDER filename
4) mplayer -vo cgx_vmem::TINYBORDER filename
5) mplayer -framedrop -vo cgx_vmem::ALWAYSBORDER filename.vob
6) mplayer filename.(mp3|ogg|wav)

and so on..

Here you can find another grab of mplayer on OS4

Please report to me if the videos are shown correctly or you have problems (like hangs). this because my A1 is sending to me insanity mental signals with some videos..

Enjoy

Last edited by afxgroup on 24-Jan-2005 at 10:35 PM.

_________________
http://www.amigasoft.net

 Status: Offline
Profile     Report this post  
gnarly 
Re: MPlayer for OS4 - Dirty Preview
Posted on 17-Jan-2005 21:22:21
#2 ]
Cult Member
Joined: 16-Mar-2003
Posts: 742
From: Cheltenham, UK

@afxgroup

Whoa nelly! Nice one :)

_________________

 Status: Offline
Profile     Report this post  
spotUP 
Re: MPlayer for OS4 - Dirty Preview
Posted on 17-Jan-2005 21:33:21
#3 ]
Elite Member
Joined: 19-Aug-2003
Posts: 2896
From: Up Rough Demo Squad

@afxgroup

yeah! freshness! will check it out for sure!...
getting closer to a final release now I guess!... If you won't be flooded with bugreports now.. :)

_________________
AOS4 Betatester, Peg2, G4@1ghz, Radeon 9250 256mb, 1gb RAM.

http://www.asciiarena.com
http://www.uprough.net

 Status: Offline
Profile     Report this post  
samo79 
Re: MPlayer for OS4 - Dirty Preview
Posted on 17-Jan-2005 21:35:05
#4 ]
Elite Member
Joined: 13-Feb-2003
Posts: 3410
From: Italy, Perugia

Thanks Andrea

_________________
BACK FOR THE FUTURE

http://www.betatesting.it/backforthefuture

Sam440ep Flex 800 Mhz 1 GB Ram + AmigaOS 4.1 Update 6
AmigaOne XE G3 800 Mhz - 640 MB Ram - Radeon 9200 SE + AmigaOS 4.1 Update 6

 Status: Offline
Profile     Report this post  
jahc 
Re: MPlayer for OS4 - Dirty Preview
Posted on 17-Jan-2005 21:43:27
#5 ]
Elite Member
Joined: 30-May-2003
Posts: 2959
From: Auckland, New Zealand

@afxgroup

it works so well! I'm playing mov's that moovid ppc couldnt play back at a good rate..

 Status: Offline
Profile     Report this post  
Deniil715 
Re: MPlayer for OS4 - Dirty Preview
Posted on 17-Jan-2005 21:45:36
#6 ]
Elite Member
Joined: 14-May-2003
Posts: 4193
From: Sweden

@afxgroup

WOHOOO!!

Finally I can watch my 55GB of StarTrek episodes WITH SOUND! And it mixes with AmigaAMP too, how nice

Are there any key-combinations or anything to seek in a movie, or put it on pause??

-----
I got a crash though after starting MPlayer with only an AVI-file as a parameter and nothing else. This is the last thing it said before I got the reaper:

***### init bestvideoout ###***
** Essaie driver 'cgx_overlay'
VO: [cgx(overlay)] Hello !.


BTW: The exception was a read access to address 0. This is the stack trace:
Cgx_GiveArg()+0x2C (section 1 @ 0x2de84)
preinit()+0x70 (section 1 @ 0x2936c)
init_best_video_out()+0x15C (section 1 @ 0x28cf4)
main()+0xD44 (section 1 @ 0x2774)
call_main()+0x98 (section 1 @ 0x334)
_main()+0x3B4 (section 1 @ 0x8ec)
native kernel module dos.library.kmod+0x01d8f8

_________________
- Don't get fooled by my avatar, I'm not like that (anymore, mostly... maybe only sometimes)
> Amiga Classic and OS4 developer for OnyxSoft.

 Status: Offline
Profile     Report this post  
afxgroup 
Re: MPlayer for OS4 - Dirty Preview
Posted on 17-Jan-2005 21:50:15
#7 ]
Super Member
Joined: 8-Mar-2004
Posts: 1967
From: Taranto, Italy

@Deniil715

overlay is not supported yet, so don't try to use it..
overlay is the default mode, so you must use a valid vo mode

to go forward and back use arrow keys. to put the movie in pause use space key

Last edited by afxgroup on 17-Jan-2005 at 09:50 PM.

_________________
http://www.amigasoft.net

 Status: Offline
Profile     Report this post  
Megatron 
Re: MPlayer for OS4 - Dirty Preview
Posted on 17-Jan-2005 22:04:39
#8 ]
Regular Member
Joined: 6-Jul-2004
Posts: 275
From: Unknown

@afxgroup

COOL

play all thos movies now nice
amp2
Movid
and now Mplayer how nice

_________________
Here they come
These gods of steel
Megatron


MY TRANSFORMER IS AN AMIGA ONE XE AND ITS AS

 Status: Offline
Profile     Report this post  
fryguy 
Re: MPlayer for OS4 - Dirty Preview
Posted on 17-Jan-2005 22:07:07
#9 ]
Cult Member
Joined: 6-Dec-2003
Posts: 852
From: Tinytown

Nice! Mplayer is one of my favorite movieplayers.

 Status: Offline
Profile     Report this post  
Amon_Re 
Re: MPlayer for OS4 - Dirty Preview
Posted on 17-Jan-2005 22:12:21
#10 ]
Regular Member
Joined: 27-Nov-2003
Posts: 427
From: Belgium

@afxgroup

If you want i could host it on a decent (read Apache) webserver
Drop me a mail: ochal at kefren dot be

_________________
Amon's digital home

 Status: Offline
Profile     Report this post  
Toaks 
Re: MPlayer for OS4 - Dirty Preview
Posted on 17-Jan-2005 22:37:41
#11 ]
Elite Member
Joined: 10-Mar-2003
Posts: 8042
From: amigaguru.com

@afxgroup

u will get that great hug when i meet u andrea

thanx, this is just GREAT! .....now whwere was i...ah yes...MPLAYER..

if im awol for the next 20 years u all know why..... watching movies..

thanx again.

_________________
See my blog and collection website! . https://www.blog.amigaguru.com

 Status: Offline
Profile     Report this post  
hotrod 
Re: MPlayer for OS4 - Dirty Preview
Posted on 17-Jan-2005 22:41:26
#12 ]
Elite Member
Joined: 11-Mar-2003
Posts: 2778
From: Stockholm, Sweden

@afxgroup

Works fine here! Thanks!

Regarding speed, it was slower playing AVI-files compared to MooVId. On the other hand, everything worked.

Does it support Altivec yet?

 Status: Offline
Profile     Report this post  
NutsAboutAmiga 
Re: MPlayer for OS4 - Dirty Preview
Posted on 17-Jan-2005 22:59:13
#13 ]
Elite Member
Joined: 9-Jun-2004
Posts: 11429
From: Norway

@afxgroup

Nice work no problems

_________________
http://lifeofliveforit.blogspot.no/
Facebook::LiveForIt Software for AmigaOS

 Status: Offline
Profile     Report this post  
ikir 
Re: MPlayer for OS4 - Dirty Preview
Posted on 17-Jan-2005 23:09:49
#14 ]
Elite Member
Joined: 18-Dec-2002
Posts: 5646
From: Italy

@afxgroup

Tried it! It works... and fast. Crypted dvd aren't supported i see.

Tomorrow i'm going to test some videos and dvds (zone free)


I want overlay!!!

_________________
Amiga News.it
Sam460ex 1,15Ghz
2GB RAM, 120GB Crucial v4 SSD, 32GB SDHC
Radeon HD 6450 1GB

 Status: Offline
Profile     Report this post  
Ayalo 
Re: MPlayer for OS4 - Dirty Preview
Posted on 17-Jan-2005 23:14:25
#15 ]
Member
Joined: 17-Jun-2004
Posts: 54
From: Stockholm (Sweden)

@afxgroup

Supercool....great job. Works perfect!!!

 Status: Offline
Profile     Report this post  
freaks 
Re: MPlayer for OS4 - Dirty Preview
Posted on 17-Jan-2005 23:27:35
#16 ]
Regular Member
Joined: 8-Jun-2004
Posts: 318
From: france

@afxgroup

Thanks a LOT!!!!!!! O_o
mplayer is the best player i know about.
its fast, always synchro, read almost all known formats(mpg/avi/divx/mov/rm....)
a must have for os4.
this is excellent news for everyone!
...now need a decent browser and i'm happy ;)

keep up the good work!

 Status: Offline
Profile     Report this post  
Bean 
Re: MPlayer for OS4 - Dirty Preview
Posted on 17-Jan-2005 23:43:22
#17 ]
Super Member
Joined: 4-Apr-2003
Posts: 1225
From: U.K.

@afxgroup

Great work!

Does it support VCD's yet? ..and if so can I change the device/unit to the sil680ide.device instead of a1ide.device?

Cheers,
Bean.

_________________
OS4.1 + SAM Flex
RIP my A1XE.. that used to have an appetite for batteries!

 Status: Offline
Profile     Report this post  
Kicko 
Re: MPlayer for OS4 - Dirty Preview
Posted on 18-Jan-2005 0:22:14
#18 ]
Elite Member
Joined: 19-Jun-2004
Posts: 5009
From: Sweden

@afxgroup

Damnit. Mplayer for os4 :) Even if its a early beta
or whatever very much thanks for this.

I waited for it and now i have it :)

 Status: Offline
Profile     Report this post  
Anonymous 
Re: MPlayer for OS4 - Dirty Preview
Posted on 18-Jan-2005 0:50:22
# ]

0
0

@afxgroup

Great stuff!

Most of the videos I threw at it worked fine. Some WMV9 videos didn't work (no surprise there - I just keep 'em around for testing), and a Quicktime movie didn't have sound (guess it's lack of a commercial audio codec).
I'll test more thoroughly tomorrow though. It seems navigation works fine (using arrow keys).

Is there a way of scaling the output without overlay? (like double size for instance)

 
     Report this post  
scabit 
Re: MPlayer for OS4 - Dirty Preview
Posted on 18-Jan-2005 3:23:56
#20 ]
Super Member
Joined: 8-Jan-2005
Posts: 1667
From: Satellite Beach, FL USA

@afxgroup

Well, try as I might, I can't get MPlayer to work at all on my uA1C. It seems
to require a cybergraphix driver, which doesn't exist for Os4 as far as I can
tell. Since I am still waiting for my "official" OS4 release 2 CD, perhaps
that is the problem. Anyway, this is the error I get when I try:

Mplayer -vo cgx_vmem::TINYBORDER trailer.avi

Starting playback...
VDec: vo config request - 360 x 240 (preferred csp: Planar YVU9)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDec: using Planar YVU9 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
SwScaler: using unscaled Planar YVU9 -> Planar YV12 special converter
VO: [cgx_vmem] 360x240 => 360x240 Planar YV12
[cgx_mem] No YUV -> RGB conversion
FATAL: Cannot initialize video driver.

FATAL: Could not initialize video filters (-vf) or video output (-vo).

So, any ideas?

Thanks for your help. And thanks for supporting AmigaOne!

_________________
AmigaOne uA1-c 512M RAM - Only Amiga Makes It Possible!
Check my blog AmigaOne Computing

 Status: Offline
Profile     Report this post  
Goto page ( 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 Next Page )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle