Click Here
home features news forums classifieds faqs links search
6092 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
61 crawler(s) on-line.
 14 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 BSzili:  6 mins ago
 michalsc:  8 mins ago
 Papiosaur:  26 mins ago
 MEGA_RJ_MICAL:  47 mins ago
 Mobileconnect:  55 mins ago
 DiscreetFX:  3 hrs 2 mins ago
 agami:  3 hrs 16 mins ago
 ed:  3 hrs 43 mins ago
 amigang:  4 hrs 32 mins ago
 freak:  5 hrs 4 mins ago

/  Forum Index
   /  Amiga OS4 Software
      /  New WookieChat: v2.12 beta 11 - 2009-11-22
Register To Post

PosterThread
jahc 
New WookieChat: v2.12 beta 11 - 2009-11-22
Posted on 3-Nov-2009 7:24:43
#1 ]
Elite Member
Joined: 30-May-2003
Posts: 2959
From: Auckland, New Zealand

UPDATE: v2.12 beta 11 - 2009-11-22
- Modified UTF8 support support slightly. Seems to work better. Works on AROS
now too.
- The "show user modes besides nicks" feature wasnt reloading the setting properly.
- /WHOIS was sending a WHOIS twice by accident, the second time with a blank
nick
- when gethostbyname() fails to find a server, it prints the servers name in
the error message now (requested by ssolie)
- The number of ops being displayed in the "Number of ops and Number of users"
box above the nicklist was not decreasing the amount of ops when an Op would
quit. Fixed, thanks to Mick for reporting this bug
Unfortunately, people are reporting connecting problems.. and I can only semi reproduce them. I'll have to investigate.


New WookieChat: v2.12 beta 9 - 2009-11-03 - http://wookiechat.amigarevolution.com for AROS/MOS/OS3/OS4

BETA 9
- ARexx events. Scripts can be used to display popups with the OS4.1.1
notification system (when its released to the mortals)
- Mode changes were broken at some point.. werent being displayed. Fixed now
- Server selection list looks a little better. No longer has a "Servers" tree
at the very top that all the groups and servers are inside.
- The usermode status is displayed in front of a persons name now when they
type a message. If they're opped, then instead of "[jahc] hi", it becomes
"[@jahc] hi". The help bubble on the nicklist shows you the key for the different usermodes.

Make sure the local charset in the server selection window is your computers charset.. US-ASCII Or ISO-8859-1 or similar... and the server charset should be UTF8, so you can view normal text and UTF8..

Last edited by jahc on 21-Nov-2009 at 10:39 PM.
Last edited by jahc on 03-Nov-2009 at 07:28 AM.

 Status: Offline
Profile     Report this post  
TiredofLife 
Re: New WookieChat: v2.12 beta 9 - 2009-11-03
Posted on 3-Nov-2009 9:54:30
#2 ]
Super Member
Joined: 6-Jul-2005
Posts: 1676
From: Here

@jahc

Cheers jahc.

_________________
If your nose runs and your feet smell, you're upside down.

 Status: Offline
Profile     Report this post  
Kicko 
Re: New WookieChat: v2.12 beta 9 - 2009-11-03
Posted on 3-Nov-2009 10:04:10
#3 ]
Elite Member
Joined: 19-Jun-2004
Posts: 5009
From: Sweden

Thanks jahc. Would be nice if you could make the user mode status to be optional as i dont like it. Too much info on screen for me which makes it dont look so clean and like i see ghosts :) (crosses)

Last edited by Kicko on 03-Nov-2009 at 02:55 PM.

 Status: Offline
Profile     Report this post  
kas1e 
Re: New WookieChat: v2.12 beta 9 - 2009-11-03
Posted on 3-Nov-2009 10:28:34
#4 ]
Elite Member
Joined: 11-Jan-2004
Posts: 3487
From: Russia

@Jahc

Just a suggestion: can you make by default (when user first time install wookie), double-clicking on the nickname opening priv.tab for chat, but not like it's now by default do (whois).
Imho it will be more logical and user-friendly for the ppls who first time will try it.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
MickJT 
Re: New WookieChat: v2.12 beta 9 - 2009-11-03
Posted on 3-Nov-2009 11:31:24
#5 ]
Cult Member
Joined: 13-Jan-2005
Posts: 525
From: Adelaide, South Australia

@jahc

Quote:
- The usermode status is displayed in front of a persons name now when they
type a message. If they're opped, then instead of "[jahc] hi", it becomes
"[@jahc] hi". The help bubble on the nicklist shows you the key for the different usermodes.


That "feature" alone is going to make me stick with beta 7.

 Status: Offline
Profile     Report this post  
Tuxedo 
Re: New WookieChat: v2.12 beta 9 - 2009-11-03
Posted on 3-Nov-2009 13:33:49
#6 ]
Elite Member
Joined: 28-Nov-2003
Posts: 2326
From: Perugia, ITALY

@jahc

Good JoB!

_________________
Simone"Tuxedo"Monsignori, Perugia, ITALY.

 Status: Offline
Profile     Report this post  
jahc 
Re: New WookieChat: v2.12 beta 9 - 2009-11-03
Posted on 3-Nov-2009 22:22:33
#7 ]
Elite Member
Joined: 30-May-2003
Posts: 2959
From: Auckland, New Zealand

@MickJT

I'll make it configurable today.

 Status: Offline
Profile     Report this post  
Phantom 
Re: New WookieChat: v2.12 beta 9 - 2009-11-03
Posted on 4-Nov-2009 1:26:42
#8 ]
Elite Member
Joined: 2-Aug-2007
Posts: 2047
From: Unknown

@jahc

Thanks for the update.

_________________

 Status: Offline
Profile     Report this post  
Moxee 
Re: New WookieChat: v2.12 beta 9 - 2009-11-03
Posted on 4-Nov-2009 2:39:51
#9 ]
Team Member
Joined: 20-Aug-2003
Posts: 6291
From: County Yakima, WA State, USA

@jahc

Please submit as a News article. I think more people will take notice.

EDIT: I decided to post it for you.

Last edited by Moxee on 04-Nov-2009 at 02:51 AM.

_________________
Moxee
AmigaOne X1000
AmigaOne XE G4
I'd agree with you, but then we'd both be wrong.

 Status: Offline
Profile     Report this post  
jahc 
Re: New WookieChat: v2.12 beta 9 - 2009-11-03
Posted on 21-Nov-2009 23:53:03
#10 ]
Elite Member
Joined: 30-May-2003
Posts: 2959
From: Auckland, New Zealand

bump..

 Status: Offline
Profile     Report this post  
Kicko 
Re: New WookieChat: v2.12 beta 9 - 2009-11-03
Posted on 22-Nov-2009 0:04:29
#11 ]
Elite Member
Joined: 19-Jun-2004
Posts: 5009
From: Sweden

@jahc

Thanks mate

 Status: Offline
Profile     Report this post  
ChrisH 
Re: New WookieChat: v2.12 beta 11 - 2009-11-22
Posted on 22-Nov-2009 10:28:29
#12 ]
Elite Member
Joined: 30-Jan-2005
Posts: 6673
From: Unknown

I hadn't noticed any problems with beta 8, but guess I better update to beta 11!

_________________
Author of the PortablE programming language.
I can usually be found on www.Amigans.net (my favourite Amiga forum).
It is pitch black. You are likely to be eaten by a grue...

 Status: Offline
Profile     Report this post  
Phantom 
Re: New WookieChat: v2.12 beta 11 - 2009-11-22
Posted on 22-Nov-2009 18:43:56
#13 ]
Elite Member
Joined: 2-Aug-2007
Posts: 2047
From: Unknown

@jahc

Thanks for the update, but I still get Gurus at the startup. Really strange, from beta9 I get Gurus and I have to stay with beta8.

_________________

 Status: Offline
Profile     Report this post  
gobgob 
Re: New WookieChat: v2.12 beta 11 - 2009-11-22
Posted on 22-Nov-2009 19:49:16
#14 ]
Member
Joined: 1-Aug-2006
Posts: 38
From: France

@jahc

Many thanks Jahc.
Work great on my Aros box.

_________________
Amiga demos on Youtube - Icaros native/Linux Gentoo/Haiku/Winxp/Win7 user.
My pictures (no Amiga related)

 Status: Offline
Profile     Report this post  
jahc 
Re: New WookieChat: v2.12 beta 11 - 2009-11-22
Posted on 22-Nov-2009 20:39:23
#15 ]
Elite Member
Joined: 30-May-2003
Posts: 2959
From: Auckland, New Zealand

@Phantom

Danny reported the same issue. Apparently if you have a server thats outside a group, it fails.. You might have to perform on surgery on your servers.txt and add a Group (just add a line thats one word) to before your servers name..

Please email me your servers.txt to (insert dots and at symbol where appropriate).. james carroll at xnet co nz ... and I'll investigate for you..

 Status: Offline
Profile     Report this post  
Phantom 
Re: New WookieChat: v2.12 beta 11 - 2009-11-22
Posted on 23-Nov-2009 0:43:15
#16 ]
Elite Member
Joined: 2-Aug-2007
Posts: 2047
From: Unknown

@jahc

Ok. I've done that. Everything is fine now. Thanx.

_________________

 Status: Offline
Profile     Report this post  

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle