Click Here
home features news forums classifieds faqs links search
5823 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)



Lost Password?

Don't have an account yet?
Register now!

Your support is needed and is appreciated as is primarily dependent upon the support of its users.

Main sections
OS4 Zone
IRC Network
AmigaWorld Radio
Top Members
Amiga Dealers
About Us
Terms of Service

IRC Channel
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
61 crawler(s) on-line.
 14 guest(s) on-line.
 1 member(s) on-line.


You are an anonymous user.
Register Now!
 Bezzen:  1 min ago
 jacadcaps:  8 mins ago
 BSzili:  12 mins ago
 K-L:  17 mins ago
 kamelito:  31 mins ago
 DiscreetFX:  32 mins ago
 MEGA_RJ_MICAL:  37 mins ago
 Lou:  38 mins ago
 BigD:  39 mins ago
 Vidar:  43 mins ago

/  Forum Index
   /  Classic Amiga Hardware
      /  Weird A4000 behaviour
Register To Post

Weird A4000 behaviour
Posted on 3-Jul-2019 11:46:18
#1 ]
Team Member
Joined: 18-Mar-2003
Posts: 626
From: Iceland


I'm attempting to get my A4k back up and running.

It's an A4000/030 originally, socketed buster 11, Cyberstorm MK2 060@50Mhz, an A2065 ethernet card and a CV64, 48 megs of fast ram, 2 megs of chip.

It's a work in progress but there are some weird things going on that I'm wondering if someone has seen or heard of before.

The first is that, before running Setpatch, or turning off caches, the keyboard repeats itself in such a way that it's almost impossible to type. This is obvious when cold or warm-rebooting into a No Startup-Sequence. Turning off the caches in the pre-boot menu, turning off the caches with cpu nocache or running Setpatch all fix the issue. Another seemingly related thing (that is also fixed by caches or setpatch) is the floppy drive trashing around until the same is done. This is an annoyance, but it's weird and I wonder if anyone has heard of this before.

The second is that the Roxxler chip on the Cybervision 64 seems to be dodgy. I've managed to get it to display RTG apps like TVPaint but promoting Workbench is a very mixed bag. There are also artifacts on the displays at every setting of the Memory clock, although at 50Mhz it seems to be usable (lots of artifacts at everything higher than that).

I've tried 3.1 running CyberGraphX,3 3.1 running Picasso 96 from Aminet, and yesterday my copy of 3.1.4 for the A4k on Picasso 96 2.1-e that was floating around.

My best success so far has been in 3.1.4 and by turning off using Planer2chunky hardware on the board in PVS for the Picasso96, that at least enabled me to get it to display the Workbench, but I don't see the mouse pointer sprite, I've tried all combinations of low-res and hi-res sprites as well as hardware and software sprites. In addition smart refresh displays don't work. Can someone post their tooltypes for a working Cybervision 64 setup under Picasso 2.1-e?

In addition to this I've had no luck trying to get Picasso 96 under 3.1.4 to display a 15 or 16 bit screen (only 256 max colors available), has any had any luck with that?


The opinions stated do not neccesarily represent those of my employer.

 Status: Offline
Profile     Report this post  

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 was originally founded by David Doyle