Click Here
home features news forums classifieds faqs links search
5829 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
66 crawler(s) on-line.
 9 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 NutsAboutAmiga:  5 mins ago
 BigD:  8 mins ago
 Rob:  17 mins ago
 Dragster:  39 mins ago
 The_Shadow:  53 mins ago
 monstercoder:  55 mins ago
 amigakit:  1 hr 3 mins ago
 jacadcaps:  1 hr 6 mins ago
 tygre:  1 hr 13 mins ago
 Jasper:  1 hr 14 mins ago

/  Forum Index
   /  Classic Amiga Software
      /  Install script error on Raspberry Pi
Register To Post

PosterThread
Ned 
Install script error on Raspberry Pi
Posted on 16-Nov-2019 23:27:02
#1 ]
Regular Member
Joined: 10-Dec-2003
Posts: 499
From: Arlington, Texas USA

My primary Amiga these days seems to be an emulated one on my
Raspberry Pi 3B where I am emulating an A4000 with OS 3.9. On more
than one occassion (and perhaps all occassions) I have tried to install
a piece of software using the install icon associated with the application,
and I seem to get a message that reads:
Unable to compile script.
Error: Out of Memory on line xxxx.
Does anyone have any ideas as to what's going on and how to fix it?
Thanks.


 Status: Offline
Profile     Report this post  
Severin 
Re: Install script error on Raspberry Pi
Posted on 16-Nov-2019 23:49:25
#2 ]
Elite Member
Joined: 19-Aug-2003
Posts: 2740
From: Gloucestershire UK

@Ned

It's probably exactly what it says, out of memory. You can try the standard amiga side things like closing uneeded programs, disable background pictures, smaller screen resolution, less colours (drop to 16 bit if you're using p96), disable wbstartup and reboot etc. But I think the best option is to upgrand your PI to a PI4 4GB and allocate the emulater 'far too much' ram

_________________
OS4 Rocks
X1000 beta tester, Sam440 Flex (733)

Visit the Official OS4 Support Site for more help.

It may be that your sole purpose is to serve as a warning to others.

 Status: Offline
Profile     Report this post  
m0lebrain 
Re: Install script error on Raspberry Pi
Posted on 18-Nov-2019 5:46:45
#3 ]
Regular Member
Joined: 21-Apr-2004
Posts: 351
From: South Western PA

@Ned

Hey Ned,
I would actually like to do the same. What did you end up using to get A4000/OS 3.9 on the Pi? Amibian or something?

_________________
-- --
aka Tony Rocks

 Status: Offline
Profile     Report this post  
smf 
Re: Install script error on Raspberry Pi
Posted on 18-Nov-2019 7:52:05
#4 ]
Regular Member
Joined: 15-Mar-2003
Posts: 291
From: Vxj, Sweden

@Ned

Try to disable the JIT.
Last time i emulated amiga on the Pi i got all kind of strange behaviours when the JIT was enabled and this problem sounds familiar.
Now it's been maybe two years since i last used it so i hope there has been progress in this area.

 Status: Offline
Profile     Report this post  

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle