Click Here
home features news forums classifieds faqs links search
5770 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
28 crawler(s) on-line.
 17 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 kolla:  7 mins ago
 remotenemesis:  22 mins ago
 gryfon:  41 mins ago
 matthey:  1 hr ago
 Hypex:  1 hr 2 mins ago
 amigakit:  1 hr 5 mins ago
 cc3d:  1 hr 8 mins ago
 Rob:  1 hr 17 mins ago
 kamelito:  1 hr 29 mins ago
 A1200:  1 hr 41 mins ago

/  Forum Index
   /  Amiga OS4.x \ Workbench 4.x
      /  GDB problems
Register To Post

PosterThread
thinkchip 
GDB problems
Posted on 30-Jan-2020 17:02:47
#1 ]
Super Member
Joined: 26-Mar-2004
Posts: 1136
From: Salt Lake City, Utah, USA

I think I last posted about my problems with gdb in 2012. Gdb is a C++ debugger. I posted about how when I was debugging a program and set a breakpoint when using my A1-500 / SAM 460 it would stop at the first breakpoint. Then if I set an additional breakpoint a couple lines down and typed c for continue, it would ignore the breakpoint (and any other breakpoints) and run until the end of the program. Gdb on my micro works as expected. Somebody posted it was a hardware problem with the SAM and nothing could be done about it. Everything was okay if I did my progamming on the micro, even though it was inconvenient. Then I got an X5000 and it did the same thing as the SAM.

Today I discovered something helpful and I wanted to run it by my Amiga buddies. I studied the gdb instructions concerning breakpoints and couldn't find anything helpful. Finally I tried deleting the first breakpoint before setting the next one. It works. When it stops at the first breakpoint, I type "d b", which deletes all the breakpoints, then I set the next one. I type c and it stops at the next breakpoint. This is doable and is better than switching computers. I haven't tried stepping, which probably won't work. I'm wondering if this is consistent with a hardware "problem". If not, can anybody figure out what's going on?

Incidentally, I like db101, but it can't handle anything even slightly complex. The author should work on it some more. I would pay if it did what I needed.

_________________
X5000 / AmigaOne 500(OS4.1 FE) / microA1(OS4.1 FE) / Cubic IDE / Imagine / Blender
Lightwave 2019 / Microsoft Visual C++

 Status: Offline
Profile     Report this post  
Hypex 
Re: GDB problems
Posted on 31-Jan-2020 15:48:43
#2 ]
Elite Member
Joined: 6-May-2007
Posts: 9933
From: Greensborough, Australia

@thinkchip

Thanks for the hints. I don't think it's limited to the Sam. I would have had the same trouble on my XE for years. And I have the same trouble on my X1000. Something broke in GDB and it hasn't been fixed since. So, in reality, anyone using the current SDK version including any OS developers, have been unable to test and debug any code with GDB.

I tried to compile it myself from the old patches and related source on OS4 Depot. But never could. I wanted to fix our broken one as well as activate the text GUI which for some reason is disabled in OS4.

As it happens, I've also found another work around, just tonight. Can't do single stepping which would be useful. But another way to break at the points is to set a breakpoint and use the "run" command. But it it gets stuck at the PC.

I share your experience with DB101. I found it showed promise but easily got confused and then crashed. There are sources for it.

 Status: Offline
Profile     Report this post  

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle