Click Here
home features news forums classifieds faqs links search
6081 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
» Home
» Features
» News
» Forums
» Classifieds
» Links
» Downloads
Extras
» OS4 Zone
» IRC Network
» AmigaWorld Radio
» Newsfeed
» Top Members
» Amiga Dealers
Information
» About Us
» FAQs
» Advertise
» Polls
» Terms of Service
» Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
17 crawler(s) on-line.
 31 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 fatbob_gb:  9 mins ago
 INFRA_PHRANKO:  32 mins ago
 amigakit:  32 mins ago
 d_w_cook:  39 mins ago
 amigang:  41 mins ago
 bison:  51 mins ago
 Bosanac:  1 hr 3 mins ago
 Gregor:  1 hr 8 mins ago
 kolla:  1 hr 15 mins ago
 BSzili:  1 hr 25 mins ago

/  Forum Index
   /  Amiga OS4.x \ Workbench 4.x
      /  AmigaOS 4.1 (FE) and AmiSSL
Register To Post

Goto page ( 1 | 2 Next Page )
PosterThread
sananaman 
AmigaOS 4.1 (FE) and AmiSSL
Posted on 24-Aug-2022 9:58:38
#1 ]
Regular Member
Joined: 28-Sep-2006
Posts: 252
From: Netherlands

Hi,

I'm trying to access websites that use SSL from my AmigaOne Micro using AmigaOS 4.1 FE using OWB.
OWB (but also iBrowse) complains that it cannot handle SSL.

So I installed AmiSSL version 5.3 from OS4 Depot.

But when I try to open several https websites it still complains about the SSL.
Loading fails!
SSL Connect Error.

Google on https does work though, but a lot of other sites don't, fore example:
https://www.amigascene.nl
https://amigaworld.net
https://www.tweakers.net

Do I need more root- and intermediate certificates ? If yes where can I get it?

Thanks..

_________________
AmigaScene.nl

 Status: Offline
Profile     Report this post  
AmigaOldskooler 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 24-Aug-2022 10:08:47
#2 ]
Regular Member
Joined: 7-Mar-2015
Posts: 262
From: Unknown

@sananaman

Hi there,

Download NetSurf from OS4Depot:

NetSurf on OS4Depot

I think that will solve your problem. OWB has not been updated for ages.

Are you using the latest version of iBrowse for AmigaOS 4?

Last edited by AmigaOldskooler on 24-Aug-2022 at 10:09 AM.

_________________
Old School Game Blog
Gaming on AmigaOS 4
Void - Amiga Demo Group

 Status: Offline
Profile     Report this post  
Fairdinkem 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 24-Aug-2022 11:03:08
#3 ]
Cult Member
Joined: 23-Feb-2010
Posts: 511
From: Victoria, Australia

@sananaman

AmiSSL is working for me on my Pegasos 2. I am using it with the following browser

http://www.os4depot.net/share/network/browser/odyssey.lha

Odyssey is the replacement for OWB.


It also works with the latest iBrowse.

http://www.ibrowse-dev.net/


I tested the websites you had trouble with and they work for me.

All the best.

_________________
Amiga A1200T - TF1260 - R9200 - Indivision AGA MK3
Amiga A500 - PiStorm EMU68
Pegasos 2 G4 - AmigaOS 4.1 FE / MorphOS 3.16

 Status: Offline
Profile     Report this post  
redfox 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 24-Aug-2022 19:40:20
#4 ]
Super Member
Joined: 7-Mar-2003
Posts: 1985
From: Canada

@sananaman

If by OWB, you mean Origyn Web Browser, then yes, this is a very old program that has issues with SSL.

I am posting this post with Origyn Web Browser 3.32 ...

It works for me on amigaworld, but I get SSL Connect Error message for the other sites in your list.

As indicated by others, you should have more success with these:
IBrowse 2.5.6
NetSurf 3.10
Odyssey Web Browser 1.23 r5

I also have some limited success viewing some websites with AWeb APL Lite 3.5.12 ...



redfox

Last edited by redfox on 24-Aug-2022 at 08:50 PM.

 Status: Offline
Profile     Report this post  
redfox 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 24-Aug-2022 19:46:44
#5 ]
Super Member
Joined: 7-Mar-2003
Posts: 1985
From: Canada

@sananaman

These days, I use mainly IBrowse, NetSurf and Odyssey.

IBrowse is great for quick access, but may not render the webpage as expected.
NetSurf renders closer to what is expected.
Odyssey is the best for amiga.org and more complicated sites, but locks up on me sometimes.

I think I may run out to memory on some sites that use alot of javascript.

Anyways, hope we have provided some helpful hints.



redfox


 Status: Offline
Profile     Report this post  
sananaman 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 25-Aug-2022 19:51:21
#6 ]
Regular Member
Joined: 28-Sep-2006
Posts: 252
From: Netherlands

@redfox, AmigaOldskooler, Fairdinkem,

Thanks a lot guys.

I was not aware that OWB was outdated.
It came with 4.1FE so I assumed it was the defacto browser, which I remembered from 10 years ago.

I tried to update iBrowse via AmiUpdate, but it seems you need an AmiUpdate-account nowadays. Otherwise it will not update anything.
I created an account on the http://amiupdate.net website (CodeBench), but when filling in the form and submitting, nothing happens, not even a confirmation mail. -weird-

Anyway I installed Odyssey, which took 30 minutes to initialize the fonts -weird-
This works ! but massively slow, almost unusable (to be fun).
And Discord is not even working , unfortunate nothing has changed in the 10 years. Still shitty browsers on the Amiga.

So I will try out the NetSurf soon.

OR, is that FireFox for Amiga an option? TimberFox i believe?

Anyway, maybe I should forget about modern internet on the Amiga.

Modern internet works soo nice on PopOS... oops... wrong forum.

_________________
AmigaScene.nl

 Status: Offline
Profile     Report this post  
redfox 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 25-Aug-2022 21:03:24
#7 ]
Super Member
Joined: 7-Mar-2003
Posts: 1985
From: Canada

@sananaman

Yeah, it's a shame about OWB (Origyn Web Browser).

OWB was my main goto browser for many many years.

Oooo yeah, Odyssey takes a long time to initialize the fonts.

I used TimberWolf a bit in the past. It always hogged vast amounts of RAM on my system, but it rendered quite well. Last time I tried it, it had SSL issues on every website. Never discovered a fix. I assume there is no support anymore.

I purchased IBrowse 2.5 from the IBrowse website. Currently IBrowse 2.5.6

Sadly, none of our current web browsers can keep up with every website.

Maybe Odyssey would work better on a system with more RAM.

I use my Samsung tablet or IPad if I want to do any heavy surfing.

---
redfox

Last edited by redfox on 25-Aug-2022 at 09:37 PM.
Last edited by redfox on 25-Aug-2022 at 09:10 PM.

 Status: Offline
Profile     Report this post  
nbache 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 25-Aug-2022 23:16:58
#8 ]
Super Member
Joined: 8-Apr-2003
Posts: 1029
From: Copenhagen, Denmark

@sananaman

Quote:
I tried to update iBrowse via AmiUpdate, but it seems you need an AmiUpdate-account nowadays. Otherwise it will not update anything.
I created an account on the http://amiupdate.net website (CodeBench), but when filling in the form and submitting, nothing happens, not even a confirmation mail. -weird-
You don't need an account to use AmiUpdate. The account you can create on AmiUpdate.net is needed only by software authors/maintainers who want to create/update a record in the AmiUpdate database for their software, so it can be updated through AmiUpdate.

As a regular end-user, you should just have to configure your Update prefs correctly, including at least one server (amiupdate.net). Then run AmiUpdate, and you should then be offered whatever updates you are lacking for the software supported. Note that often the updates are configured so they only get offered if an earlier version of the package in question is installed already. And there may also be other requirements which have to be met before a given package is being offered (some library of a certain minimum version etc.).

AmiUpdate should take care of all this, but you may need to run it more than one to get everything.

Best regards,

Niels

 Status: Offline
Profile     Report this post  
smf 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 26-Aug-2022 9:09:15
#9 ]
Regular Member
Joined: 15-Mar-2003
Posts: 333
From: Växjö, Sweden

@sananaman

If if takes 30 mins to initialize the fonts you must be running ffs?
When i need to do it it takes only a few seconds.
I have not timed it and it's been a long time since i had to do it last time but my estimation is 5 seconds.
My machine is a little bit faster than yours (x5000) but it also needs a long time to do it from ffs.

 Status: Offline
Profile     Report this post  
AmigaOldskooler 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 26-Aug-2022 18:30:26
#10 ]
Regular Member
Joined: 7-Mar-2015
Posts: 262
From: Unknown

@sananaman

I mostly use NetSurf on the Sam Flex, which should be comparable in terms of performance with your Micro. I think you will find it better for your setup than Odyssey and iBrowse.

_________________
Old School Game Blog
Gaming on AmigaOS 4
Void - Amiga Demo Group

 Status: Offline
Profile     Report this post  
Fairdinkem 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 27-Aug-2022 8:54:21
#11 ]
Cult Member
Joined: 23-Feb-2010
Posts: 511
From: Victoria, Australia

@sananaman

Trash the fonts folder in the Odyssey folder and then restart Odyssey, it will initialise the fonts again and it shouldn't do it again after that.

Odyssey>>Conf>>Font

Last edited by Fairdinkem on 27-Aug-2022 at 08:57 AM.
Last edited by Fairdinkem on 27-Aug-2022 at 08:55 AM.

_________________
Amiga A1200T - TF1260 - R9200 - Indivision AGA MK3
Amiga A500 - PiStorm EMU68
Pegasos 2 G4 - AmigaOS 4.1 FE / MorphOS 3.16

 Status: Offline
Profile     Report this post  
Futaura 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 27-Aug-2022 19:13:03
#12 ]
Regular Member
Joined: 10-May-2004
Posts: 250
From: UK

@sananaman

If you're having trouble with AmiUpdate, you can always update your IBrowse installation by simply running the installer after unpacking the archive from http://www.ibrowse-dev.net/2.5/download.php instead. IBrowse 2.5.6 is required for AmiSSL v5 usage (earlier 2.5 versions used AmiSSL v4).

_________________
IBrowse, AmiSSL and Warp Datatype Developer

 Status: Offline
Profile     Report this post  
kolla 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 27-Aug-2022 20:47:01
#13 ]
Elite Member
Joined: 20-Aug-2003
Posts: 2315
From: Trondheim, Norway

@Futaura

Doesn’t that http just redirect to https and thus creating a funny catch22? :)

_________________
B5D6A1D019D5D45BCC56F4782AC220D8B3E2A6CC

 Status: Offline
Profile     Report this post  
sananaman 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 28-Aug-2022 11:50:51
#14 ]
Regular Member
Joined: 28-Sep-2006
Posts: 252
From: Netherlands

@nbache

Quote:
You don't need an account to use AmiUpdate. The account you can create on AmiUpdate.net is needed only by software authors/maintainers who want to create/update a record in the AmiUpdate database for their software, so it can be updated through AmiUpdate.

As a regular end-user, you should just have to configure your Update prefs correctly, including at least one server (amiupdate.net). Then run AmiUpdate, and you should then be offered whatever updates you are lacking for the software supported. Note that often the updates are configured so they only get offered if an earlier version of the package in question is installed already. And there may also be other requirements which have to be met before a given package is being offered (some library of a certain minimum version etc.).

AmiUpdate should take care of all this, but you may need to run it more than one to get everything.

Best regards,

Niels


Hi Niels, that is what I remember of 10 years ago when I used AmigaOS 4.

But when I start AmiUpdate (4.1FE) it starts rotating in my dock, then it stops and nothing happens. Then I click on the stopped rotating icon then it changes into another icon when I click it another time the AmiUpdate UI pops up.
Then I press scan then a login window pops up. When I cancel the window select the items to update it takes a fraction of a second to "install" (well nothing is installed). Then when I restart over, the updates are in the list again, the username + password popup appears again.

It seems it got stuck at some login. If it does not require a login, I have no clue why it shows this behavior.
From what I remember AmiUpdate was a nice tool, but the 4.1FE AmiUpdate experience is really a bad experience to be honest.

Today I'm at a point that when I started the machine this morning that my dock suddenly dissapeared (it only showed a small empty square with a drag handel in the middle of my workbench).
When I look in the AmiDock preferences, the entire preference is gone (totally empty, no icons, no apps, nothing).

I must say it hasn't been a smooth experience so far.

I think I'm at a point I have to start over.

_________________
AmigaScene.nl

 Status: Offline
Profile     Report this post  
Futaura 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 28-Aug-2022 18:47:53
#15 ]
Regular Member
Joined: 10-May-2004
Posts: 250
From: UK

@kolla

Quote:

kolla wrote:

Doesn’t that http just redirect to https and thus creating a funny catch22? :)

No server http to https redirects on www.ibrowse-dev.net if you are using IBrowse

_________________
IBrowse, AmiSSL and Warp Datatype Developer

 Status: Offline
Profile     Report this post  
nbache 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 28-Aug-2022 22:17:35
#16 ]
Super Member
Joined: 8-Apr-2003
Posts: 1029
From: Copenhagen, Denmark

@sananaman

Which servers do you have listed in the prefs?

The amiupdate.net server (for third-party updates) does not require any login.

But the update.amigaos.net server (for official OS4 updates from Hyperion) does.

For that one, you use the same username and password you also use when logging into your account on https://www.hyperion-entertainment.com/ e.g. to manage your registrations.

Best regards,

Niels

 Status: Offline
Profile     Report this post  
sananaman 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 28-Aug-2022 23:11:50
#17 ]
Regular Member
Joined: 28-Sep-2006
Posts: 252
From: Netherlands

@smf

Quote:

If if takes 30 mins to initialize the fonts you must be running ffs?
When i need to do it it takes only a few seconds.
I have not timed it and it's been a long time since i had to do it last time but my estimation is 5 seconds.
My machine is a little bit faster than yours (x5000) but it also needs a long time to do it from ffs.


Yess it took 30 mins, i tried it twice and it took in both times around 30 mins.
Yess I use Fast File System with long file names and cache.
As a drive I use a IDE-2-CF 64GB solution.

Any other filesystem that is recommended?
Smart Filesystem maybe?

Last edited by sananaman on 28-Aug-2022 at 11:13 PM.

_________________
AmigaScene.nl

 Status: Offline
Profile     Report this post  
Fairdinkem 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 29-Aug-2022 2:26:00
#18 ]
Cult Member
Joined: 23-Feb-2010
Posts: 511
From: Victoria, Australia

@sananaman

Did you try my suggestion in my post #11 to speed up the the launch of Odyssey and stop the font initialisation?

_________________
Amiga A1200T - TF1260 - R9200 - Indivision AGA MK3
Amiga A500 - PiStorm EMU68
Pegasos 2 G4 - AmigaOS 4.1 FE / MorphOS 3.16

 Status: Offline
Profile     Report this post  
smf 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 29-Aug-2022 10:30:41
#19 ]
Regular Member
Joined: 15-Mar-2003
Posts: 333
From: Växjö, Sweden

@sananaman

Yes Smartfilesystem is your best choice.
the fonts will initialize pretty fast with it but not as fast as with ngfs but it's not released yet (there is an old version on the X5000 iso but that one is old and probably locked to work on X5000 only)

 Status: Offline
Profile     Report this post  
sananaman 
Re: AmigaOS 4.1 (FE) and AmiSSL
Posted on 29-Aug-2022 16:54:07
#20 ]
Regular Member
Joined: 28-Sep-2006
Posts: 252
From: Netherlands

@Fairdinkem

Quote:

@sananaman

Did you try my suggestion in my post #11 to speed up the the launch of Odyssey and stop the font initialisation?

Thanks for letting me know this , but it only happens when doing the installation of Odyssey.
It does not happen when running it. Although loading is a bit slow.

_________________
AmigaScene.nl

 Status: Offline
Profile     Report this post  
Goto page ( 1 | 2 Next Page )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle