Click Here
home features news forums classifieds faqs links search
5759 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
84 crawler(s) on-line.
 8 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 Bezzen:  10 mins ago
 BSzili:  15 mins ago
 Fl@sh:  31 mins ago
 Lou:  34 mins ago
 Fairdinkem:  46 mins ago
 kamelito:  48 mins ago
 clint:  57 mins ago
 shastar:  1 hr 4 mins ago
 ggw:  1 hr 28 mins ago
 MEGA_RJ_MICAL:  2 hrs 2 mins ago

Software News   Software News : First AmigaOne/OS4 demo released at Slash Party 5
   posted by MikeB on 11-Aug-2004 18:30:42 (2805 reads)
As discussed within this thread, the demo group Universe has released the first ever AmigaOne/OS4 demo, named "Zero", at a demo party. You can download the demo or an AVI capture at the homepage of the group's coder, Crisot:

"http://uniweb.free.fr/prerelease

Watch the AVI ;) And sorry for crap framerate/quality."
    

Related Links
· More about Software News
· News by MikeB


Most read story about Software News
UBoot 2010.06.04 for Sam460ex available

Last news about Software News
Goadf! 3.0 has been released
Printer Friendly Page  Send this Story to a Friend

PosterThread
Toaks 
Re: First AmigaOne/OS4 demo released at Slash Party
Posted on 11-Aug-2004 19:11:07
#1 ]
Elite Member
Joined: 10-Mar-2003
Posts: 8042
From: amigaguru.com

Maybe a bit late to announce this as news now ?

anyway, Univere's demo is great, i like the design alot and 50-60 Fps aint bad at all for a demo and most of all the way it was made! (no 3d api etc)

----->

ps: we in push-entertainment has released our 4k Warp3d 68k Assembly 04 intro too, and yes its AmigaOs4 Ready too.

its for:

Amiga's With 040 / 060 With MEDIATOR "WARP3d"
Amiga's With PPC's 040 / 060 with BVISION or CV643d/CVISION
AMIGA ONE With Warp3d!
"UAE With W3d?"
"Amithlon With W3d?"

Anyway i cant test more until i have a final? warp3d Os4 native version.

cheers


_________________
See my blog and collection website! . https://www.blog.amigaguru.com

 Status: Offline
Profile     Report this post  
MikeB 
Re: First AmigaOne/OS4 demo released at Slash Party
Posted on 11-Aug-2004 19:25:00
#2 ]
Elite Member
Joined: 3-Mar-2003
Posts: 6487
From: Europe

@ Toaks

Quote:
Maybe a bit late


Sorry, I have been travelling back home from California to the Netherlands.

At least Crisot's AVI and z5's thread were just posted yesterday. Thought it might be a shame if anyone interested missed this thread.

 Status: Offline
Profile     Report this post  
_Steve_ 
Re: First AmigaOne/OS4 demo released at Slash Party
Posted on 11-Aug-2004 22:14:53
#3 ]
Team Member
Joined: 18-Oct-2002
Posts: 6770
From: UK

@Toaks

That would be Rebirth wouldn't it?

If so, the plain non "os" and "voodoo" versions do not work for me at all (the exe called Rebirth.exe). If I try running it, the CLI pauses for about 20 seconds, then I am greeted with my CLI prompt again.

The "os" exe worked, but flickers terribly, as though it doesn't buffer the screen properly. It did however look pretty decent ignoring that fact, and the music was great especially for 4K.

For information, I tried running it on:
A4000 with 604e/233 060/50 with CVPPC gfx card running WarpOS/Warp3D 4.2a, 112MB Fast, Prelude, HC4+.


_________________
Test sig

 Status: Offline
Profile     Report this post  
herewegoagain 
Re: First AmigaOne/OS4 demo released at Slash Party
Posted on 12-Aug-2004 1:07:57
#4 ]
Elite Member
Joined: 8-Jan-2003
Posts: 3270
From: Charlotte, NC

@MikeB

Better late than never... :)

It actually didn't occur to me to bump this up as a news item. Anyway, I think the AVI is very cool... It has me really anxious to get my A1 now....

 Status: Offline
Profile     Report this post  
CyberViking2000 
Re: First AmigaOne/OS4 demo released at Slash Party 5
Posted on 12-Aug-2004 2:33:18
#5 ]
Member
Joined: 8-Mar-2003
Posts: 55
From: Canada

This brings back a feeling I haven't had in a long time. Enjoying watching a demo that was made with pride and optimism.


_________________
Regards,

Vance
a.k.a.
CyberViking2000
-= Northern Light Videography =-

 Status: Offline
Profile     Report this post  
Coder 
Re: First AmigaOne/OS4 demo released at Slash Party 5
Posted on 12-Aug-2004 5:36:52
#6 ]
Team Member
Joined: 15-May-2003
Posts: 4523
From: The Netherlands

It would be nice if we would end up with some more demogroups in the coming months. And provide us some really cool demos.

Coder


_________________
Can't get enough of me?
The Bucket Diary Blog
The Bucket Diary Twitter Account

 Status: Offline
Profile     Report this post  
Toaks 
Re: First AmigaOne/OS4 demo released at Slash Party
Posted on 12-Aug-2004 6:52:24
#7 ]
Elite Member
Joined: 10-Mar-2003
Posts: 8042
From: amigaguru.com

@steve:

@Toaks

---That would be Rebirth wouldn't it?

Correct!


---If so, the plain non "os" and "voodoo" versions do not work for me at all (-----the exe called Rebirth.exe). If I try running it, the CLI pauses for about -----20 seconds, then I am greeted with my CLI prompt again.

You are supposed to be Running "Rebirth.EXE" and no other as your on CGX api (as stated in the Doc)
Voodoo Version is for Mediators !
?And yes u must run from CLI , approx 20 seconds wait befor eit runs yes , remeber you also need to create the screen mode , so make that screen mode ASAP! (320x240x16) -.


---The "os" exe worked, but flickers terribly, as though it doesn't buffer the ----screen properly. It did however look pretty decent ignoring that fact, and -----the music was great especially for 4K.

The OS version is for OS4 and not you , it needs Voodoo card so yes naturally it would not work perfectly on an CVISION.

---For information, I tried running it on:
---A4000 with 604e/233 060/50 with CVPPC gfx card running WarpOS/Warp3D 4.2a, ----112MB Fast, Prelude, HC4+.

You have what this intro was made for (the specs on assembly compo machine was and is IDENTICAL to it,so you shouldnt have a problem at all, just follow my guidelines and you should be ok.


goodluck , let me know if u have a problem still.

cheers


_________________
See my blog and collection website! . https://www.blog.amigaguru.com

 Status: Offline
Profile     Report this post  
Toaks 
Re: First AmigaOne/OS4 demo released at Slash Party
Posted on 12-Aug-2004 6:54:21
#8 ]
Elite Member
Joined: 10-Mar-2003
Posts: 8042
From: amigaguru.com

mikeB: ah, well i just belived that the post entrys would have been much higher if it had been posted as soon as the demo was out, thats all.

anyway it seems some people missed that thread so, great that you posted it as news...

keep on rocking

cheers


_________________
See my blog and collection website! . https://www.blog.amigaguru.com

 Status: Offline
Profile     Report this post  
Agafaster 
Re: First AmigaOne/OS4 demo released at Slash Party
Posted on 12-Aug-2004 11:51:47
#9 ]
Super Member
Joined: 10-Mar-2003
Posts: 1413
From: West Midlands, England - sector ZZ9 plural Z alpha

so... will it work on me radeon 7000 ?
where do I get warp 3d for a1, or will the 68k version do ?


_________________
XH558 - the worlds last flying Vulcan.
ok, its actually XL426 in the picture but you know what I mean.

 Status: Offline
Profile     Report this post  
stimpzilla 
Re: First AmigaOne/OS4 demo released at Slash Party
Posted on 12-Aug-2004 13:10:37
#10 ]
Regular Member
Joined: 20-Nov-2003
Posts: 116
From: W. Midlands, UK

@Agafaster

It ran at about 60fps on my G4@800 with software rendering and a Radeon 7000, so you should be OK.

Stimpzilla
====


_________________
incredibly irritated owner of an A1G4-XE800 that won't even work these days...

 Status: Offline
Profile     Report this post  
_Steve_ 
Re: First AmigaOne/OS4 demo released at Slash Party
Posted on 12-Aug-2004 13:45:27
#11 ]
Team Member
Joined: 18-Oct-2002
Posts: 6770
From: UK

@Toaks:

Ahh, I read the files that came in the archive, but none specified a screensize the demo needed to run. I know the OS/Voodoo versions were not meant for my machine, but they did at least run, unlike the plain "Rebirth.exe" which just left me at the CLI without doing very much.

I do have most screenmodes defined, but I don't believe 320x240 was one of them I think I have 320x200 and 320x256 (ntsc/pal mode sizes) and 384x240 for MAME

I'll have another go tonight when I get home and see if a 320x240 screen makes it run ok.

Edit: I just checked, and I do have 320x240 modes defined for 8, 15/16 and 24 bits, and the exe refuses to work for me. I have tried from a clean boot no-startup, booting into a clean 3.9 install with W3D 3.0 installed and a separate install with W3D 4.2 installed in all 3 cases the Rebirth.exe just delays for 15-20 secs, then gives me the CLI prompt again - unlike the voodoo and OS4 versions which both execute - just not quite as you'd want


_________________
Test sig

 Status: Offline
Profile     Report this post  
Agafaster 
Re: First AmigaOne/OS4 demo released at Slash Party
Posted on 12-Aug-2004 22:00:30
#12 ]
Super Member
Joined: 10-Mar-2003
Posts: 1413
From: West Midlands, England - sector ZZ9 plural Z alpha

@Stimzilla

Cheers me mon !


_________________
XH558 - the worlds last flying Vulcan.
ok, its actually XL426 in the picture but you know what I mean.

 Status: Offline
Profile     Report this post  
Toaks 
Re: First AmigaOne/OS4 demo released at Slash Party
Posted on 13-Aug-2004 0:50:51
#13 ]
Elite Member
Joined: 10-Mar-2003
Posts: 8042
From: amigaguru.com

_steve_: thats really weird, it was made for your machine really!.

make sure you have them activated, other than that not much i can do sadly since i have got like 100 emails about it work and beeing great on their cybervision 3d etc...

so i dont know really, sorry..

and i dont have a cv even and no one in my team has but it was shown with a cv on assembly. so...it works...

Bv and Cv has 24 bit btw since its 16 on voodoo and 15 thats standard on bv/cv. hope that helps!

good luck.......MAKE IT WORK!


_________________
See my blog and collection website! . https://www.blog.amigaguru.com

 Status: Offline
Profile     Report this post  
MikeB 
Re: First AmigaOne/OS4 demo released at Slash Party 5
Posted on 13-Aug-2004 3:25:04
#14 ]
Elite Member
Joined: 3-Mar-2003
Posts: 6487
From: Europe

@ CyberViking2000

Quote:
This brings back a feeling I haven't had in a long time. Enjoying watching a demo that was made with pride and optimism.


Yeah, what a nice first demo! Really upbeat and very encouraging for the platform! Thanks Crisot and the rest of Universe. Looking forward to your future efforts.

 Status: Offline
Profile     Report this post  
_Steve_ 
Re: First AmigaOne/OS4 demo released at Slash Party
Posted on 13-Aug-2004 12:59:55
#15 ]
Team Member
Joined: 18-Oct-2002
Posts: 6770
From: UK

@toaks:

Quote:
make sure you have them activated, other than that not much i can do sadly since i have got like 100 emails about it work and beeing great on their cybervision 3d etc...


They are definitely active I only wish I knew the reason for the BV version not starting on my system.Snoopdos doesn't show anything naturally, and the exe contains no error messages (probably to keep code to <4K ), so I really do not know why it fails to run but the voodoo and OS4 versions do.

I have the screen sizes defined for all modes (8, 15, 16 and 24) for all screenmodes that I use. Each has the same setup just differing bit depths, so that flipping between them doesn't require me adjusting the monitor every time (eg 800x600 at 8 bits has same VFreq, HFreq, Polarity, PixelClk speed as 800x600 at 16 bits)


_________________
Test sig

 Status: Offline
Profile     Report this post  
BigBentheAussie 
Re: First AmigaOne/OS4 demo released at Slash Party
Posted on 14-Aug-2004 6:41:04
#16 ]
Super Member
Joined: 28-Oct-2003
Posts: 1690
From: Melbourne, Australia

Goodness..... I was amazed at the demo. The first next gen Amiga demo, and it wasn't even 3d accellerated I understand. Wow!!!! I haven't watched a PC demo in many many years so I guess I can't determine how it rates.

Gives me the warm and fuzzies big time though. These demo people are amazing and the demo culture for OS4 hasn't even started.

I dunno, but this thing blew my mind. I watched it about 3 times in a row to take it all in.

I guess it can all be done on a PC technically, but while I was watching the AVI I was transported to the days of yesteryear, when I sat on my Amiga and watched these incredible demos all freakin day. Awesome.

We need stuff like this running on the new Amigas in the shops. Hell, we need AmigaOS4 to display a sequence of demos like this as a screensaver!!!!!

I'm starting to believe the Amiga is back.


_________________
Leo Nigro, CTO Commodore USA, LLC
Opinions expressed are my own and not those of C= USA.
Commodore/AMIGA "Beautiful, High-Performance, Home Computers for Creativity and Entertainment."

 Status: Offline
Profile     Report this post  
[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle