Click Here
home features news forums classifieds faqs links search
5773 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
55 crawler(s) on-line.
 12 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 Derfs:  26 mins ago
 utukku:  29 mins ago
 BSzili:  1 hr 43 mins ago
 Argo:  2 hrs 2 mins ago
 Kraftwerk2:  3 hrs 22 mins ago
 tygre:  4 hrs 2 mins ago
 Randune:  4 hrs 5 mins ago
 freak:  4 hrs 7 mins ago
 DiscreetFX:  5 hrs ago
 Rob:  6 hrs 3 mins ago

Software News   Software News : OS4 E-UAE 0.8.29-WIP1 released
   posted by fishy_fis on 1-May-2006 15:16:09 (5509 reads)
Richard Drummonds UAE variant has been updated and relased for Amiga OS4.



Direct link to download.

A full changelog is available as is a small readme.
    

Related Links
· More about Software News
· News by fishy_fis


Most read story about Software News
UBoot 2010.06.04 for Sam460ex available

Last news about Software News
IBrowse 2.5 Released
Printer Friendly Page  Send this Story to a Friend

Goto page ( 1 | 2 | 3 )

PosterThread
T_Power 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 15:58:09
#1 ]
Regular Member
Joined: 8-Sep-2003
Posts: 359
From: Durban, South Africa

Thanks.

Busy downLoading now.
Hope to enjoy the speed-up you spoke about in the SDL thread.

Cheers,
Tim

Last edited by T_Power on 01-May-2006 at 04:01 PM.

 Status: Offline
Profile     Report this post  
Rob 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 16:15:25
#2 ]
Elite Member
Joined: 20-Mar-2003
Posts: 5849
From: S.Wales

I'll check this out later on.

 Status: Offline
Profile     Report this post  
zErec 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 16:32:27
#3 ]
Cult Member
Joined: 17-Dec-2003
Posts: 512
From: Germany

@ thread

Thank you evilrich for your continued support!!!
I love the os4 version of e-uae since its the only solution (and a really
good one) to support hardware banging legacy software on modern Amiga.

Hope 2 see openGL filters and drive click sounds (for the nostalgic ones)
soon. I would like to see some speedups by integrationg the petunia jit
The author stated it should be posible and he would like to help such project.

greetings
zErec

PS. Downloading the new release right now...


_________________
- AmigaX1Ooo with OS4.1FE // CD32/SX32Pro/SX1/CD32Shuttle
- A600-Vampire600 FPGA // A4KT/CSPPC233,144MB,PCI, AOS4.1.6FE
- MACmini 1.5GHz // Pegasos 2 1GHz // Efika
- ATARI Falcon/060/SuperVidel // ATARI Falcon MK X

 Status: Offline
Profile     Report this post  
Kicko 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 17:27:27
#4 ]
Elite Member
Joined: 19-Jun-2004
Posts: 5009
From: Sweden

Thanks for the update Evilrich :) Just installed it. Now next thing is to try it out :) I wish the X-UAE for xbox will have RTG support in future.

 Status: Offline
Profile     Report this post  
redfox 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 17:28:18
#5 ]
Super Member
Joined: 7-Mar-2003
Posts: 1709
From: Canada

Thanks Richard.

Download in progress.

---
redfox

 Status: Offline
Profile     Report this post  
Rudei 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 17:43:22
#6 ]
Elite Member
Joined: 20-Nov-2002
Posts: 3580
From: Dallas, Texas

Cheers Rich!

Rude!


_________________
Nissan GTR '08

 Status: Offline
Profile     Report this post  
evilrich 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 17:44:00
#7 ]
Cult Member
Joined: 19-Oct-2003
Posts: 534
From: Unknown

@T_Power

Quote:
Hope to enjoy the speed-up you spoke about in the SDL thread.

You should notice that the emulated Amiga display (not the emulated P96 display) is much faster in full-screen mode.

@thread
Please report any problems to me or to the E-UAE mailing list. (You can find a link to that on the E-UAE web page. There seems to be few OS4.0 users subscribed at the moment.)

Cheers,
Rich

 Status: Offline
Profile     Report this post  
Anonymous 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 18:00:30
# ]



@evilrich

Quote:
There seems to be few OS4.0 users subscribed at the moment.)

heh, i am...

...and you got a mail...

sadly, it crashes when WB is loded in (AIAB and AmiSYS2), must be some proggy
causing it, WB31 and 39 are fine, mmm ... crap (not your release, of course)

 
     Report this post  
amipal 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 18:20:17
#9 ]
Super Member
Joined: 8-Apr-2003
Posts: 1898
From: Saltdean, East Sussex, UK

Downloading now! Thanks evilrich!


_________________
After a decade away from the scene, I am back!

 Status: Offline
Profile     Report this post  
evilrich 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 19:19:45
#10 ]
Cult Member
Joined: 19-Oct-2003
Posts: 534
From: Unknown

Hi Raziel

Quote:
sadly, it crashes when WB is loded in (AIAB and AmiSYS2), must be some proggy
causing it, WB31 and 39 are fine, mmm ... crap (not your release, of course)

Thanks for the crashlog. I'll investigate.

Cheers,
Rich

 Status: Offline
Profile     Report this post  
cap 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 20:09:19
#11 ]
Regular Member
Joined: 30-Jan-2003
Posts: 284
From: Melton Mowbray - Porkpie centre.

Thanks Rich. Excellent.

I tried Cannon Fodder and Deluxe Galaga-Spot on.
Like playing on the original hardware.

Mark


_________________
A1/G4 1GHZ

OS4.1 latest update.
1ghz Radeon Club3d 9250
Usb/Dma fixed.

 Status: Offline
Profile     Report this post  
Agafaster 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 20:39:37
#12 ]
Super Member
Joined: 10-Mar-2003
Posts: 1413
From: West Midlands, England - sector ZZ9 plural Z alpha

eee thats gradely that is ! d/l'ing as we speak...


_________________
XH558 - the worlds last flying Vulcan.
ok, its actually XL426 in the picture but you know what I mean.

 Status: Offline
Profile     Report this post  
Tuxedo 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 20:58:45
#13 ]
Elite Member
Joined: 28-Nov-2003
Posts: 2323
From: Perugia, ITALY

REALLY GOOD NEWS!

Tuxedo.


_________________
Simone"Tuxedo"Monsignori, Perugia, ITALY.

 Status: Offline
Profile     Report this post  
nubechecorre 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 21:52:15
#14 ]
Cult Member
Joined: 21-Nov-2003
Posts: 890
From: San remo -Italy-

Great News !

But every version that i tried, gives me problem with the audio.. the audio has a gap while playing or during the intro..

Is there an audio option that i missed ?.. Here is my config file :

# UAE Configuration File
# Created with UAE Config for OS4
# By Scott A. Cabit
#
joyport0=mouse
joyport1=kbd2
cpu_type=68020
chipset=AGA
cpu_speed=max
cpu_compatible=yes
cpu_24bit_addressing=yes
chipmem_size=4
sound_frequency=44100
sound_bits=16
sound_output=normal
amiga.publicscreen=ask
floppy_speed=800


_________________
GDG-Entertainment
OS4Games
Iksnet
Bitplane

 Status: Offline
Profile     Report this post  
GrumpyOldMan 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 21:59:50
#15 ]
Cult Member
Joined: 3-Nov-2003
Posts: 675
From: Haukipudas, Finland

@evilrich

Many thanks for this new release!


_________________
"Those are my principles, and if you don't like them... well, I have others." (Groucho Marx)

 Status: Offline
Profile     Report this post  
evilrich 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 22:02:23
#16 ]
Cult Member
Joined: 19-Oct-2003
Posts: 534
From: Unknown

Hi Scott

Quote:
the audio has a gap while playing or during the intro..


What are running with this config file? If it's an AGA game, then you may find that even this version isn't up to full-speed emulation at 640x480.

Try:

1) Reducing the audio frequency:
sound_frequency=22050

2) If running 640x480, use 'scanlines' line-doubling rather than 'double':
gfx_linemode=scanlines

3) Running in a 16-bit screen. (With the SDL version this can only be done by making your OS4.0 Workbench screen 16-bit. This will be fixed shortly.)

4) Skipping every other output frame:
gfx_framerate=2

5) Reducing display size:
gfx_lores=true
gfx_linemode=none
gfx_width_windowed=320
gfx_height_windowed=240
gfx_center_horizontal=smart
gfx_center_vertical=smart


If you're not trying to play an AGA game, then don't set chipset=aga.

Cheers,
Rich

 Status: Offline
Profile     Report this post  
evilrich 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 22:03:54
#17 ]
Cult Member
Joined: 19-Oct-2003
Posts: 534
From: Unknown

Quote:
floppy_speed=800

This will also slow things down (due to higher overhead of doing 8x disk speed emulation).

Cheers,
Rich

 Status: Offline
Profile     Report this post  
nubechecorre 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 22:27:07
#18 ]
Cult Member
Joined: 21-Nov-2003
Posts: 890
From: San remo -Italy-

Yes it's an aga game and i tried to use a screenmode instead a window mode ( SDL version and non-SDL version ) but i also have problem with the audio.. now i'll try as you said..

My amiga is a micro amiga one G3 800 Mhz..


_________________
GDG-Entertainment
OS4Games
Iksnet
Bitplane

 Status: Offline
Profile     Report this post  
evilrich 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 1-May-2006 22:41:25
#19 ]
Cult Member
Joined: 19-Oct-2003
Posts: 534
From: Unknown

Quote:
Yes it's an aga game and i tried to use a screenmode instead a window mode ( SDL version and non-SDL version ) but i also have problem with the audio.. now i'll try as you said.

There's no non-SDL version of this new, interim release. But the this 0.8.29-WIP1 SDL version should be faster (in full-screen mode) than the old non-SDL version. (There will eventually be a new non-SDL version and as I have said before the SDL version will eventually be dropped. Sorry for any confusion caused in the meantime.)

Some AGA software works fine here at 640x480 (such as the CD32 version of SuperFrog). Some others work less well (e.g. Marvin's Marvelous Adventure) and you may need to adjust your configuration (as I mentioned above) to get full speed.

Cheers,
Rich

 Status: Offline
Profile     Report this post  
firbodi 
Re: OS4 E-UAE 0.8.29-WIP1 released
Posted on 2-May-2006 3:45:24
#20 ]
Super Member
Joined: 2-Sep-2003
Posts: 1046
From: Planet Earth!

Hi there,

This is really weird! The previous version did'nt work here (A1-SE). I thought this might work, but still no luck.

The errors that I get (for both the lates version and .28 SDL) are random:

- Can't open GUI.
- Hard crash when building the CPU table.
- error in line 189 of file ../../newcpu.c

I have no idea what may cause this!

Here is my .uaerc:

# Example UAE configuration
#
# Lines beginning with a '#' are comments

# Path to file containing Kickstart ROM image
kickstart_rom_file=Work:Programs/E-UAE_0.8.28_SDL/Roms/Kick31.rom

# If you have an encrypted ROM image from Amiga forever,
# this is a path to the key file
# kickstart_key_file=rom.key

# Show status LEDs on emulator screen
show_leds=true

# Floppy image in drive 0
# floppy0=Work:Programs/E-UAE_0.8.28_SDL/AmigaDisks/SystemDisks/wb31.adf
# Floppy image in drive 1
# floppy1=

# Joystick port emulation
# joyport0=mouse
joyport1=kbd1

# CPU type to emulate
cpu_type=68020
# CPU emulation speed
# real = approx A500 speed. max = CPU emulation will run as fast as it can
#cpu_speed=real
cpu_speed=max

# Amiga chipset to emulate
# Can be ocs, ecs or aga
#chipset=ecs
chipset=aga

# Amount of chip memory to emulate
# in multiples of 512K. Thus chipmem=4 is 2MB
chipmem_size=4

# Amount of fast memory to emulate in MB
#fastmem_size=32
z3mem_size=32

# Amount of graphic card memory
gfxcard_size=16

# Sound output
# none=no ouput
sound_output=normal
sound_channels=mono

# Frequency of emulated sound output in Hz
sound_frequency=22050
sound_bits=8
# Prompt for screen mode to use
#amiga.screen_type=ask

# Don't dither
#amiga.use_dither=false

gfx_fullscreen_amiga=false
gfx_framerate=2
#gfx_fullscreen_picasso=true

scsi=true

#filesystem=ro,Test:Work:Data/
#filesystem2=ro,CD99:CDROM:Ram:cdrom,0
filesystem2=rw,hd0:Workbench:Work:Data/Emulation/Workbench,0
filesystem2=rw,hd1:Work:Work:Data/Emulation/Work,0
#filesystem2=ro,cd99:AmigaOS3.9:Work:Data/Emulation/AmigaOS3.9,0


Any ideas?

Thanks,
Firbodi


_________________
MicroA1 G3, 512MB RAM, DVD-RW; and A1-SE G3,512MB RAM, CD-RW & DVD-ROM
Avatar: Perspolis, Capital of Achaemenid Empire 500 B.C.

 Status: Offline
Profile     Report this post  

Goto page ( 1 | 2 | 3 )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle