Click Here
home features news forums classifieds faqs links search
5778 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
18 crawler(s) on-line.
 22 guest(s) on-line.
 1 member(s) on-line.


 Plexus

You are an anonymous user.
Register Now!
 Plexus:  1 min ago
 Seaquest:  12 mins ago
 lionstorm:  15 mins ago
 Brian:  16 mins ago
 billt:  19 mins ago
 kamelito:  21 mins ago
 zipper:  28 mins ago
 towo2099:  41 mins ago
 Comi:  42 mins ago
 ROMwack:  43 mins ago

Software News   Software News : E-UAE-0.8.29-WIP3 released
   posted by GrumpyOldMan on 1-Aug-2006 21:57:15 (5731 reads)
Richard Drummond has released a new WIP release of the great E-UAE. Check out the details and download the emulator from

E-UAE
    

Related Links
· More about Software News
· News by GrumpyOldMan


Most read story about Software News
UBoot 2010.06.04 for Sam460ex available

Last news about Software News
IBrowse 2.5 Released
Printer Friendly Page  Send this Story to a Friend

PosterThread
spotUP 
Re: E-UAE-0.8.29-WIP3 released
Posted on 2-Aug-2006 0:20:27
#1 ]
Elite Member
Joined: 19-Aug-2003
Posts: 2896
From: Up Rough Demo Squad

cool!


_________________
AOS4 Betatester, Peg2, G4@1ghz, Radeon 9250 256mb, 1gb RAM.

http://www.asciiarena.com
http://www.uprough.net

 Status: Offline
Profile     Report this post  
jahc 
Re: E-UAE-0.8.29-WIP3 released
Posted on 2-Aug-2006 2:01:52
#2 ]
Elite Member
Joined: 30-May-2003
Posts: 2959
From: Auckland, New Zealand

I just sent a bug report to evilrich:

Quote:

I get a crash when I exit e-uae but only when I use a hard file..

If I comment out my hardfile line, it works fine!

the offending line from my .uaerc config:
#hardfile2=rw,:uaehd:/gcc_working.hdf,32,1,2,512,1,

I wonder if its crashing because of incorrect values. The hard drive file
does work though when reading/writing to it.


Apart from that though, hard drive access through "filesystem" hard drives is ALOT quicker now. OS3.9 boots at near the same speed as it does on my PC. Good stuff!

 Status: Offline
Profile     Report this post  
saimo 
Re: E-UAE-0.8.29-WIP3 released
Posted on 2-Aug-2006 14:08:17
#3 ]
Elite Member
Joined: 11-Mar-2003
Posts: 2271
From: Unknown

Just gave it a very quick spin trying a couple of games, AOS 3.9 and a classic application... they all worked nicely .
, Richard!

saimo

 Status: Offline
Profile     Report this post  
JurassicC 
Re: E-UAE-0.8.29-WIP3 released
Posted on 2-Aug-2006 14:25:24
#4 ]
Super Member
Joined: 13-Mar-2003
Posts: 1433
From: Somerset, UK

looking forward to giving it a whirl after work


_________________
A1200T 603e 330Mhz - Mediator TX OS4.1 F.E.
CDTV 8MB Fast, OS3.1, SCSI, MicroSD SCSI & CD32 FMV
X5000, X1000, A1XE with OS4.1F.E.

 Status: Offline
Profile     Report this post  
amipal 
Re: E-UAE-0.8.29-WIP3 released
Posted on 2-Aug-2006 21:45:46
#5 ]
Super Member
Joined: 8-Apr-2003
Posts: 1899
From: Saltdean, East Sussex, UK

This is the first thing I will download as soon as I get near my AmigaOne!

Thanks as always for your continued work on this EvilRich!


_________________
After a decade away from the scene, I am back!

 Status: Offline
Profile     Report this post  
redfox 
Re: E-UAE-0.8.29-WIP3 released
Posted on 3-Aug-2006 1:37:41
#6 ]
Super Member
Joined: 7-Mar-2003
Posts: 1709
From: Canada

Thanks Richard.

---
redfox

 Status: Offline
Profile     Report this post  
evilrich 
Re: E-UAE-0.8.29-WIP3 released
Posted on 3-Aug-2006 4:35:22
#7 ]
Cult Member
Joined: 19-Oct-2003
Posts: 534
From: Unknown

@thread

Thanks for the positive comments.

Beware there does seem to be a problem with the current m68k build (in particular, with the 68020+ emulation), and I'm working to fix that.

I still haven't uploaded MorphOS or AROS builds yet. I'll try and get these up as soon as I can. Please be patient if you're waiting for those.

Keep the bug reports coming...

Cheers,
Rich

 Status: Offline
Profile     Report this post  
shoe 
Re: E-UAE-0.8.29-WIP3 released
Posted on 3-Aug-2006 7:31:15
#8 ]
Super Member
Joined: 14-Sep-2003
Posts: 1585
From: Gothenburg, Sweden

Wonderful! Thanks for the update.


--www.amigasummerparty.se
/shoe

 Status: Offline
Profile     Report this post  
royleith 
Re: E-UAE-0.8.29-WIP3 released
Posted on 3-Aug-2006 9:28:17
#9 ]
Cult Member
Joined: 31-Jul-2003
Posts: 765
From: UK

@ jahc

I agree. EUAE disk operations have gone from too slow to bear to making EUAE really worthwhile. I will make the journey to the Paypal button in the near future. Congrats, EvilRich.

I tried several ways on several OSs to make a hardfile to overcome the slowness of the directory based emulation, but failed. I would still like to try a variable sized version. Can you tell me how you created your hardfiles?

Regards
Roy Leith

 Status: Offline
Profile     Report this post  
JurassicC 
Re: E-UAE-0.8.29-WIP3 released
Posted on 3-Aug-2006 14:05:53
#10 ]
Super Member
Joined: 13-Mar-2003
Posts: 1433
From: Somerset, UK

Makes for a fantastic CD32 Emulator.
Getting full speed on the games I have tried.
Guardian seem faster in E-UAE than on the Real McCoy

Found a little problem I'll drop you a mail about it.


_________________
A1200T 603e 330Mhz - Mediator TX OS4.1 F.E.
CDTV 8MB Fast, OS3.1, SCSI, MicroSD SCSI & CD32 FMV
X5000, X1000, A1XE with OS4.1F.E.

 Status: Offline
Profile     Report this post  
nubechecorre 
Re: E-UAE-0.8.29-WIP3 released
Posted on 3-Aug-2006 21:04:16
#11 ]
Cult Member
Joined: 21-Nov-2003
Posts: 890
From: San remo -Italy-

mmm... Could someone send me a good configuration file in order to be able to play with the amiga aga games and amiga ecs game ?...

They run with audio problems or they run slow...

My config is micro amiga one, 512 Mbram, radeon 7000 and soundblaster audigy

Thanks


_________________
GDG-Entertainment
OS4Games
Iksnet
Bitplane

 Status: Offline
Profile     Report this post  
JurassicC 
Re: E-UAE-0.8.29-WIP3 released
Posted on 4-Aug-2006 8:10:44
#12 ]
Super Member
Joined: 13-Mar-2003
Posts: 1433
From: Somerset, UK

Create a 400x300 mode screen in Picasso96 Prefs.
As most games are 320x256 running UAE in a larger screen eg 800x600 is just a waste.

I find disabling DMA on the CDROM drive makes loading CD32 games faster.

Here is my CD32 Config using the ROMs from AF2005

--snip--
kickstart_key_file=UAE:rom/rom.key
kickstart_rom_file=UAE:rom/amiga-os-310-cd32.rom
kickstart_ext_rom_file=UAE:rom/amiga-ext-310-cd32.rom

joyport0=mouse
joyport1=joy0

floppy0type=none
floppy1type=none

scsi=true

cpu_type=68020
chipset=aga
cpu_speed=max
cpu_compatible=no
cpu_24bit_addressing=no

show_leds=true

chipmem_size=4
fastmem_size=0

amiga.screen_type=custom
gfx_width_windowed=400
gfx_height_windowed=300
gfx_lores=true
gfx_linemode=none
gfx_center_horizontal=true
gfx_center_vertical=true
--snip--

A1200 4 floppy drives No HD or CDROM

--snip--
kickstart_key_file=UAE:rom/rom.key
kickstart_rom_file=UAE:rom/amiga-os-300.rom

amiga.floppy_path=UAE:games-adf

floppy0type=0
floppy1type=0
floppy2type=0
floppy3type=0

joyport0=mouse
joyport1=joy0

cpu_type=68020
chipset=aga
cpu_speed=max
cpu_compatible=no
cpu_24bit_addressing=no
show_leds=true
chipmem_size=4
fastmem_size=0

amiga.screen_type=custom
gfx_width_windowed=400
gfx_height_windowed=300
gfx_lores=true
gfx_linemode=none
gfx_center_horizontal=true
gfx_center_vertical=true
--snip--

My 500 config

--snip--
kickstart_key_file=UAE:rom/rom.key
kickstart_rom_file=UAE:rom/amiga-os-130.rom

amiga.floppy_path=UAE:games-adf

floppy0type=0
floppy1type=0
floppy2type=0
floppy3type=0

joyport0=mouse
joyport1=joy0

cpu_type=68000
chipset=ocs
cpu_speed=real
cpu_compatible=no
cpu_24bit_addressing=no
show_leds=true
chipmem_size=1
fastmem_size=1

amiga.screen_type=custom
gfx_width_windowed=400
gfx_height_windowed=300
gfx_lores=true
gfx_linemode=none
gfx_center_horizontal=true
gfx_center_vertical=true
--snip--

Last edited by JurassicC on 04-Aug-2006 at 08:13 AM.


_________________
A1200T 603e 330Mhz - Mediator TX OS4.1 F.E.
CDTV 8MB Fast, OS3.1, SCSI, MicroSD SCSI & CD32 FMV
X5000, X1000, A1XE with OS4.1F.E.

 Status: Offline
Profile     Report this post  
nubechecorre 
Re: E-UAE-0.8.29-WIP3 released
Posted on 4-Aug-2006 11:13:56
#13 ]
Cult Member
Joined: 21-Nov-2003
Posts: 890
From: San remo -Italy-

Thanx

For the audio settings how do you set it ?


_________________
GDG-Entertainment
OS4Games
Iksnet
Bitplane

 Status: Offline
Profile     Report this post  
Crumb 
Re: E-UAE-0.8.29-WIP3 released
Posted on 4-Aug-2006 11:44:12
#14 ]
Elite Member
Joined: 12-Mar-2003
Posts: 2208
From: Zaragoza (Aragonian State)

@JurassicC

Quote:
Create a 400x300 mode screen in Picasso96 Prefs.
As most games are 320x256 running UAE in a larger screen eg 800x600 is just a waste.


Why don't create a 320x256 mode then? You can create also 640x512, 640x256 and other typical Amiga screenmodes


_________________
The only spanish amiga news web page/club: CUAZ

 Status: Offline
Profile     Report this post  
salass00 
Re: E-UAE-0.8.29-WIP3 released
Posted on 4-Aug-2006 12:53:38
#15 ]
Elite Member
Joined: 31-Oct-2003
Posts: 2701
From: Finland

@Crumb

Some monitors can't do 320x256 very well. F.e. my 19" Samsung LCD (native res: 1280x1024) doesn't. The CRT I'm using now handles it well enough though (also Samsung). Speedwise there isn't much (if any) difference between 400x300 and 320x256 though, and you won't have any room for onscreen leds in a 320x256 screenmode...

 Status: Offline
Profile     Report this post  
JurassicC 
Re: E-UAE-0.8.29-WIP3 released
Posted on 4-Aug-2006 13:54:16
#16 ]
Super Member
Joined: 13-Mar-2003
Posts: 1433
From: Somerset, UK

@Crumb

You could do but i guess but 400x300 gives you get the LED's accross the bottom that way.
My LG TFT won't do 320x256 belive me i've tried.

@nubechecorre

I just use the settings E-UAE defaults to.
If your getting clipping it might be your AHI prefs or because your using to big a screen or running in a window.

Last edited by JurassicC on 04-Aug-2006 at 01:57 PM.


_________________
A1200T 603e 330Mhz - Mediator TX OS4.1 F.E.
CDTV 8MB Fast, OS3.1, SCSI, MicroSD SCSI & CD32 FMV
X5000, X1000, A1XE with OS4.1F.E.

 Status: Offline
Profile     Report this post  
Haymigga 
Re: E-UAE-0.8.29-WIP3 released
Posted on 4-Aug-2006 20:25:43
#17 ]
Regular Member
Joined: 14-Jun-2003
Posts: 213
From: Danmark

excellent, already installed....


_________________
0 % Amiga.
www.amigabounty.net

 Status: Offline
Profile     Report this post  
nubechecorre 
Re: E-UAE-0.8.29-WIP3 released
Posted on 4-Aug-2006 20:47:54
#18 ]
Cult Member
Joined: 21-Nov-2003
Posts: 890
From: San remo -Italy-

Ok thanks for your help.. i will try it as soon as i can

Last question how do you set AHI prefs ?


_________________
GDG-Entertainment
OS4Games
Iksnet
Bitplane

 Status: Offline
Profile     Report this post  
Snuffy 
Re: E-UAE-0.8.29-WIP3 released
Posted on 5-Aug-2006 18:38:19
#19 ]
Super Member
Joined: 25-Oct-2005
Posts: 1121
From: Michigan, USA

Thanks! :)

Umm, in WIP#2, I didn't have the 'verbose' window. Is there a way to turn
off all the text output?


_________________

 Status: Offline
Profile     Report this post  
[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle