Click Here
home features news forums classifieds faqs links search
6029 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
» Home
» Features
» News
» Forums
» Classifieds
» Links
» Downloads
Extras
» OS4 Zone
» IRC Network
» AmigaWorld Radio
» Newsfeed
» Top Members
» Amiga Dealers
Information
» About Us
» FAQs
» Advertise
» Polls
» Terms of Service
» Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
20 crawler(s) on-line.
 14 guest(s) on-line.
 2 member(s) on-line.


 zipper,  miggymac

You are an anonymous user.
Register Now!
 zipper:  24 secs ago
 miggymac:  2 mins ago
 mbrantley:  6 mins ago
 pavlor:  8 mins ago
 Karlos:  23 mins ago
 Rob:  23 mins ago
 MickJT:  59 mins ago
 MEGA_RJ_MICAL:  1 hr 13 mins ago
 fishy_fis:  1 hr 21 mins ago
 Evans68:  2 hrs 22 mins ago

Software News   Software News : New 51.54 IDE/SATA driver pack on os4depot
   posted by sg2 on 1-Apr-2006 16:03:19 (3494 reads)
http://os4depot.net/?function=comments&file=driver/storage/ide_driverpack.zip

This 51.54 driver set is to be installed over an OS4 update 4 system (with or
without the 51.51 driver pack pre-installed).


These drivers address a couple of issues which arose after the OS4 update 4 release, which were not completely fixed in the 51.51 pack:
- the "strange pause" problem with sii0680 was not fully fixed
- a minor bug in IDETool (would not "-r" or "-d" some CD/DVD drives)

Just copy the files from "Kickstart/" to the directory where you store your kickstart modules (usually "SYS:Kickstart/"), and cold reboot.

If you have found the alien easter egg driver, and want to try it, do not forget to add it to your kicklayout, and to read the corresponding doc (you may have to set an uboot envvar to have your board recognized).

If you want to purchase a supported board, please head up to the hardware sponsors who supplied the boards used to develop those drivers:
www.soft3.net
or
www.gurumeditation.se

Enjoy !-)

Disclaimer:
This informal interim release has been considered opportunate by the author since the OS4 components concerned are somehow critical.

This release is made on the author's goodwill basis.
It is not to be considered as official Hyperion Entertainment software.
Use at your own risk ; do not use if you do not want to.
Do not waste your time spilling comments everywhere about this "illegitimate nonprofessional release process", especially if you do not use AmigaOS4. Same would go for the use of a ZIP archive, which works perfectly on OS4.

Kind regards,
--
Stéphane Guillard
    

STORYID: 2994
Related Links
· More about Software News
· News by sg2


Most read story about Software News
UBoot 2010.06.04 for Sam460ex available

Last news about Software News
Hollywood APK Compiler 4.0 released
Printer Friendly Page  Send this Story to a Friend

Goto page ( 1 | 2 )

PosterThread
Matt 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 1-Apr-2006 18:33:51
#1 ]
Regular Member
Joined: 16-Nov-2003
Posts: 467
From: Sherborne, UK

Thanks for your continued efforts Stephane.


_________________


AmigaOne XE-G4, 512MB RAM (AmigaOS 4.1)
Radeon 9250, Terratec Aureon 5.1
CDRW, DVDRW, SII0680

 Status: Offline
Profile     Report this post  
Moxee 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 1-Apr-2006 18:42:15
#2 ]
Team Member
Joined: 20-Aug-2003
Posts: 6291
From: County Yakima, WA State, USA

I will not complain! I will only thank you, thank you, thank you.

_____________________
Moxee


_________________
Moxee
AmigaOne X1000
AmigaOne XE G4
I'd agree with you, but then we'd both be wrong.

 Status: Offline
Profile     Report this post  
lylehaze 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 1-Apr-2006 18:45:31
#3 ]
Super Member
Joined: 1-Sep-2004
Posts: 1132
From: North Florida - Big Bend area.

Thank you very much for being willing to support
the community, and to go "Above and Beyond" to
keep things working well.

Would you suggest that I install this if I haven't
noticed any problems? I'm running a micro with
the builtin IDE using FFS.

Thanks again,
LyleHaze


_________________
question=(2b||!(2b))

 Status: Offline
Profile     Report this post  
AmigaClyde 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 1-Apr-2006 18:46:40
#4 ]
Elite Member
Joined: 8-Mar-2003
Posts: 2007
From: Noranda Canada

Thanks for the update. Excellent work.


_________________
---------
AmigaClyde

µA1-C 750GX@800 using OS4.1

 Status: Offline
Profile     Report this post  
CodeSmith 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 1-Apr-2006 18:50:25
#5 ]
Elite Member
Joined: 8-Mar-2003
Posts: 3045
From: USA

Thank you for the update! I'll be installing it shortly, looking forward to it

 Status: Offline
Profile     Report this post  
ikir 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 1-Apr-2006 18:57:36
#6 ]
Elite Member
Joined: 18-Dec-2002
Posts: 5647
From: Italy

Thanks Stéphane


_________________
ikir

 Status: Offline
Profile     Report this post  
AmigaPapst 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 1-Apr-2006 19:56:11
#7 ]
Cult Member
Joined: 2-Nov-2003
Posts: 628
From: Amigavatikan

Thank you for that update.


_________________
AmigaOne X1000 1,8 Ghz/2 GB Ram + Radeon 6670 2 GB + AmigaOS4.1
A4000T CyberstormPPC 604e-200Mhz/060/128MB+CybervisionPPC 8MB + AmigaOS4
and anymore other Amigas...

 Status: Offline
Profile     Report this post  
AmigaPapst 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 1-Apr-2006 19:56:11
#8 ]
Cult Member
Joined: 2-Nov-2003
Posts: 628
From: Amigavatikan

Thank you for that update.


_________________
AmigaOne X1000 1,8 Ghz/2 GB Ram + Radeon 6670 2 GB + AmigaOS4.1
A4000T CyberstormPPC 604e-200Mhz/060/128MB+CybervisionPPC 8MB + AmigaOS4
and anymore other Amigas...

 Status: Offline
Profile     Report this post  
Kicko 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 1-Apr-2006 21:43:15
#9 ]
Elite Member
Joined: 19-Jun-2004
Posts: 5009
From: Sweden

kisses from me

 Status: Offline
Profile     Report this post  
redfox 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 1-Apr-2006 23:22:42
#10 ]
Super Member
Joined: 7-Mar-2003
Posts: 1927
From: Canada

Thanks very much for your continued support Stéphane. Downloaded and implimented.


redfox
µA1-C (750 GX)

 Status: Offline
Profile     Report this post  
Tomppeli 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 1-Apr-2006 23:39:41
#11 ]
Super Member
Joined: 18-Jun-2004
Posts: 1645
From: Home land of Santa, sauna, sisu and salmiakki


_________________
Rock lobster bit me, so excuse me. My Workbench has always preferences. X1000 + AmigaOS4.1 FE
"Anyone can build a fast CPU. The trick is to build a fast system." -Seymour Cray

 Status: Offline
Profile     Report this post  
Samwel 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 2-Apr-2006 8:33:40
#12 ]
Elite Member
Joined: 7-Apr-2004
Posts: 3404
From: Sweden

Thanks. Not that I have had any problems with your previous releases
but it's always nice to have updates.


_________________
/Harry

[SOLD] µA1-C - 750GX 800MHz - 512MB - Antec Aria case

Avatar by HNL_DK!

 Status: Offline
Profile     Report this post  
Samwel 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 2-Apr-2006 8:39:03
#13 ]
Elite Member
Joined: 7-Apr-2004
Posts: 3404
From: Sweden

Btw did anyone notice that the SCSI driver is also in the package?
And also that the files are A LOT smaller.


_________________
/Harry

[SOLD] µA1-C - 750GX 800MHz - 512MB - Antec Aria case

Avatar by HNL_DK!

 Status: Offline
Profile     Report this post  
GuruMeditation 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 2-Apr-2006 17:00:58
#14 ]
Regular Member
Joined: 6-Apr-2004
Posts: 281
From: Gothenburg, Sweden

Not too many seems to have made a note about the SCSI drivers, no :)

This ought to make some people happy, since migrating data over from your scsi disks in the classic will be so much easier now. Quite a few amigans also has other scsi units, which now has a chance of working in their A1's, should they want that.


_________________
It is not the critic who counts: not the man who points out how the strong man stumbles or where the doer of deeds could have done better. The credit belongs to the man who is actually in the arena." Theodore Roosevelt, speech in Paris, 1910

 Status: Offline
Profile     Report this post  
BCP 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 3-Apr-2006 1:28:41
#15 ]
Regular Member
Joined: 30-Mar-2003
Posts: 184
From: Indianapolis, IN USA

@ GuruMeditation & Sg2

I'm delighted to see the Scsi driver included, however I've so far not been able to get it to work. I have an ASUS PCI-SC875 (with SYM53c875 controller) which I am trying to use with a SyQuest 230 scsi drive. I've tried to follow the instructions as best as I can, however the instructions for changing the UBoot environs are much less than adequate for me at least. When booting the Syqest drive is recognized by UBoot, but is not seen by Workbench. I've changed the toolype for Media Toolbox and Mounter to lsi53c8xx.device which I assume is necessary. At this point I have no idea what else needs to be done.
Any help would be greatly appreciated.

Thanks,

BCP
Amiga Response Crew Users Group
Indianapolis, IN USA


_________________
- BCP
AmigaOne X1000 & Amiga 4000

Amiga Response Crew Users Group
Indianapolis, IN USA

 Status: Offline
Profile     Report this post  
sg2 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 3-Apr-2006 9:46:50
#16 ]
Regular Member
Joined: 16-Jun-2004
Posts: 223
From: Lyon, France

Hi,

The general theory behind the UBoot envvar is this :

- every PCI chip has an unique PCI vendor / product ID pair (a couple of 16 bit values).

- the SCSI code embedded in UBoot should work with any chip of the 53c8xx family

- the SCSI code embedded in UBoot only searches for a chip with vendor 0x1000 : product 0x000F

- there are chances that your board's product ID is different from 0x000F. Typically, my board's 83C895 has a product ID which is 0x000C

- the way to force UBoot to use the right product ID when it is not the default 0x000F, is to set the "scsi_pci_override" UBoot environment variable to the right product ID. This var holds an ASCII (text) case-insensitive 4 char string which represents the hexadecimal product ID value, without the leading C-conventional "0x". Example : in my case it will hold the string "000C" or "000c".

- if the product ID envvar is properly set (or not if your board has the default value 0x000F), then UBoot should detect your board properly, and list the devices found during the SCSI scan process (with a couple of problems that I will address later, namely UBoot assumes that everything is a harddisk or a CD drive, which tends to hang some non block devices like scanners).

- I chose to make my driver use the same UBoot envvar to define the PCI product ID to search for, in order to save the need for another variable to set, basing on the principle "if UBoot sees your board/drives, then my driver will too".

If the drive is seen by UBoot then the UBoot envvar is properly set. My driver should see it too.

This driver has been successfully tested by Ferran with :
- Iomega ZIP100 drive (Ferran)
- Epson GT7000 scanner with BetaScan 2 and 3 (ignore the DSI's in the Epson driver) ;
ScanQuix 3 and 5, including any program using ARexx hooks or other means to load
through it : ADPro, fxScan v2 ImageFX v4.5 ;
ImageFX v4.5 using its own driver

This driver has been successfully tested by myself with :
- IBM 4.3 GB UWSCSI harddrive holding FFS & SFS partitions from a Classic system
- Epson GT7000 scanner with BetaScan 3 (ignore the DSI's in the Epson driver)
- Wangtek DC6525 tape drive with Diavolo Backup (auto detection)
- Wangtek DC6120 tape drive with Diavolo Backup (auto detection)
- Wangtek DC6150 tape drive with Diavolo Backup (auto detection)
- Fujitsu H2249 330 MB ESDI harddrive and EMULEX ESDI to SCSI attachment
board from an old VAX
- IBM CDRM001 CD-Rom reader
- TEAC FC-1 SCSI floppy drive
- Apple SC-300 CD-Rom drive
- NeXT black external CD-Rom drive
- various other harddrives from a Silicon Graphics Personal Iris

So if this process fails for you there is definately something going wrong :)

In order to find out / fix, could you please :

- set the "lsi53c8xx_verbose" UBoot envvar to anything, and saveenv (to force the driver into verbose mode)

- grab the full serial port boot log with nondebug kernel

- send my way

Alternatively if you cannot grab the serial log, redirect the log to memory with
kdebug "console memory"
then warmboot then
dumpdebugbuffer ram:log
then send ram:log my way

Kind regards,
--
Stéphane

 Status: Offline
Profile     Report this post  
Deniil715 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 3-Apr-2006 10:09:42
#17 ]
Elite Member
Joined: 14-May-2003
Posts: 4212
From: Sweden

Great news

I didn't use to have the pause-problem (with a few strange exceptions while buring audio-CDs) until I updated to the last release, then I started getting pauses so I reverted back to upd4 original and the problem disappeared. Perhaps I should do another try now then with this release? Or perhaps I should just let it be...


_________________
- Don't get fooled by my avatar, I'm not like that (anymore, mostly... maybe only sometimes)
> Amiga Classic and OS4 developer for OnyxSoft.

 Status: Offline
Profile     Report this post  
Samwel 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 4-Apr-2006 8:21:49
#18 ]
Elite Member
Joined: 7-Apr-2004
Posts: 3404
From: Sweden

@Gurumeditation

Have you added the scsi driver to the kicklayout?


_________________
/Harry

[SOLD] µA1-C - 750GX 800MHz - 512MB - Antec Aria case

Avatar by HNL_DK!

 Status: Offline
Profile     Report this post  
janimator 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 5-Apr-2006 4:17:31
#19 ]
Member
Joined: 20-May-2004
Posts: 58
From: Glendale, CA USA

Hi Stephane,
Here is my report on the lsi53c8xx driver as well. Also having problems
with the system not spinning up the SCSI hard disk. I currently have a Tekram
DC-390U2W PCI board installed on my AmigaOne XE 800 G4. I will note that the
drive recognition and spin up works perfectly fine in Linux using debian 2.4.26.

Also have an Epson 1640SU scanner. It appears to be identified and accessible in OS4 (via ImageFX). Also recognized fine in Linux debian 2.4.26 via xsane.

Wondering if perhaps it is because I have an IBM 16-bit 68-pin wide Ultra2 SCSI hard drive as opposed to an 8-bit 50-pin SCSI-II drive.
Hope this is helpful,

=============================================================================

a1ide.device 51.54 (01.04.2006)
lsi53c8xx.device 51.54 (01.04.2006)
Waiting for devices to spin up..
Scanning SCSI bus...
Device 2: (2:0) Vendor: EPSON Prod.: Perfection1640 Rev: 1.03
Type: Processor (scanner, ...)
Request_sense sense key 6 ASC 29 ASCQ 2
Target 10 not ready, retry 0
Request_sense sense key 2 ASC 4 ASCQ 2
SCSI Error: Target 10 LUN 0 Command 00
CCB: 00 00 00 00 00 00 (len = 6)
Cntrl: Complete (no Error)
Sense: SK 2 (Not Ready) ASC 4 ASCQ 2
Status: Check condition
[lsi53c8xx/scsi_get_capacity] cant get drive capacity from unit 2

 Status: Offline
Profile     Report this post  
sg2 
Re: New 51.54 IDE/SATA driver pack on os4depot
Posted on 6-Apr-2006 10:59:41
#20 ]
Regular Member
Joined: 16-Jun-2004
Posts: 223
From: Lyon, France

Hi,

Well I also have an IBM 68 pin UWSCSI hd. Mine has the "auto spin up" (or whatever name) jumper set.

My driver does not ask the drive to spin up but that should not be necessary, as UBoot should already have done so...

Does UBoot properly detect your HD & list its capacity ?

By hearing the noise out of it, can you tell if the drive has properly spun up at the time when my driver tries to query it ?

Regards,
--
Stéphane

Last edited by sg2 on 06-Apr-2006 at 11:01 AM.

 Status: Offline
Profile     Report this post  

Goto page ( 1 | 2 )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle