Click Here
home features news forums classifieds faqs links search
5760 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
» Home
» Features
» News
» Forums
» Classifieds
» Links
» Downloads
Extras
» OS4 Zone
» IRC Network
» AmigaWorld Radio
» Newsfeed
» Top Members
» Amiga Dealers
Information
» About Us
» FAQs
» Advertise
» Polls
» Terms of Service
» Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
81 crawler(s) on-line.
 15 guest(s) on-line.
 1 member(s) on-line.


 Arnie

You are an anonymous user.
Register Now!
 Arnie:  2 mins ago
 TRIPOS:  19 mins ago
 DiscreetFX:  31 mins ago
 Argo:  34 mins ago
 Bezzen:  44 mins ago
 Derfs:  52 mins ago
 K-L:  54 mins ago
 DiskDoctor:  1 hr 2 mins ago
 CosmosUnivers:  1 hr 50 mins ago
 kamelito:  2 hrs 2 mins ago

hardware OS4   hardware OS4 : Updated AmigaOne 2.6.x Linux kernels
   posted by Geri on 16-Dec-2006 21:33:36 (5289 reads)
Updated AmigaOne 2.6.8 and 2.6.16.35 Linux kernels are now available on amigaone-linux.sourceforge.net.




Changes:
- Recompiled the 2.6.8 kernel, as there was a minor bug in the platform setup code.
- The 2.6.8 kernel includes modules for MacOnLinux 0.9.70:
I don't know, if MacOS X will work, but I was able to load the yaboot bootloader within MoL and the system didn't lock up. Let's try it out!
- The 2.6.16.35 kernel supports USB EHCI. Thanks again to Marcus Comstedt for the patch!
- Removed the transfer request limit for IDE LBA48 devices:
Please report, if you experience DMA timeout errors. I couldn't reproduce them, thus I hope the workaround is not needed anymore.

Note:
My A1 seems to have some hardware problems currently, so I can't guarantee that everything is working fine. Feedback is welcome.
    

Related Links
· More about hardware OS4
· News by Geri


Printer Friendly Page  Send this Story to a Friend

Goto page ( 1 | 2 )

PosterThread
acefnq 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 0:33:30
#1 ]
Cult Member
Joined: 11-Jan-2006
Posts: 617
From: Adelaide, South Australia

Just installed the 2.6.8 kernel on my Testing/Unstable. Works well with memory limit removed but can't get mol going, will try on my stable distro. Thanks for your hard work.

ace

 Status: Offline
Profile     Report this post  
Tomppeli 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 0:36:33
#2 ]
Super Member
Joined: 18-Jun-2004
Posts: 1636
From: Home land of Santa, sauna, sisu and salmiakki

@Geri

2.6.8-kernel work other ways but network don't work. (I have to check will it work with 2.4.26 and try to re-install everything.)

2.6.16.35-kernel starts but then freezes. Last two lines on screen are:
hda: cache flushes supported
hda: RDSK (512) hda1 (DOS^G)(res 2 spb 4) hda2 ... hda6 (DOS^G)(res 2 spb 4)

My system:
hda1-hda6 AOS4-FFS2-partitions
hda7-hda9 Linux-partitions (boot,swap,root)
hda10-hda11 AOS4-FFS2-partitions

I have one newbie question. Where that a1boot.conf-file should be. Linux-partition/AOS4-partition ? In what dir ?


_________________
Rock lobster bit me, so excuse me. Amiga. Never forget.
X1000 + AmigaOS4.1 FE
"Anyone can build a fast CPU. The trick is to build a fast system." -Seymour Cray

 Status: Offline
Profile     Report this post  
Kicko 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 1:50:26
#3 ]
Elite Member
Joined: 19-Jun-2004
Posts: 5009
From: Sweden

I installed both modules and kernel files. Is system.map also to be installed or is it a file for coders ? The same for the patches ?

The system boots ok and shows kernel 2.6.16.35.

As before i have problems with anything connected to the usb ports.
Either it is my mobilephone, my midi or my mediacardreader.
And i dont have any other computer then the a1 so i cant do any debug.
But that you already know ;) So my usb ports are "off" in uboot when
running linux.

! I did something mad when i installed this new kernel, i installed
it over my os4 system partition (hda1) so i had to reformat my HD0:
in os4 and lucky me i had a newly made backup of my system on CD's.
So not a big problem. Os4 runs ok again and this time i used hdb1 ;)
for linux kernel.

! For some time ago i damaged my linux with trying to upgrade debian
to unstable version so i could install firefox2. It couldnt find some
files etc. So i changed back to stable. But it seems it lacks some
stuff as i cant run some programs like firefox1 etc. I can run KDE at
least. Is there a easy way to reinstall debian sarge without having
to install everything from the debian boot cd ? Maybe using apt-get install.
But i dont know what to install.
The bootcd has old kernel and does only work with internal ide and
i dont want to play around in the tower, removing units etc.

 Status: Offline
Profile     Report this post  
acefnq 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 5:11:11
#4 ]
Cult Member
Joined: 11-Jan-2006
Posts: 617
From: Adelaide, South Australia

@Geri
I have just installed on my Debian Stable. USB, net and high memory working well no problems. I am having trouble running MOL but I am playing around with some configs, have managed to bott to the Tux/Apple motif but the freezes. I couldn't get that far until I ran molvconfig first. I'll let you know how I go.

cheers
ace

 Status: Offline
Profile     Report this post  
lionstorm 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 10:09:03
#5 ]
Super Member
Joined: 31-Jul-2003
Posts: 1564
From: the french side

thanks Geri, downloading it right now.

whats the system.map usefull for ?
probably not needed if I am not compiling the kernel myself I guess ?

 Status: Offline
Profile     Report this post  
Geri 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 10:42:28
#6 ]
Elite Member
Joined: 7-Oct-2003
Posts: 2033
From: ST/AT

About the System.map file:

It's not needed, but allows the kernel to display useful information when it crashes (functions names and the offset within the function where the oops happened).

@Tomppeli

Quote:
2.6.16.35-kernel starts but then freezes. Last two lines on screen are:
hda: cache flushes supported
hda: RDSK (512) hda1 (DOS^G)(res 2 spb 4) hda2 ... hda6 (DOS^G)(res 2 spb 4)


That's one of the mysteries I'm trying to solve. It's either a cooling/CPU frequency/core voltage problem, an interrupt problem or a problem with the kernel and the non cache coherent DMA workaround.

Quote:
I have one newbie question. Where that a1boot.conf-file should be. Linux-partition/AOS4-partition ? In what dir ?


I have it in the boot directory, which is located on the root "/" partition. I don't know, if the SLB can find it, if you have a separate boot partition (well, you could try to create a boot/ subdirectory on the boot partition and copy the a1boot.conf file there).

@Kicko

Quote:
As before i have problems with anything connected to the usb ports.
Either it is my mobilephone, my midi or my mediacardreader.
And i dont have any other computer then the a1 so i cant do any debug.
But that you already know ;) So my usb ports are "off" in uboot when
running linux.


Yeah, I hoped the new southbridge settings would relieve this problem a little bit. I'm still waiting for an answer about the interrupt problem from the OS4 developers.

Quote:
Is there a easy way to reinstall debian sarge without having
to install everything from the debian boot cd ? Maybe using apt-get install.
But i dont know what to install.


Uhh, I'm not the expert in fiddling around with apt-get and these things. I normally do a reinstall, because it's the only way to get a clean system.

@acefnq

Quote:
I have just installed on my Debian Stable. USB, net and high memory working well no problems. I am having trouble running MOL but I am playing around with some configs, have managed to bott to the Tux/Apple motif but the freezes. I couldn't get that far until I ran molvconfig first. I'll let you know how I go.


Interesting. MoL displayed the Tux/Apple motif on my A1, but didn't freeze the system. I don't have a OSX install CD, so I tested MoL with the yaboot bootloader.

Last edited by Geri on 17-Dec-2006 at 11:09 AM.


_________________
A1SE: G3@600MHz, 2GB, 1GBit network card
A1XE: G4@933MHz, 2GB, refitted AC'97 codec
microA1: G3@800MHz, 1GB

- A1 Linux support -

 Status: Offline
Profile     Report this post  
elwood 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 11:02:01
#7 ]
Elite Member
Joined: 17-Sep-2003
Posts: 3424
From: Lyon, France

@Tomppeli

a1boot.conf goes on Linux in /boot


_________________
Philippe 'Elwood' Ferrucci
Sam460 1.10 Ghz
AmigaOS 4 betatester
Amiga Translator Organisation

 Status: Offline
Profile     Report this post  
Geri 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 12:14:58
#8 ]
Elite Member
Joined: 7-Oct-2003
Posts: 2033
From: ST/AT

@Kicko

I compiled a new driver for your webcam. Download it here: gspcav1-20061216-2.6.16.35.tar.gz

Install the driver with make install under root.


_________________
A1SE: G3@600MHz, 2GB, 1GBit network card
A1XE: G4@933MHz, 2GB, refitted AC'97 codec
microA1: G3@800MHz, 1GB

- A1 Linux support -

 Status: Offline
Profile     Report this post  
Tuokki 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 13:24:46
#9 ]
Member
Joined: 25-Aug-2003
Posts: 94
From: Nökä , Finland

@Geri
Could you compile spca5xx driver for me ?

Last edited by Tuokki on 17-Dec-2006 at 01:25 PM.

 Status: Offline
Profile     Report this post  
Geri 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 13:33:36
#10 ]
Elite Member
Joined: 7-Oct-2003
Posts: 2033
From: ST/AT

@Tuokki

You can use the gspcav1-20061216 driver. It's a newer version of the spca driver.


_________________
A1SE: G3@600MHz, 2GB, 1GBit network card
A1XE: G4@933MHz, 2GB, refitted AC'97 codec
microA1: G3@800MHz, 1GB

- A1 Linux support -

 Status: Offline
Profile     Report this post  
Tuokki 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 15:12:44
#11 ]
Member
Joined: 25-Aug-2003
Posts: 94
From: Nökä , Finland

@Geri
Ok, thanks!

 Status: Offline
Profile     Report this post  
Kicko 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 15:54:42
#12 ]
Elite Member
Joined: 19-Jun-2004
Posts: 5009
From: Sweden

Thanks Geri for the new camdriver. I dont have the cam here. However as i have the usb problem i dont believe it will work. Ill test it later when i do get borrow the cam again. Maybe Tuokki or some other person can test if the driver works with their cams.

 Status: Offline
Profile     Report this post  
Tomppeli 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 16:04:27
#13 ]
Super Member
Joined: 18-Jun-2004
Posts: 1636
From: Home land of Santa, sauna, sisu and salmiakki

@Geri

Quote:
cooling/CPU frequency/core voltage problem

I'm using SE-G3 so cooling/CPU frequency/core voltage should be all correct. (And memory is tested and OK.)

Quote:
I don't know, if the SLB can find it, if you have a separate boot partition

So do this mean I don't need a separate boot partition at all ?

Quote:
hda: RDSK (512) hda1 (DOS^G)(res 2 spb 4) hda2 ... hda6 (DOS^G)(res 2 spb 4)

I'm wondering why it stops before it lists hda7. My Linux partitions are all above 90GB on my hd. Does it matter ?


_________________
Rock lobster bit me, so excuse me. Amiga. Never forget.
X1000 + AmigaOS4.1 FE
"Anyone can build a fast CPU. The trick is to build a fast system." -Seymour Cray

 Status: Offline
Profile     Report this post  
lionstorm 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 16:43:02
#14 ]
Super Member
Joined: 31-Jul-2003
Posts: 1564
From: the french side

both kernels are booting fine on my A1G4, radeon7500, 512Mb RAM, Stable/Sarge and net is working as well

how do I see if there are ide timount errors ?

where should the system.map be copied to ?

EDIT : got a total system lockup with 2.6.15, X keys not able to recover so I had to reboot the hard way, and that was when apt-getting mol-modules

Last edited by lionstorm on 17-Dec-2006 at 04:51 PM.

 Status: Offline
Profile     Report this post  
Geri 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 18:09:41
#15 ]
Elite Member
Joined: 7-Oct-2003
Posts: 2033
From: ST/AT

Quote:
So do this mean I don't need a separate boot partition at all ?

Yes.

Quote:
I'm wondering why it stops before it lists hda7. My Linux partitions are all above 90GB on my hd. Does it matter ?

I don't think so. Does the kernel always stop at this point?

Last edited by Geri on 17-Dec-2006 at 06:11 PM.


_________________
A1SE: G3@600MHz, 2GB, 1GBit network card
A1XE: G4@933MHz, 2GB, refitted AC'97 codec
microA1: G3@800MHz, 1GB

- A1 Linux support -

 Status: Offline
Profile     Report this post  
Geri 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 18:14:35
#16 ]
Elite Member
Joined: 7-Oct-2003
Posts: 2033
From: ST/AT

@lionstorm

Quote:
how do I see if there are ide timount errors ?

The kernel log is the right place to lock for dma timeout messages.

Quote:
where should the system.map be copied to ?

Just copy it to the /boot directory.


_________________
A1SE: G3@600MHz, 2GB, 1GBit network card
A1XE: G4@933MHz, 2GB, refitted AC'97 codec
microA1: G3@800MHz, 1GB

- A1 Linux support -

 Status: Offline
Profile     Report this post  
zErec 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 18:37:24
#17 ]
Cult Member
Joined: 17-Dec-2003
Posts: 512
From: Germany

Hi Geri you got a PIM :O)


_________________
- AmigaX1Ooo with OS4.1FE // CD32/SX32Pro/SX1/CD32Shuttle
- A600-Vampire600 FPGA // A4KT/CSPPC233,144MB,PCI, AOS4.1.6FE
- MACmini 1.5GHz // Pegasos 2 1GHz // Efika
- ATARI Falcon/060/SuperVidel // ATARI Falcon MK X

 Status: Offline
Profile     Report this post  
Tomppeli 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 17-Dec-2006 19:53:44
#18 ]
Super Member
Joined: 18-Jun-2004
Posts: 1636
From: Home land of Santa, sauna, sisu and salmiakki

@Geri

Quote:
I'm wondering why it stops before it lists hda7. My Linux partitions are all above 90GB on my hd. Does it matter ?

Quote:
I don't think so. Does the kernel always stop at this point?

Yes.


_________________
Rock lobster bit me, so excuse me. Amiga. Never forget.
X1000 + AmigaOS4.1 FE
"Anyone can build a fast CPU. The trick is to build a fast system." -Seymour Cray

 Status: Offline
Profile     Report this post  
Geri 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 18-Dec-2006 14:01:57
#19 ]
Elite Member
Joined: 7-Oct-2003
Posts: 2033
From: ST/AT

Regarding MoL:

Can somebody please check, if MacOS 9 is working with MoL on the A1?


_________________
A1SE: G3@600MHz, 2GB, 1GBit network card
A1XE: G4@933MHz, 2GB, refitted AC'97 codec
microA1: G3@800MHz, 1GB

- A1 Linux support -

 Status: Offline
Profile     Report this post  
lionstorm 
Re: Updated AmigaOne 2.6.x Linux kernels
Posted on 18-Dec-2006 19:54:46
#20 ]
Super Member
Joined: 31-Jul-2003
Posts: 1564
From: the french side

with 2.6.8 I was able to run molvconfig, mol --loadonly and mol --test.

when it comes to boot from MacOS9.1 CD, I got a lockup at the splash screen.
I then changed /dev/cdrom by /dev/hda and startmol exited (see below).
I dont know if it is related to the question about initrd and lilo, which arose during apt-get mol mol-linux-modules.
Lio

aone:/# startmol --cdboot --newworld
Mac-on-Linux 0.9.70 [Mar 18 2005 11:51]
Copyright (C) 1997-2004 Samuel Rydh
Starting MOL session 0
Running in PowerPC 750 mode, 128 MB RAM
Timebase: 33.33 MHz, Bus: 133.33 MHz, Clock: 800 MHz
Could not open driver 'drivers/misc.nw': No such file or directory
Using USB mouse on /dev/input/mice
OHCI USB controller registered
Could not open '/var/lib/mol/x11.kbd'
Could not open driver 'drivers/video.nw': No such file or directory
Fullscreen video on VT 8.
Could not open '/var/lib/mol/console.kbd'
Cache enabled for console-video
Video driver(s): [xvideo] [console_video]

640* 480, depth 8,15,32 { 59.9, 74.9 } Hz
800* 600, depth 8,15,32 { 74.9 } Hz
1024* 768, depth 8,15,32 { 60.0, 75.0 } Hz
1152* 864, depth 8,15 { 0.0 } Hz
1280*1024, depth 8,15,32 { 0.0, 60.0, 60.0 } Hz
1600*1200, depth 8,15 { 0.0 } Hz

Autoswitching to console
ALSA lib confmisc.c:550:(snd_determine_driver) could not open control for card 0
ALSA lib conf.c:3461:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:387:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3461:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:945:(snd_func_refer) error evaluating name
ALSA lib conf.c:3461:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3930:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2068:(snd_pcm_open_noupdate) Unknown PCM default
OSS sound driver
Could not open driver 'drivers/scsi.nw': No such file or directory
MOL SCSI controller registered




Unknown disk flag '$|cdboot|'
CD /dev/hda CD-ROM ------
Disk /dev/hdc3 5192 MB

Could not open driver 'drivers/blk.nw': No such file or directory

>> =============================================================
>> Mac-on-Linux OpenFirmware 0.9.70

>> --- No bootable disk was found! -----------------------------
>> If this is an oldworld machine, try booting from the MacOS
>> install CD and install MacOS from within MOL.
>> -------------------------------------------------------------
cleaning up...
Terminating threads...
DONE


EDIT: by setting the scsi emu for CD to no, I could reach the splash screen again but got a lockup after the CD tries to launch...

Last edited by lionstorm on 18-Dec-2006 at 08:03 PM.

 Status: Offline
Profile     Report this post  

Goto page ( 1 | 2 )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle