Click Here
home features news forums classifieds faqs links search
5651 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
54 crawler(s) on-line.
 14 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 NutsAboutAmiga:  5 mins ago
 Tarzin:  20 mins ago
 BSzili:  33 mins ago
 ferrels:  46 mins ago
 vox:  53 mins ago
 Argo:  1 hr 5 mins ago
 blasterreal:  1 hr 11 mins ago
 Trekiej:  1 hr 52 mins ago
 Rob:  2 hrs 48 mins ago
 kolla:  4 hrs 14 mins ago

Software News   Software News : AmiPodder 1.7 Released
   posted by rhino on 16-Sep-2007 14:16:13 (2883 reads)
A new version of AmiPodder, my utility that allows Amiga users to subscribe to audio and video podcasts, is now available.

The major new feature in version 1.7 is support for Podcasts that require authentication (a username and password). In addition there are the usual minor enhancements:


* Support for Amplifier as a player.
* Improved podcast feed compatibility.
* Much improved requirements (libraries and MUI custom classes) checking.
* Various bug fixes.

If you've previously had trouble getting AmiPodder to run, it's well worth trying again with this version as the improved requirements checking should give you a more informative error.

AmiPodder 1.7 is written in AREXX using rxMUI and therefore works on OS 3.x, OS 4 and MorphOS. It's released as freeware and can be downloaded from:
http://www.amipodder.com
    

Related Links
· More about Software News
· News by rhino


Most read story about Software News
UBoot 2010.06.04 for Sam460ex available

Last news about Software News
IBrowse 2.5 Released
Printer Friendly Page  Send this Story to a Friend

PosterThread
ajs 
Re: AmiPodder 1.7 Released
Posted on 16-Sep-2007 15:18:05
#1 ]
Super Member
Joined: 8-Mar-2003
Posts: 1459
From: Surrey

Nice one Robert.


_________________
Everything is proceeding as I have foreseen

Some people are like slinkies. Not really good for anything but they bring a smile to your face when pushed down the stairs.

 Status: Offline
Profile     Report this post  
cap 
Re: AmiPodder 1.7 Released
Posted on 16-Sep-2007 15:25:45
#2 ]
Regular Member
Joined: 30-Jan-2003
Posts: 283
From: Melton Mowbray - Porkpie centre.

Only problem is i`ve downloaded it and it gives out an error on loading.
I will download again and give more info.

Ok. Heres the problem which comes up in a window.

"An error has ocurred in program:
Ram Disk:AmiPodder/AmiPodder:
Error 41 in line 375: Invalid expression
Please check the documentation for solutions and to report bugs."

This happens before i use the installer and after.

Also in an output window i get "0"

Keep up the good work tho Robert :)

Last edited by cap on 16-Sep-2007 at 03:32 PM.
Last edited by cap on 16-Sep-2007 at 03:31 PM.


_________________
A1/G4 1GHZ

OS4.1 latest update.
1ghz Radeon Club3d 9250
Usb/Dma fixed.

 Status: Offline
Profile     Report this post  
rhino 
Re: AmiPodder 1.7 Released
Posted on 16-Sep-2007 15:50:10
#3 ]
Regular Member
Joined: 11-Mar-2003
Posts: 280
From: Unknown

@cap

Sorry to hear you're having problems.

Quote:

Ok. Heres the problem which comes up in a window.

"An error has ocurred in program:
Ram Disk:AmiPodder/AmiPodder:
Error 41 in line 375: Invalid expression
Please check the documentation for solutions and to report bugs."


I'm not sure quite why you're getting this error, but that area of the program is checking to see if you have all the required libraries etc. installed. In particular, do you have the latest version of rxMUI installed? If not you can download it from:
http://alfie.altervista.org/rxmui/

Hope that helps,

Robert


_________________
Total Amiga (Archive) http://www.totalamiga.org

 Status: Offline
Profile     Report this post  
firbodi 
Re: AmiPodder 1.7 Released
Posted on 16-Sep-2007 16:14:48
#4 ]
Super Member
Joined: 2-Sep-2003
Posts: 1046
From: Planet Earth!

Please install it in a harddrive partition! And try again.

I have had problems with some programs running from the "ram disk:" I think it is because this is a the only volume with a blank in its name. Some programs can't handle that.

I think the script is having the same problem, because it says:
Quote:

Ram Disk:AmiPodder/AmiPodder:
Error 41 in line 375: Invalid expression

Firbodi

Last edited by firbodi on 16-Sep-2007 at 04:17 PM.


_________________
MicroA1 G3, 512MB RAM, DVD-RW; and A1-SE G3,512MB RAM, CD-RW & DVD-ROM
Avatar: Perspolis, Capital of Achaemenid Empire 500 B.C.

 Status: Offline
Profile     Report this post  
rhino 
Re: AmiPodder 1.7 Released
Posted on 16-Sep-2007 16:48:03
#5 ]
Regular Member
Joined: 11-Mar-2003
Posts: 280
From: Unknown

@firbodi

Quote:

Please install it in a harddrive partition! And try again.

I have had problems with some programs running from the "ram disk:" I think it is because this is a the only volume with a blank in its name. Some programs can't handle that.


You're right that running from the RAM Disk does cause problems with some programs. However I have tested AmiPodder running from there and it works fine, so I think cap's problem is more likely caused by missing libraries. If that turns out to be the case I'll have to work out why the script is failing rather than showing an appropriate message (as it is supposed to).

Robert


_________________
Total Amiga (Archive) http://www.totalamiga.org

 Status: Offline
Profile     Report this post  
cap 
Re: AmiPodder 1.7 Released
Posted on 16-Sep-2007 20:43:19
#6 ]
Regular Member
Joined: 30-Jan-2003
Posts: 283
From: Melton Mowbray - Porkpie centre.

Thanks Robert.

That was the solution to install rxmui.

Alls working fine now. :)


_________________
A1/G4 1GHZ

OS4.1 latest update.
1ghz Radeon Club3d 9250
Usb/Dma fixed.

 Status: Offline
Profile     Report this post  
sundown 
Re: AmiPodder 1.7 Released
Posted on 16-Sep-2007 20:58:46
#7 ]
Elite Member
Joined: 30-Aug-2003
Posts: 5112
From: Right here...

@rhino

I get an aborted install. I had to manually install v1.6 & will have to do the same with v1.7. I have RxMUI installed & v1.6 is working, although prefs configuring drives me nuts asking for the Work: volume, which doesn't exist.

Here's the install error I get. I get this no matter where I un-archive the app.


_________________
Hate tends to make you look stupid...

 Status: Offline
Profile     Report this post  
Kicko 
Re: AmiPodder 1.7 Released
Posted on 16-Sep-2007 21:55:48
#8 ]
Elite Member
Joined: 19-Jun-2004
Posts: 5008
From: Sweden

Nice to see an update. Go amiga ;)

 Status: Offline
Profile     Report this post  
rhino 
Re: AmiPodder 1.7 Released
Posted on 16-Sep-2007 22:08:16
#9 ]
Regular Member
Joined: 11-Mar-2003
Posts: 280
From: Unknown

@sundown

Quote:
I get an aborted install. I had to manually install v1.6 & will have to do the same with v1.7.


I suspect I know why you're getting this error. If you're updating from an existing version you need to select the drawer containing the AmiPodder drawer (not the existing AmiPodder drawer) in the installer. For example, if AmiPodder 1.6 is already installed in Work:Utilities/AmiPodder/, select Work:Utilities/ when running the 1.7 installer to update it.

Quote:
I have RxMUI installed & v1.6 is working, although prefs configuring drives me nuts asking for the Work: volume, which doesn't exist.


This is caused when the default paths in prefs do not exist on your system. You can get around this by selecting a path for the audio and video sync directories even if you are not going to use that feature (just select a any directory, if you don't sync it won't be used). I'll add that to the list of things to fix in the next release.

Thanks

Robert


_________________
Total Amiga (Archive) http://www.totalamiga.org

 Status: Offline
Profile     Report this post  
sundown 
Re: AmiPodder 1.7 Released
Posted on 16-Sep-2007 22:16:59
#10 ]
Elite Member
Joined: 30-Aug-2003
Posts: 5112
From: Right here...

@rhino

You were correct about the install problem, just selecting the directory where AmiPodder v1.6 was installed did the trick as you said.
Thanks for the other tip on configuring.


_________________
Hate tends to make you look stupid...

 Status: Offline
Profile     Report this post  
nbache 
Re: AmiPodder 1.7 Released
Posted on 16-Sep-2007 23:05:03
#11 ]
Cult Member
Joined: 8-Apr-2003
Posts: 958
From: Copenhagen, Denmark

Quote:
I suspect I know why you're getting this error. If you're updating from an existing version you need to select the drawer containing the AmiPodder drawer (not the existing AmiPodder drawer) in the installer. For example, if AmiPodder 1.6 is already installed in Work:Utilities/AmiPodder/, select Work:Utilities/ when running the 1.7 installer to update it.

This is a common problem in many installer scripts. I think it would be helpful if the author (in this case you, Rhino ) would make the script detect if the user selects the actual installation drawer instead of its parent, and simply cut off the final drawer from the selected path. It's usually no problem to check if the selected path contains a file with the name of your main executable, or a drawer containing such a file. And that's all you need to know in order to "improve" the user's selection.

Wouldn't this be a nice "best practice" for installer script writers?

Best regards,

Niels

 Status: Offline
Profile     Report this post  
rhino 
Re: AmiPodder 1.7 Released
Posted on 17-Sep-2007 9:58:08
#12 ]
Regular Member
Joined: 11-Mar-2003
Posts: 280
From: Unknown

@nbache

Quote:
This is a common problem in many installer scripts. I think it would be helpful if the author (in this case you, Rhino ) would make the script detect if the user selects the actual installation drawer instead of its parent


Good point, I'll make a note to improve the behaviour of the installer for the next version.

Thanks

Robert


_________________
Total Amiga (Archive) http://www.totalamiga.org

 Status: Offline
Profile     Report this post  
AmigaClyde 
Re: AmiPodder 1.7 Released
Posted on 17-Sep-2007 16:45:58
#13 ]
Elite Member
Joined: 8-Mar-2003
Posts: 2007
From: Noranda Canada

Great news. Thanks for the update


_________________
---------
AmigaClyde

A1-C 750GX@800 using OS4.1

 Status: Offline
Profile     Report this post  
[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle