Click Here
home features news forums classifieds faqs links search
6082 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
28 crawler(s) on-line.
 13 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 Hammer:  5 mins ago
 Matt3k:  39 mins ago
 Hypex:  40 mins ago
 matthey:  40 mins ago
 paulhenge:  1 hr 49 mins ago
 amigakit:  2 hrs 23 mins ago
 Lou:  2 hrs 31 mins ago
 ggw:  3 hrs 18 mins ago
 kolla:  3 hrs 20 mins ago
 Seiya:  3 hrs 50 mins ago

Software News   Software News : AmigaOS 4.0 for Classic has gone Gold!
   posted by Rogue on 22-Nov-2007 22:35:49 (10205 reads)
Antwerp, Belgium – 22 November, 2007.

Hyperion Entertainment is pleased to announce that AmigaOS 4.0 for PowerPC equipped Amiga 1200/3000/4000’s has gone gold and should be available for sale around 30 November depending on location.

Further information can be found here.

Prospective customers are once more encouraged to verify the (regularly updated) compatibility list prior to purchase.

AmigaOS 4.0 for classic Amiga’s will be distributed worldwide by Acube Systems s.r.l..
    

STORYID: 4073
Related Links
· More about Software News
· News by Rogue


Most read story about Software News
UBoot 2010.06.04 for Sam460ex available

Last news about Software News
Hollywood APK Compiler 4.0 released
Printer Friendly Page  Send this Story to a Friend

Goto page ( 1 | 2 | 3 | 4 )

PosterThread
MagicSN 
Re: AmigaOS 4.0 for Classic has gone Gold!
Posted on 26-Nov-2007 12:41:24
#61 ]
Hyperion
Joined: 10-Mar-2003
Posts: 638
From: Unknown

Hmmm, somehow I feel like doing some new versions of some of my Amiga Projects again

MagicSN

 Status: Offline
Profile     Report this post  
BinoX 
Re: AmigaOS 4.0 for Classic has gone Gold!
Posted on 26-Nov-2007 15:00:18
#62 ]
Cult Member
Joined: 2-Nov-2005
Posts: 711
From: Cornwall, UK

Just wondering (if any OS4 devs read this)

Is there ever going to be a driver for the A3000 SCSI? 'cause I would quite like to have access to the drives connected to it from OS4 :)


_________________
Back to action!

 Status: Offline
Profile     Report this post  
TetiSoft 
Re: AmigaOS 4.0 for Classic has gone Gold!
Posted on 26-Nov-2007 17:34:08
#63 ]
Cult Member
Joined: 3-Mar-2005
Posts: 585
From: Germany

@BinoX

Quote:

Is there ever going to be a driver for the A3000 SCSI? 'cause I would quite like to have access to the drives connected to it from OS4 :)

When you have an A3000 and want to run OS4 you need to plug in a CSPPC board.
The CSPPC board already includes an UWSCSI controller and OS4 comes with
a driver for this, so you can attach the drives there and use them.

There exists 68k assembler source code for the A3000 version of scsi.device.
Unfortunately the developers dont know yet why it does not work with OS4 anymore.

I'm not aware of a developer who has the skills, the time, the motivation,
an A3000, a CSPPC, some SCSI drives and access to the OS4 CVS with the
68k source code. Such a person would be needed to fix the driver. Creating
a new driver without the old sources is possible too, but its IMHO more
complicated than other drivers because of the SCRIPTS code which is executed
by the WD SCSI chip.

 Status: Offline
Profile     Report this post  
BinoX 
Re: AmigaOS 4.0 for Classic has gone Gold!
Posted on 26-Nov-2007 18:18:25
#64 ]
Cult Member
Joined: 2-Nov-2005
Posts: 711
From: Cornwall, UK

Quote:
When you have an A3000 and want to run OS4 you need to plug in a CSPPC board.
The CSPPC board already includes an UWSCSI controller and OS4 comes with
a driver for this, so you can attach the drives there and use them.


Well.. I don't want to do the INT2 mod to the motherboard... I wanna keep it as it is... 'cause I'll probably mess it up big time!

Hoepfully they'll add support for it sometime...

For now I'll just use OS4 on my A1200T I guess...
And I'll investigate whether my 3000T needs the INT2 mod 'cause the later ones didn't...

Also, since I'm on the subject of asking... I see no mention of the Algor USB device on the compatibility list... Any idea if that works?


_________________
Back to action!

 Status: Offline
Profile     Report this post  
ChrisH 
Re: AmigaOS 4.0 for Classic has gone Gold!
Posted on 26-Nov-2007 18:21:24
#65 ]
Elite Member
Joined: 30-Jan-2005
Posts: 6679
From: Unknown

@TetiSoft who said Quote:
scsi.device. Unfortunately the developers dont know yet why it does not work with OS4 anymore.

On the rare chance this might be related: The author of TLFSMem reported that scsi.device has a nasty memory bug where it writes a few bytes past the end of it's memory allocations. To me it seems likely that such a bug (if not already fixed in OS4) would upset OS4's new memory system...

Last edited by ChrisH on 26-Nov-2007 at 09:34 PM.
Last edited by ChrisH on 26-Nov-2007 at 06:21 PM.


_________________
Author of the PortablE programming language.
It is pitch black. You are likely to be eaten by a grue...

 Status: Offline
Profile     Report this post  
TetiSoft 
Re: AmigaOS 4.0 for Classic has gone Gold!
Posted on 27-Nov-2007 10:36:58
#66 ]
Cult Member
Joined: 3-Mar-2005
Posts: 585
From: Germany

@BinoX

Quote:

I see no mention of the Algor USB device on the compatibility list... Any idea if that works?

The E3B website says it uses a different USB chip than the Highway so the
OS4 Highway driver wont work with it.

The compatibility list says that its possible to use the Poseidon USB stack
instead of the OS4 Sirion USB stack to use a Subway card. Eventually its also
possible to use Poseidon with its Algor driver, but it was not tested.

 Status: Offline
Profile     Report this post  
TetiSoft 
Re: AmigaOS 4.0 for Classic has gone Gold!
Posted on 27-Nov-2007 10:50:16
#67 ]
Cult Member
Joined: 3-Mar-2005
Posts: 585
From: Germany

@ChrisH

Quote:

Quote:

scsi.device. Unfortunately the developers dont know yet why it does not work with OS4 anymore.

On the rare chance this might be related: The author of TLFSMem reported that
scsi.device has a nasty memory bug where it writes a few bytes past the end of
it's memory allocations. To me it seems likely that such a bug (if not already
fixed in OS4) would upset OS4's new memory system...

Yes, this is likely to cause problems with OS4, unfortunately the following
suggests its already fixed.
Quote:

scsi.device 50.5 (19.6.2006) (dwuerkner)
- The device init code did write to the io_Offset field of a faked
IORequest (not IOStdReq) structure which caused a longword to be
cleared which was located behind the end of the memory which was
allocated by the device. This fixes a problem on my machine where
the exact number of KickLayout modules and their order was important
for a successfull boot.


The different scsi.device versions share common source code parts so
I guess that this fix which I did for the A4k IDE driver also affected the
A3k SCSI driver.

 Status: Offline
Profile     Report this post  
AmigaPapst 
Re: AmigaOS 4.0 for Classic has gone Gold!
Posted on 27-Nov-2007 17:31:11
#68 ]
Cult Member
Joined: 2-Nov-2003
Posts: 634
From: Amigavatikan

@MagicSN
Welcome back to the Amiga community.
I hope you will work on your game projects for AmigaOS 4.


_________________
AmigaOne X1000 1,8 Ghz/2 GB Ram + Radeon 6670 2 GB + AmigaOS4.1
A4000T CyberstormPPC 604e-200Mhz/060/128MB+CybervisionPPC 8MB + AmigaOS4
and anymore other Amigas...

 Status: Offline
Profile     Report this post  
TiredofLife 
Re: AmigaOS 4.0 for Classic has gone Gold!
Posted on 28-Nov-2007 14:59:37
#69 ]
Super Member
Joined: 6-Jul-2005
Posts: 1694
From: Here

Have read several times about PCI cards working in a Mediator under OS4, if the Mediator drivers are used instead of OS4.0 drivers.

Have any of the beta testers tried this and can they provide any tips on how to go about this?


_________________
If your nose runs and your feet smell, you're upside down.

 Status: Offline
Profile     Report this post  

Goto page ( 1 | 2 | 3 | 4 )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle