Click Here
home features news forums classifieds faqs links search
5700 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
» Home
» Features
» News
» Forums
» Classifieds
» Links
» Downloads
Extras
» OS4 Zone
» IRC Network
» AmigaWorld Radio
» Newsfeed
» Top Members
» Amiga Dealers
Information
» About Us
» FAQs
» Advertise
» Polls
» Terms of Service
» Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
46 crawler(s) on-line.
 14 guest(s) on-line.
 1 member(s) on-line.


 CygnusEd

You are an anonymous user.
Register Now!
 CygnusEd:  1 min ago
 BSzili:  5 mins ago
 nikosidis:  20 mins ago
 Daedalus:  35 mins ago
 MEGA_RJ_MICAL:  1 hr 4 mins ago
 ERoy:  1 hr 12 mins ago
 kamelito:  1 hr 20 mins ago
 BigD:  1 hr 21 mins ago
 kolla:  1 hr 40 mins ago
 Frank:  1 hr 47 mins ago

Software News   Software News : OWB updates
   posted by tomazkid on 26-Jan-2008 0:50:07 (2919 reads)
Jörg Strohmayer has worked hard with the Origyn Web Browser lately.
Several new versions this year, of which the latest is version 1.6.

You can download it from http://strohmayer.org/
Update: Jahc tells there is a toolbar too now, in this thread.

Read more for the changelog...





Changelog (from http://strohmayer.org/

* 1.6 (24.1.2008)
o No changes in the code, but it's now using shared libicu#? objects instead of statically linking the same 10 MB in each version again.
* 1.5 (22.1.2008)
o Updated to SVN revision 232.
o Built using shared objects, you have to copy libSDL-1.2.so from http://www.rcdrummond.net/sdl/SDL-1.2.11_20080121-AmigaOS4_shared.lha to SOBJS:.
* 1.4 (17.1.2008)
o Now opens clicked links with target "_blank", which would open in new tab or window in a real browser, in the same frame ("_self") instead of ignoring them.
o Added a workaround for the SDL charset bug, now you can enter all chars of your system default charset which don't need a dead key.
* 1.3 (15.1.2008)
o Added the experimental web UI and made it the default start page. There are lots of problems with it (back/forward doesn't work, PgUp/PgDown doesn't work, ...), but it's probably better than nothing. Of course you can still start OWB with a different start page by passing an URL as argument.
o Changed default window size to 960 x 720.
o Enabled two pass loading.
o Added a workaround for a memory trashing bug, http://wikipedia.org/ main page is working now (http://en.wikipedia.org/ still doesn't, 100% CPU usage without displaying anything).
o More optimizions in the memory allocator.
o Disabled GIF animations for now, they slow down everything too much.
o Chars which need <alt> can be entered now, but the AmigaOS4 SDL seems to ignore the charset, for chars not in ISO-8859-1 you get something different.
* 1.2 (11.1.2008)
o Updated to SVN revision 224.
o Now cleanly exit()s if running out of memory instead of crashing, most parts of OWB don't check if allocating memory succeeded.
o Reworked the memory allocator, should be nearly as fast as the original one.
    

Related Links
· More about Software News
· News by tomazkid


Most read story about Software News
UBoot 2010.06.04 for Sam460ex available

Last news about Software News
IBrowse 2.5 Released
Printer Friendly Page  Send this Story to a Friend

PosterThread
Moxee 
Re: OWB updates
Posted on 26-Jan-2008 1:27:56
#1 ]
Team Member
Joined: 20-Aug-2003
Posts: 6291
From: County Yakima, WA State, USA

Great! Thanks for the news.


_________________
Moxee
AmigaOne X1000
AmigaOne XE G4
I'd agree with you, but then we'd both be wrong.

 Status: Offline
Profile     Report this post  
Akiko 
Re: OWB updates
Posted on 26-Jan-2008 1:36:01
#2 ]
Cult Member
Joined: 26-Mar-2004
Posts: 769
From: UK

looking good


_________________
Amiga 4000T, CSPPC@233,50 , Amiga OS3.9 / OS4.1
Amiga 1200, Blizzard IV
CD32/SX32

 Status: Offline
Profile     Report this post  
AmigaClyde 
Re: OWB updates
Posted on 26-Jan-2008 1:50:45
#3 ]
Elite Member
Joined: 8-Mar-2003
Posts: 2007
From: Noranda Canada

Great news. This browser is getting better every day.
Don't let up it'll surpass Windoze IE.


_________________
---------
AmigaClyde

µA1-C 750GX@800 using OS4.1

 Status: Offline
Profile     Report this post  
RacerX 
Re: OWB updates
Posted on 26-Jan-2008 2:05:36
#4 ]
Super Member
Joined: 21-Aug-2003
Posts: 1158
From: Parts Unknown, USA

Cool!


_________________
'unfixed' A1XE, 512mb RAM, plug-in USB card, Sil 0680 IDE card, Radeon 9250, built-in sound, OS4.1 update 5.

 Status: Offline
Profile     Report this post  
pavlor 
Re: OWB updates
Posted on 26-Jan-2008 8:51:49
#5 ]
Elite Member
Joined: 10-Jul-2005
Posts: 9019
From: Unknown

Good! Good! Good!

 Status: Offline
Profile     Report this post  
GrumpyOldMan 
Re: OWB updates
Posted on 26-Jan-2008 10:26:46
#6 ]
Cult Member
Joined: 3-Nov-2003
Posts: 675
From: Haukipudas, Finland

When viewing some sites with latest OWB I get these messages:

CONSOLE MESSAGE: line 2233: ReferenceError: Can't find variable: getTMqs
CONSOLE MESSAGE: line 2155: ReferenceError: Can't find variable: GetCookie
The W3C recommands that Location headers uses absolute paths and not relative ones, this website used :' Location: /addyn|3.0|387|109054|0|82|ADTECH;cfp=1;rndc=120134235;loc=100;target=_blank;grp=[group];misc=1201342374891
'
CONSOLE MESSAGE: line 2155: Can't find variable: GetCookie

Any ideas what could cause these?

To all those involved with OWB development (especially for OS4): many thanks, and keep up the good work!


_________________
"Those are my principles, and if you don't like them... well, I have others." (Groucho Marx)

 Status: Offline
Profile     Report this post  
Kicko 
Re: OWB updates
Posted on 26-Jan-2008 10:38:35
#7 ]
Elite Member
Joined: 19-Jun-2004
Posts: 5008
From: Sweden

Keep up the good work :)

 Status: Offline
Profile     Report this post  
Metalheart 
Re: OWB updates
Posted on 26-Jan-2008 11:01:11
#8 ]
Elite Member
Joined: 21-Aug-2003
Posts: 2968
From: Somewhere in the Dutch mountains....

I get a 'requiered object missing' message.... When I click on its icon.

anyone ??

Thanks

Martin


_________________
Theres a time to live and a time to die
When its time to meet the maker
Theres a time to live but isnt it strange
That as soon as you're born you're dying

 Status: Offline
Profile     Report this post  
poweramiga2002 
Re: OWB updates
Posted on 26-Jan-2008 11:14:09
#9 ]
Super Member
Joined: 29-Jul-2003
Posts: 1389
From: Flinders NSW Australia

@Martin
you need to add the librarys then it will work :)

Last edited by poweramiga2002 on 26-Jan-2008 at 11:14 AM.

 Status: Offline
Profile     Report this post  
Metalheart 
Re: OWB updates
Posted on 26-Jan-2008 11:19:09
#10 ]
Elite Member
Joined: 21-Aug-2003
Posts: 2968
From: Somewhere in the Dutch mountains....

it works now.... thanks

Last edited by Metalheart on 26-Jan-2008 at 11:33 AM.
Last edited by Metalheart on 26-Jan-2008 at 11:31 AM.


_________________
Theres a time to live and a time to die
When its time to meet the maker
Theres a time to live but isnt it strange
That as soon as you're born you're dying

 Status: Offline
Profile     Report this post  
Crumb 
Re: OWB updates
Posted on 26-Jan-2008 14:26:23
#11 ]
Elite Member
Joined: 12-Mar-2003
Posts: 2208
From: Zaragoza (Aragonian State)

any chance of getting "tabs"?


_________________
The only spanish amiga news web page/club: CUAZ

 Status: Offline
Profile     Report this post  
VooDoo 
Re: OWB updates
Posted on 26-Jan-2008 19:00:44
#12 ]
Super Member
Joined: 16-Jun-2003
Posts: 1495
From: Croatia

It works great for me...thx ppl for this great sw


_________________
--
A1200 sandwich :)

uA1c/g3-800 mHz/512mb/160gb hdd/OS4.1 Final + upd #1

MacMini G4 1.5ghz 1GB ram + MorphOS 3.9

Croatian Amiga portal

 Status: Offline
Profile     Report this post  
Mark 
Re: OWB updates
Posted on 28-Jan-2008 15:45:57
#13 ]
Team Member
Joined: 12-Mar-2003
Posts: 1457
From: UK

I notice in the todo list that you have a "create flash plugin", wouldnt it be better/easier to create an MPlayer plugin of somesort to play all those video formats and the like?

Mark


_________________
IceStar Media Ltd.

 Status: Offline
Profile     Report this post  
[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle