Click Here
home features news forums classifieds faqs links search
5669 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
53 crawler(s) on-line.
 14 guest(s) on-line.
 2 member(s) on-line.


 billt,  Breed

You are an anonymous user.
Register Now!
 Breed:  1 min ago
 billt:  3 mins ago
 tekmage:  5 mins ago
 DiscreetFX:  24 mins ago
 g0blin:  28 mins ago
 kolla:  47 mins ago
 tonyw:  59 mins ago
 Fl@sh:  1 hr ago
 guibrush:  1 hr 21 mins ago
 simplex:  1 hr 24 mins ago

Software News   Software News : Origyn Web Browser 3.14 for AmigaOS
   posted by ssolie on 10-Jun-2009 0:17:27 (3945 reads)

Check out the AmigaOS version of OWB at the OWB web site.



Changes in the 3.14 (8.6.2009) version include:
- Fixed progress bar. Since the changes need new methods the text search is now disabled on AmigaOS 4.0.
- Fixed several cookie bugs, for example GMail and the URL from bugs.os4depot.net issue #131 are working now.
- Added more checks for broken font installations.
- Implemented HTTP authentication, partially based on the AROS OWB diffs with minor bug fixes, and added support for http://username:password@example.com/ urls (bugs.os4depot.net issues #121 and #149).
- Added support for scrolling with space and backspace (bugs.os4depot.net issue #169) and <shift><cursor up/down> (#186).
- Added ToolType DOWNLOADDIR (bugs.os4depot.net issue #154).
- Added ToolType DISABLEGIFANIMS.
- Fixed bugs.os4depot.net issues #170, #175, #180, #183 and #185.
- Added Accept-Language: header based on locale preferences.
- URL and web search gadgets did not always work if they weren't activated with the mouse, fixed.
- Updated to SVN revision 994 (OWB milestone Galeking).
- Changed <RAmiga><C> menu shortcut from "Copy" (UTF-8) to "Copy as {8 bit locale charset}" (bugs.os4depot.net issue #176).
- Added support for closing the current window/tab with <ESC> (bugs.os4depot.net issue #187).
- Updated SplashLauncher to version 1.3 (bugs.os4depot.net issue #117).
- Added new toolbar images and updated scripts from Martin Merz.
    

Related Links
· More about Software News
· News by ssolie


Most read story about Software News
UBoot 2010.06.04 for Sam460ex available

Last news about Software News
IBrowse 2.5 Released
Printer Friendly Page  Send this Story to a Friend

PosterThread
RacerX 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 10-Jun-2009 1:26:32
#1 ]
Super Member
Joined: 21-Aug-2003
Posts: 1158
From: Parts Unknown, USA

Cool!


_________________
'unfixed' A1XE, 512mb RAM, plug-in USB card, Sil 0680 IDE card, Radeon 9250, built-in sound, OS4.1 update 5.

 Status: Offline
Profile     Report this post  
Paul 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 10-Jun-2009 2:50:52
#2 ]
Cult Member
Joined: 7-Mar-2003
Posts: 617
From: Michigan

Using it now. It seems noticeably faster than 3.13.

Thanks for the download directory tooltype. Might seem like a little change, but it reallly makes usage more elegant.

So far so good here on Amigaworld.

Thanks joerg!

Paul


_________________
Builder of Frankenthousand, the monster A1000
The Young Frankenthousand A1-XE G4

 Status: Offline
Profile     Report this post  
Kicko 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 10-Jun-2009 6:26:07
#3 ]
Elite Member
Joined: 19-Jun-2004
Posts: 5008
From: Sweden

Thanks mate. feels faster. hotmail loads for the first time but have problems with reading mails and some other.

Thanks

 Status: Offline
Profile     Report this post  
KimmoK 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 10-Jun-2009 7:08:09
#4 ]
Elite Member
Joined: 14-Mar-2003
Posts: 5109
From: Ylikiiminki, Finland

I wonder what HW was used when doing this:
http://amigaowb.googlepages.com/screenshot2.png


_________________
- KimmoK
// For freedom, for honor, for AMIGA
//
// Thing that I should find more time for: CC64 - 64bit Community Computer?

 Status: Offline
Profile     Report this post  
mausle 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 10-Jun-2009 8:37:03
#5 ]
Regular Member
Joined: 12-Sep-2003
Posts: 139
From: Unknown

Nice to see that people start working together by reusing each others code.

Btw. when first reading the news I thought that "the OWB web site" would
lead to this place http://www.sand-labs.org/owb

ciao

Last edited by mausle on 10-Jun-2009 at 11:09 AM.

 Status: Offline
Profile     Report this post  
ikir 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 10-Jun-2009 9:46:09
#6 ]
Elite Member
Joined: 18-Dec-2002
Posts: 5646
From: Italy


_________________
Amiga News.it
Sam460ex 1,15Ghz
2GB RAM, 120GB Crucial v4 SSD, 32GB SDHC
Radeon HD 6450 1GB

 Status: Offline
Profile     Report this post  
d0c 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 10-Jun-2009 10:45:49
#7 ]
Cult Member
Joined: 8-Sep-2004
Posts: 896
From: UK

its a beginning and thats good but it have a loooooooooong way to go yet. until we get the firefox standards of a modern web browser.


_________________
I was a ZX Spectrum owner....

 Status: Offline
Profile     Report this post  
cv643d 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 10-Jun-2009 13:44:45
#8 ]
Regular Member
Joined: 29-May-2009
Posts: 262
From: Stockholm - Sweden

Very nice!

I knew download dirs would be implemented in the future! Been missing that one a lot

Great work!

 Status: Offline
Profile     Report this post  
AmigaClyde 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 10-Jun-2009 18:12:54
#9 ]
Elite Member
Joined: 8-Mar-2003
Posts: 2007
From: Noranda Canada

Thanks for this excellent browser.
Keep up the great work.


_________________
---------
AmigaClyde

A1-C 750GX@800 using OS4.1

 Status: Offline
Profile     Report this post  
MichaelMerkel 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 10-Jun-2009 18:20:57
#10 ]
Cult Member
Joined: 9-Mar-2003
Posts: 811
From: Ilvesheim, Germany

well done!
i just though middle clicking would work noe (opening a new tab). but it does not open a new tab... maybe next time?

byebye...

Last edited by MichaelMerkel on 10-Jun-2009 at 06:27 PM.


_________________
Michael Merkel
(Michael.Merkel@gmx.net Home)
Member of Amiga-Freunde Pfalz, OS4 Welt

 Status: Offline
Profile     Report this post  
HKvalhe 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 10-Jun-2009 20:10:08
#11 ]
Regular Member
Joined: 2-Apr-2009
Posts: 483
From: Norway

Ah, excellent! This is getting better and better! Wonderful!


_________________
Probably Pegasos 2 G4 1Ghz 1GB DDR-system, ATI Radeon 9250, ESI@Juli PCi-soundcard, all running
AmigaOS 4.1 with latest updates, or a new powerful
Amiga! Fingers crossed!

 Status: Offline
Profile     Report this post  
Hans 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 11-Jun-2009 0:43:13
#12 ]
Elite Member
Joined: 27-Dec-2003
Posts: 4912
From: New Zealand

@KimmoK

Quote:
I wonder what HW was used when doing this:
http://amigaowb.googlepages.com/screenshot2.png


I just tried the acid3 test on my A1-XE G4, and it took about 6 seconds. However, I didn't get the popup window at the end.

Hans

Last edited by Hans on 11-Jun-2009 at 01:01 AM.


_________________
http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more. Home of the RadeonHD driver for Amiga OS 4.x project.
https://keasigmadelta.com/ - More of my work.

 Status: Offline
Profile     Report this post  
salass00 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 11-Jun-2009 4:30:17
#13 ]
Elite Member
Joined: 31-Oct-2003
Posts: 2699
From: Finland

@MichaelMerkel

Quote:

i just though middle clicking would work noe (opening a new tab). but it does not open a new tab... maybe next time?


Probably you have it configured as context menu key (no CONTEXTMENURMB tooltype), because it works here.

 Status: Offline
Profile     Report this post  
sundown 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 11-Jun-2009 5:51:17
#14 ]
Elite Member
Joined: 30-Aug-2003
Posts: 5112
From: Right here...

OWB doesn't know the date or time here. A minor problem if your checking an online TV guide or sports scores.


_________________
Hate tends to make you look stupid...

 Status: Offline
Profile     Report this post  
MichaelMerkel 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 11-Jun-2009 8:19:46
#15 ]
Cult Member
Joined: 9-Mar-2003
Posts: 811
From: Ilvesheim, Germany

Quote:
Probably you have it configured as context menu key (no CONTEXTMENURMB tooltype), because it works here.


no. i use the rmb for ctx menus (this should be the default, btw!).
middle mouse button loads the link but not in a new tab.

byebye...


_________________
Michael Merkel
(Michael.Merkel@gmx.net Home)
Member of Amiga-Freunde Pfalz, OS4 Welt

 Status: Offline
Profile     Report this post  
Jamie_S 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 11-Jun-2009 16:50:50
#16 ]
Cult Member
Joined: 26-Oct-2003
Posts: 793
From: Purbeck, UK

@Hans
Quote:
I just tried the acid3 test on my A1-XE G4, and it took about 6 seconds. However, I didn't get the popup window at the end.

Hans

I thought the popup wasn't working when I tried it but I found that you need to click on the text 'Acid' and it appears.

@Joerg Great progress on OWB.. look forward to when we get some form of progress display/cancel ability for downloads.

Cheers


_________________
A600 OS3.1 ACA620 | '030 A1200 OS3.5 | A1-C 750GX OS4.1 | SAM460 OS4.1 | '040 A3000 OS2.1 | Christian Aid |

 Status: Offline
Profile     Report this post  
sananaman 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 11-Jun-2009 21:17:44
#17 ]
Regular Member
Joined: 28-Sep-2006
Posts: 221
From: Netherlands

Well guys, I don't know why you all are so happy with this release, but it's worse than the previous version.
I noticed that forms are not always working properly. 80% of the time when hitting the "submit" button the form "stays" on the screen acting likte he post button didn't work. But actually the "post" has been sent. Very annoying.
I also noticed a lot of "new" artifacts when pages are loading. It looks quite ugly.
Animated GIF's are having a problem when they loop...


_________________
AmigaScene.nl

 Status: Offline
Profile     Report this post  
salass00 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 12-Jun-2009 9:13:58
#18 ]
Elite Member
Joined: 31-Oct-2003
Posts: 2699
From: Finland

Quote:

no. i use the rmb for ctx menus (this should be the default, btw!).
middle mouse button loads the link but not in a new tab.


FWIW I did try clicking a link with MMB and it did open in a new tab, but apparently that link was set to open in a new window in the HTML so it would have done so on LMB as well.

 Status: Offline
Profile     Report this post  
mr_homm 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 13-Jun-2009 5:31:49
#19 ]
Regular Member
Joined: 21-Mar-2003
Posts: 180
From: Seattle

Does anyone else have a serious memory leak with this version. With OWB 3.14, if I open it and browse around for a half hour or so (I usually have 2 or 3 tabs open at once), when I check the available memory on the WB title bar, it is down from 500MB to about 10MB or so. It keeps going down, and eventually other applications cannot allocate memory they need to open. Throughout this, the system remains stable. I do not know why virtual memory doesn't kick in, as I have it set up properly (I think).

I'm also aware (from HJ Frieden's comments elsewhere) that the available memory number doesn't mean much with the new memory system, but the BEHAVIOR of not being able to open applications certainly indicates a problem. Also, when free memory approaches 2 or 3 MB, the system becomes VERY slow (probably using virtual, but then why isn't there enough memory to open new applications?)

None of the previous recent versions of OWB showed this behavior. Can anyonw verify? This is on a microA1.

Thanks!

--Stuart Anderson

 Status: Offline
Profile     Report this post  
Stephen_Robinson 
Re: Origyn Web Browser 3.14 for AmigaOS
Posted on 13-Jun-2009 10:12:32
#20 ]
Super Member
Joined: 29-Apr-2005
Posts: 1991
From: UK

I noticed the last couple, and possibly all of the releases would run down the memory as I surfin' but when I quit it all comes back.

There was a recent release that moving .gif would suck the memory out but it seems fixed for me.

So do you get the memory back when you quit?


_________________
Rage quited 29th May 2011

 Status: Offline
Profile     Report this post  
[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle