Click Here
home features news forums classifieds faqs links search
5688 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
48 crawler(s) on-line.
 8 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 m0lebrain:  6 mins ago
 Argo:  11 mins ago
 TrevorDick:  25 mins ago
 alpyre:  28 mins ago
 billt:  1 hr 43 mins ago
 freak:  2 hrs 34 mins ago
 DiscreetFX:  3 hrs 20 mins ago
 ggw:  3 hrs 36 mins ago
 Trekiej:  4 hrs 13 mins ago
 Dragster:  4 hrs 30 mins ago

Software News   Software News : LoView 1.79 OUT!
   posted by Tuxedo on 26-Apr-2010 23:21:35 (3971 reads)
Hi ALL!
I just uploaded LoView 1.79 on OS4Depot. Hope that you all can try it and tell me if like/don't like it!

OS3(68k e WOS) and AROS will be released hopefully tomorrow evening.

Read more...


Download here: http://os4depot.net/?function=showfile&file=graphics/viewer/loview.lha

Thank you!

Here the ChangeLog:

27.04.2010 v1.79
- Added time counter to display the time needed to load images,
- Added a busy pointer when the program is working,
- Added preliminary Exif TAGs support,
- Added EXIF_ORIENTATION ToolType to choose if load pics with correct orientation reading the relative Exif TAG,
- Added EXIF_LOAD,
- Added the "SinglePIC" and "NoASL" arguments from CLI,
- added a reworked and powerfull LoViewDT script (thanks to AmigaPhil for that!),
- Added a SlideShow mode with nice transition effects,
- Added Music play option in SlideShow Mode,
- Added SLIDESHOW_TIME, SLIDESHOW_FX and MID_MOUSE_ZOOM ToolTypes,
- Added a simple ContextMenu,
- Added an About window,
- Added an Info window (ATM displays only the Exif infos if presents),
- Added a window to choose the file to load from the files already scanned,
- Some code clean-up and corrected bug(s).
    

Related Links
· More about Software News
· News by Tuxedo


Most read story about Software News
UBoot 2010.06.04 for Sam460ex available

Last news about Software News
IBrowse 2.5 Released
Printer Friendly Page  Send this Story to a Friend

PosterThread
Barana 
Re: LoView 1.79 OUT!
Posted on 27-Apr-2010 1:01:05
#1 ]
Cult Member
Joined: 1-Sep-2003
Posts: 843
From: Straya!

Brilliant! thanks :)


_________________
Never underestimate the bandwidth of a station wagon full of tapes hurtling down the highway.

I serve King Jesus.
What/who do you serve?

 Status: Offline
Profile     Report this post  
Kicko 
Re: LoView 1.79 OUT!
Posted on 27-Apr-2010 8:32:20
#2 ]
Elite Member
Joined: 19-Jun-2004
Posts: 5008
From: Sweden

Nice app. Just watched my pictures in slideshow mode listening to my mp3 music :)

I see we cant select dirs with pictures but have to pick one image in the actual drawer to start showing the pictures. Would be nice if we just could choose a drawer or several to play them all (and subdirs).

Does anyone else think this is needed ?

thanks mate

 Status: Offline
Profile     Report this post  
kas1e 
Re: LoView 1.79 OUT!
Posted on 27-Apr-2010 8:40:46
#3 ]
Amiga Developer Team
Joined: 11-Jan-2004
Posts: 3380
From: Russia

@Kicko
Yes, i think it's need it, and i already say that some times to author. But, as he say, it's problem of Hollywood, which can't handle open dirs like this way, and for dirs you need open dirs, and for files, you need open files (pretty boring, yes).

He (author) also ask about fixing that in Hollywood mailing list, and, i was in sure that it already fixed with new Hollywood, but, looks like not :(


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
Seiya 
Re: LoView 1.79 OUT!
Posted on 27-Apr-2010 10:55:15
#4 ]
Super Member
Joined: 19-Aug-2006
Posts: 1416
From: Italia

release windows version too


_________________

 Status: Offline
Profile     Report this post  
Tuxedo 
Re: LoView 1.79 OUT!
Posted on 27-Apr-2010 11:22:52
#5 ]
Elite Member
Joined: 28-Nov-2003
Posts: 2321
From: Perugia, ITALY

@Kicko

Afaik Asl req dont return the path if you dont select anything in file select mode...
So you have to use the toolbar or the ContextMenu...


_________________
Simone"Tuxedo"Monsignori, Perugia, ITALY.

 Status: Offline
Profile     Report this post  
pvanni 
Re: LoView 1.79 OUT!
Posted on 27-Apr-2010 16:30:54
#6 ]
Regular Member
Joined: 25-Aug-2003
Posts: 464
From: Lecco, Italy

The toolbar images are missing from the archive, so LoView cannot found slideshow
and maybe others who can know

 Status: Offline
Profile     Report this post  
kas1e 
Re: LoView 1.79 OUT!
Posted on 27-Apr-2010 16:43:36
#7 ]
Amiga Developer Team
Joined: 11-Jan-2004
Posts: 3380
From: Russia

@pvanni
Images are from AISS archive, which everyone must setup after install os4 (dunno why they all is not on aos4.1, only few by deafult). There is


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
pvanni 
Re: LoView 1.79 OUT!
Posted on 27-Apr-2010 19:29:53
#8 ]
Regular Member
Joined: 25-Aug-2003
Posts: 464
From: Lecco, Italy

Thanks, problem solved,
there was a Data drawer in the LoView drawer, removing it solved the malfunction

 Status: Offline
Profile     Report this post  
Tuxedo 
Re: LoView 1.79 OUT!
Posted on 27-Apr-2010 19:30:48
#9 ]
Elite Member
Joined: 28-Nov-2003
Posts: 2321
From: Perugia, ITALY

@pvanni

as described on LoView.txt and as kas1e stated you have to get a full AISS install to get LoView working...

PS If you have a Data dir LoView use it as default ToolBar images location(as described on the txt)...
maybe you have an old LoVie winstall...?

Last edited by Tuxedo on 27-Apr-2010 at 07:32 PM.


_________________
Simone"Tuxedo"Monsignori, Perugia, ITALY.

 Status: Offline
Profile     Report this post  
samo79 
Re: LoView 1.79 OUT!
Posted on 27-Apr-2010 22:05:32
#10 ]
Elite Member
Joined: 13-Feb-2003
Posts: 3384
From: Italy, Perugia

@Tuxedo

Do you remember when I told you to include the toolbar's images also into the archive ?
Not all user like (or have) to install the all AISS package


_________________
BACK FOR THE FUTURE

http://www.betatesting.it/backforthefuture

Sam440ep Flex 800 Mhz 1 GB Ram + AmigaOS 4.1 Update 6
AmigaOne XE G3 800 Mhz - 640 MB Ram - Radeon 9200 SE + AmigaOS 4.1 Update 6

 Status: Offline
Profile     Report this post  
Gebrochen 
Re: LoView 1.79 OUT!
Posted on 28-Apr-2010 2:37:22
#11 ]
Super Member
Joined: 23-Nov-2008
Posts: 1410
From: Australia, VIC

@ Seiya,

Are you lost?


_________________
Courtesy of SAM440Flex & Amiga OS4.1 only
CD32 / SX1 Expansion
A500 with HxC & 1mb Chip Ram, Flicker Fixer Box
C=OS (Usa) Laptops
MorphOS PowerBook G4
AROS / AmiPUP Netbook
A1000 with 1.5MB RAM.
https://blitterwolf.blogspot.com

 Status: Offline
Profile     Report this post  
Gebrochen 
Re: LoView 1.79 OUT!
Posted on 28-Apr-2010 2:40:05
#12 ]
Super Member
Joined: 23-Nov-2008
Posts: 1410
From: Australia, VIC

@ Tuxedo:

Nice program, I will use it in conjunction with warpview, look here, eye viewer and my other programs for images, amiphoto, there were a couple of others.

Im at work so cant check what I have in my docky menu system - dockies.

cheers


_________________
Courtesy of SAM440Flex & Amiga OS4.1 only
CD32 / SX1 Expansion
A500 with HxC & 1mb Chip Ram, Flicker Fixer Box
C=OS (Usa) Laptops
MorphOS PowerBook G4
AROS / AmiPUP Netbook
A1000 with 1.5MB RAM.
https://blitterwolf.blogspot.com

 Status: Offline
Profile     Report this post  
Seiya 
Re: LoView 1.79 OUT!
Posted on 28-Apr-2010 15:52:21
#13 ]
Super Member
Joined: 19-Aug-2006
Posts: 1416
From: Italia

becuase it'is a good image viewer as lookhere for windwos, so a valid alternative softwares
and a win software realized with amiga

Last edited by Seiya on 28-Apr-2010 at 03:54 PM.
Last edited by Seiya on 28-Apr-2010 at 03:53 PM.


_________________

 Status: Offline
Profile     Report this post  
Tuxedo 
Re: LoView 1.79 OUT!
Posted on 28-Apr-2010 23:12:00
#14 ]
Elite Member
Joined: 28-Nov-2003
Posts: 2321
From: Perugia, ITALY

LOView for AROS released!
Tomorrow (I hope) arrives AmigaOS3.x 68k/WOS

Feedback welcome!


_________________
Simone"Tuxedo"Monsignori, Perugia, ITALY.

 Status: Offline
Profile     Report this post  
nikosidis 
Re: LoView 1.79 OUT!
Posted on 29-Apr-2010 19:09:23
#15 ]
Cult Member
Joined: 9-Dec-2008
Posts: 899
From: Norway, Oslo

Testing AROS version right now.
Whow, impressive work :D
busy pointer and slideshow :)

Thx and keep on the great work.

 Status: Offline
Profile     Report this post  
Tuxedo 
Re: LoView 1.79 OUT!
Posted on 29-Apr-2010 20:04:06
#16 ]
Elite Member
Joined: 28-Nov-2003
Posts: 2321
From: Perugia, ITALY

@nikosidis

Thank you!
The only problem with AROS version now was that dont support music in SlideShow mode since currently Hollywood can use mpega.library due to licensing problems...

See you next release :)

Last edited by Tuxedo on 29-Apr-2010 at 08:04 PM.


_________________
Simone"Tuxedo"Monsignori, Perugia, ITALY.

 Status: Offline
Profile     Report this post  
Tuxedo 
Re: LoView 1.79 OUT!
Posted on 29-Apr-2010 20:39:20
#17 ]
Elite Member
Joined: 28-Nov-2003
Posts: 2321
From: Perugia, ITALY

@ALL

OS3 68k/WOS was on AmiNET upload queue...


_________________
Simone"Tuxedo"Monsignori, Perugia, ITALY.

 Status: Offline
Profile     Report this post  
klx300r 
Re: LoView 1.79 OUT!
Posted on 8-May-2010 2:13:42
#18 ]
Elite Member
Joined: 4-Mar-2008
Posts: 3490
From: Toronto, Canada

I'm getting an error when I try to load LoView saying 'cannot read file nav_east!' ? Never got this on the previous version


_________________
____________________________
c64-2sids, A1000, A1200T-060@50(finally working!),A4000-CSMKIII
! My Master Miggies- Amiga 1000 & AmigaOne X1000 !
mancave-ramblings
X1000 I BELIEVE

 Status: Offline
Profile     Report this post  
[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle