Click Here
home features news forums classifieds faqs links search
5687 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
62 crawler(s) on-line.
 13 guest(s) on-line.
 2 member(s) on-line.


 Zylesea,  Fl@sh

You are an anonymous user.
Register Now!
 Fl@sh:  2 mins ago
 Zylesea:  4 mins ago
 billt:  20 mins ago
 Derfs:  24 mins ago
 NutsAboutAmiga:  37 mins ago
 mdr:  38 mins ago
 Kronos:  43 mins ago
 BSzili:  48 mins ago
 emeck:  51 mins ago
 PhantomInterrogative:  56 mins ago

hardware OS4   hardware OS4 : Cube 1: 3D FPS , bugfix release !
   posted by kas1e on 20-Nov-2010 17:18:05 (2323 reads)
10 days ago we release a port of well-known and good 3d fps game based on cube engine called "cube: 1". The news item with screenshots and videos are here.

But sadly to say, it was unplayable just because of one major bug : game uses glReadPixel() function for founding the chords with refers to Z-component, which our warp3d/minigl can't handle at all for now.

The result was bugs like "you fire in air like to the wall", "fire from grenade kill yourself", "you cant fire to anyone" and so on. So, after some pestering on forums I found one man with nickname "Tempest", who replaced the read_depth function to make it work not with glReadPixel + z_buffer, but by SANE method (sin/cos/etc), and as result we have for now, a fully working game.

So all the greetings should be gone to that man with nickname "Tempest", who was interested about all these AmigaOS4 videos, and because of that he was interested to help.

The other minor fixes:
-- new icons done by cha05e90
-- binary compiled statically (no more sobj-hell)
-- fixing archive itself (previous version was a bit badly packed, just because of some wrong bits set for some files by default).

You can grab new archive from os4depot (for the moment in upload query, so be sure that you download the new one and not the old one).

If someone can set-up a cube server for now (even on Win32, but AOS4 server binary works too), and can share for us an address and so on , we can have some fun with

For now I have only tested it locally by running the server binary, and then by starting 2 instances of the client, and connecting them to the server (just to see that both players are on the map). All was fine and works.

Enjoy !
    

Related Links
· More about hardware OS4
· News by kas1e


Printer Friendly Page  Send this Story to a Friend

PosterThread
marko 
Re: Cube 1: 3D FPS , bugfix release !
Posted on 20-Nov-2010 18:18:12
#1 ]
Super Member
Joined: 17-Dec-2007
Posts: 1794
From: Gothenburg, THE front side of Sweden ;), (via Finland), EU

Thanx!


_________________
AmigaOS 4.1 FEu1 on Sam440ep-flex 800MHz 1GB RAM
C128, A500+, A1200, A1200/40, AmigaForever 2008+09+16, 5 x86/x64 boxes
Still waiting (or dreaming) for the Amiga revolution...
m4rko.com/AMIGA

 Status: Offline
Profile     Report this post  
Tuxedo 
Re: Cube 1: 3D FPS , bugfix release !
Posted on 20-Nov-2010 19:07:40
#2 ]
Elite Member
Joined: 28-Nov-2003
Posts: 2321
From: Perugia, ITALY

Well done!


_________________
Simone"Tuxedo"Monsignori, Perugia, ITALY.

 Status: Offline
Profile     Report this post  
Templario 
Re: Cube 1: 3D FPS , bugfix release !
Posted on 20-Nov-2010 22:13:26
#3 ]
Elite Member
Joined: 22-Jun-2004
Posts: 3422
From: Palencia (Spain)

Good job friend!


_________________
Amiga 500 with ROMs 1.3-2.05 and M-Tec AT500 with hard disk and 4MB Ram.
WinUAE + original OS 3.5&3.9
Sam440ep 800 MHZ + OS 4.1 F.E.
Sam460ex 1 GHz + OS 4.1 F.E.
MacMini 1.5 GHz + MorphOS 3.12
PowerBook G4 1.65 + MorphOS 3.12

 Status: Offline
Profile     Report this post  
QuBe 
Re: Cube 1: 3D FPS , bugfix release !
Posted on 21-Nov-2010 7:24:36
#4 ]
Super Member
Joined: 3-Dec-2006
Posts: 1063
From: Dunes of Uridia

Continue with this development, your engine and game will help sculpt the future of Amiga gaming...

Q!

"i am home"

 Status: Offline
Profile     Report this post  
VooDoo 
Re: Cube 1: 3D FPS , bugfix release !
Posted on 21-Nov-2010 7:43:45
#5 ]
Super Member
Joined: 16-Jun-2003
Posts: 1495
From: Croatia

Thanx for new version I like this game!


_________________
--
A1200 sandwich :)

uA1c/g3-800 mHz/512mb/160gb hdd/OS4.1 Final + upd #1

MacMini G4 1.5ghz 1GB ram + MorphOS 3.9

Croatian Amiga portal

 Status: Offline
Profile     Report this post  
klx300r 
Re: Cube 1: 3D FPS , bugfix release !
Posted on 21-Nov-2010 17:50:30
#6 ]
Elite Member
Joined: 4-Mar-2008
Posts: 3490
From: Toronto, Canada

..working much better now on the complex maps with my Samflex@800


_________________
____________________________
c64-2sids, A1000, A1200T-060@50(finally working!),A4000-CSMKIII
! My Master Miggies- Amiga 1000 & AmigaOne X1000 !
mancave-ramblings
X1000 I BELIEVE

 Status: Offline
Profile     Report this post  
Nuder_Try 
Re: Cube 1: 3D FPS , bugfix release !
Posted on 21-Nov-2010 21:44:24
#7 ]
Cult Member
Joined: 8-Sep-2003
Posts: 524
From: Wisconsin (Moo!!!)

Would like to try this, but the game is too dark to see. The gamma editing doesn't work on my machine. Anythings I should look for?

Thanks!


_________________
This sig. intentionally left blank

 Status: Offline
Profile     Report this post  
[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle