Click Here
home features news forums classifieds faqs links search
5630 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel

Who's Online
 58 guest(s) on-line.
 2 member(s) on-line.


 Frank,  sicky

You are an anonymous user.
Register Now!
 sicky:  2 mins ago
 Frank:  3 mins ago
 densho:  47 mins ago
 sTix:  1 hr 47 mins ago
 Fl@sh:  1 hr 53 mins ago
 Argo:  3 hrs 41 mins ago
 RobertB:  3 hrs 53 mins ago
 saipaman4366:  4 hrs 31 mins ago
 tygre:  6 hrs 44 mins ago
 Rob:  7 hrs 30 mins ago

software OS4   software OS4 : NetSurf 3.0 released
   posted by Chris_Y on 25-Apr-2013 17:58:09 (2259 reads)
NetSurf is a small, fast, CSS capable web browser for AmigaOS 4 and other platforms. The OS4 version has an OS4 native GUI and does not require AmiCygnix.

Click read more


NetSurf 3.0 contains many changes over the 2.x release series. The biggest difference is the use of our new Document Object Model library, LibDOM. This new library is a foundation that paves the way for us to implement a fully dynamic layout engine in the future. Other improvements in NetSurf 3.0 include completely new textarea support, ability to fetch and parse CSS in parallel with HTML documents, extensive behind-the-scenes refactoring, and a host of smaller changes and fixes. A more complete listing is available in the Change Log.

Download
NB: This is a "semi-unofficial" build with early JavaScript support. There may be an "official" build from the more well-tested CI server at a later date.
    

Related Links
· More about software OS4
· News by Chris_Y


Most read story about software OS4
Homebank 4.4 for AmiCygnix released

Last news about software OS4
Dir Me Up 3.96 released for AmigaOS 4.1!
Printer Friendly Page  Send this Story to a Friend

PosterThread
pavlor 
Re: NetSurf 3.0 released
Posted on 25-Apr-2013 18:26:22
#1 ]
Elite Member
Joined: 10-Jul-2005
Posts: 8963
From: Unknown

Good work!

 Status: Offline
Profile     Report this post  
Toaks 
Re: NetSurf 3.0 released
Posted on 25-Apr-2013 18:51:08
#2 ]
Elite Member
Joined: 10-Mar-2003
Posts: 8037
From: amigaguru.com

great work chris , i am confused about why you mention that this version doesn't use amicygnix ... i didn't know the older ones used it, did they???????


_________________
See my blog and collection website! . https://www.blog.amigaguru.com

 Status: Offline
Profile     Report this post  
djrikki 
Re: NetSurf 3.0 released
Posted on 25-Apr-2013 20:00:59
#3 ]
Elite Member
Joined: 22-Jun-2010
Posts: 2077
From: Grimsby, UK

Found out from my work experience colleague that NetSurf runs on the Raspberry Pi so yes it derives from the X11 window system which yes AmiCygnix is itself based on.


_________________

 Status: Offline
Profile     Report this post  
Toaks 
Re: NetSurf 3.0 released
Posted on 25-Apr-2013 20:07:40
#4 ]
Elite Member
Joined: 10-Mar-2003
Posts: 8037
From: amigaguru.com

ok but on Amiga???


_________________
See my blog and collection website! . https://www.blog.amigaguru.com

 Status: Offline
Profile     Report this post  
wawa 
Re: NetSurf 3.0 released
Posted on 25-Apr-2013 20:42:12
#5 ]
Elite Member
Joined: 21-Jan-2008
Posts: 6140
From: Unknown

on amiga netsurf si still sdl unfortunately.

 Status: Offline
Profile     Report this post  
Moxee 
Re: NetSurf 3.0 released
Posted on 25-Apr-2013 20:52:19
#6 ]
Team Member
Joined: 20-Aug-2003
Posts: 6291
From: County Yakima, WA State, USA

Chris

_____________
Moxee


_________________
Moxee
AmigaOne X1000
AmigaOne XE G4
I'd agree with you, but then we'd both be wrong.

 Status: Offline
Profile     Report this post  
Chris_Y 
Re: NetSurf 3.0 released
Posted on 25-Apr-2013 21:24:20
#7 ]
Elite Member
Joined: 21-Jun-2003
Posts: 3132
From: Beds, UK

Quote:
Toaks wrote:
great work chris , i am confused about why you mention that this version doesn't use amicygnix ... i didn't know the older ones used it, did they???????


No, my native version never has. However there is a build included with AmiCygnix which is the gtk version. Some people thought that was the only version apparently, so I was trying to avoid confusion.

Quote:
wawa wrote:
on amiga netsurf si still sdl unfortunately.


And that's the other source of confusion which I didn't mention this time. There is a 68k version which is SDL (framebuffer frontend). The OS4 version has never used SDL and there is no relationship between the OS4 and OS3 (68k) frontends.

Last edited by Chris_Y on 25-Apr-2013 at 09:25 PM.


_________________
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar is Tabitha by Eric W Schwartz

 Status: Offline
Profile     Report this post  
Toaks 
Re: NetSurf 3.0 released
Posted on 25-Apr-2013 21:33:50
#8 ]
Elite Member
Joined: 10-Mar-2003
Posts: 8037
From: amigaguru.com

@chris

thanks, that was what i thought.

off to play with it some more


_________________
See my blog and collection website! . https://www.blog.amigaguru.com

 Status: Offline
Profile     Report this post  
scabit 
Re: NetSurf 3.0 released
Posted on 26-Apr-2013 3:14:15
#9 ]
Super Member
Joined: 8-Jan-2005
Posts: 1667
From: Satellite Beach, FL USA

Doesn't work for me at all. I ran the installer and gave it a new directory (I had version 2.9 loaded previously), it installed the .so files, etc and the install completed.
When I ran it the first time, it went through and parsed and fonts...took several seconds. Then I get this error:
"The tree was unable to be correctly loaded". I click OK and get another error:

"An unexpected error occured"

Thats it. No internet access in netsurf. THe window opens but remains blank.


_________________
AmigaOne uA1-c 512M RAM - Only Amiga Makes It Possible!
Check my blog AmigaOne Computing

 Status: Offline
Profile     Report this post  
hUMUNGUs 
Re: NetSurf 3.0 released
Posted on 26-Apr-2013 8:22:43
#10 ]
Member
Joined: 27-Nov-2012
Posts: 35
From: Norway

Remove 2.9, install 3.0 from scratch ! Try that.

 Status: Offline
Profile     Report this post  
elwood 
Re: NetSurf 3.0 released
Posted on 26-Apr-2013 12:55:28
#11 ]
Elite Member
Joined: 17-Sep-2003
Posts: 3417
From: Lyon, France

The installer was updated. Download again and install...


_________________
Philippe 'Elwood' Ferrucci
Sam460 1.10 Ghz
AmigaOS 4 betatester
Amiga Translator Organisation

 Status: Offline
Profile     Report this post  
lionstorm 
Re: NetSurf 3.0 released
Posted on 27-Apr-2013 15:55:01
#12 ]
Super Member
Joined: 31-Jul-2003
Posts: 1555
From: the french side

excellent !
even better with favorites bar, even if it was not that easy to set up !

thanks Chris and the rest of the Netsurf team.

 Status: Offline
Profile     Report this post  
PR 
Re: NetSurf 3.0 released
Posted on 27-Apr-2013 19:01:06
#13 ]
Super Member
Joined: 1-Sep-2004
Posts: 1914
From: Suomi-Finland

So is this the pc-killer so they can be ditched away? Install straight on OS4?

Dreaming maybe...

 Status: Offline
Profile     Report this post  
scabit 
Re: NetSurf 3.0 released
Posted on 28-Apr-2013 12:36:17
#14 ]
Super Member
Joined: 8-Jan-2005
Posts: 1667
From: Satellite Beach, FL USA

I reinstalled Netsurf 3.0 yesterday and still get the exact same errors:

"The tree was unable to be correctly loaded". I click OK and get another error:

"An unexpected error occured"

Thats it. No internet access in netsurf. THe window opens but remains blank.


I have a micro A1 with 512M RAM. All previous versions of Netsurf worked (and no longer do now by the way).
Any idea why it doesn't work? Am I missing a required library or something?


_________________
AmigaOne uA1-c 512M RAM - Only Amiga Makes It Possible!
Check my blog AmigaOne Computing

 Status: Offline
Profile     Report this post  
Chris_Y 
Re: NetSurf 3.0 released
Posted on 29-Apr-2013 7:54:55
#15 ]
Elite Member
Joined: 21-Jun-2003
Posts: 3132
From: Beds, UK

@scabit

Rename users/Default/Hotlist and try again.

A fresh install into a new directory (as suggested above) would also work.


_________________
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar is Tabitha by Eric W Schwartz

 Status: Offline
Profile     Report this post  
amigang 
Re: NetSurf 3.0 released
Posted on 29-Apr-2013 10:29:22
#16 ]
Super Member
Joined: 12-Jan-2005
Posts: 1437
From: Cheshire, England

Very nice update. Very quick on my x1000, thanks.


_________________
AmigaNG, YouTube, Software

 Status: Offline
Profile     Report this post  
Coder 
Re: NetSurf 3.0 released
Posted on 1-May-2013 21:10:13
#17 ]
Team Member
Joined: 15-May-2003
Posts: 4523
From: The Netherlands

Installation worked great and I am using it to post here. So far it runs fine on my A1SE.

Coder


_________________
Can't get enough of me?
The Bucket Diary Blog
The Bucket Diary Twitter Account

 Status: Offline
Profile     Report this post  
[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle