Click Here
home features news forums classifieds faqs links search
5654 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
» Home
» Features
» News
» Forums
» Classifieds
» Links
» Downloads
Extras
» OS4 Zone
» IRC Network
» AmigaWorld Radio
» Newsfeed
» Top Members
» Amiga Dealers
Information
» About Us
» FAQs
» Advertise
» Polls
» Terms of Service
» Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
48 crawler(s) on-line.
 18 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 _ThEcRoW:  11 mins ago
 Argo:  25 mins ago
 Lazi:  26 mins ago
 LarsB:  40 mins ago
 Petah:  46 mins ago
 Musashi5150:  1 hr 4 mins ago
 murakami:  1 hr 13 mins ago
 kolla:  1 hr 16 mins ago
 OlafS25:  1 hr 42 mins ago
 kamelito:  1 hr 48 mins ago

Software News   Software News : AHI v6.0 released
   posted by Anonymous on 22-Nov-2005 17:31:14 (4966 reads)
Martin Blom has released v6.0 of his audio driver software AHI.

There are version for AmigaOS4, AmigaOS3, MorphOS and AROS available.

News & recent changes [Read on]


Here are all the major changes since the last stable release, v4:

o Anti-click mixing routines, which makes AHI search for a zero-crossing before playing a new note
o Playback of 32 bit samples.
o Multi-channel audio. Eight channels are supported.
o Support for four more architectures: MorphOS/PPC, AmigaOS4/PPC, Amithlon/ix86, AROS/ix86.
o Support for PowerPC accelerator cards (MorphOS and AmigaOS4 only).
o A new driver, device.audio, can be used to make all low-level AHI applications, which normally open AHI in exclusive mode, behave as if they used the high-level API which allows several AHI applications to work simultaneously.
o The 68000 processor is no longer supported; a 68020 or better is required.

For a full log of everything that has been updated, see the ChangeLog file below.
    

Related Links
· More about Software News



Most read story about Software News
UBoot 2010.06.04 for Sam460ex available

Last news about Software News
IBrowse 2.5 Released
Printer Friendly Page  Send this Story to a Friend

Goto page ( 1 | 2 )

PosterThread
Anonymous 
Re: AHI v6.0 released
Posted on 22-Nov-2005 17:49:12
# ]



Aaargh, can one of the mods please fix my links (again)

The "target=_blank" part doesn't need to be in the site's name

Just click the Changelog link, it will bring you to the site, too

Hurray, AHI 6...

 
     Report this post  
PEB 
Re: AHI v6.0 released
Posted on 22-Nov-2005 17:50:00
#2 ]
Cult Member
Joined: 8-Mar-2003
Posts: 502
From: Unknown

Thanks, Martin, for your continued support of OS4.

 Status: Offline
Profile     Report this post  
firbodi 
Re: AHI v6.0 released
Posted on 22-Nov-2005 18:03:31
#3 ]
Super Member
Joined: 2-Sep-2003
Posts: 1046
From: Planet Earth!

Quote:

The 68000 processor is no longer supported; a 68020 or better is required.


Ohhh Noooo! My A600 hurts now!

Just kidding! A LOT for your great work!!

Firbodi

Last edited by firbodi on 22-Nov-2005 at 06:03 PM.


_________________
MicroA1 G3, 512MB RAM, DVD-RW; and A1-SE G3,512MB RAM, CD-RW & DVD-ROM
Avatar: Perspolis, Capital of Achaemenid Empire 500 B.C.

 Status: Offline
Profile     Report this post  
_PAB_ 
Re: AHI v6.0 released
Posted on 22-Nov-2005 18:08:34
#4 ]
Regular Member
Joined: 20-Sep-2003
Posts: 189
From: Germany

Great to see a full release of the long awaited AHI v6 !
Multi-channel support is a very nice feature, which is already implemented in some OS4 soundcard-drivers.
I hope DVPlayer will support this, too.


_________________

 Status: Offline
Profile     Report this post  
wegster 
Re: AHI v6.0 released
Posted on 22-Nov-2005 18:20:01
#5 ]
Elite Member
Joined: 29-Nov-2004
Posts: 8554
From: RTP, NC USA

@Raziel - links fixed.

Glad to see this released! Been using the beta for a while now..


_________________
Are we not done with the same silly arguments and flames yet??!

 Status: Offline
Profile     Report this post  
number6 
Re: AHI v6.0 released
Posted on 22-Nov-2005 18:22:18
#6 ]
Elite Member
Joined: 25-Mar-2005
Posts: 10652
From: In the village

@Martin

Thank you very much for the update and your continued support.
I particularly appreciate the updated webpage.
This will make things much easier for people to understand which file/s
they need to download.

Best Wishes,
#6


_________________
This posting, in its entirety, represents solely the perspective of the author.
*Secrecy has served us so well*

 Status: Offline
Profile     Report this post  
VooDoo 
Re: AHI v6.0 released
Posted on 22-Nov-2005 19:25:06
#7 ]
Super Member
Joined: 16-Jun-2003
Posts: 1495
From: Croatia

Martin thanx on great work..


_________________
--
A1200 sandwich :)

uA1c/g3-800 mHz/512mb/160gb hdd/OS4.1 Final + upd #1

MacMini G4 1.5ghz 1GB ram + MorphOS 3.9

Croatian Amiga portal

 Status: Offline
Profile     Report this post  
TrevorDick 
Re: AHI v6.0 released
Posted on 22-Nov-2005 19:41:09
#8 ]
Elite Member
Joined: 30-Dec-2004
Posts: 2663
From: Wellington

Many thanks Martin.

I have just downloaded the 0S3 & 0S4 versions and made a small donation by Paypal.

TrevorDick


_________________
No, I don't need no reason, I'm just breezin'

 Status: Offline
Profile     Report this post  
ChrisH 
Re: AHI v6.0 released
Posted on 22-Nov-2005 22:18:14
#9 ]
Elite Member
Joined: 30-Jan-2005
Posts: 6673
From: Unknown

"A new driver, device.audio, can be used to ... allows several AHI applications to work simultaneously."

WOOOOOOOOOH! This is a major new feature, and something which has always been greatly lacking on the Amiga compared to other OSes, so I am very glad to see that it is finally addressed

So I can now have DeliTracker playing music, and not have to worry about JabberWocky (or whatever) playing a sound (which would usually freeze whatever was trying to play a sound).

BTW, hopefully this means that I can now have Paula emulation (PuhDerBaer or NallePUH) running all the time, without it preventing normal AHI apps from working.

Last edited by ChrisH on 22-Nov-2005 at 10:22 PM.


_________________
Author of the PortablE programming language.
I can usually be found on www.Amigans.net (my favourite Amiga forum).
It is pitch black. You are likely to be eaten by a grue...

 Status: Offline
Profile     Report this post  
Curty 
Re: AHI v6.0 released
Posted on 22-Nov-2005 22:42:41
#10 ]
Super Member
Joined: 20-Dec-2003
Posts: 1202
From: South Wales. UK

Cool, ill try it soon.


_________________
A1XE G4 800mhz,512mb,Radeon9200,SonyDRU-510A and 800a,ESI Juli@, Sil680, WiFi.

 Status: Offline
Profile     Report this post  
Moxee 
Re: AHI v6.0 released
Posted on 23-Nov-2005 1:15:08
#11 ]
Team Member
Joined: 20-Aug-2003
Posts: 6291
From: County Yakima, WA State, USA

Very nice, Martin


_________________
Moxee
AmigaOne X1000
AmigaOne XE G4
I'd agree with you, but then we'd both be wrong.

 Status: Offline
Profile     Report this post  
BlackNinja 
Re: AHI v6.0 released
Posted on 23-Nov-2005 1:44:58
#12 ]
Regular Member
Joined: 2-May-2005
Posts: 123
From: Germany

Thanks for the Final Version of Ahi 6.0. Has AHi 5.1 surround support, or only 7.1?

Last edited by BlackNinja on 23-Nov-2005 at 01:48 AM.
Last edited by BlackNinja on 23-Nov-2005 at 01:46 AM.

 Status: Offline
Profile     Report this post  
sundown 
Re: AHI v6.0 released
Posted on 23-Nov-2005 6:07:48
#13 ]
Elite Member
Joined: 30-Aug-2003
Posts: 5112
From: Right here...

Martin


_________________
Hate tends to make you look stupid...

 Status: Offline
Profile     Report this post  
AmigaHeretic 
Re: AHI v6.0 released
Posted on 23-Nov-2005 7:33:26
#14 ]
Super Member
Joined: 7-Mar-2003
Posts: 1697
From: Oregon

Thanks Martin been waiting a while for this, you're awsome!

Everything working good except on my WinUAE setup (which I also carry a version of on my usb pen drive to use at work).

Copied everything over and when I first play a sound using any program or even if I just open AHI prefs it says it "can't find openpci.libary v1" I have version 1.0 and even tried installed the newer version 2.0 and still get the same message. It only says it the first time and then everything works great, until I restart, then it does it again the first time I play something, but never comes back until a restart. Any one have any ideas? Also, the uae.device I have is 4.2, is there a different version I should have? I tried using device.audio instead of uae.audio and the sound is very shakey even on my AMD64 3000+ system, do I need to use device.audio to get all the new features? I get the error message using either device though. Should I have started a forum post for this?

Amiga_Guy


_________________
A3000D (16mhz, 2MB Chip, 4MB Fast, SCSI (300+MB), SuperGen Genlock, Kick 3.1)
---------------------------------------------------------------------------
Back in my day, we didn't have water. We only had Oxygen & Hydrogen, & we'd just shove 'em together

 Status: Offline
Profile     Report this post  
Condor 
Re: AHI v6.0 released
Posted on 23-Nov-2005 7:40:47
#15 ]
Regular Member
Joined: 28-Feb-2004
Posts: 189
From: Zagreb, Croatia

Thank you for new version of AHI.
Great work!!!!


_________________
Amiga_Os3-Os4-Mos User!!!

 Status: Offline
Profile     Report this post  
Trixie 
Re: AHI v6.0 released
Posted on 23-Nov-2005 8:31:13
#16 ]
Amiga Developer Team
Joined: 1-Sep-2003
Posts: 1805
From: Czech Republic

Quote:
"can't find openpci.libary v1"

Remove the EMU10k audio driver, you donť need it under WinUAE anyway.


_________________
Smoke me a kipper, I'll be back for breakfast!

AmigaOne X5000/020 @ 2GHz / 4GB RAM / Radeon RX 560 / ESI Juli@ / AmigaOS 4.1 Final Edition
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition

 Status: Offline
Profile     Report this post  
emavys 
Re: AHI v6.0 released
Posted on 23-Nov-2005 8:34:52
#17 ]
Regular Member
Joined: 7-Dec-2003
Posts: 224
From: La Coruña (a nice place in the North-West coast of Spain)

Great news but I have one question, in the ChangeLog says that in 2003-10-16 Martin Blom Released paula.audio 4.31.

Is this a special version for MorphOS or is for classic Amiga?
If it is for the classic where can I find it? The newest version I could find is 4.29 wich is located in the beta directory of ahi in the drivers section.

So is there anybody out there who knows where can I download this paula.audio 4.31?

 Status: Offline
Profile     Report this post  
Kicko 
Re: AHI v6.0 released
Posted on 23-Nov-2005 11:07:46
#18 ]
Elite Member
Joined: 19-Jun-2004
Posts: 5008
From: Sweden

Thanks Martin for one of the best things we do use daily for our
amigaOS'es. Makes the sound come thru with amiga quality :)

 Status: Offline
Profile     Report this post  
kas1e 
Re: AHI v6.0 released
Posted on 23-Nov-2005 11:50:27
#19 ]
Amiga Developer Team
Joined: 11-Jan-2004
Posts: 3344
From: Russia

Maybe i do not understand some :) but, i try to run with ne drivers (for example) octamed, and next try to run ArtKanoid, Artkanoid said - can't open ahi.device. It is normally ?:) I use a1200 with paula.

also i try to run digibooster and octamed in the same time, and try to play module in octamed, have 'can't allocate audio channels'.

Well, if i understand correctly, still only one app per ahi ?:) Or i am wrong and just can't setup somethink ?:)

Last edited by kas1e on 23-Nov-2005 at 01:11 PM.


_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites

 Status: Offline
Profile     Report this post  
Mr_Capehill 
Re: AHI v6.0 released
Posted on 23-Nov-2005 13:14:50
#20 ]
Super Member
Joined: 15-Mar-2003
Posts: 1922
From: Yharnam

Because OctaMED doesn't use AHI at all and it will steal your audio channels. AFAIK, there is a menu option for this in OM.

 Status: Offline
Profile     Report this post  

Goto page ( 1 | 2 )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle