Click Here
home features news forums classifieds faqs links search
5832 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
» Home
» Features
» News
» Forums
» Classifieds
» Links
» Downloads
Extras
» OS4 Zone
» IRC Network
» AmigaWorld Radio
» Newsfeed
» Top Members
» Amiga Dealers
Information
» About Us
» FAQs
» Advertise
» Polls
» Terms of Service
» Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
29 crawler(s) on-line.
 11 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 Trekiej:  11 mins ago
 DiscreetFX:  40 mins ago
 eliyahu:  53 mins ago
 billt:  2 hrs 28 mins ago
 Jasper:  2 hrs 38 mins ago
 Fl@sh:  2 hrs 42 mins ago
 BigD:  3 hrs 19 mins ago
 OlafS25:  3 hrs 33 mins ago
 NutsAboutAmiga:  4 hrs 12 mins ago
 Rob:  4 hrs 27 mins ago

Software News   Software News : MPlayer 1April Version is ready to download
   posted by afxgroup on 1-Apr-2009 18:33:16 (6471 reads)
A new version of mplayer is ready to download
These are the main changes between the last version

MPlayer 1.0rc3 for AmigaOS4
01-04-2009
* Should be really faster than previous version (due a faster ffmpeg.. ;)
* Fixed fullscreen mouse pointer hide/show when click the mouse
* Now if you press "c"..
* Fixed Fullscreen play
* Updated to the mplayer last version
* Fixed Arexx port. Now the Daniel GUI should work ok
- Thanks to Fab for his Morphos port of Mplayer that is a lot enhanced and faster.. :)
(more)


There is also a new dvdnav:// dvd menu functionality but i suggest you to use the the old dvd:// method

Dowload here

and.. is not a joke..
    

Related Links
· More about Software News
· News by afxgroup


Most read story about Software News
UBoot 2010.06.04 for Sam460ex available

Last news about Software News
IBrowse 2.5 Released
Printer Friendly Page  Send this Story to a Friend

Goto page ( 1 | 2 )

PosterThread
Varthall 
Re: MPlayer 1April Version is ready to download
Posted on 2-Apr-2009 8:29:02
#1 ]
Super Member
Joined: 17-Feb-2004
Posts: 1552
From: Up Rough

Bravo afx... a most welcomed update, lots of people will appreciate your work :)

Varthall


_________________
AmigaOne XE - AmigaOS 4.1 - Freescale 7457 1GHz - 1GB ram
MPlayer for OS4: https://sourceforge.net/projects/mplayer-amigaos/

 Status: Offline
Profile     Report this post  
afxgroup 
Re: MPlayer 1April Version is ready to download
Posted on 2-Apr-2009 8:51:14
#2 ]
Super Member
Joined: 8-Mar-2004
Posts: 1965
From: Taranto, Italy

A little tip:

comment (with #) the line

menu=1

int the file

conf/config

and you will speed up all


_________________
http://www.amigasoft.net

 Status: Offline
Profile     Report this post  
ChrisH 
Re: MPlayer 1April Version is ready to download
Posted on 2-Apr-2009 9:15:58
#3 ]
Elite Member
Joined: 30-Jan-2005
Posts: 6673
From: Unknown

Very nice menu system ("c" key), especially being able to enable frame skipping... but it seems to play less videos than before? (albeit only ones which were very jerky & unwatchable before anyway, such as .mp4 files)


_________________
Author of the PortablE programming language.
I can usually be found on www.Amigans.net (my favourite Amiga forum).
It is pitch black. You are likely to be eaten by a grue...

 Status: Offline
Profile     Report this post  
ChrisH 
Re: MPlayer 1April Version is ready to download
Posted on 2-Apr-2009 9:19:19
#4 ]
Elite Member
Joined: 30-Jan-2005
Posts: 6673
From: Unknown

@afxgroup
Is there any way to set frame skipping to be permanently enabled?


_________________
Author of the PortablE programming language.
I can usually be found on www.Amigans.net (my favourite Amiga forum).
It is pitch black. You are likely to be eaten by a grue...

 Status: Offline
Profile     Report this post  
afxgroup 
Re: MPlayer 1April Version is ready to download
Posted on 2-Apr-2009 9:27:22
#5 ]
Super Member
Joined: 8-Mar-2004
Posts: 1965
From: Taranto, Italy

the menu option will slow all playing. disable it if you want tme maximum speed
for the frame skipping there is this option

framedrop = yes

you will find all you want in the example.conf file


_________________
http://www.amigasoft.net

 Status: Offline
Profile     Report this post  
number6 
Re: MPlayer 1April Version is ready to download
Posted on 2-Apr-2009 13:26:33
#6 ]
Elite Member
Joined: 25-Mar-2005
Posts: 10837
From: In the village

@afxgroup

The following, which were broken under Leitmotiv, now function correctly in MPlayer:

MPlayer for AmigaOS4 SVN-r29068-4.2.3

(1)arex stop at end of .mp3 file playback
(2)parameter "-vf screenshot" (although saving to ram: by default now, instead of progdir:)

However, on OS4 (not 4.1), pressing "esc" to quit is now producing a crash that seems to be in relation to newlib. Can you confirm?

Added: tested with both shell and
MPlayer-GUI 1.45 by Deniil715 (02/11/2009)

#6

Last edited by number6 on 02-Apr-2009 at 02:06 PM.


_________________
This posting, in its entirety, represents solely the perspective of the author.
*Secrecy has served us so well*

 Status: Offline
Profile     Report this post  
afxgroup 
Re: MPlayer 1April Version is ready to download
Posted on 2-Apr-2009 14:24:35
#7 ]
Super Member
Joined: 8-Mar-2004
Posts: 1965
From: Taranto, Italy

uhm, i don't have os4 anymore but i've found something that could crash mplayer at exit. it will be corrected on the next mplayer version


_________________
http://www.amigasoft.net

 Status: Offline
Profile     Report this post  
Kicko 
Re: MPlayer 1April Version is ready to download
Posted on 2-Apr-2009 15:51:51
#8 ]
Elite Member
Joined: 19-Jun-2004
Posts: 5009
From: Sweden

thanks mate. will check it out later

 Status: Offline
Profile     Report this post  
ChrisH 
Re: MPlayer 1April Version is ready to download
Posted on 2-Apr-2009 18:00:31
#9 ]
Elite Member
Joined: 30-Jan-2005
Posts: 6673
From: Unknown

@afxgroup
So do you have any idea why this version plays less videos than the older version? e.g. mp4 files.

All I get now is a blank screen (and maybe some audio if I am lucky), where-as before I got video (albiet very very slow & jerky video).


_________________
Author of the PortablE programming language.
I can usually be found on www.Amigans.net (my favourite Amiga forum).
It is pitch black. You are likely to be eaten by a grue...

 Status: Offline
Profile     Report this post  
number6 
Re: MPlayer 1April Version is ready to download
Posted on 2-Apr-2009 18:08:53
#10 ]
Elite Member
Joined: 25-Mar-2005
Posts: 10837
From: In the village

@ChrisH

Quote:
So do you have any idea why this version plays less videos than the older version? e.g. mp4 files.


I have this sample that we've used before for testing prior versions:
http://members.shaw.ca/michael.brooks/animations/tumblingrock.avi

Plays or no?

Added: better, more official samples here:
http://support.apple.com/kb/HT1425?viewlocale=en_US

The files all play fine here, including the MPEG-4s.

@afxgroup

I should extend this to say it was not just crash using "ESC" but also:
ALL files result in a crash at end of playback.

#6

Last edited by number6 on 02-Apr-2009 at 06:20 PM.


_________________
This posting, in its entirety, represents solely the perspective of the author.
*Secrecy has served us so well*

 Status: Offline
Profile     Report this post  
ChrisH 
Re: MPlayer 1April Version is ready to download
Posted on 2-Apr-2009 20:18:22
#11 ]
Elite Member
Joined: 30-Jan-2005
Posts: 6673
From: Unknown

@afxgroup & number6
Short/Small MP4s don't seem a good test. Try this 320x240 video (13MB).
After about 1 min 30 secs the video dies completely, and before that (about 50 seconds in) it starts to jerk a lot. It does not do this on the old MPlayer.

Larger videos, say 636 x 366 with a higher bit rate, die MUCH quicker. Try this one (6MB).
After about two seconds the video dies completely. PLEASE IGNORE THE VIDEO DISTORTION, as this is also present on the old MPlayer (which continues to play the video but very jerkily (one frame every second or so).

EDIT:
I found another example, better & worse here (56MB). Unlike the previous video it is not corrupted, and after about 20 seconds the video completely freezes. But unlike other examples it *eventually* restarts again, for a few seconds. Where-as the old MPlayer just gets very jerky very quickly. I think this is a different aspect of the same bug. Most likely it would play very fast in MPlayer if the bug was fixed, so I'd LOVE to see this fixed.

Last edited by ChrisH on 02-Apr-2009 at 08:38 PM.
Last edited by ChrisH on 02-Apr-2009 at 08:35 PM.


_________________
Author of the PortablE programming language.
I can usually be found on www.Amigans.net (my favourite Amiga forum).
It is pitch black. You are likely to be eaten by a grue...

 Status: Offline
Profile     Report this post  
afxgroup 
Re: MPlayer 1April Version is ready to download
Posted on 2-Apr-2009 21:12:13
#12 ]
Super Member
Joined: 8-Mar-2004
Posts: 1965
From: Taranto, Italy

it seems like you have the "old" vcore problem.. which hardware do you have? that's because your three files doesn't freeze nothing here. but the second one is not played correctly by mplayer.
but no freezes so far i play that files


_________________
http://www.amigasoft.net

 Status: Offline
Profile     Report this post  
ChrisH 
Re: MPlayer 1April Version is ready to download
Posted on 2-Apr-2009 21:37:50
#13 ]
Elite Member
Joined: 30-Jan-2005
Posts: 6673
From: Unknown

@afxgroup
(I assume you are talking to me)

Not sure what you mean by "old vcore problem".

I have a Sam440ep (667MHz) with OS4.1 (beta).


_________________
Author of the PortablE programming language.
I can usually be found on www.Amigans.net (my favourite Amiga forum).
It is pitch black. You are likely to be eaten by a grue...

 Status: Offline
Profile     Report this post  
afxgroup 
Re: MPlayer 1April Version is ready to download
Posted on 3-Apr-2009 11:49:56
#14 ]
Super Member
Joined: 8-Mar-2004
Posts: 1965
From: Taranto, Italy

i've seen all three files also on my SAM 533Mhz and also here i have no problem to see the entire movies
That's strange
the vcore problem on the A1 will cause instabilty and freezes when the value was too high or low on the CPU but i don't think SAM has this problem.


_________________
http://www.amigasoft.net

 Status: Offline
Profile     Report this post  
Daff 
Re: MPlayer 1April Version is ready to download
Posted on 3-Apr-2009 15:29:18
#15 ]
Regular Member
Joined: 17-Jul-2004
Posts: 117
From: Unknown

ChrisH : enable the framesckipping is not necessary the best solution in MPlayer. In some cases (most cases ?) MPlayer is smotther without, at least with the Linux and the very optimised MorphOS version.

 Status: Offline
Profile     Report this post  
number6 
Re: MPlayer 1April Version is ready to download
Posted on 3-Apr-2009 21:43:00
#16 ]
Elite Member
Joined: 25-Mar-2005
Posts: 10837
From: In the village

@ChrisH

Quote:
Larger videos, say 636 x 366 with a higher bit rate, die MUCH quicker. Try this one (6MB).After about two seconds the video dies completely. PLEASE IGNORE THE VIDEO DISTORTION, as this is also present on the old MPlayer (which continues to play the video but very jerkily (one frame every second or so).


No problem here. Plays perfectly and in sync with Leitmotiv version.
sundown is checking with current version.

MPlayer-GUI 1.45 by Deniil715 (02/11/2009)
(1) Input/file - choose the file
(2) Audio - sdl
(3) Video - sdl
(4) Extras - use framedrop

Should have no distortion and text/audio should be completely in sync at beginning of file. Yes/no?

ok. sundown had the same issues and made the changes I suggested above to current MPlayer (MPlayer for AmigaOS4 SVN-r29068-4.2.3] with the current GUI.

He's says this cured everything, for all the files he's tested so far.

#6

Last edited by number6 on 04-Apr-2009 at 03:30 PM.


_________________
This posting, in its entirety, represents solely the perspective of the author.
*Secrecy has served us so well*

 Status: Offline
Profile     Report this post  
Xenic 
Re: MPlayer 1April Version is ready to download
Posted on 4-Apr-2009 15:19:56
#17 ]
Super Member
Joined: 2-Feb-2004
Posts: 1242
From: Pennsylvania, USA

@afxgroup
Entering mplayer -help gives this message:

Warning unknown option a52volume at line 19

My old MPlayer didn't have a conf directory so I'm unsure what to do with it. I notice that the conf/fonts/fonts.conf starts with sys:fonts/_ttf
and I don't have that directory on my system. Do I need to install some fonts?

Can someone provide a list of external libraries etc. that are used my new MPlayer? It's been a long time since I installed the last version and forget what is needed.

Last edited by Xenic on 04-Apr-2009 at 03:21 PM.
Last edited by Xenic on 04-Apr-2009 at 03:20 PM.


_________________
X1000 with 2GB memory & OS4.1FE

 Status: Offline
Profile     Report this post  
number6 
Re: MPlayer 1April Version is ready to download
Posted on 4-Apr-2009 15:25:54
#18 ]
Elite Member
Joined: 25-Mar-2005
Posts: 10837
From: In the village

@Xenic

Quote:
Can someone provide a list of external libraries etc. that are used my new MPlayer?


pthreads

#6


_________________
This posting, in its entirety, represents solely the perspective of the author.
*Secrecy has served us so well*

 Status: Offline
Profile     Report this post  
Xenic 
Re: MPlayer 1April Version is ready to download
Posted on 4-Apr-2009 16:13:30
#19 ]
Super Member
Joined: 2-Feb-2004
Posts: 1242
From: Pennsylvania, USA

@ChrisH
I D/L the 6MB video and it doesn't display properly with old or new MPlayer. It looks like an old TV with the diagonal control out of adjustment (picture extremely slanted diagonally). Is there some option required to view it?


_________________
X1000 with 2GB memory & OS4.1FE

 Status: Offline
Profile     Report this post  
number6 
Re: MPlayer 1April Version is ready to download
Posted on 4-Apr-2009 16:18:14
#20 ]
Elite Member
Joined: 25-Mar-2005
Posts: 10837
From: In the village

@Xenic

Did you try the settings from my post #16 ^^

#6


_________________
This posting, in its entirety, represents solely the perspective of the author.
*Secrecy has served us so well*

 Status: Offline
Profile     Report this post  

Goto page ( 1 | 2 )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle