Click Here
home features news forums classifieds faqs links search
5768 members 
Amiga Q&A /  Free for All /  Emulation /  Gaming / (Latest Posts)
Login

Nickname

Password

Lost Password?

Don't have an account yet?
Register now!

Support Amigaworld.net
Your support is needed and is appreciated as Amigaworld.net is primarily dependent upon the support of its users.
Donate

Menu
Main sections
Home
Features
News
Forums
Classifieds
Links
Downloads
Extras
OS4 Zone
IRC Network
AmigaWorld Radio
Newsfeed
Top Members
Amiga Dealers
Information
About Us
FAQs
Advertise
Polls
Terms of Service
Search

IRC Channel
Server: irc.amigaworld.net
Ports: 1024,5555, 6665-6669
SSL port: 6697
Channel: #Amigaworld
Channel Policy and Guidelines

Who's Online
43 crawler(s) on-line.
 13 guest(s) on-line.
 0 member(s) on-line.



You are an anonymous user.
Register Now!
 MEGA_RJ_MICAL:  12 mins ago
 Barret:  16 mins ago
 DiscreetFX:  44 mins ago
 Kraftwerk2:  44 mins ago
 tygre:  1 hr 42 mins ago
 amisteph:  1 hr 57 mins ago
 The_Shadow:  2 hrs 38 mins ago
 Samurai_Crow:  2 hrs 47 mins ago
 JKD:  3 hrs 26 mins ago
 Jasper:  3 hrs 36 mins ago

Software News   Software News : MPlayer 1April Version is ready to download
   posted by afxgroup on 1-Apr-2009 17:33:16 (6431 reads)
A new version of mplayer is ready to download
These are the main changes between the last version

MPlayer 1.0rc3 for AmigaOS4
01-04-2009
* Should be really faster than previous version (due a faster ffmpeg.. ;)
* Fixed fullscreen mouse pointer hide/show when click the mouse
* Now if you press "c"..
* Fixed Fullscreen play
* Updated to the mplayer last version
* Fixed Arexx port. Now the Daniel GUI should work ok
- Thanks to Fab for his Morphos port of Mplayer that is a lot enhanced and faster.. :)
(more)


There is also a new dvdnav:// dvd menu functionality but i suggest you to use the the old dvd:// method

Dowload here

and.. is not a joke..
    

Related Links
· More about Software News
· News by afxgroup


Most read story about Software News
UBoot 2010.06.04 for Sam460ex available

Last news about Software News
IBrowse 2.5 Released
Printer Friendly Page  Send this Story to a Friend

Goto page ( 1 | 2 )

PosterThread
Xenic 
Re: MPlayer 1April Version is ready to download
Posted on 4-Apr-2009 15:19:50
#21 ]
Super Member
Joined: 2-Feb-2004
Posts: 1241
From: Pennsylvania, USA

I already have pthreads.library in SYS:Libs but the pthreads.lha file exctacts to a threads.library which I already had installed in another drawer assigned to LIBS:. Maybe I should get rid of one of them?


_________________
X1000 with 2GB memory & OS4.1FE

 Status: Offline
Profile     Report this post  
number6 
Re: MPlayer 1April Version is ready to download
Posted on 4-Apr-2009 15:25:41
#22 ]
Elite Member
Joined: 25-Mar-2005
Posts: 10832
From: In the village

@Xenic

Quote:
I already have pthreads.library in SYS:Libs but the pthreads.lha file exctacts to a threads.library which I already had installed in another drawer assigned to LIBS:. Maybe I should get rid of one of them?


Please keep in mind that I'm running OS4.0 and sundown is running OS4.1, both on MicroA1:

BOTH in my libs:
threads.library 1.4 (05/31/2005)
pthreads.library 52.2 (07/02/2007)

#6


_________________
This posting, in its entirety, represents solely the perspective of the author.
*Secrecy has served us so well*

 Status: Offline
Profile     Report this post  
Xenic 
Re: MPlayer 1April Version is ready to download
Posted on 4-Apr-2009 15:40:44
#23 ]
Super Member
Joined: 2-Feb-2004
Posts: 1241
From: Pennsylvania, USA

I was testing MPlayer from the shell, not the GUI. I just tried it with the settings you pointed out and the file now plays on a seperate screen. At the end of the video MPLayer crashed with a Grim Reaper. I'm using a A1/OS 4.1. I need to reboot before proceeding but I'll try it again and see what happens.


_________________
X1000 with 2GB memory & OS4.1FE

 Status: Offline
Profile     Report this post  
number6 
Re: MPlayer 1April Version is ready to download
Posted on 4-Apr-2009 15:46:06
#24 ]
Elite Member
Joined: 25-Mar-2005
Posts: 10832
From: In the village

@Xenic

Quote:
I was testing MPlayer from the shell, not the GUI. I just tried it with the settings you pointed out and the file now plays on a seperate screen.


ok.
(1)You can still press "f" to flip it back to WB.
(2)Is it now playing properly and in sync with my settings?
(3)Yes, the crash is consistent then whether on OS4.0 or OS4.1 using "sdl", but that seems to be the tradeoff for playing back properly, no?

#6


_________________
This posting, in its entirety, represents solely the perspective of the author.
*Secrecy has served us so well*

 Status: Offline
Profile     Report this post  
Xenic 
Re: MPlayer 1April Version is ready to download
Posted on 4-Apr-2009 15:51:05
#25 ]
Super Member
Joined: 2-Feb-2004
Posts: 1241
From: Pennsylvania, USA

My threads.library is v1.5 (08/02/2005) and I have A1/OS 4.1. I've been testing from a shell and get this error on the command line whenever I run MPlayer from the shell:

Warning unknown option a52volume at line 19

Does MPlayer use the a52.codec I have in LIBS:avcodecs directory?


_________________
X1000 with 2GB memory & OS4.1FE

 Status: Offline
Profile     Report this post  
number6 
Re: MPlayer 1April Version is ready to download
Posted on 4-Apr-2009 16:04:24
#26 ]
Elite Member
Joined: 25-Mar-2005
Posts: 10832
From: In the village

@Xenic

Quote:
My threads.library is v1.5 (08/02/2005)

Link to file please or similar.

Added: Nevermind. I answered my own question.

Quote:
Trouble is, threads.library v1.5 is in the SDK, & most ppl most likely don't have that.

from:
Which threads is which (thread libraries)?

Quote:
I've been testing from a shell and get this error on the command line whenever I run MPlayer from the shell:Warning unknown option a52volume at line 19


I'll check that on my setup for comparison sake.

Added: checked

Quote:
Warning unknown option a52volume at line 19
MPlayer SVN-r29068-4.2.3 (C) 2000-2009 MPlayer Team
131 audio & 273 video codecs


But MPlayer goes merrily on its way passed that line, so I don't think that's the same concern as the crash we're all noticing on exit/quit.
I've seen other such lines before where something is ignored and execution continues.

Quote:
Does MPlayer use the a52.codec I have in LIBS:avcodecs directory?


That's for DVPlayer.

#6

Last edited by number6 on 04-Apr-2009 at 04:28 PM.
Last edited by number6 on 04-Apr-2009 at 04:24 PM.
Last edited by number6 on 04-Apr-2009 at 04:15 PM.


_________________
This posting, in its entirety, represents solely the perspective of the author.
*Secrecy has served us so well*

 Status: Offline
Profile     Report this post  
Xenic 
Re: MPlayer 1April Version is ready to download
Posted on 4-Apr-2009 16:29:48
#27 ]
Super Member
Joined: 2-Feb-2004
Posts: 1241
From: Pennsylvania, USA

@number6
Quote:
Link to file please or similar.

I wish I knew where v 1.5 came from. My lha archive contains v1.3 and the one on OS4Depot is v1.4. My v1.5 is over 1MB in size and appears to be an unstripped debug version. If I can figure out where I got it I'll let you know. I just rebooted and retested the new MPlayer with the 6MB video and it always crashes upon completion.

I tried the old MPlayer (from a shell) with the same options and it appears to play the same but doesn't crash when done. It also streams a bunch of decoding output to the shell. The old MPlayer also has an Amiga version string which makes it easier to keep the versions straight. Maybe the new version can have an Amiga version string again in the next release. So far, the old version seems more stable on my system (no crashes).


_________________
X1000 with 2GB memory & OS4.1FE

 Status: Offline
Profile     Report this post  
number6 
Re: MPlayer 1April Version is ready to download
Posted on 4-Apr-2009 16:43:45
#28 ]
Elite Member
Joined: 25-Mar-2005
Posts: 10832
From: In the village

@Xenic

Quote:
I wish I knew where v 1.5 came from.


Please see my above post (amended) where I traced this and posted the source of the answer.

Quote:
I just rebooted and retested the new MPlayer with the 6MB video and it always crashes upon completion


Try any other A/V file. For me everything crashes on quit/exit with April version, given the settings I posted.

Quote:
I tried the old MPlayer (from a shell) with the same options and it appears to play the same but doesn't crash when done.


Correct. Leitmotiv from November, 2007 does not show the quit/exit crash with the sdl setting.

Quote:
So far, the old version seems more stable on my system (no crashes).


If you mean Leitmotiv, I think it will crash. Add in arguments "-vf screenshot" as parameter so you can take screengrabs from the A/V file while it's running by pressing "s". Afxgroup already confirmed this, as well as the failure to stop after playing .mp3 through the GUI (lack of Arexx stop now fixed in April)

#6


_________________
This posting, in its entirety, represents solely the perspective of the author.
*Secrecy has served us so well*

 Status: Offline
Profile     Report this post  
afxgroup 
Re: MPlayer 1April Version is ready to download
Posted on 5-Apr-2009 9:44:28
#29 ]
Super Member
Joined: 8-Mar-2004
Posts: 1965
From: Taranto, Italy

yes,
there are a couple of bug that will removed in the next version.
By the way, why do you use SDL for video? it is damned slow and not hardware accelerated so is the worst solution to see a video


_________________
http://www.amigasoft.net

 Status: Offline
Profile     Report this post  
ChrisH 
Re: MPlayer 1April Version is ready to download
Posted on 5-Apr-2009 9:51:19
#30 ]
Elite Member
Joined: 30-Jan-2005
Posts: 6673
From: Unknown

@number6 (post #16)
Using those settings with the OLD mplayer (Leitmotiv), I find that
1. No video distortion.
2. Audio is fine (as before).
3. Frame rate drops exponentially as time goes by, so it starts fast, but quickly deteriorates to one frame every 4 seconds, then 14 seconds, etc.

Using those settings with the NEW mplayer, I find that:
1. No video distortion.
2. Audio is fine (as before).
3. Frame rate drops VERY quickly (far quicker than old mplayer), so I get a few jerky frames of the logo, and then a white screen for ages (seems like forever).

IMHO, seems like the bug in NEW mplayer existed in OLD mplayer, but now it is much worse.

BTW, I am playing video from RAM disk.


_________________
Author of the PortablE programming language.
I can usually be found on www.Amigans.net (my favourite Amiga forum).
It is pitch black. You are likely to be eaten by a grue...

 Status: Offline
Profile     Report this post  
ChrisH 
Re: MPlayer 1April Version is ready to download
Posted on 5-Apr-2009 9:52:13
#31 ]
Elite Member
Joined: 30-Jan-2005
Posts: 6673
From: Unknown

@Xenic
The 6MB video looks wrong for me too (hence why I said VIDEO DISTORTIONS), unless I use SDL.


_________________
Author of the PortablE programming language.
I can usually be found on www.Amigans.net (my favourite Amiga forum).
It is pitch black. You are likely to be eaten by a grue...

 Status: Offline
Profile     Report this post  
number6 
Re: MPlayer 1April Version is ready to download
Posted on 5-Apr-2009 13:10:35
#32 ]
Elite Member
Joined: 25-Mar-2005
Posts: 10832
From: In the village

@afxgroup

Everything after post #11 is merely about how to see the distorted videos linked to IN post #11.
Hopefully everyone knows hw render is faster than sw render, as you have said.

But the settings I offered in post #16 seem to have been solution for the 2 posters in this thread plus some in irc, so...I offered the temporary solution.

#6


_________________
This posting, in its entirety, represents solely the perspective of the author.
*Secrecy has served us so well*

 Status: Offline
Profile     Report this post  
Xenic 
Re: MPlayer 1April Version is ready to download
Posted on 5-Apr-2009 14:13:35
#33 ]
Super Member
Joined: 2-Feb-2004
Posts: 1241
From: Pennsylvania, USA

@number6
Quote:
Which threads is which (thread libraries)?

It seems I've been down the "threads library confusion" road almost a year ago to this date. I guess "senior moments" are real because I'm very senior and I don't remember that previous conversation


_________________
X1000 with 2GB memory & OS4.1FE

 Status: Offline
Profile     Report this post  
ChrisH 
Re: MPlayer 1April Version is ready to download
Posted on 5-Apr-2009 14:58:38
#34 ]
Elite Member
Joined: 30-Jan-2005
Posts: 6673
From: Unknown

@number6 Quote:
Everything after post #11 is merely about how to see the distorted videos linked to IN post #11.

Ah, disappointing, I was hoping it was suppose to solve the bad frame rate too.


_________________
Author of the PortablE programming language.
I can usually be found on www.Amigans.net (my favourite Amiga forum).
It is pitch black. You are likely to be eaten by a grue...

 Status: Offline
Profile     Report this post  
Thematic 
Re: MPlayer 1April Version is ready to download
Posted on 5-Apr-2009 17:51:32
#35 ]
Super Member
Joined: 28-Oct-2003
Posts: 1616
From: I'm actually flying into a bug!

@ChrisH

You play the video from RAM disk, and that's exactly why it doesn't keep sync. Copy the file some place else.


_________________
: AmigaOneXE (unmod.) 750FX/512 MB +stuff & AmigaOS 4.(0|1)
: A1200/68060&96MB/SCSI/EM1200-Voodoo3 & OS 3.5
: A500/1MB
: Pegasos (ff) 512 MB & MorphOS
Praise seitan.

 Status: Offline
Profile     Report this post  
afxgroup 
Re: MPlayer 1April Version is ready to download
Posted on 6-Apr-2009 10:37:56
#36 ]
Super Member
Joined: 8-Mar-2004
Posts: 1965
From: Taranto, Italy

@ChrisH

Did you remove the menu=1 from config file?


_________________
http://www.amigasoft.net

 Status: Offline
Profile     Report this post  
ChrisH 
Re: MPlayer 1April Version is ready to download
Posted on 6-Apr-2009 19:55:03
#37 ]
Elite Member
Joined: 30-Jan-2005
Posts: 6673
From: Unknown

@afxgroup
I just tried removing menu=1, and it made no difference.

BTW, the first video file (13MB) now works for me (although it does get slightly jerky towards the end). I have no idea why, as I re-enabled menu=1.

@Thematic
I normally play for harddisk, but did from RAM to eliminate harddisk as a potential problem. Why on earth would RAM disk cause problems? Anyway, it makes no difference that I can see.


_________________
Author of the PortablE programming language.
I can usually be found on www.Amigans.net (my favourite Amiga forum).
It is pitch black. You are likely to be eaten by a grue...

 Status: Offline
Profile     Report this post  
Thematic 
Re: MPlayer 1April Version is ready to download
Posted on 6-Apr-2009 20:28:55
#38 ]
Super Member
Joined: 28-Oct-2003
Posts: 1616
From: I'm actually flying into a bug!

It'd be great if the next release would handle caching (for streaming) better, I still resort to the Epiphany version for some streams (wmv video).

@ChrisH:

Maybe it has to do with reading the video and audio parts simultaneously, it's too slow. See also Your system is too SLOW....

Last edited by Thematic on 06-Apr-2009 at 09:00 PM.


_________________
: AmigaOneXE (unmod.) 750FX/512 MB +stuff & AmigaOS 4.(0|1)
: A1200/68060&96MB/SCSI/EM1200-Voodoo3 & OS 3.5
: A500/1MB
: Pegasos (ff) 512 MB & MorphOS
Praise seitan.

 Status: Offline
Profile     Report this post  

Goto page ( 1 | 2 )

[ home ][ about us ][ privacy ] [ forums ][ classifieds ] [ links ][ news archive ] [ link to us ][ user account ]
Copyright (C) 2000 - 2019 Amigaworld.net.
Amigaworld.net was originally founded by David Doyle